Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Diesel Questions and Problems in General (non specific makes)

12346»

Comments

  • go to this website. www.dmaxwrenchkit.com
  • same happened to me. I went to dmaxwrenchkit.com and had my fuel filter housing rebuilt and my truck has never run better! that was two years ago.
  • waltingramwaltingram Posts: 1
    Are there any european diesel suvs that can be brought back to the states that are not already imported. I am interested in buying one there, using it and then shipping it back. thanks
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 45,261
    No, if it's not certified for the USA it's not coming here without enormous difficulties and no guarantee of success.

    MODERATOR --Need help with anything? Click on my name!

  • romemayaromemaya Posts: 1
    can someone help me i have a kia sedona common rail diesel 2.9 2002 model the engine turns over and has plenty of fuel going to the fuel injectors but the injectors dont have any power (volts) going to them .i have tested the power leads and when the engine is turned over there is no voltage going to them . i have checked all the fuses and they are all ok . and all connections are ok so iam confused as i have enough mechanical knolage to fix it but its got me buged?
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 45,261
    Oh you must be in Canada or overseas? We don't get this vehicle in the US, so I don't have a database on it.

    Generally, on modern diesel the injectors are controlled electronically by a direct injection module. I think the only way to diagnose this is with a scan tool.

    So can you momentarily start the engine with a squirt of starting fluid? --use very sparingly on a diesel---I'm only asking so that you can double-check your original diagnosis--it should kick right off with starter fluid.

    If it doesn't start, you might check your glow plug circuit.

    MODERATOR --Need help with anything? Click on my name!

  • I need some advice.I have a 1989 timberjack logging skidder with a 4 cyl.cummins motor.The motor runs good and will pull a heavy load, wide open but when you let off the gas it smokes bad !! The smoke is whiteish with a strong smell of oil,but does not use any oil,and when it idles after it is hot the motor will start to miss a little.Could it be the turbo,or the head or maybe the rings.And how can I test it to see which.I would be grateful for any help.
  • Need a bit more info. How many hrs. on unit? Put your thumb on breather tube, should not feel over 8 - 15 psi air hose. Valves adjusted lately? Check exhaust port manifold temp with infrared temp gun...20*F +/- max with each other. Use temp gun at coolant outlet neck...195*F-230*F operating temperature. White smoke probably is from non-combusted fuel-if engine temp is ranging 130*F - 150*F operating temp this condition can occur. If low temp,check t-stat(opening to soon).
  • tilfordtilford Posts: 3
    Truck is building pressure in radiator and pushing coolant into overflow jug, then out of jug on ground. I replaced thermostat and radiator cap, still have same problem. The factory temp guage has never showed hot. Any suggestions ???????????????
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 45,261
    edited August 2011
    Gauge could be wrong. You might want to get a radiator thermometer to double-check. One thing that drives people nuts with diagnosing overheating issues is making assumptions, such as relying on the gauge, or thinking that because a part came new out of the box, then it must be good.

    If in fact you aren't overheating, then you might have a clogged radiator. Have you ever put a stop-leak product in it? That'll do it.

    MODERATOR --Need help with anything? Click on my name!

  • 31hog31hog Posts: 1
    I have chevy 2500hd with a duramax that is giving me problems. estimates to repair are 7500-9000, wondering if I can change it out and put a gas crate motor in it for less. all thoughts are welcomed
  • tilfordtilford Posts: 3
    Appreciate the advice, but since then it has began smoking white smoke out of the right exhaust tailpipe. I drive a big truck for a living and when they do this, it usually a blown head gasket. Of course it still has pressure in the radiator. I'm 99% sure it has not been hot. I checked the water temperature with a laser, and it shows around 190 degrees. What do you think about the head gasket "assumption" ?
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 45,261
    You can buy a test kit to test for combustion gases in the coolant.

    MODERATOR --Need help with anything? Click on my name!

12346»
Sign In or Register to comment.