Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevy Tahoe Maintenance and Repair

13132333436

Comments

  • 73shark73shark Posts: 325
    What was the fuel pressure w/ the engine running?
  • msb624msb624 Posts: 1
    I have the same exact problem!! I have a 2007 suburban with 151,000 miles sitting at the dealer not drivable and in pieces with a price tag of +/-$4500 to replace lifters and CAM shaft ...
    this is a huge problem I have found with our Cars... This should be a recall.!!!
    I don't know what to do ..Fix it??? Get a new (USED) engine..??? Trade it in..??
    The dealer here in Texas said he will give me $10K to trade it in?
    SO FRUSTRATED!!! Please let me know if you have had any luck with recalls.
  • 73shark73shark Posts: 325
    You can get a crate engine for a lot less than $4,500 and it has a 3 yr warranty.
  • zboaterzboater Posts: 17
    My passenger side rear-view mirror does not return to the "saved" / auto setting. The interriror controls will adjust it and it works fine, but no matter how many times I re-set my seat/mirror driver preferences - all works and changes except the passenger mirror. Any ideas what may be causing this?
  • markj2153markj2153 Posts: 1
    edited May 2012
    the rattle is your front shocks, they're loose and there's a recall on the instrument cluster. I have a 2005 Tahoe and I'm a GM ASE certified mechanic.
  • ferfridayferfriday Posts: 6
    well... mines an LT2 and guess where it is...sitting at the mechanics and i have to put another motor in or pay $3500 and up to get this one fixed. And then Chevrolet is gonna email me from their Socialmedia area and want to know all my info before I find out this is what it is...guess who won't answer me back now. They troll this forum and act like they are gonna help you and then disappear when it comes to something like this. They need to do a mass recall. What can we do to get this started!!!! I am furious. I will NEVER buy another one of the $43000 pieces of junk. :mad:
  • I have an 05 Tahoe 5.3L Z71, Cylinder #5 was was misfiring, stuck valve, i took it apart replaced the valves and had the head cleaned, it still ran rough and the check engine light was still on, then the ABS/Parking Brake lights started coming on randomly while driving. I took it to Les Schwab to have them check it out the system and brakes are good but when they scanned it they got a bad ECM code, i brought it home, scanned it and got a P0300 code I'm also getting Catalyst Monitoring not complete, Evaporative System Monitoring not complete, Oxygen Sensor Monitoring not complete, and Oxygen Sensor Heater Monitoring not complete. Can a bad ECM cause all of these symptoms or are they not related and the thing is just falling apart? i'm running out of ideas and money! lol. Any help would be greatly appreciated.
  • I've read a lot of posts about Tahoe owners having to replace the cam shaft. I have an 07 LTZ with nearly 104,000 miles. At 99,750 I got a pat on the back from the dealer when I went in for my 100k mile service for taking such great care of the Tahoe. "Everything looks great!" they said. Less than 5k miles later I'm quoted $4,000+ to replace the cam shaft. Ridiculous. The service guy said we can't rule out oil maintenance, to which my wife replied that we regularly service the vehicle. He looked at the history and said "Yeah, I see you've taken great care of the car and gotten most of your work done here." So we ask again why this happened out of the blue and he again defaulted to "Well, we can't rule out oil maintenance." After reading the posts I am convinced this is a total sham by Chevrolet, who obviously has enough consumer data to recognize a legitimate issue. The guy said he'd check with GM to see if they can knock the price down. We will see. What gets me the most is that they are so nonchalant about it. Anyone ever get the dealer to bend on their ridiculous labor charges.
  • 73shark73shark Posts: 325
    For $4K you could get a new engine.
  • GM ended up covering a lot of the cost. Got it back today and paid $1,400. Still concerned that it happened and could happen again, but sure glad they ponied up. Got the work done at Stonebriar Chevrolet in Frisco...and no, I don't work for them.
  • chubbs2chubbs2 Posts: 1
    On a resent vacation trip in my 1999 Tahoe my Service Engine Soon light came on and I soon discovered I had lost reverse, second & forth gears on my transmission. Had the transmission replaced by dealer and was sent on my way. Approximately 650 miles down the road the Service Engine Soon light came back on and shortly after that I heard some really bad noise coming from under the hood. Had the Tahoe towed to a shop. The shop thought maybe the bolts on the torque converter or flywheel might have come loose since it had just been replaced or it could be a rod was knocking. They checked for loose bolts but said they found none. Tahoe has only 112,000 miles and was serviced properly. Anyone have any idea what the heck is going on?
  • I had the same problem on my 2002 Z71. The problem only occurred when I had a full tank of gas. Ended up needing a new fuel pump to fix the problem.
  • it will be the fuel injector poppets, the wierd spider feet looking things that feed the fuel to the cylinders
  • The exact thing happened to my 08 5.3l Tahoe. Cam issue with a thrown rod. GM
    has serious issues with this engine due to the AFM. I have owned other GM 5.3's
    with no issues. 07-08 have a quality issue which is the same years GM was having financial issues. Bye GM. Hello Toyota, now the largest car maker. GM was the largest auto maker. I wonder why GM lost #1?
  • gmcustsvcgmcustsvc Posts: 4,004
    deadtahoe,
    Do you still have your Tahoe, and if so are you planning on getting your cam concern looked into? Keep us posted - we're available to you if you should need any assistance in the process of working with a dealership.
    Sarah, GM Customer Service
  • I also have a 2004 Tahoe 2wd LT that I bought new. At about 35K miles, I noticed the same "airplane" noise at the drivers side. The dealer claimed the tires were defective and replaced all 4. At 45k miles, the sound was back, and the service technician said that the front wheel-bearing hubs needed to be replaced. Done, and the noise is gone! At 70K miles the noise is back again and I can't believe the dealer said the I needed new hubs again. These items are not cheap. I went to a different Chevy dealer and was told that these GM parts were defective from the day they were manufactured. Not good for GM.
  • I have a 09 Tahoe that has started smoking blue when you first start it in the morning. Has only 85000 miles. Any ideas what the problem is???
  • I am not real happy with GM. Tahoe is smoking now and just had to replace the transmission is our 06 Monte Carlo SS(only 79000 miles).
  • gmcustsvcgmcustsvc Posts: 4,004
    edited March 2013
    indiananorm,

    While it is not a GM website and GM is not responsible for its contents, this article on the Top 5 Signs of Engine Trouble may be helpful for you.

    If there is anything further that we can look into for you, please don't hesitate to contact us at socialmedia@gm.com with more details (include your name and contact information, as well as the last 8 digits of your VIN).

    Regards,
    Sarah, GM Customer Service
  • nokobillnokobill Posts: 1
    Clicking-ticking, similar to the directional blinker noise. Not all the time but more then not. Please help!
Sign In or Register to comment.