Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Mazda Miata Problems and Solutions

17891012

Comments

  • manybmwsmanybmws Posts: 347
    What bass level is the system set at? What volume level also? I have the Bose as well. I think the audiopilot volume changes are more subtle than you think.
  • kymikekymike Posts: 115
    You may want to contact the local Miata club - http://www.mthoodmiata.org/ to see if they have a member that will take a look at it and help you out. From their website, it looks like thay have a fairly active club.
  • coastie52coastie52 Posts: 5
    Thanks, I will check it out! Got my repair manual in the mail today, so maybe that will help also.
  • edukesedukes Posts: 3
    Hi,
    I just bought a 93 Miata from Washington, and it's a real pain to import it to Canada. You have contacted RIV. Then you contact Mazda and you send them the VIN#. within 2 weeks they will tell you what you have to do to meet Canadian safety standards. My 93 had to have daytime running lights and bumper modifications. I changed the wiring so that the lights come on when the ignition is turned on. I have to take it to Mazda for the $500 bumper mod . Kilometer stickers for the speedo. Then to Canadian Tire for the federal inspection. Then a Provincial inspection. Then I can get insurance and plates.
    It's a real pain and so stupid, however I bought my 93 for $3500 and the same car sells in Vancouver for $10.000 so the hassle is worth it.
  • ateixeiraateixeira Posts: 72,587
    If the plug wires are original that could be it. I have a '93 and I'm on my 3rd set!

    Next I'd look at the fuel pump. You're doing all the right things, IMO.

    -juice
  • wfbwfb Posts: 10
    I just bought a 2002 Miata and noticed that when I turn the key, it cranks a couple of times before starting. I'm used to cars starting almost immediately and I wondered if this is normal for the Miata because the battery is so far away from the starter or is it indicative that I should be replacing the battery soon?
  • ateixeiraateixeira Posts: 72,587
    I'd look at other things, spark or fuel as they say.

    Not that there is a real problem, but I'd go ahead and change the spark plug wires if they're original. I'm already on my 3rd set.

    -juice
  • have oyu ever noticed that the more new fangled features that are in cars, the more headaches there are?

    If my radio is too low with the top down I reach over and turn it up. :P

    I often wonder if the new hardtop will also become a bane of existence when it starts having problems.

    Give me my old manual drop top any day.
  • Hi, Miata Friends!

    Thanks to all for the repair advice. Although our daughter's Miata is running better, we are still not there yet. As I said in the last message, we had the injectors cleaned and also had chemicals added. It would never have any pick up before, and that is no longer the case. We ran the chemicals all the way to less than a quarter tank. It is very sluggish when first started and remains so for the first mile (sometimes only going a couple of miles per hour), then it kicks in and runs great--like there is not a thing in the world wrong! If run again in a relatively short period of time, it does great; if it sits for a couple of hours or more, it is back to the slow start.

    The computer indicates G-signal and the manual says that means the distributor (although, I have been told that the Miata doesn't have one) and the PCM circuitry or components. I have no clue as to what the PCM circuitry or components are.

    Has anyone out there had any experience with this?

    Thanks,
    Steve White
  • edukesedukes Posts: 3
    I have finally successfully imported a 1993 Miata to canada.
    The bumper mod cost $780 cdn at a Mazda dealer. The daytime running lights I did myself with a wiring mod.
    I had the federal inspection at Canadian Tire and it passed. Then I had the provincial inspection (British Columbia) last week and it passed. It is finally lisensed and insured. The biggest hastle was dealing with RIV. You have 45 days to successfully import the car to canada, but after 3 weeks, I had not heard from RIV and called them again. They emailed the form to me and I had only 2 weeks to have the mods and inspection done. Between the mods, duty, taxes etc it cost an extra $2000 but it's worth it.
    Contact me if you want any help.
  • edukesedukes Posts: 3
    One thing I forgot to mention. RIV requires you to contact Mazda, give them the serial# and they will send you a reply as to what you have to do to comply with Canadian standards also if there are any outstanding recals.
    Good Luck
  • My Miata has 192K miles and has been relatively maintenance free until two days ago. When first starting it died once but when on the road it dies if you put the blinkers on or turn on the head lights. It cannot be re-started until the blinkers are canceled and or the head lights are off. Until I figured out why every time I changed lanes the engine quit it was fairly exciting on the Calif freeways. Needless to say the car is parked and I am trying to figure out if I have a harness, computer, or other problem. The car crank fine so it is not a weak battery. Any thoughts?
  • kneisl1kneisl1 Posts: 1,690
    Today I became the proud owner of a 1999 silver and black Miata! 28k miles and in overall excellent shape. Female owner. A california car I believe. The only fly in the ointment is a one inch tear in the top. Can anyone recommend a product to reair it? Thanks!
  • base can be set from nil to full, and still get this horrible distortion. There is no change in volume when car is moving. Only way to hear radio as speed increases is to do it manually. Nothing in manual that you can program this other than 'on' and off', and this is all I have been able to do. Service rep at dealer was an ahole and refused to illustrate programming though he clams it can be done. Have you done this? Menu I call up is same as shown in manual for autopilot units.
  • yeah, I agree re: electronics. This is what got the Germans in trouble. I question the hardtop in this car too. I love throwing the top off in <5 sec, so, to me there is no need. Many of those roofs look like a sea of trouble to come.
  • I used to own a 91 miata and it ran like crap, plug wires solved the problem, they were no good from the factory after 20,000 miles.
  • ateixeiraateixeira Posts: 72,587
    Ditto on the spark plug wire suggestion. Beyond that it could be the alternator, since it seems to be related to electrical.

    -juice
  • ateixeiraateixeira Posts: 72,587
    For a while I got away with using some silicone caulk on my top, that sealed it well enough to stretch it for an extra year or so. Use very little and then add a layer if needed.

    But if the top it brittle it'll keep cracking. If yours is original it's 7+ years old, and they only last up to 10 years if you're lucky.

    -juice
  • Thanks for all the great ideas. Turns out it was water in the gas tank. Drained it, added a drying agent and filled it up. Runs great!!
  • ateixeiraateixeira Posts: 72,587
    DOH! :D

    Reminds me of that scene from Sling Blade when Billy Bob goes "ain't got no gas in it!"

    -juice
  • kneisl1kneisl1 Posts: 1,690
    Instead of putting a new top, what about getting a car cover and just covering it? Does that work?
  • My 1994 MX5 took unsually long to start (usually starts first crank). The same evening it started first crank but then died. Checked for sparks. No sparks from any of the leads. Checked coil pack. Cleaned and checked resistance between High voltage outputs - 10kOhms on both coils. Reconnected coil but still no spark and engine just cranks over but does not even fire.

    Cam belt seems fine.

    Car has an alarm but no idea if it has the ability to kill the engine.

    How does one get access to the fuse panel inside the car?

    Appreciate any input.
  • kymikekymike Posts: 115
    The interior fuse panel is by the driver's left foot on the 89-97 models.
  • In the mornings, not exactly cold this summer, but starts fine, but no radio, fan, windows, but lights work then slowly over one to two miles fan starts, windows work. wierd thing radio works sometimes, but flip the lights and the radio goes off. turn off the lights radio back on....? Help me on where to start looking
  • ateixeiraateixeira Posts: 72,587
    I would have the alternator looked at and maybe check the belt tension to see if it's slipping. I hope it's not an electrical short, those are hard to trace.

    -juice
  • I removed my battery and put it back. Now the parking lights flash and the anti theft red button flashes but car will not start. Please any help would be appreciated.
    dmitch2
  • ateixeiraateixeira Posts: 72,587
    I don't have anti-theft on my Forester, but the lights flash like that. I have to lock/unlock a few cycles to get it to stop. Do you have keyless? If so try that.

    -juice
  • We just bought a 1996 Miata with automatic transmission. The previous owner said something about the button on the gearshift being a "half" gear? When we push it the dashboard lights up and says "Hold". As you can tell, we are very car illiterate, and there was no owner's manuel. When we try to accellerate hard, it feels like it slips out of gear. Can anyone help us understand how to work this button?
  • tonight heading out to check the mail I got the worst electrical smell coming inside my car from the engine. Lifting the hood to check the engine I saw a craftsman magnetic laying on from what I can tell from the manual is the canister purge solenoid valve & EGR boost sensor. Left side if your looking at the engine in the middle of the windshield fluid bottle & radiator bottle. This is also a 1990 Miata
    Can anyone tell me if this might've been a interference causing a electrical smell? I noticed that when I put it in 2nd gear it didn't seem to have the power it usually has, this was before the smell.
    Of course once I saw the tool & took it out, I drove it back home, ran it for 5 min looking to see if wires were touching or if I could see smoke. Smell is gone from the engine & seemed to run fine, but I had to leave the windows open to air out. Any thoughts would be great! thanks :sick:
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 44,829
    It's just a way to keep your transmission from shifting into high gear...it's a manually enforced downshift and will cause your engine RPMs to go up---which you will see on your tachometer....You use it for going up hills, so that you don't "lug" the engine in the highest gear.

    MODERATOR

This discussion has been closed.