Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Cooling Systems -- Problems & Solutions (Radiator, Fan, etc)

1151617181921»

Comments

  • nise188nise188 Posts: 3
    anyone ever heard of or tried this method?
  • nise188nise188 Posts: 3
    Can your transmission pick up dirt from your road and transfer it to your radiator?
  • burdawgburdawg Posts: 1,522
    No, I haven't heard of that method. How are you going to get the radiator to fit in the glass on your nitestand?
    Seriously though, if that radiator is original, it probably needs to be replaced. trying to clean it will just open up the holes the corrosion is plugging up.
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 44,521
    I would pull the radiator and have it tested for leaks in the bottom transmission cooler tank, and if that's what the radiator indicates is wrong, replace the radiator.

    Don't waste your time trying to clean out a badly clogged up radiator with additives, IMO.

    MODERATOR

  • I'm Having trouble changing out the thermostat on my 96' grand am. It has a 3.1 v6 in it. I have so far removed most of everything that is in my way; however, there is a small black bar that is preventing me from getting to the housing units two bolts. Any Ideas?

    - I have taken out the battery, air ducts, and loosened the big mess with the brake fluid spot to have room. The small black bar is just in the way enough that when i put my extension on, it lays just off center enough were it won't turn the whole bolt.
  • Good morning,
    2 weeks ago, I was in a shopping mall for at least 45 minutes. I came out to the car and saw the greenish puddle under my car. I wasnt sure if it came from my car so I had my daughter move the car to a different parking spot. I opened the hood and noticed that my coolant reservour was empty. I called my husband to get some coolant, we put some on the reservour and we went home. We checked it again and it was empty and the top of the radiator had some of the coolant leaking. We figured, we needed a new radiator.

    Here's all the things we have done so far...
    Last July : brought it in shop for overheating - new timing belt and water pump and check cooling system. It was okay until 2 weeks ago

    Last week:
    Replace radiator
    Replace 2 (big) hoses top and bottom
    Replace thermostat
    Replace the harness wire that connects from the temperature sensor to the right cooling fan. We had to replace it because we broke it when we were taking it out. there were 2 wires and one of them came off. Ordered that through Toyota dealer.
    Put in new Coolant anti-freeze coolant both in radiator and coolant reservour

    Started the car and let it idle, temperature gauge is midway from COLD and HOT
    No leaks
    The 2 cooling fan starts to work when A/C is on
    The right cooling fan turns on when we disconnect the harness wire connected from the temperature sensor to the right cooling fan.
    Both hoses came hot.

    After 30-45 minutes, The temperature gauge went up slowly. I was told that when the radiator reaches a certain degree, one of the fan should turn on... none of the fan came on at all.

    I don't see any switch for the fan - green wire that is near the thermostat. What did we do wrong?
  • I was wondering if my new radiator could be causing my transmission act up.I have a 01 galant that ran fin til i replaced the radiator.Now the gears doesn't shift properly
  • bolivarbolivar Posts: 2,316
    Well, many cars have a trany fluid cooling radiator as part of the overall radiator. In other words, lines go into and out of a radiator, carrying tranny fluid. There is a small, separate radiator for the tranny fluid inside the radiator.

    If there is a leak into this tranny radiator, you've got big problems. Pull the tranny dipstick, and see if the tranny fluid looks ok. It should be red, usually. If there is any foam, or looks like water bubbles on the stick, the coolant if probably leaking into the tranny coolant.
  • The cooling fans of my 1996 Plymouth Grand Voyager SE won't come on, which is the cause of my car's overheating, even after I have replaced the fan relay, thermostat and coolant temperature sensor. What could be the real problem?
  • Not my car of choice but it has to do so I can get to work. Just had it towed home tonight, missing the Super Bowl, darn. It took me 3 1/2 hours longer to get home from the lake then normal as I had to stop 4 times to let the car cool down. Before it would be that I lost most of the antifreeze and after cooling and adding antifreeze, I was back up & running. But tonight it would overheat but did not loose any antifreeze. Once cooled, I made it maybe 3-4 miles before having to pull over again to cool. Temp gauge went beyond H and heater started blowing cold air. I was told the upper radiator hose has a leak but it seems to be more problems than that now. I have never replaced the radiator, flushed, thermostat or any hoses. I am a single lady with a small income and do not have a man/mechanic friend to help me out. I am very competent and would attempt to do any repair that is fairly easy. I have built houses, poured concrete, laid landscaping bricks and the like. Oh I also caught a 8 1/2 lb walleye! I am willing to try something new and if it does not work out, at least I can say I gave it my best shot. Any suggestions would be appreciated.
    Terry
  • bolivarbolivar Posts: 2,316
    Possibly a blown head gasket. Major fix required for this. Maybe the motor is already ruined from all the overheating. You need a good mechanic to diagnoise this.
  • My 92 voyager overheats after aprox 1/2 hour idling. Oil looks clean. Radiator water looks pretty clean. Can you tell anything from the graph or suggest further tests? Below are a graph of radiator inlet temp and radiator outlet temp vs time; and the data; the radiator boils over into the overflow container at the end of the test. Thanks

    image

    image
  • burdawgburdawg Posts: 1,522
    Does the fan or fans come on at any point during the 1/2 hour?
  • imidazol97imidazol97 Crossroads of America: I70 & I75Posts: 18,064
    Is there a thermostat in it? Or stuck open? This is not the graph for the top hose temperature (at radiator? or at thermostat end?) that I would have expected. I would expect it to stay fairly cool for 5 minutes or more as the thermostat holds back the flow, with only minimal heated water volume getting past it into the upper hose.

    Then I'd expect the lower hose temp to stay cool until after the thermostat has started opening and higher volume of warm water flows into the top but is mostly cooled by the time the water reaches the bottom. Then I'd expect the lower hose temp to start up.

    Does the heater inside produce good heat after 3-5 minutes?
  • Fan on at 4:28 and again at 4:32.
  • Ready To Blow Up My Diamante!!!!!

    Hey, Hoping you can help me with an issue I am having with a 97 Diamante. Problem, radiator fan not turning on. Here is what has been replaced so far.

    Fan Motor Works When Jumped To Battery
    Replaced Fan Switch
    Replaced Fan Sensor
    Replaced Fan Relay (All 3) with Horn Relay, All Work Fine
    Replaced Thermostat

    Only way I get the fan to come on is when I pul;l the connection to the sensor, then it comes on with and without the air.

    If I had a gun I would shoot it right now. But since I need it I'm asking for suggestions, Any Thoughts????????

    Joe
  • dcdgdcdg Posts: 1
    I'd try and troubleshoot the Fan Switch with a volt/ohm meter to make sure it operates at correct temperature, there is always a possibility that the new switch is bad. Maybe even troubleshoot the Fan Sensor.
Sign In or Register to comment.