Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Mitsubishi 3000GT help

15678911»

Comments

  • jamj1234jamj1234 Posts: 24
    My 95' Mits 3000GT will not start two, three , maybe four times a week. Wait 10 minutes and she starts right up. over the last 4 years I have put an rebuilt engine in her,(water pump went bad, blew the engine) Battery cables, Battery, Alternator, clutch, clutch cylinder, radiator and hoses, brakes and more. She runs and looks great. I have had it to a few mechanics, the last fixing a ground. However the problem persists. Has anyone had a issue like mine? What was the fix.

    Thanks,
    Frustrated Jack
  • it can be many things.. try doing a whole tune up starting from plugs wires (make sure to gap the plugs correctly) and air filter. while you're there, check for any restrictions that the intake might have, clean the throtle body inside and out, and you should notice a difference. If you still have the same problem then check the MAF sensor cause it might be going bad on you but I really doubt it
  • sam97gtosam97gto Posts: 12
    edited October 2010
    well 300 bucks is hell cheap man!! I say you buy it if you dont have the money for a better one (stick ;) ) dont worry about making power right now, make sure you take care of all the problems that the car might have first and make sure that the reg maintance of the car has been done (timing belt, plugs, wires, etc) you'll get the power later cause a healthy 3000gt has no problems giving it to you. DOCH engines can be modified really easy even if they're automatic. anyways, good luck with the car and enjoy it!
  • let it warm up for a while when you first start the engine, it should go away after a few mins, if not, you can give it gas, first take it to 1000 then to 1500 for about 10 seconds then let it go. you really shouldnt go as far as 8k cause it could damage the engine. if this doesnt work for you then I'd get, either a less thicker oil and go synthetic
  • there's many.. the vr4 comes with factory twin turbos making about 320hp and putting them on the four wheels which make a hell of a fast car!! sl model has the same engine but has a FWD transmission and no turbos :( still makes about 210hp and could look exactly the same as the vr4
  • if this is you're first car, you shouldn't be looking for a vr4 lol too much power and thats not good if you cant drive stick, and not even to mention how dangerous it can be on ice! you like the car? then get the sl model :) still a wonderful car
  • if you have a 24valve engine then you gat the sl model. as far as parts, some might but it depends on what you need
  • do it and send me the link!
  • sounds like an oil leak.. but you can tell if your car is a DOCH or a SOCH by looking at the valve cover.. the SOCH is way smaller than the 24v and if the distributor has 3 wires going to the front of the engine right above the exhaust manifold and 3 going to the back then it would be a SOCH engine.. I own a base model and ppl might say that it's slower than the DOCH engine, but I've taken many of them with just a few mods.. in fact, base models are lighter and can get the same power as the sl model with the right modifications. anyways i think you should be happy with what you have even if it's not what u thought it was
  • go to 3sx.com and type "belt" look up the diagram of how the belt goes and it'll tell you the names of all the parts. save it or print it out, and all you have to do is losen a couple of bolts that hold the tensioners, is really not complicated. about 25 mins i'd say... good luck
  • sam97gtosam97gto Posts: 12
    edited October 2010
    look it up on wikipedia, it'll give you some info about the car. then you can go to 3si.org to find out more stuff about it. for parts i'd say 3sx.com and vr4's not only come with the turbos, but the're always stick and have many other cool features
  • sam97gtosam97gto Posts: 12
    edited October 2010
    I got a 12v engine, there's a noise coming from the driver side of the car, sounds like a rattling. it makes it when i step on the gas and force the car to move, cant hear it at idle tho... if i go over 1500rpm it starts to make it, and the higher the rpms the faster it makes the sound, it is always constant and i have no problems with it cause it doesnt seem to be doing any harm but its annoying the **** out of me!! any idea of what it might be?
  • How hard is it to do a starter on a 93 mitsubishi 3000gt. Not a SL or the VR4. What tools do i need and approx. how long to do the job?
  • kbear58kbear58 Posts: 1
    I am having the same exact problem! Mine set for 3 years and is now doing the same thing! Did you ever figure out what the problem was? It would be so much appreciated!!
  • jamj1234jamj1234 Posts: 24
    My AC looses its cold air after about 2 weeks. If I try to top it off it wont take much and does not make much off a diference. If I drain the system and put 2 cans of AC in it works great but only for the 2 weeks or so. It seems to still have quite a bit off preasure in the system when it looses its cold air. I have tried stop leak and also had the dealer check for a leak with no success. Any ideas.
    Jack
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 44,528
    You may have overfilled it, and it is freezing up. I'd have an expert service it with proper equipment it and see how it goes.

    MODERATOR

  • You need to change your orifice tube( its clogged up) . I believe that will fix your problem :)
  • jamj1234jamj1234 Posts: 24
    Hi Firestone,
    I think your on to smething. I am trying to find the orifice tube. I'm guesing it's up in front of the condensing coils. can you confirm?
    Thanks,
    Jack
  • what year is your car? Hell just call me 334-898-9988
  • Can any one tell me where the AC orifice tube is located on a 1995 Mitsubishi 3000 GT.

    Thanks,
    Jack
  • What are the best non-hid replacement halogen headlight bulbs for our vehicles?
  • jamj1234jamj1234 Posts: 24
    Sorry for the late reply, I have not visited for a while. Never figured out the problem. Replaced oriface valve, and o rings and no success. Still does the same thing.
  • jamj1234jamj1234 Posts: 24
    My gas gage and speedometer are not working on my 95' 3000gt. Tried replacing the gage cluster ( bought on e-bay). The speedo registers 20 mph at a stand still and the gas dial still is not working. Any ideas?

    The rest of the features on the cluster are working fine. (Rpm pointer, lights, directional s)

    Thanks
    Jack
  • jamj1234jamj1234 Posts: 24
    I have put a second gauge cluster in my Mits 3000GT. At first the Speedo and Gas gage still did not work. Then suddenly the Speedo started working. Since then the gas gage started working but only read 3/4 full. The gas tank was just filled to the top. It then stopped working, went back to reading empty, and has again started working but only reading back up but to 3/4 of a tank
    Any suggestions?
    Thanks,
    JACK
15678911»
Sign In or Register to comment.