Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Dodge Durango Maintenance and Repair

191012141528

Comments

  • aec_88aec_88 Posts: 2
    if its happening at highway cruising or anything over 45 have the overdrive checked out it can be slipping in an out of o.d.
  • silkiesilkie Posts: 2
    I'm having a problem with my 02 dodge durango 5.9 rt. I've had it since jan 06. The door locks started locking and unlocking while driving as well as the wipers occasionally keep going off by themselves. I've brougth it to the dealer who told me it could be the ground wire , which they replace or the remote car starter that came with my truck when I bought it. They tell me that it should have been removed as the don't come with that model anymore, which makes no sense to me as it works fine. Has this happened to anyone, or does anyone have any idea how to resolve this problem? Any help would be appreciated
  • I had a recall on my 2006 Durango for the CCN Control Module, which affected the wipers, headlights, and god knows what else. BEFORE, you could go on Dodge's website, and pull up all the recalls. Now you have to put your VIN in. And if they have "fixed" it, it will say, "No Incomplete Recalls or Customer Satisfaction Notifications Exist.". Bull. I'm STILL having issues. But tell them to check that if you have a CCN Control Module on your model. :(
  • I'm having a serious issue with the airbag lights either staying on after I start the vehicle, or coming on after I am driving down the road. I bought the vehicle in Feb 06..14,000 miles. I took it in Mar 4, 06 for 3 recalls out. Airbag lights still issue. Call back..get this, they never did the recall work! Go back in Jun 17th (06), get recall work done, airbag lights checked. Still having problems. Now, they are coming while driving, (before, they would just stay on after starting). Took to different dearlership...they recaliberated seats (huh?..okay) and looked at the airbag lights. I don't carry ANYTHING in passenger side seat to "throw off" sensors. Today, they came on while driving to big city, in the pouring rain. Anybody else having these issues??? It is really starting to PO me. There IS a recall for Airbags for 2006 Durangos, but not mine, it apparently only affected 335 units and mine was not one of them. I am going to disagree! :mad: :sick: :lemon:
  • I have a '99 Durango. The ABS light was staying on and speedometer was cutting out. I read a bunch of post and all indication were that it was the speed sensor. I replaced the speed sensor and all the lights went off. However, when I am braking <10mph the speedometer drops immediately to 0 and the ABS brakes kick in. As soon as I take my foot off the pedal and reapply them the issue stops. Does anyone have an idea of why this is happening? Are there different speed sensors that have a different ratio?
  • Not sure if you have fixed your problem or if this is your answer but its worth a shot. I had the same issue, replaced the thermostat and it was still blowing cold air. One day, in the middle of winter I was adding washer fluid to the reservoir and heard the AC compressor kick in. Obviously, I did not have the AC on, but the clutch was engaging. I pulled the AC clutch relay and amazingly I had nice hot air blowing.
  • I had the same experience with my 2000 Durango. Had to replace the door lock solenoid mechanism. It can be a do it yourself project. You need to remove the inside door panel to get to the mechanism. I would recommend buying the replacement prior to attempting this. That way you will see exactly which screws and levers need to be removed to replace it.
  • I have recently had this problem. It has happened 3x in 2 months, thank God I was never hit. Twice it happened while intersecting traffic, one while attempting a u-turn which became a left turn on an unprotected green light and the other time while cutting across a busy 4-lane highway and dying in the middle thankfully at the median where the oncoming traffic wouldn't hit me. The other time it was at about 30mph before entering a turn and stopped along the grass shoulder. I have been to two dealers who say they cannot do anything unless the problem ocurrs while they are driving it, no such luck yet! I just filed a complaint with NHTSA, but there doesn't seem to be much more I can do. I drive 6 kids to school 3 days a week in a carpool and I don't feel safe driving them anymore, it's not worth the risk, at least not for me, but Dodge doesn't seem concerned enough. If anyone has any information on how to get this fixed, please let me know! I am without a car until it is :( :lemon:
  • Don't know if you solved or not but we also had a gremlin doing all sorts of strange things and it turned out to be a short in an afermarket trailer harness. I cut above the connection and all my gremlins went away
  • There are 2 speed sensors. One is on the transmission. the other in on top of the rear gear housing. I had to replace the one on top of the rear end for this problem to go away on my 99.
  • I have a 2004 Durango SLT with about 36000 miles on it. The problem I'm having is the clock/radio stopped working and the dome light and the power door locks only work when the key is in the "on" position.I checked all of the fuses and it seems there are several that don't have any power to them. The ones that do have power are good. Does anyone have a chart or schematic telling what fuses control what?
  • Did you get this resolved? my 00 Durango P.S.P.S code came up. In removing the Switch (which i located), is it hard to remove; will there be draining of fluid; any special precautions; await your response. :cry:
  • I've read all your posted messages regarding the Power Steering Pressure Switch(problem just registered on my check engine diagnostics).

    Could someone list the step-by-step process? Correcting this doesnt seems difficult. So far: problem is 3 months old, Switch and harness is wet, poor gas milages, check light on dash, pending emissions test next month. Help & Thank You Board Members :sick:
  • OK, I bought the Power Steering Pressure Switch and replaced it with the old one. It was a bit hard to remove, but had to use 2 adjustable wrench to undo it. Brake and fluid remover was used to spray out the harness and plug, and let it dry for a few minutes. The battery (+ve) terminal was also removed to reprogram the computer code. Battery terminal reconnected and plugs replaced. Only need to top off the power steering fluid, and i should be back to normal (hopefully). Will access the situation a few days to see the progress. Hopefully this will help other members interested. Peace. :shades:
  • This is happening to my 99 Durang as well. Shuts off without warning, very dangerous. Brought it to 2 mechanics who couldn't figure it out and now after a week the dealer is saying it's they THINK it's the control module but won't know until they replace it $650.
    I just got my car back from the body shop because a tree and power lines feel on it. Does anyone know if the electrical wires could have caused this? I'm trying to get this covered under insurance since I've already paid $1000 for my deductible and JUST paid the car off.
  • Did replacing the PCM fix your problem? I have an 01 doing the same thing and the dealer can't find the problem. Thank you..
  • I read several posts about Durangos surging at idle and at speed but haven't really seen a solution. Has anyone out there actually found the problem and repaired it. My 01 started surging around 88,000 miles and the dealer doesn't have a clue. Any advice, besides getting rid of it, would be helpful. Bought it new and haven't had a problem of any kind before this one. Thank you.
  • My 01 does the same thing, but so does my wifes Buick Regal. Perhaps there is a conspiracy involving the Big Three.........
  • The resistor is defective. It is either located under the dash behind the glove box in the evaporator housing, or under the hood by the firewall on the passenger side. $10.00 to $12.00 dollars at your dealer.
  • Having same surging problem.
    Transmission just failed.
  • Powered door locks, but had to replace almost all the powered door mechanism (actuentator ). Disconnected the R Rear since that one is now going bad. Notice that the doors do not lock automatically with the alarm or the master lock button - - and does this if the temp falls below 70 degrees. Over 70 degrees, they work purrfect! To unlock it, all doors work, but to lock, there is a clicking sound under the glove box (like a relay sound - - think that is good).

    Anyone else experiencing this problem and what are your solutions? :confuse:
  • I have a 2001 with 86,000 miles and recently noticed the same surging of the engine while maintaining a constant speed. One other thing I noticed was that it went away after the car has been running for a while. If you find out what it is, I'd love to hear it!
  • rich28rich28 Posts: 23
    My 01 Dakota surged, especially through hills and with the cruise on. I had the Throttle Position Sensor (TPS) replaced and that absolutely fixed the problem.
  • Just wondering how many of you have had the same problems...
    Just in the last year we've had
    1 - Recall on upper ball joints
    2 - lower ball joints failed 3 months later (our expense)
    3 - Steering column key lock failure (our expense)
    4 - Transmission failed (our expense)
    5 - Air conditioner evaporator failed (our expense)
    Total cost - $3600.00 since last car payment - lucky us?
    I do plan on starting a class action lawsuit as I have heard these problems are quite common from used car dealers and auto repair shops and transmission shops. :lemon:
  • I haven't had the problems YOU'VE experienced, but I have had my own! Airbag lights is still a main issue. However, I believe the transmission is starting to give me problems. Been to the dealer once already (still under warranty- 23,000 miles). I have 2006 Durango. Just out of curiousity, what year is your Durango? I had someome tell me from a non-Dodge Dealer that Dodge was going to reduce there powertrain warranty by "20,000" miles due to all the issues! Does anyone know if this is true too? :lemon:
  • I may be to late but my 2000 has had this problem, I decided to just let it idle in my driveway to wait for it to shut down. When it finally did I was able to restart it without problem, unlike if i were driving it. As I went through and checked all the relays i noticed that the automatic shut off relay was extremely hot, I replaced it and that seems to have cured it, I would imagine the same could happen to the fuel pump relay as well. But of course if it is running at the time you take it in it wont be detected until it acts up again.
  • You might try the automatic shut off relay, i replaced mine and it fixed the problem
  • 2001 durango R/T
    spent almost $4000
    forgot about the lower ball joints $300
    they recalled the uppers and replaced
    but then refused to align front end
  • I have a 2000 Durango and had the same problem. It would rev 200-400 rpm. I only noticed it with the cruise control set. I replaced the Throttle Positioning Sensor and completely repaired the problem. This is an easy fix, and relatively inexpensive ($38.00 at O'reilly Auto Parts). 2 Torx bolts and one electrial plug (on left side of throttle body assembly)
  • Hi les7311, im wondering what came of your problem, i'm having the exact same one. Need to figure this out, it's killing me. Anything would be helpful. Thanks very much.

    Jonathan
Sign In or Register to comment.