Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Dodge Durango Maintenance and Repair

1131416181928

Comments

  • dodgeohdodgeoh Posts: 9
    Steelman4....what year is your Durango? Was your vehicle stalling just after start when cold? I have another observation....My 2005 somtimes when just started and put into reverse, will not move unitl gas is applied. Seems like it has to back-out over a large bump (takes effort). Other times, it acts like a normal car when put into reverse, and it starts to roll without any gas.

    J
  • dodgeohdodgeoh Posts: 9
    cbr1...you ever fix this? I have a 2005 with the exact same issue. Sounds like exhaust rubbing but only when hitting the right bump or rough patch in the road. Been back to the dealer over and over and still no resolve.

    J
  • steelman4steelman4 Posts: 4
    it is a 1999. and the stalling was more when cold, but also would do if hot(not as much). by cold or hot i mean if the vehicle had set overnight, and it was the first time starting. after getting to run, would do great, if you let set for 5 to 6 hrs, would stall, somtimes would do after and hour, gut not as much. what is your RPM's running, mine would drop to 500 from around 750. i am checking with a few others who have a durango, will check on your problem if ya like me to, just let me know.
  • dodgeohdodgeoh Posts: 9
    When you say "check on your problem"....what do you mean? Mine stalling has been almost always after sitting overnight. Usually backing out of the garage, and or shortly after making it to the road (my driveway is 700' long), when pulling out into traffic. Just stumbles for a split second, then dies. Always starts back-up and runs fine from there. I have filed paperwork for Ohio's lemon law. We'll see if that goes anywhere.

    Thanks, for any help.
  • larry72larry72 Posts: 1
    1999 Dodge Durango 65,000 miles. When starting, there is a pinging or dinging noise from the engine area. Sounds like a bearing going out. When engine is warm, the noise goes away. Been in several times to dealer without finding the problem. Water pump has been eliminated as the problem. Any thoughts? Thanks.
  • lsk1974lsk1974 Posts: 1
    I have the exact problem. It sounded like I had written this post. The only thing is that I unplugged my battery and all this started. What did you do to resolve this issue? Everyone tells me to replace the unit.
  • :( I have had this 99 durango maybe 2 weeks and 1 1/2 weeks it was at the dealer I had Paid Cash After the Cash Switch Hands And all that blassa happened he said he was going to detail it for me since I was nice enough to Pay Straight out Cash! The next day he says it wont start sends it down to the mechanic and he says it just needed a new Battery, So get it home drive it for a half day Go to sleep wake up for church and No Juice! I used a voltage meter and could find nuthin myself excepted some dumming cant hook up a stereo So I re-installed it change every fuse Charged the battery And Go to work come home to Drive it Back DEAD PLEASE HELP

    DODGE BITES
  • When making sharp turns the truck doesn't want to go and when it does go there is a low grinding, rubbing noise. the engine is fine it doesnt stall or anything. the right front tire also makes a sound like it's peeling out, like it's sliding across the pavement. I did check the power steering fluid and the level is fine. Please help.
  • Check engine light on, hard to read the codes. Running very rough at cold start and slight rough at other starts. Dodge kept it for a week..changed fuel pump, coil pack, powertrain(because they fried it)finally said carbon build-up problem. Completed emission cleanse and BG throttle, which had been done 6 months earlier. Drive it a week and let us know. Week to the day, engine light back on. They want to open the engine and clean my heads...?Now at local shop..motorvac engine..still scratching their heads. Airbag lights randomly comes on..scary! Called Dodge..recommended that we take it to another Dodge shop for a diagnosis..told us if they can't figure it out, they are sorry...they can't do anything.AHHHHHHHHHHHHHHHHhhhhhhhh Any ideas????
  • so the CD player has stopped working in my durango.... the dealer wants to replace it the problem seems to be that there are CD's in the unit that will not come out and the unit will not except any CD's. any one have any other ideas other than replacing the unit?
  • The once silver side trim that is attached to the center of the doors is beginning to turn a shade of yellow/orange.

    I brought it to the dealership and they said that it was not a warranted part.

    Have/are any of you silver Durango owners experiencing the same?
  • I have the same problem in my 04 any other idea's than just replacing the unit?
  • I have a 97 Dodge Durango and the middle dome/reading light isn't working. How do you take the plastic cover off to change the bulb? :confuse:
  • I had the same issue with a 2005 Durango. Two things fixed it. There is a TSB for a new guage cluster (electrical issue) and for the airbag light, they found the harness was not fully seated under the hood. I have not had the issue since.

    Hope this helps. Are you taking the vehicle to a factory garage?
  • this is a 2001 slt 4wd power everything. the horn won't blow on demand but the panic button on the remote will set it off. the sound system makes a deafening buzz/hum when you shut the front passenger door or run over bumpy surfaces. the key will only unlock the doors from the driver door, even the door that the key is in. the airbag light is on. sometimes it will not start hot or cold. this is a recently aquired truck and no history is known.
  • Just saw this post. If you haven't already resolved this, what you're describing is transmision wind-up, which occurs when the central differential is locked on paved roads. If the vehicle isn't in full 4WD mode (which is the only time the centre diff should lock), then it sounds like the centre diff is locked when it shouldn't be. Try shifting between 4x4 modes, and when you put it back into non-4x4 mode (can't remember what this is called on the Durango)try driving back and forth a couple of times. If still stuck, drive the vehicle slowly to a workshop.
  • kinkkink Posts: 1
    i have a 2000 durango 4.7 eng 4x4. when i crank the eng it wont start then i crank the eng a second time it starts up right away but run a little rough anyone ever have this problem?
  • This is a 2001 SLT 4.7L 4wd. I bought it about a month ago. I don't know much history about it. It has 108,000 miles on it. After its driven for a short time it will not start. It has not stalled while driving but when I turn it off it will crank but sometimes will not start. If I turn the key off and on several times it will start up, but some times it can take 30 mins. of trying. As I said in an earlier post there are other odd electrical issues. I don't take my cars to dealerships because they guess at the problem and "let's try this part" at my expence. I need a fix soon as this wife's kid taxi.
  • We have a 1999 V8 5.2L that will not idle unless your foot is on the gas. The problem worsens when the weather changes.

    We have replaced the Idle Air Control Valve, the TPS, and reset the ECU countless times.

    Is there somebody else with this problem that has a resolution? Will replacing the O2 sensors fix it?

    The AC pump has also gone out. It whines (loudly) when it is turned on. Is there a specific part that I could replace rather than forking out the dough for a new compressor? :confuse:
  • I had a similar problem, except the lights would go out the wipers would quit working and the remote key also quit working. I have a manual so I traced it to the central control module, once I replaced that everything worked.

    Gary
  • Buchanangw47, I have a question. When you replaced the central control module ... did you have it replaced at the dealer or what? AND how much did they charge you ????????? Thanks BIG TIME dodge01driver
  • The ABS light and the Brake like came on the other day and stayed on (1999 Durango). I restarted the engine throughout the day and all, say four times the two stayed on. However this morning when I started the engine, they both turned off. A glitch or a fault in the brakes?
  • I have a 99 Dodge Durango 5.7. When I drive the car a "dinging" sound comes from the truck and the check gages light comes on. The oil pressure gage will be at 0 and the water temperature gage will be at the highest i think 280. Then after about 3 secounds it all goes back to normal for the time being. Then about a minute later it all happens again. :mad: does anyone one have the same problem.. Thank you a lot!!!!!!
  • felixmfelixm Posts: 1
    My Durango has 107,000 miles. So for knock on wood I haven't had a problem. My wife drives it to work 3 days a week for 60 miles round trip. Most of her dirving is highway miles. My check engine light went on and she took it to the dealer. It turned out that two hoses needed to be replace for vaccume canister and leak detection pump.Lets not talk about what I paid for labor.The dealer is telling me that I will need the steering gear assembly,which will cost an arm. Has anyone needed to replace this before. I also wonder with so many miles what can I look for to avoid any major breakdowns?
  • I have the same problem changed out blower for new and still nothing blows unless going down road in the front!!! did you ever get yours fixed
    AC OR HEAT Neither blow out in my 2001 Dodge Durango

    any ideas????
  • :confuse: We just purchased a 2002 Dodge durango and found that it had a warning lamp for the "Cargo Lamp" that would blink occasionally. I looked in the manual and it had no reference to the "cargo lamp" which is located on the bottom right 2nd lamp on the instrument warning cluster. Could someone point me in the right direction to get this fixed.

    Thank You,

    Michael
  • It is the turn signal relay/flasher that is causing this. I believe the part number is PC507, and can be purchased from any auto parts store, I think I paid around $12. It does not look like a fuse from the regular fuse box, it is a 2in x 2in box. And it does in fact go underneath the dash. There is actually a hidden fuse box there. The relay you are looking for is almost directly above the emergency brake, up past the mess of wires, and plugs in toward the drivers side. The factory relay/ flasher is green in color rather than black(like the one you purchased) Find that little green box and switch them out and your good to go.

    Helpful hint: The flasher/relay prongs match and do fit into an open fuse in the regular fuse box. Don't waste your time. I tried it and wound up back at the auto parts store buying another one because I fried it.
  • have your cam sensor checked out mine had the same problem eventually if your truck keeps shutting off when driving you will have to have the computer replaced and your problems will continue i've had sensors replaced, a computer put in and my check engine light still comes on
  • i have a 1999 dodge durango that has had a diagnostic check and it reads "no bus' does anyone know what i can do about the problem. I've had a new computer put in it and several other things done to it. i've also had some sensors replaced. it runs real rough and the check engine light, brake light, and ABS light. have spent a lot of money and do not want to spend a lot more. Can any one tell me what the "no bus" means and what i am supposed to do about it.
  • tidestertidester Posts: 10,110
    "No bus" means the Powertrain Control Module (PCM) isn't communicating with the rest of the system. The cause may be a short circuit in one of the sensors. Hopefully, one of the experts here can help. Anyone?

    tidester, host
    SUVs and Smart Shopper
Sign In or Register to comment.