Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Dodge Durango Maintenance and Repair

12223242527

Comments

  • flmikeflmike Posts: 3
    I have an 01 Durango. It seems to happen sooner when it is very hot outside or once the truck warms up. The wipers, horn, door dinger, and security light on dash all flicker. The door locks lock and unlock, and if the headlights are on they flicker also. I have figured out this much, if I take the fuse out that is labeled over H/D console purge it all stops, but my A/C stops working with that fuse out I think it is something in alam but unsure. If anybody has any Ideas please let me know
  • From what I have seen and mine just went too and the job to replace it on a 2000 Durango is about a 2 hour job that requires the removal of the dash and dropping the steering column. The core is located between the radio and the glove box.
  • burdawgburdawg Posts: 1,524
    Two hour job? More like eight hours. You'll need to discharge the A/C since the evaporator is in the same housing and it will need to be disconnected.
    It wasn't recommended but I also removed the front seats for better access, and the fender liner on the right side to get to the nuts that hold the plenum on the firewall easier.
    This is not a job for a beginner.
  • Did you ever find a solution to this problem? My 2002 Durango just started having the same issue.

    Thank you.
  • stoutrstoutr Posts: 1
    Similar problem with my 2005 Durango. The dealer completed some recall work that involved replacing the entire instrument cluster. Since then, the CD player does not work (unable to select CD player). Although I occationally hear things shuffling around in there. Took it back to the dealer and they report all wiring connections are good and the player has power. Told me the remedy is to replace the radio ($650)
  • raullraull Posts: 1
    I have recently noticed a metalic pinging coming from the undercarriage of my 2006 Durango. The pinging is sporatic (every 5-8 seconds), can be heard when driving the backroads (< 35 mph) and continues after the engine is shut off for a short period. My local mechanic checked it out and identified the ping is coming from the catalytic converter but did not recommend replacing it. He could not determine the cause of the ping - any ideas?

    Thanks,

    Raul L.
  • i had the same problem and i changed all kind of parts including the fuel pump in the gas tank which i didnt need to do.
    all it was was a upstream O2 sensor { the front one on the drivers side}
    that took cake of the problem. i think the part at the parts store was only about $30.00 and it fix it.
    have fun
    PS- it is on the y pipe coming down off the engine on drivers side and the closest one to the front
  • Hello everyone.

    First of all, I hope I've posted this in the correct section. Forgive me If I haven't. I'm ok with it being moved to its correct forum section if need be.

    Anyways, I own a 2000 Dodge Durango. This car has been great to me since I purchased it used from a buddy just over a year ago. It's fulfilled its job quite well, while sparing me any headache. However, just yesterday my car overheated on me. When I got home I inspected its radiator and found that this part was to blame. It showed signs of leakage and a majority of the fins were severely bent. I know that replacement is my only option at this point, but before I do so, I'd like some advice. I've decided to purchase an aftermarket version online, but don't know which companies are reputable. I've found two that I particularly like but before I buy from one of them, I'd like some sort of verification that they are a legitimate business. I almost never buy anything online so I don't know how to spot a scam, and I can't afford to be scammed.

    Has anyone dealt with either of the following companies and can verify that they are a legitimate company? The parts on each site match the OEM number of the part I need.. Thanks in advance.

    http://www.radiatorspot.com/dodge/durango/radiators.html#MjAyNjY
    or
    http://www.acpartshouse.com/showitem.aspx?id=122312&googwd368916
  • steverstever Viva Las CrucesPosts: 40,860
    I'd crosscheck them with RockAuto.com.

    Moderator
    Need help navigating? stever@edmunds.com - or send a private message by clicking on my name.

  • burdawgburdawg Posts: 1,524
    edited November 2011
    A/C Parts House is reputable. Make sure you get the HD radiator, for the few dollars more it's much better.
    Also, if the heater core is original I'd check it for leaks also.
  • My Durango is a 2001, 4.7 liter with 2WD. There are a few problems with it, and I would really love some guidance, as I just can't afford to trade it in and get an even higher payment. First, when it's a cold start, regardless of the weather, the crank takes several tries before it turns over. Then, once it has turned over, there are times where it will idle, and times where I have to hold down the accelerator pedal for a few minutes before I can ease off of it and let the idle take over. Second, my right turn signal has quick. When it first happened, I could smack my fist into the dash just behind the steering wheel and it would work for a few blinks, but not even that will work for now. The light on the dash just doesn't even come on. Next, my left brake light has stopped working. I have replaced the bulb, the socket and then the entire light assembly, complete with the attached circuit board. Nothing has made any difference. All the other problems are easy, and I can take care of them. The three listed above are the ones that I'm having a hard time with. Anyone have these problems and been able to find solutions? (Left turn signal and right brake light work, by the way)
  • debbie72debbie72 Posts: 1
    I have a 1999 Dodge Durango and was given a remote that used to go to another Dodge. I have replaced the battery but still cannot get it to program to my Durango. I have followed the instructions for reprogramming but it still won't work, short of going to a dealer and paying $$$$$ is there something else I can do to get it to program to my Durango?
  • hi debbie- i have a 2000 durango and had the same problem and it was on dodge.com is where i found my answer which is you need to give them the number off the back of the remote and insist that it have the dodge rams head on the remote or it will not work and do not let them tell you that they are all the same because they are not. i cant remember what i paid {i think $20} but alot cheaper than the dealer. this should take care of you.
    hammer
  • mort58mort58 Posts: 2
    Did you find a repair for your front heater fan not working? I just experienced a similiar problem. The first 2 speeds don't work, but the fan works great on high speed.
  • mort58mort58 Posts: 2
    Did you find a repair for your front heater fan not working? I just experienced a similiar problem. The first 2 speeds don't work, but the fan works great on high speed.
  • rolyanrolyan Posts: 1
    Removed tire, Upper shock absorber fasteners, lower bracket retaining bolt, stabilizer bar link upper nut. How do I get the thing off?
  • I have a 2000 Dodge Durango 4.7ltr. Check Engine light is on, so I pluged in OBD2 and came up with 7 codes.
    PO304 Cyl 4 misfire
    PO302
    PO306
    Replaced all 8 spark plugs and direct coils.

    Still have the same error messages (302,304,306).

    In addition to the PO302, 304, 306, I also have PO300, PO351, PO352 and PO135. Can you help?
  • LASHAWNLASHAWN Posts: 303
    The P0300 code is a random misfire code, P0351, P352 and P135 could be either a bad coil over plug, bad wiring harness/connector in coil or PCM internal fault. Recommend you take to dealer to address those codes since it's probable that the PCM may have to be reflashed.
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 45,050
    USUALLY (caveat) having this many codes all thrown at once does suggest a PCM issue.

    MODERATOR --Need help with anything? Click on my name!

  • i a too experiencing the same problem in my 2004 dodge durango limited,,, my engine stalls during heavy rains and turn off when i am at traffic lights. i found out the oxygen sensor needs to be replaced. only had the truck for 3 months....
  • dee81877dee81877 Posts: 2
    This happened to us but after replacing battery everything seemed to be fine
  • heatherlzheatherlz Posts: 1
    Same problem with my 2004 Durango as far as Humming noise and rough idiling when it rains. Any fixes yet?
  • if it is the same thing i had it turned out to be my o2 sensor that took care of all that
  • tp11tp11 Posts: 3
    I changed ALL my oxygen sensors hopeing it would fix the humming noise & rough idleing in the rain/carwash, but it never helped at all. A new problem came up, went to acceleriate on the highway and it was like it reved up and then got "stuck". Scared me to death! Then the cruise wouldn't work. So I pulled over, shut it off checked the fluid, which were good. When I restarted the durango the cruise was working again.
    Anyone know whats up or had the same issues?
    My durango is an 2004 with a 5.7 hemi
    thanks
  • frankb12frankb12 Posts: 1
    Have you fixed or found the solution. I'm having the same exact problem and now my headlights won't come on either. I brought it up to autozone to hook it up to their computer but they said unless the check engine light comes on they can't help. Help if you can please..
  • tp11tp11 Posts: 3
    Unfortunately I haven't figured out the problem. I went through a rain storm the other day and it started ideling so rough I thought it was going to stall. Also even after changing all the oxygen sensors it still hums after I turn it off. Trying to figure out the problem is driving me nuts. If anyone has any ideas let me know! Thanks!
  • Electrical problems so far, I drove it into a car wash and it for soaked and flooded/drowned out. Got running, when air is real damp vehicle idles/runs rough, the second issue is the radio works sometimes. dead most of the time, then other days it works fine, next issue is the factory trailer wiring harness burned out the taillight wire so I had that replace. I started it up another day an nothing worked on the inside for dash ac radio.
  • Will a 2007 4.7L dodge motor fit in my 2003 Dodge Durango (also a 4.7)?
  • 2001 durango has a brown fluid showing up in the 3rd plug of the harness(3rd from left to right,furthest right in other words) My dashboard crashes and says no bus.Gagaes are go to zero. I found this issue week ago, dried it out with electronic fluid and car was fine for 5 days but crashed again. Took harness apart from pcm and found liquid in 3 rd compartment again. The harness wires are DRY going into the pcm and there is no visual splatter on the pcm if it was coming from the engine. Any ideas?
  • 2000 Durango with 4.7

    I had fluid coming from faulty brake fluid level sensor - going back to the O2 sensor. From the upstream junction, the PCM can also receive the same fluid. I bypassed the fluid filled wires and use fresh wires. O2 sensor wiped out but never had the problem with the PCM. Low fluid sensor is the problem.
Sign In or Register to comment.