Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Dodge Durango Maintenance and Repair

13537394041

Comments

  • catniprcatnipr Posts: 6
    When the mechanic was performing the diagnosic, it also came up with a "Engine speed input circuit malfunction." (P0725) The RPM's would go to "0" when he would put the car in drive or reverse and would be normal when he had it in park or neutral. I'm not sure if this is a separate issue or may be part of the possible Transmission Control Module problem.

    You said that a scan tool can erase the codes. Do I have to go to a mechanic to have this done or can I purchase it? About how much do they cost.
  • MrShift@EdmundsMrShift@Edmunds Posts: 43,626
    I think Chrysler uses a special scan tool---DRB or something like that.

    Here's an interesting article on SCAN TOOLS
  • mucunamucuna Posts: 19
    assuming its an automatic, I suspect the torque converter or the tranny soft pack (belts etc.). Good you have the warranty. This could be 1000's to repair.
  • mucunamucuna Posts: 19
    Keep it in mind that there is a common harness grounding problem exclusive to the 2000 durango. It originates from a failure of the power steering sensor which allows power steering fluid to slowly wick (over a period of months) through the entire ground wiring of the main harness. This creates all kinds of codes and system failures. The worst of these- it affects the readings from the O2 sensors to the PCM creating extremely rich fuel mixtures, soot and poor gas mileage. Another system affected is the idle control (erratic) and engine codes start popping on for the fuel injectors. It is at least a possibility that it could ground out the tranny sensor and create "pending failure" codes (these do not trigger the engine light but show up in the OBD history. These pre-engine light codes can make you fail a smog test.
    Look at "o2 sensor nightmare" message streams in this forum if you want to learn more about this serious flaw in the 2000 durango.
  • MrShift@EdmundsMrShift@Edmunds Posts: 43,626
    man, what a weird problem. Who ever figured THAT one out?
  • dodgeposdodgepos Posts: 1
    After a recent rain, I got into may 2000 Durango and found that the radio, rear wiper, dome lights and power mirror adjustment were no longer working. I checked the fuse panel to the left of the dash and the fuse/relay panel behind the battery in the engine compartment. All the fuses check out ok. I even replaced the radio fuse just in case it was blown where I couldn't see it. Still nothing. Inside the fuse cover there was a notation about circuit breakers????? I could not find where they are located.
    Does anyone know where to find these circuit breaker or do they even exist? What else can I be looking for?
    I bought this used and there was no manual with it.
  • I have a 1998 Dodge Durango , recently I been having trouble starting it in the morning. I therefore went out and replaced the battery , sparkplugs etc. It then started fine for a day or two , but as of yesterday I have been having the same problem. The computer reads error code P1682 , I know what the code means , but cannot find any solutions for it online. What should I do????????????
  • jmr1125jmr1125 Posts: 2
    Last year in the rain I got out of my 2006 with the engine running, opened & shut the hatch and all the locks locked. I thought it was my fault. A few days later, in a heavy rain, my wipers stopped working and my headlights would not turn off and the engine would not stop running with the key out of the ignition. After I got the truck to turn off after driving it around the block in the rain, the lights were going on and off all night long by themselves. What it was -was I had had a windsheild replaced a year before that and they did not seal it correctly and water was pouring onto the computer component and fried it. The dealership had to do wind/air/water seal test on the windsheild to make sure of this and then I had to get a new windsheild. At first the windsheild co. said it was fine but when I explained the liability side of the car turning off or "doing what the compter wanted to do" they changed it no questions asked.
  • gossomerrgossomerr Posts: 1
    edited June 2010
    I have a 1999 Dodge Durange 5.2L SLT. My rear brakes started to lock up. The first thing we found was that the e-brake had come apart and jammed the wheel. That was fixed and didnt resolve the issue. Next we changed the master cylinder. That didn't resolve the issue. Next we have changed the RWAL valve (proportion valve). That has also not resolved the issue. The issue is with both rear wheels. Any suggestions???
  • dee81877dee81877 Posts: 2
    We are having the same problem but the emission light goes on and off. When the emission light goes off, the vehicle drives normal. I have no clue what it could be! Does anyone have any answers?
  • catniprcatnipr Posts: 6
    I just had my car serviced and the mechanic told me that my rear and front differentials and my transfer case has leaks. I just had the rear and front differentials serviced about 6 months ago. It sounds serious and wondered how much it would cost to have this fixed. I have a 2000 4.7 Dodge Durango 4wd and it has about 232,000 miles on it.
  • MrShift@EdmundsMrShift@Edmunds Posts: 43,626
    Well there are "leaks" and then there is a kind of "weeping". If you lift the car and see fluid actually dripping out, or the underside washed with oil streaming back from the XFR case or DIFF, then yeah, you'll be losing considerable fluid over time and you need to attend to it. But if there is only a small damp spot and a minor weep---given the miles on your truck---I think I'd just keep an eye on it and not do anything.
  • catniprcatnipr Posts: 6
    It must just be weeping because there are no spots on the ground. I assume that if was actually leaking then there would be drips on the ground. I will keep an eye on it. Thank you
  • MrShift@EdmundsMrShift@Edmunds Posts: 43,626
    Taking things apart to fix a small "weep" could even make things worse.
  • burdawgburdawg Posts: 1,524
    Are they leaking out of the front seals, the cover, or those rubber plugs they use instead of threaded plugs in the fill/check hole? That would make a difference. A small seal leak isn't a big deal unless you let it go without refilling the differential for a long time. If the cover is leaking then it should be fixed since gravity will cause fluid to come out all the time. If it's the plug, you can just change it yourself (those plugs get old, hard and shrink over time).
  • catniprcatnipr Posts: 6
    I'm not sure. I can't see the front differential unless I get under the car, but the back one seems to be moist around half of it. No drips on the ground though from any of the differentials or the transfer case. I'm not sure where the transfer case is. I am really good about having my car serviced (oil changes) at 3000 miles and they always add to the differentials and transfer case if needed. I just had the differentials serviced about 7000 miles ago. I am due for a transfer case service though.

    If it's the covers that are leaking is that very expensive?
  • ladydee65ladydee65 Posts: 1
    Hi, I'm a female so seeing the engine come on is going to always freak me out. I just got an oil change around early july, the engine light was on then and had it diagnosed and said something with feul injection;so got a fuel injection serv. done 2 weeks ago; then last week the radiator overheated because it was empty( I thougth jiffy lube looked at this); so I bought a new hose and got it flushed; the engine light went off for a couple of days and now it is back on. I had it diagnosed again by a friend and said the codes were reading fuel injection cap off? and emissions leak. About how much will this cost me? It is a 2000 Durango, 153,000 miles.
  • burdawgburdawg Posts: 1,524
    So replacing the hose fixed the problem with the radiator leak?
    Do you know what the codes retrieved were? P0442 is one I was getting on my 2000. It indicates a small leak in the evap control system. One of the hoses had small leak that I repaired.
    If you had codes set for an injector problem then I doubt if a "fuel injection service" would have any lasting effect. Most times the codes are only an indicator of where to start looking, not the actual fault.
  • BreznikBreznik Posts: 3
    My vehicle only has 67 thous on the engine. It has been over heating since I bought it a year ago. It only over heats up hill or when pulling something. I have replaced the thermostat the clutch fan. The water pump is not loose or leaking and the radiator fluid is presteen. When I check the fluid level in the radiator it is full, but the overflow is always empty. After I replaced the clutch fan it stopped. That was last summer, but it just started heating up again. The dial is almost to the H. Anyone have any ideas? Is the radiator too small?
    Debbie :)
  • tietz99tietz99 Posts: 2
    About 2 months ago, our Dodge Durango began making a vibrating type noise when on but only when idling. This noise disappears when one of two things happen (1 when I am moving, or two when I turn off the AC). Anyone else had this issue with a Dodge and know what it could be?
Sign In or Register to comment.