Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Millenia Starting and Stalling Issues

Hi my '95 Mazda Millenia will not start now. It cranks like it's out of fuel, but I checked the fuel gauges and everything looks normal. Could it be a relay of some sort? I had a similar problem with my '99 Honda Accord and I switched out the relay in it and now it starts fine. Someone told me that it could be a fuel pump relay, is there such a relay on my car and if so where would it be? Of course I could have my car taken to a repair shop, but I would like to at least troubleshoot the problem prior to taking it in. I hope someone will provide some answers. Thank you in advance for any help.
«1

Comments

  • Steve,

    I have a '97 Millenia and I had a problem before with my Millennia. Try what I did, put the car in Neutral then start it should help. I am having a problem with it starting today. These things have a characteristic of bad EGR valves. My mechanic is coming over later to fix it and I am having symptoms like the no turn over, dash battery drainage
  • 1995 Mazda Millenia. Some times when you turn on the ignition key the "HOLD" light comes on and the car will not start. The "HOLD" light is the one that is activated at the automatic transmission shift lever that down shifts one gear when you drive. If I turn the ignition key on / off X times the "HOLD" light goes off and the car starts and runs fine. This happens about 2 or 3 times a week. Is this a known problem with Mazda? I am concerned that this problem may some day leave me stranded.
    Thanks for your assistants
  • I just bought a mazda millenia L (1997) It runs great but the gas gauge don't seem to work right. This morning the car wouldn't crank. Waited for 30minute tried again and it crank. could the gas sending unit be going out or someother problems. if any one can help thank in advance
  • wrd88wrd88 Posts: 5
    I recently purchases a 2000 Millenia S. It has only been 1 month and already there are many things wrong with the car. The day after I purchased the car the "Check Engine" light came on. I took the car to my regular mechanic who really had no idea what they were doing since that miller engine was so difficult to work on. I ended up taking it to the nearest Mazda dealership. Since I've had the car I've replaced the fan motor because the car would unexpectedly overheat. Two O2 censors were also replaced totaling about $1,100! A few days after I got my Millenia back the same "Check Engine" light magically appeared again! I took the car back to the dealership where the said that the catalytic converters had to be replaced! Luckly it was still under the 80,000k warranty.
    I still have the car however every time I start it up blue/white smoke comes out of the exhaust, then it quickly stops after the car has idled for a minute. I don't know what to do about this. This is my first car and I don't think I can affort any more repairs! Do I keep the car or do I avaoid future headaches and sell it and get somthing else? The car is beautiful and looks great but if it dosent run then whats the point of keeping it? Someone help!
  • mgillmgill Posts: 4
    I have a 95 millenia not too long ago i change distributor because of sluggest and not advancing,put another one in{used} is better on take off now than before but the distributor still not advancing,has any one ever had that problem before.
  • I was driving down the road and the car began to lose power. Then it picked up again Then a clunk and lots of noise. Had it towed. The harmonic balancer had come off and wedged itself between the crankshaft and the frame.
    Now I am still getting occasional clunking where it feels like the engine for a brief second has stopped completely. It almost feels as if I have hit the brakes pretty hard for a brief second and then it keeps running fine like normal. This is at highway speed. A clunk and jerk all at the same time. At regular speeds when I get to a light, a few times it has just died - then restarted right afterwards.
    I am thinking that the harmonic balancer thing is a symptom and not a cause. Something is freezing the engine for just a second on occasion. Is this something that a bad distributor could cause? I replaced it a year ago with a used one. I can't think of anything else. I don't lose power and everything else runs fine. I can't create a situation that makes it do this - it seems emtirely random.
    It literally feels as if I am just driving along and the whole engine transmission stops for just a fraction of a second.
    Keep in mind that a normal stall won't cause this jerking sudden stop motion. If it just dies, it should coast. This is more like tapping the brake with your left foot while still on the accelerator with the right - except the feeling is from the engine and not the wheels. It's really hard to explain. Any ideas?
  • please please help me- i have had my 01 millenia for a little over a year- it has about 52k and has been great- when i try to start it though it cranks and turns over and sounds asthough it wants to start but just doesnt have the extra oomph to finish the turn over- any ideas or suggestions
  • I have a 1995 millenia, runs great for about 15 to 20 miles the it's like you just shut off the key. I pull it off to the side of the road and wait for about 5 to 10 minutes and it starts right back up!! My mechanic put in a brand new distributor from mazda but it is still doing the same thing. It has 225000 miles everything else works perfect. Please help.
  • foustofousto Posts: 1
    enviroman1
    please tell me the problem
    I have the same one
    fousto@mac.com
  • hello new to the forum. when driving my car and hitting around 2500 RPM, my car starts stalling and jumping, like its missing. just wondering if anyone had any thoughts of what could be causing it.
  • Will crank but won't start. Have no fire at coil. Anyone have this problem??
  • when i drive my car it runs good then out of the blue car dies no power like key was turned off then it will start again sometimes wont start for a day any ideas?
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 44,422
    Bad ignition switch? Faulty alarm system/security system?

    MODERATOR

  • thanks for info i just got the same reply from a friend.but mr shiftright the car owner told me wrong the car will crank over but not start so it is stalling and wont start for a period of time if you have any advice would love to hear from you thanks again
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 44,422
    sounds like some kind of sensor fading in and out of consciousness? He'd need to do a diagnostic code reading for starters (no pun intended). No starts can be a gazillion things, so one has to work by elimination and establishing basics. Like, when it won't start, someone needs to a) check for spark and b) put a fuel pressure gauge on the fuel rail.

    MODERATOR

  • ok I understand we are in that process now testing tps and sort and as far as the codes my so called help cleared codes so need to run so all monitors can run self tests and no pun taken here. am just picking up where someone else left off and just miss comunication on the symptoms of how it was running or not.so thanks again for you time this is a great site
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 44,422
    Good. Methodical approaches and patience usually pay off in these intermittent sort of issues. Intermittents are a real challenge even for the best of mechanics.

    MODERATOR

  • ckoneckone Posts: 2
    checked distributer /cam sensor housings no cracks.if i spray engine with water no problems itll keep running. if i use a spray bottle and mist the entire engine. after the entire engine is coated car stalls. once the moistue leaves car will start and run fine even at high rpms no sputtering. covered previous mentioned housings in die electric grease as well as some wire harnesses still have problem. sont want to waste 600 for a new distributer if thats not the culprit
    please help
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 44,422
    Could you cover the distributor in plastic and mist the engine and see what happens then?

    MODERATOR

  • ckoneckone Posts: 2
    I found seal on inside of distributor was worn down
    and found moisture rust and corrosion on the inside
    So Im just gonna rePlace it thanks
«1
Sign In or Register to comment.