Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Millenia Starting and Stalling Issues

2»

Comments

  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 44,404
    Sounds like a good bet there.

    MODERATOR

  • kimraj2kimraj2 Posts: 1
    i have a 1999 mazda mellinia s series. all the lights comes on , on the dash when i turn the key to start the engine but the starter wouldn't turn, check all the fuses, thats ok. please help.

    thanks
  • davey97davey97 Posts: 1
    I have a '95 Millenia S, with the same problems. At first I thought maybe it was the neutral safety switch. I won't turn over when the interior of the car gets hot. So what I've been doing is I turn the key to ACC, put on the brakes and shift the gear into N. It normally starts when I do that. I normally encounter this problem when the car has been sitting in the sun, right around noon to late afternoon, in the summer.
    Now I'm thinking it might be something under the dash, because the neutral/safety switch should be on the linkage where it connects to the tranny.
    Does anyone else have the same problem?
  • fordnaticfordnatic Posts: 2
    Did anyone ever awnser this problem ? I have the same problem. I'm new too edmunds and don't know exactly what I'm doin so laugh at me if I'm not figuing this out.
  • annette71annette71 Posts: 1
    I too have this problem, were you able to resolve the issue? I am wondering if the air intake hose can be a culprit? I noticed it was cracked and was hoping that might be it???? Thanks for any help you may be able to offer.
  • fordnaticfordnatic Posts: 2
    I could manually cause the car to have the same problem just by unplugging the mass air flow sensor.
  • Did you ever solve your problem of jerking. I also have this problem with my 2002 Millenia and my mechanic cannot decide what it is. A reply would be greatly appreciated.
  • I have a 2000 type s and the car drove fine i went inside a buddy's house and came out to start it and when i turn the key all lights come on but the car will not turn over i looked under the hood to see if any of the belts was off or any wires was disconnected and all was good but did notice that the two timing covers on the side of the motor looks like they was pushed out so idk what to thank at this point if anyone else know any info please let me know thank u
2»
Sign In or Register to comment.