Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Jeep Commander Maintenance and Repair

1678911

Comments

  • jaynbayjaynbay Posts: 6
    Check the starter. Commanders seem to have a lot of issues with the starter. I have an 06 Limited with the 5.7 Hemi and had the same problems with it not starting. We had the starter replaced and have not had any issues since.
  • lowenivylowenivy Posts: 14
    Hi Jaynbay, Thanks for the info... I'll check the starter then and will update you. I hope I could troubleshoot it ASAP.
  • lowenivylowenivy Posts: 14
    Hi Jaynbay, I left the jeep on the driveway for approximately 24 hours with the battery cable untapped. Then it was time for me to call a flatbed for an ICU trip, but before doing so, I installed the battery cables back and tried to switch on the ignition. Lo and behold!!! It cranked just once and surprisingly worked fine. I left the engine running for 4 minutes and shut it off, then re-started it once again and everything went back to normal. Meaning, it wasn't a problem on the starter but maybe on the computer or the wiring to the starter getting sweaty due to hot & humid Summer weather. A friend of mine suggested to replace the battery cable bolt with a quick release system so anytime the jeep won't start, it is just easy to take off the battery cable without any tools, just a flick of your finger. I did replace mine with that and sure it was easy.
    I browsed Ebay for that quick release battery bolt and sells like $22.00. It's on the battery category sold by a seller "mihmasa". It really works.
    I am really worried when will I get stucked again!! Thanks for your advise Jaynbay, It helped me a lot by tinkering the jeep for a while before deciding to call a car doctor. Regards..
  • lowenivylowenivy Posts: 14
    All doors on my '08 Jeep with 42k miles on it squeaks so loud when being opened and closed, sometimes it sounds like a frog croaking. I did everything from greasing the hinges and springs. Cleaned them first with WD40, wiped them clean and applied some grease. It works for 2-3 days and then the squeaking noise comes back. My '95 Honda Passport does not make that sound and never had been greased for 15 years. The weather here in Chicago is hot and humid nowadays, just wondering why. The noise started a year ago and when I park and get off the car, the guy next to me turns around to see what's the squeaking sound and I say I have a mouse in my trunk.
  • Here I am once again and for the last time, it will be the end of making comments in this column. After my previous write up here, (especially due to STARTING PROBLEMS FOR 6 TIMES), unplugging the battery with the newly installed quick release clamps, the Jeep Commander (2008 – Sport 4WD - 6cyl.- 42K miles) started without hesitation at first try, but it took 12 hours before it came back to normal, I drove it for two days and it was fine. So all along I thought the problem was just minimal and was relieved of my headaches. We went shopping to a Walmart Store one weekend and parked the Jeep for 2 hours on a parking lot, unfortunately, it did not start again. No cranking, no sound nor click on the hood, just a faint humming sound underneath the front passenger seat, is it the computer or MAP? We got stuck up for 3 long hours waiting for a towing service with flatbed just to get my truck dumped on my driveway. I inquired the tow truck driver how many Jeep Commander he had towed, and the reply was “countless”, and advised us to trade-it-in immediately ‘coz it’s a scrap.
    Again, I disconnected the ground pole of the battery and surprisingly, it started the following day. It’s really so unpredictable.., so it was time again to visit the Jeep “fortune teller” for the fourth time. He checked on the battery and was good (2 month old, I had it replaced thinking it was the problem), checked on the starter, it was cranking. Plugged it to a computer module, and he says no problem at all. Then here comes the fortune telling: The gas I was using might have a higher octane, or the gas cap was not closed properly, or the sub woofer was not well installed. He tried to use my spare key fob and still does not start. After consuming 5 cups of free coffee inside the Jeep dealership and 4 hours of endless waiting, it started once again and the “fortune teller” says nothing is wrong. Yeah, right. My warranty was still enforced. But what about the guy also waiting for his ‘06 Commander being “fixed”? His warranty expired and was very worried of the many parts to be replaced.
    I left the Jeep Dealer in a hurry and without any second thought, I proceeded to another dealer to negotiate a trade-in right away. Comment of the dealer across the street? The Jeep Commander is a JUNK!
    NOW I KNOW WHAT A JEEP IS, THAT IS WHY I NOW DRIVE A 4 RUNNER!!!
    Whew… What a great sigh of relief !!!
    Note to all Prospective Jeep Commander Buyers…”THINK countless times first & check out for NEGATIVE REVIEWS, before you buy it to avoid this worst nightmare that I EVER had”.
  • Runners also have many problems! From these forums...

    I have a 2007 4 runner. After shutting the vehicle off and letting it sit for a few minutes, when I try and start it, it cranks over and over without starting. When I turn it off and start again, it works. I only have 11,000 miles on it and it is still under warantee.

    What the Heck
    My 2010 Toyota 4runner has been to two different dealerships a total of 4b times and I am getting the same [non-permissible content removed] from them.
    Toyota has to know there is a major problem and is covering it up.
    I am about to go to a third party and sue them.

    I even gave them the TSB # to correct the problem and they ignored it.
    They have been told to hide the problem.

    A 32,000 vehicle should not shift like a tractor

    * digg
    * delicious
    * stumbleupon
    * netscape
    * addthis

    * Replies to this message: edpol (Sep 16, 2010 3:35 pm)

    #216 of 224
    Re: 09 4Runner Trans Problem [edpol] by lee363
    Sep 16, 2010 (2:04 pm)
    Reply

    Replying to: edpol (Jul 05, 2010 9:22 am)
    I have an 09 4Runner. The dealership kept the vehicle overnight to check the transmission fluid. They said it was low and topped it off. The hesitation in shifting diminished significantly but has not gone away entirely.

    * digg
    * delicious
    * stumbleupon
    * netscape
    * addthis

    #217 of 224
    Re: Same Story Again [sawmecoming] by edpol
    Sep 16, 2010 (3:35 pm)
    Reply

    Replying to: sawmecoming (Sep 16, 2010 11:51 am)
    I agree 100%!! Mine is a May, 2009 4Runner and had what feels like trans problem since day-one! I have been in close contact with my dealership service manager and e-mail her all of the comments I read so she can keep record. I have file a complaint with the national highway assn and Toyota and sent the TSB# also. I got some form letter from Toyota thanking me for my concern. Something has to be done. I was told at one point that, with time, the problem will get better, but that isn't what happened. If anything, it's getting worse. Now it bogs down when I have to accellerate quickly not just when turning a corner, and I can't get out of the way fast enough. This happened to me in heavy Houston traffic the other day, and scared me to death. I guess an accident has to happen before they take serious notice. Please continue to comment on this site about any results you get. I refuse to give up! Like you said, a $32,000 vehicle should run perfectly, period. For them to keep telling me that's just the way they are made, is insulting.
  • I have a 2008 Jeep Commander (30,000 miles) that has had an ongoing problem. After driving somewhere and you park, then return after doing whatever, it won't start. Battery is good, turn key and dash lights up but no click, nothing... I've had it towed to the dealer 4 times now for repair.

    1st time- loose wire
    2nd time-bad connector
    3rd time- starter replaced
    4th time- another bad connection

    Anyone else having issues like this? As of now my wife won't drive it anymore due to fear of being stranded with our 2 year old (can't really blame her since it has happened 4 times within the last year). She has been on the phone multiple times with Chrysler with no solution in sight, "It's fixed." they say, I say "Sure it is, see you next month when it breaks down again..."
  • Hi there! We have exactly the same issues with our 2008 Commander & it was really a nightmare especially when you have a very important appointment & you're ready to go & tadah...it wont even crank. & you don't know what to do.. When we still had it, we're always anxious to use it 'coz you never know when it will ever start or not. That is why on our last Towing Service backed up by the Towing Driver, saying he had a countless number of Jeep Commanders being towed & you better get rid of it immediately. We never had a second thought & took heed of his advise. On the next day, we right away went to a Car Dealer & finally decided to trade it in for a new car. Well, what do you expect, we had the Jeep towed again just to reach the Dealer. 'coz, as usual., it really won't start. Moreover, we also had a friend working at a Jeep Chrysler Dealer & he said that we made the Best decision ever. Wheww...what a great sigh of relief indeed !.So my advise to you too is.."You better get rid of your 2008 Jeep Commander ASAP or your problem will never end ".
  • Ihave the same problem as yours now, granted my radio did not shorted out until now but had a water leak since the beginning. Of course your's got fixed cuz still under warranty but what else did they tell you about the root cause of the problem?

    thanks.
  • coop23coop23 Posts: 2
    edited October 2010
    I have a 2007 Commander. Bought it used with 8k miles on it. LOVED IT...but now want to get rid of it. The first issue started with the 4WD light. This dashboard comes on and off. Recently, the ABS and traction control light come on at the same time as the 4wd. This happened going over speed bumps...or slowing down. NOW, my car is having brake issues...as if the ABS is no longer functioning. When the car brakes are checked...they are "just fine". there have been 4 recalls about brakes in this year and model...all electronic related. Only one is valid for my particular VIN#. But, my car is clearly having the issues of the other recalls. My point is...the 4wd light was just the begining....give it a year and I guarantee you will have MANY more warning lights come on...then your car will either slow while driving or brakes won't work.
  • coop23coop23 Posts: 2
    Oh my goodness. this website is like a support group. I love it! I felt like I had all these issues that I have been describing to the car dealers, that of course you cannot replicate in front of them. And, they look at you like your an idiot! YES! my autoclose on my car windows will reverse too if the sunroof is closing at teh same time. not to mention 8 million other electronic issues. Of course I have to warranty there is only 1 recall for my particular VIN #...which I have already had repaired. I hate my Jeep!
  • itabotitabot Posts: 105
    I noticed during rain storm that socked the east coast about a month ago that the foot well of the front passenger side was soaking wet. I noticed this when a handbag ($1,500.00) that I had placed there came back soaking and according to the stockist, destroyed. I thought maybe because this has never happened before that it was just such a uniquely horrible storm and that this was a one time incident. And, a $1,500 bag is nothing compared to what others lost in the storm.

    But now it is happening every time that it rains to point that yesterday i got into car and ended up scooping out the water with a cup. Then went to splash car wash had them get as much of the moisture out as they could at a charge of $70.

    Has anyone else had problems with windshields on commander. I remember reading someone else did a couple of years ago. I want to know how that leaking windshield was finally totally repaired. Thank you.
  • itabotitabot Posts: 105
    Now having same problem as you did with windshield whistling since 3rd install by SafeLite, and as of the last month, also dashboard leaking. Safelite auto replaced windshield last year after they couldn't rub the window chip out (rock hit car on highway).

    Tomorrow will be trip #4 with safelite auto because the water is ending up in the footwell of passenger side.

    Safelite's install was obv. a problem from the start - you could see the banding around the window was coming undone prompting me to bring it in 2nd time; 3rd time I brought it in because of whistling sound, and 4th time, tomorrow, I will be bringing it in because of water leaking in.

    Please tell me how did you finally get the windshield fixed so that it stopped leaking and stopped whistling? And, if you don't mind, can you tell me which safelite auto did this so that I can tell the NYC location I will be at tomorrow how the windshield eventually was installed correctly?

    thank you!
  • jaynbayjaynbay Posts: 6
    We had a similar issue with our Commander, but it was due to a leaking sun roof and not the windshield. Every time it rained hard, the passenger floor board would fill with water. After a couple of unsuccessful attempts by the dealer to fix the problem, the dealer had to totally replace the sun roof. Fortunately, it was under warranty. This was just the first of many strange issues we had with our 5.7 limited 4X4. I solved all issues with the vehicle a couple of weeks ago by trading it off for a new Tahoe. I now sleep much better at night. I loved the Jeep when it was functioning properly, but couldn't stand having to constantly worry about what was going to go wrong with it next.
  • heiressmj or anyone else,
    I have this same issue where the amplifier seems to have just "died."
    Is there a replacement amp or do you know what you replaced it with?
    Thanks!
  • cgchriscgchris Posts: 1
    So my battery died and couldn't start it so checked the battery and it was bad. I bought a new one, replaced it and started it. I put it in drive stepped on gas peddle and it didn't go. Put it in park and tried to rev the engine and nothing. I replaced the peddle and same problem. I replaced the throttle body and tried to relearn the computer and nothing... So $400 latr and not being able to return the parts because they are electric parts I'm out of ideas. Any have any ideas... I'm tempted to tow it to the dealer and spend what they are gonna charge me to put it on the comPuter.
  • wew1wew1 Posts: 1
    I have a 2006 commander door pulls pull off door panel
  • I have two issues with the commander! Won't start and windshield leaking. Can't wait to unload this piece of crap truck!
  • I just bought a Jeep Commander. I am scared!!
  • steverstever Ex Yooper, just arrived in New MexicoPosts: 40,547
    People who aren't having issues don't tend to post. Overall reliability has been pretty good for the '06 - '08 models, according to Identifix.

    Moderator
    Need help navigating? stever@edmunds.com - or send a private message by clicking on my name.

  • inuvikinuvik Posts: 131
    I've had no issues with my 2010 Commander Sport. No visits to the dealer for any quality issues. We love it!
  • Enjoy! Mine has been happy ever since I replaced every component possible. I would suggest a third party extended warranty when factory's ends. Just in case.
  • 2006 3.7, purchased new and only has 35K on it ( I really don't drive much which is probably a good thing). Sorry to hear about your troubles. I am way past leaking windshield, cracked windshield (3 times), whistling windshield, bad blow motor, won't start, will start, won't start, panel lights that come on for no reason (no reason according to the stealership), abismally stained seat coverings, windows that go up and down by themselves, exterior paint that scratches with a fingernail, disappearing antifreeze. I am now up to a transmission that is leaking onto the driveway. Yay for me.
  • I have a 2006 Jeep Commander 4.7L. bought it at Peel Chrysler (Mississauga, Canada). Had tire indicator problem for one tire.... would not indicate tire pressure, took it to dealership and they replaced/recalibrated the sensor $$$.
    As of today I'm having intermittent starting problems...... All the dashboard lights and blower motor turn on when the key is in the ON position but the vehicle just wont start!!! The past few times this has happened, all I would have to do is to wait 24-36 hours and the vehicle would start with no problem??? Although when it does start the blower motor will sporadically turn on and off.... Cant wait for the cold weather to begin. OH yes, almost forgot to mention that since the first month that I've owned the vehicle (3 years) I have had transmission problems...... It seems to take a freakashly long period of time to switch from first to second gear. At times I wonder if my transmission is about to explode?! But when it finally does shift into second, the following gear shifts are effortless??? Brought it back to the dealership twice for this same problem and each time they so called "fixed" the problem it would reoccur a few weeks later. They revised the software the first time and replaced the filter the second time (not covered under warranty). This went on until my extended warranty expired and I dont want to have to use my hard earned money to pay for them to fix and not repair my problem!!! So to this day I truly believe that the only way to resolve my problems is to get rid of the CRAPPY COMMANDER and NEVER, EVER PURCHASE another CHRYSLER VEHICLE EVER AGAIN!!!

    Good Luck to all the Commander owners out there.
  • Love your sense of humour!!! I guess if you cant drive it, you might as well laugh about ( at ) it.

    Cheers.
  • Okay, so same problems. Start, no start, start, no start. Tire problem, no problem, leaking windsheild, easily scratched paint you name it. I still love the car, I am just angry that no one seems to know what the hell is wrong here. At this moment I finally had mine towed to the dealership after being stuck in a freezing ice box at the gas station. Oh yes, filled her up and then she repayed me by not starting. Same thing will not start, however, all of the other features come on. When I go to turn it off the computer says the transmission is overheated when it is clear that this could not possibly be true. So at this moment I am paying $100 hr. for confused mechanics. Any advice? :lemon: :lemon: :lemon: :cry:
  • Yes, get an aftermarket service contract. We got a good one for 2,500 or so, which will take us through 100k miles. Of course, nothing has gone wrong since the initial slate of troubles, probably because every computer component in the car was replaced. Leather seat is starting to crack on driver's side, though - unacceptable at 50k miles.

    Good luck!
  • We bought a 2006 Jeep Commander 5.7L in July. We like it but it could get better gas mileage, we average about 12.7MPG. Have noticed some engine hesitations while going 30-40 MPH and engine at 1-1.5k RPM. Not sure if this is causing the below average mileage or not.

    Also, I only read a few posts and noticed alot of engine not starting issues. I wonder if anyone has found that there are some recalls on various Jeep Commanders. One notably for engine stalls. Here's a link.

    http://www.lemonauto.com/complaints/daimler_chrysler/jeep_commander.htm
  • itabotitabot Posts: 105
    I've also replaced many components. Now, today, the radio - the buttons on the bottom of the radio panel - are not functioning. The radio display has been flashing for about 3 years now but I have not had it replaced deciding instead to replace parts that were keeping the jeep from starting, running without talking, etc.

    Have you ever had this radio problem? If you did, what was the solution? I'm worried about cost of - not even the repair - but the time it will take the audio repair shop to determine the problem; I haven't been able to find audio repair with jeep commander experience.

    Thank you!
  • I also have a 06 jeep commander & have been having the same exact problem with the jerking when I reach 60mph. The engine light comes on after it jerks Everytime. My husband is deployed right now so I've taken it to several mahcanic/dealers & no one can seems to find the problem, I get a different solution to whats wrong everywhere I go. Finally my friends husband came home from deployment who is a mechanic and told me it was the transmission. I've been waiting to figure the problem out for some time now, so now the end result... now my transmission completely gave out & I'm basically carless at the moment.
Sign In or Register to comment.