Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Jeep Commander Maintenance and Repair

11214161718

Comments

  • gigagirlgigagirl Posts: 21
    Sameye, hello - I went through that exact situation and live in the midwest hence water during fall/winter turned into ice and not just water and/or foot bathes as it were! No matter - all was finally rectified - please read my transmission regarding this about three plus months back.

    All the best,
    Debbie-
  • tidestertidester Posts: 10,110
    please read my transmission regarding this about three plus months back.

    Would this be the one? http://townhall-talk.edmunds.com/direct/view/.efdb98e/259

    tidester, host
    SUVs and Smart Shopper
  • gigagirlgigagirl Posts: 21
    Yes, that would be the one! It has all been taken care of due to the slits being placed in the door gaskets - about 6 or so on each door gasket (as the newer models now have).
    Best,
  • gigagirlgigagirl Posts: 21
    I have posted prior - the one that had the massive water in the door sills which turned into ice and doors wouldn't open etc. - finally after much back and forth got to the bottom of it!

    Like almost one year ago when we were returning from Door County and stopped in Sheboygan to get gas - we turned the car off and it would not even turn over - had to have it flatbedded to Libertyville! That was electrical and was then fixed.

    Now...for the past month have reencountered similar issues. At a home depot came out to the car and it wouldn't turn over - would not start - dashboard lights came on - radio - on but the car wouldn't turn over - a slight clicking sound was heard. Let it sit while steaming calling my husband to contact my dealership to pick the ..car up and about 25 minutes later while sitting there - low and behold the darn thing turned on. Immediately drove it to our driveway and was picked up to return to our office - not trusting it. The following day went out and the thing turned on like normal.

    This past weekend - while in Wheaton went to leave from a relatives home and the car would not - again - start up and/or even turn over - nothing - again dash board lights on - radio on - but nothing and this time no clicking noise to be heard. About 2.5 hours later - trying same again - the darn thing started back up - my husband and I immediately high-tailed it home and parked the car in the driveway. Sunday came (yesterday) and we tried the car and again it started right up like nothing ever happened!!!

    Bottom line - once bitten by a dog I guess...but the mobile is being brought in to the dealership and we do not want it back until which time as someone has determined what the heck is occurring!

    Anyone else go through this one - this commander is an '07 with only 19,500 miles on it, what a piece of work!!!
  • itabotitabot Posts: 105
    Let me know if you find out what the problem is. You see that (below is e-mail going to Chrysler-Jeep-Dodge in Michigan) i had similiar problem and they told me that it was the starter. Now, and i haven't addressed this with chrysler yet, i am driving this jeep with the fresh oil change and new starter and where on the dash the D - indicating Drive - is usually lit up it shows me that i'm in 1 and the RPM are climbing. i pull in shut off and start over and the car is fine. And i really thought that this car would be a long term investment; otherwise, for what i payed for it, i should have just gotten a small BMW and called it a day.

    Follow up to Phone Call This Afternoon:

    I've already spoken with: 1. a friend who the same dealer's sales people acknowledge was set to buy another car from the them in cash (a sebring convertible), and 2. financial analysts following the current state of the auto-industry and Chrysler in particular, i.e., in addition to reviewing the following within your customer service department, I'd also cc your investor relations department.

    The Situation:
    I purchased slightly used car (Jeep Commander) from the Jeep Dealer in Westport, CT in October 2008. It was working well enough - with exception of radio light flashing - until the day after I picked it up from an oil change service. The service was last Thursday, July 23. The problems started Friday, July 24.
    The day after I picked car up from the oil service the starter apparently failed. While stranded with a car that wouldn't start, The dealer told me to call Road Side Emergency Assistance and while The Service Department couldn't give me that number themselves, I had the Emergency Road Side Service Cards that the same dealership had given to me when I purchased the car. They gave me these cards when they gave me the keys.

    Only when I phoned The Emergency Road Side Service they told me that the cards were no good because they expired one month before I purchcased the car!!!

    So, another local resident who is waiting with me at the local Starbucks where about 7 people have gathered wondering what could be wrong with this Jeep that looks so new especially after I told them that it only had 30k miles on it, calls a tow truck and I pay for tow on my own ($90).

    Then back at The Dealership, they have me waiting for hours while they try to locate the paperwork for my car. What they discover is that the salesman who left a month or so after I purchased the car never entered my paperwork; the result: i am not in the system. They explained to me that I needed to understand that as far as they knew on the day that I purchased the car, they thought were being shut down the following month, so things were sort of crazy, some paperwork didn't get entered, etc.

    So, while they believe I didn't steal the car off of The Lot, they aren't sure that the starter is covered under the warranty. I remind them that at time of sale I was told that (and my brother who covers the auto industry from a financial markets perspective was told that) The Warranty they were giving me on the used car covered everything except the tires and windshield wipers in addition to the power train warranty of (8) years/(80)k miles. However, what they insisted on when the starter needed replacing, was that i had the warranty that required i provide a $100 deductible.

    So, i give them the $100 + 6% tax, as well as having paid for the tow of $90. Only now they are telling me that they can't find any indication in the paperwork -again, never entered into the computer system as is their regular practice - that indicates that I have any warranty at all!!!

    And that is not acceptable.

    As I told them 1. I would not be so dumb as to buy a used car without an extended warranty; 2. they should not be so dumb as to sell one without one; 3. they gave me cards for road side service that expired one month before i purchased the car; 4. they should be ashamed of themselves and apologizng to me for selling me a car with a bad starter, I should not be working so hard to get it covered by a warranty; 5. i could accept the starter not being covered under a particular warranty but i will not accept no warranty at all on a used car that has under 36k miles on it; 6. the car is going in for a $1500-1600 30k mile servicing - none of which is covered - during the last week of August, but if I don't have a warranty on anything I'm certainly not having it serviced at a jeep dealership, and 7. the friend who met me at The Dealership and who gave me a ride there while The Jeep was being towed was about to pay cash for a new sebring there but because i'm receiving this sort of treatment he's holding back on doing so. Regarding this friend, his family and he have always purchased - in cash - thier trucks and now their sebring convertibles from this dealership, but seeing the difficulty that i'm enduring he's holding back; the dealerships salespeople can attest to this.

    Short of Long: I expect the warranty on this car that i was told i had on it, i.e., the comprehensive 6 year/60k in addition to the 8 year/80k power train warranty. I also expect - if they want me to do business with them that is not covered - a discount on my 30k servicing to compensate me for all of this inconvenience.

    I paid a very large price for this car and I purchased within a dealership - which costs more than not doing so - because of the warrantys! So please contact me and let me know what next steps to take.
  • gigagirlgigagirl Posts: 21
    wow...and I thought I had commander problems! I will let you know what transpires - my infamous commander is due to hit the garage again..... and typically when it does it is there for almost a week each time mind you - any-who it goes in Thursday (provided it starts if not it will be flatbedded). Thereafter next week sometime I'll make a post - hopefully with a conclusion. Trying to keep the faith here!

    Sorry for all you have been enduring - that is maddening to say the least! Yes, we both should have gotten a BMW - for me it would have been my second - had one back in the day and am considering it again perhaps next year.

    Best,
    Debbie-
  • Just bought a 2008 jeep commander. No problems yet. However, the blue tooth buttons above the radio, for U-Connect, says "U-connect" unavailable when pushed. What do I have to buy/install to activate my hands free device? I have bluetooth for my cell in my other vehicle which is great. This one is for my wife and she really needs blue tooth as much as she talks?
  • Yup - happened today with our 2007 Commander Limited w/ Hemi. This after a week of trying to chase down sticking in 4th gear problem. Just had it towed back to dealer service. Thinking Lemon Law,
  • Trite but can't help myself - welcome to the club - I have gone through this twice in the past year - it happened that again (within one year) it appears to be the 'starter'. Interestingly the last post placed by me regarding this - I have been so darn disgusted I decided I wouldn't even follow it up - but then your message - hence response. I was told the last time we brought it in - until the jeep died again they wouldn't be able to duplicate anything! Well someone must have been listening - as the darn thing died right in the entry way of the dealership - couldn't have asked for better! Sorry you are encountering same - a year back had to have it flatbedded back from Sheboygan to Libertyville, IL as it was a Sunday afternoon & everything locally was closed and I run a business. Anyway have them check the starter - ridiculous as it sounds to us, this done twice in one year - it appears that is the problem with this commander I've got. Again it's a 2007 - bought it new - and mind you has less than 20,000 miles as my office is but 3 minutes from my home! Best,
  • Thanks for your welcome and response. Funny you should mention - just got off of phone w/ dealer service: They started the Commander right up this a.m. and could not find any diagnostic code. I will call back and suggest they actually take a look at a mechanical not software based cause... the starter.

    BTW, this on the heels of 3 trips to service last week to diagnose why car is sticking in fourth gear. Love this vehicle (Limited, 5.7 Hemi), but considering going down replacement road, hopefully w/o invoking Lemon Law...

    Thanks again!
  • Did I mention that we bought w/ 4200 miles on it, now has 9100?
  • i bought a 2008 commander in 8/08. it had to be flat bedded to dealer in 2/09 because first the radio/phone/navigation system went dead. after a day the car would not start at all, completely dead. it just went in for the 5th time in 7 mos. the dealer replaced the radio system twice didn't work. they think it is a intermittent software problem. they said that the computer shuts the radio down because it senses a problem so it shuts down the least critical system. but the problem is that it also causes a drain on the battery- eventually going dead!! i contacted a lawyer. any advice???
  • Erie, PA
    11/3/08
    search under Rumsey, Joann

    The newspapers describe it all and pictures speak a thousand words.
    This 2007 Jeep Commander crashed by stallling at a high speed claiming the lives of a young woman 40 years old and her 2 children who were 4 yrs old and 18 months old.
    Please search and review this incident before selecting to put your family in a brand new Jeep Vehicle. A 5 star crash rating will not do much good if the vehicle stalls at a high speed and the driver is unable to control such vehicle.
    Please, if you have a family review this before purchasing a Jeep Product
  • Hello, I've had the same problems posted here as it relates to the whistling windshields and the Water in the Dash.
    The whistling windshield though I didn't know that it was a common problem. Mine didn't start until I had the windshield replaced from a stone chip. I had SafeLite AutoGlass out to replace the windshield 4 times - thinking it was their faulty work. It's now fixed and I haven't had a problem since.
    The water in the dash I was told was from a clogged drain in the sun roof. But I had sooooo much water it actually shorted out the speakers. Got that fixed.

    Now the new prob... Had some crackling in the speakers and then no audio at all. Took it to the dealer and was told it needed an update. After nearly 2 hours of labor they tell me its not an update that the Amplifier was "burnt" and so were the feed wires. Everything was blackened. and it was going to cost 700 plus to fix it.

    Well I bought the extended 100k warranty and was then told that I didn't buy a Chrysler warranty from the original Jeep Dealer but some after market crap and the "new" dealer wasn't going to honor it. After hours of going back and forth the dealer agreed to honor the warranty but then had the audacity to tell me they went over the allocated amount of claimable warranty hours and that I was expected to pay this. I wound up NOT paying it but good grief this has been agrevating.

    I'm thinking at this point that the amplifier went due to the previous water issue but no one will tell me. I'm somewhat mechanically inclined and know that to have this arching problem there's something seriously wrong somewhere with the electrical in general or that there is water. And I'm now very concerned since I have this 3rd party warranty instead of a real Jeep Warranty.

    Any thoughts from the peanut gallery.
  • I was wondering if you ever got the starting issue resolved. I have an 06 Limited and am experiencing the same issues as it occassionally will not start. Took it in to the dealer and they could not replicate the issue. thanks
  • Yes, I did, thank you. Replacing the starter and pretty much all the modules seems to have fixed the issue. Luckily ours is still under warranty so "gee, let's try replacing this" approach is still possible. Dealers could not replicate. Actually, it did happen once since and I sat there, breathed in and out three times, removed key, tapped steering wheel, prayed - then it started right up.
  • for my 2007 - twice it was the starter switch - twice in one year -

    Now separately and recently all the advisory lights for service 4wd kept popping on -brought it in they replaced the brake switch (seemed odd to us a brake switch) but anyway two weeks later the same thing happened again and they had me bring it back in overnight and again replaced the brake switch!!

    Hope that helps - good luck!
  • I have a 2006 Jeep Commander, 3.7, 4x4 with 22K original miles.This truck has multiple problems. Right now it is sitting in the driveway leaking fluids. The most fluid leaking is yellowish and oily feeling. Tons of it. My son checked the fluid resevoirs and discovered that the power steering fluid keeps disappearing as well. This truck will not start right now. When I turn the key all the dashboard lights come on but the truck doesn't turn over. The "not starting" has been going on for a couple of months. It has been flatbedded home twice. I go out to start it and it starts like nothing is wrong. I get in to start it to go back home....won't start. I have had it in to be looked at but it started each time the mechanic turned the key. (go figure). The very last time it started there was a loud rumbling coming from somewhere under the car. In addition, the windshield wiper fluid won't spray. The fluid resevoir is full but the liquid won't come out. In addition addition, when backing up, the back up bells ring even when there is nothing in the vicinity of the truck. Also. My dashboard tire light is always on. Never goes off. I have had it in to the dealer for this. Dealer claimed it was fixed but the light came back on and has been on since.The last time I brought the truck in for service it ended up costing me $700.00 and I only wanted a yearly sticker. Before I bring it in for service I am hoping that someone can give me an idea of what all these problems stem from. Things have changed since 2006. I am now on a fixed income and can't afford these dealer visits at $700.00+ a pop. Any help or advise would be greatly appreciated.
  • Hi...I am having the same problem with my 2006. Jerking around 40 mph. It's been to the dealership twice this month and they can't diagnose it. Did you ever have any luck?
  • Sorry. I am in the midst of these issues right now. I haven't put it in the shop yet. My car is undriveable. It will be flatbedded to the shop this Wednesday. I will post back if the shop finds the problem. Right now I am trembling in my boots over how much money this excursion to the shop is going to cost.

    I wish Edmunds.com (or anyone) could post a list of reputable mechanics on a state by state by city basis. Then it wouldn't hurt so much when we hand over $700 plus for car problems because we would know that the job was done right.
Sign In or Register to comment.