Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Honda Accord (1990-1993) Maintenance and Repair

19091939596103

Comments

  • cybercoolcybercool Posts: 117
    Hi
    When the TCM light (D4 light) flickers from time to time and drives at low gear, most likely it's a bad TCM unit correct? One mechanic tells me it's the solenoids that may need replacing. Is this true?

    My TCM light has been on the blink for a while now and I'd like to get it fixed.
    Thanks
    Cybercool
  • I wrote a small book explaining the possible solution. Then when I was looking for the TCM fault codes I found a good source of reading material for you to check out. This better explains what I was going to say.

    http://techauto.awardspace.com/transmission.html
  • lizz1234lizz1234 Posts: 13
    So recently, I noticed my car is having a hard time shifting on it's own. I have to take my foot off the gas and floor it for it to shift. I think I need a new transmission, but someone said it could just need new transmission fluid. How do I know?
  • elroy5elroy5 Posts: 3,741
    First, I would drain 3 quarts of fluid out, and see what it looks like. If the fluid is dark, and there is a glob of metal attached to the drain plug magnet, it should be changed (I would use Honda ATF-Z1 fluid). Since you can only drain about half of the fluid, there will still be some old fluid in the transmission. If the shifting improves, you may want to drain and fill 3 quarts a couple more times. If the fluid was really bad, you could try taking the shift solenoids off, and cleaning the solenoids and screens (I would use carb cleaner). If the D4 light is blinking, there is probably a fault code stored in the computer, which will give you an idea where to start, to solve the problem. The link posted above has a great deal of information about 4th gen Accords (90-93), and has diagnostic information, so you can test the parts before replacing them.
  • elroy5elroy5 Posts: 3,741
    cybercool,
    When the TCM is bad, the D4 light will usually stay on constantly (not just blink). You may just need to do a fluid drain and fill, and maybe clean the solenoids and screens. This link has a wealth of information you can use to find the problem. Good luck
    http://techauto.awardspace.com/transmission.html
  • lizz1234lizz1234 Posts: 13
    So lately my car has been shutting off when I come to complete stops. I've noticed it more if it's colder outside and I don't let it warm up for about five minutes. It was tolerable before, because it would turn off once, and I'd just start it back up and be fine...but lately it's been getting worse. The most it's turned off on me is four times, and I'm not sure what the problem is.
  • I'm just throwing things out here but when was the last time the fuel filter was replaced? How does the car run when it is warm? Does it idle rough when you initially start the vehicle before you start to drive it? Have you noticed any other things going on at any time when the vehicle is on? Is the check engine light coming on at all?
  • lizz1234lizz1234 Posts: 13
    I'm not sure when the fuel filter was last replaced. Nor do I know where it is or how to know if it needs replacing :( When my car is warmed up, it runs just fine. I want to say about 50% of the time when I start my car it idles rough, and even after I start driving it, once I stop at like a stop sign or red light it'll still idle until I've been driving for a few minutes. The only other thing I've noticed when my car is on is sometimes when I press on the gas after leaving a stop sign it seems like my car isn't recognizing that I'm trying to accelerate. It sometimes will take a few seconds to actually go anywhere, and my check engine light comes on once in awhile, I still haven't been able to find out what's going on with that either.
  • I would take the oil cap off and check to see if the color of the oil indicates a water oil mixture, just to be sure there isn't a serious problem. I really don't think that you would have that problem but its a quick easy check. Also, you need to check the ecu for the error codes whenever the check engine light comes on, it could tell you exactly why your car is doing that. Other than those two things, from the info you have given I cannot really give you any other help. If you had some more details about things out of the ordinary that might be happening that would help.
  • lizz1234lizz1234 Posts: 13
    I just did that, and I'm pretty sure I got 41 and 1. It blinked 4 long blinks, then one short blink. Then there was a pause and there was 1 short blink. I hope I did that right.
  • Well if it is throwing a code 41, which is 4 long blinks and one short...then that means theres an issue with the primary oxygen sensor which is on the exaust manifold. That could cause running issues since it tells the ecu how to adjust the air/fuel ratio so the car runs smoothly and reduces emissions. I would check the oxygen sensor to see if its working properly and then replace if its bad. I wouldn't rush out to buy one unless you just have money to throw around. I do believe they are still kind of pricey. Hopefully that is all that is wrong with your car and its an easy fix for you.
  • lizz1234lizz1234 Posts: 13
    Okay, thanks! But after the four long blinks and one short, there was a pause, and then there was one short blink again. Is it supposed to do that or is that another code?
  • That is another code.

    Code 1---oxygen content---Check the oxygen sensor, heater and the oxygen sensor circuit

    Code 41---oxygen sensor heater---Check the heater for proper voltage signal

    Try checking to see if the O2 sensor is even plugged in, or check for damaged wires.
    If you're looking for cheap sensors try: Discount O2 Sensors
    Good luck!
  • cybercoolcybercool Posts: 117
    As I start up my 93' Accord EX, from underneath drivers side I hear a released compressed air sound. What can this be?

    Thanks
  • MrShift@EdmundsMrShift@Edmunds Posts: 43,694
    edited April 2010
    Possibly a leaking power brake booster? Try it without your foot on the brake.
  • Hey all,
    My belt(s) are squealing when I start my car. I know its possibly oil leaking, because I'm losing oil, but only when the car is on. I dont see any oil spots on the ground. What can I check and how do I check it? Thanks.
  • MrShift@EdmundsMrShift@Edmunds Posts: 43,694
    edited April 2010
    Check for a loose drive belt and/or a belt that has a cracked or glazed (very shiny) inner surface. Chances of oil on the belt are pretty slim.
  • cybercoolcybercool Posts: 117
    Hi all
    Well... my starter from my 93' accord EX went dead. I had my car towed to my place due to no-funds to fix. Is the starter a DIY work? It's near the front and visible. I found the starter for $87 at Discount Auto.
  • We just recently replaced the belts, but I will check anyways. Could you tell me where all my oil is going? Within two tanks of gas I need to add about two quarts. Seems a little much to me.
  • MrShift@EdmundsMrShift@Edmunds Posts: 43,694
    Easy job.

    1. Disconnect the cable from the battery negative terminal.

    2 .Remove the engine wire harness from the harness clip on the starter motor.

    3. Disconnect the starter cable from the B terminal on the solenoid, and the BLK / WHT wire from the S terminal.

    4. Remove the two bolts holding the starter, and remove the starter.
Sign In or Register to comment.