Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Honda Accord (2003-2007) Maintenance and Repair

1265266268270271291

Comments

  • biomanbioman Posts: 171
    My 04 EX V6 Coupe's battery died quite suddenly. I had been noticing some unusual behavior for months prior to the battery giving out. The Outside Temperature would frequently switch back to the odometer reading after shutting off the car and then re starting. The gas mileage decreased 2-3 MPG over a period of months. In addition, the cranking seemed to be slower than usual. When I checked the voltage with the car off I was getting reading of 12.4-12.6. After starting the voltage was ~14.6. I assumed that the battery was ok since the voltages indicated no problem with the battery or alternator. Of course I probably should have done a more testing, but I thought this was not necessary. Obviously I was wrong. Does anyone have an explanation of unusual outside temp behavior and the drop in mileage?? Since replacing the battery mileage is back to normal and the Outside Temp has stopped switching off.
  • You could possibly have been tricked by funky battery connections or grounds. Sometimes erratic voltage from the battery will trick the car's computer.

    Really, a "load test" is the only sure way to test a battery. Just ready voltage off it won't cut it. We could get you the same reading by putting flashlight batteries together, but they wouldn't start your car.
  • 2005 Honda Accord 3.0 VTEC automatic Manufacture Plate 09/2004.
    Was running fine parked in garage as usual next morning started fine but would not accelerate above 2000 RPM or go forward above 20 to 25 MPH. Idles at 1200 sitting in PARK. TCS lights MIL and maint light all on. Battery tested low Replaced with new Battery $100.00. OBD2 Codes read Emission. Cleared codes, set security code. Attempted Idle Learn. NO SUCCESS. Towed to mechanic $100.00 said throttle body was bad replaced for 700.00,...mechanic (dealer) said needed new fuse box add $200.00,..No apparent fix?? Any ideas before ship sinks? Thanks for any help or assistance..
  • 2005 Honda Accord 3.0 VTEC automatic Manufacture Plate 09/2004.
    Was running fine parked in garage as usual next morning started fine but would not accelerate above 2000 RPM or go forward above 20 to 25 MPH. Idles at 1200 sitting in PARK. TCS lights MIL and maint light all on. Battery tested low Replaced with new Battery $100.00. OBD2 Codes read Emission. Cleared codes, set security code. Attempted Idle Learn. NO SUCCESS. Towed to mechanic $100.00 said throttle body was bad replaced for 700.00,...mechanic (dealer) said needed new fuse box add $200.00,..No apparent fix?? Any ideas before ship sinks? Thanks for any help or assistance..
  • Hey, everyone! I have to apologize in advance for my explanation of the problem since I'm not that familiar with the technical components of cars, and I'm trying to figure out the problem myself!

    I purchased a 2007 Honda Accord EX 4-cyl auto a few months ago, and so far I've been very happy with it. However, over the past couple of weeks, I've noticed that when I accelerate, the car feels a bit slower than normal, and I feel a bit of a vibration in the pedal when I accelerate; the engine sounds a bit louder too. When I'm cruising on the highway, no big deal. After accelerating from a stop or just driving in the city- no matter whether the car is warmed up or not- I can feel the buzz, and the transmission seems delayed as well- I've been noticing the shifts have been rougher and more noticeable. Sometimes when I go 35mph on a flat city road and stopped pressing the gas pedal, I can feel/hear a bit of vibration and know that the car probably wants to upshift/downshift (?)

    I wasn't quite sure what to make of the slightly louder,slower, and buzzier feel, so I resigned myself to thinking it was normal, but a few days ago I pulled out of my school's parking lot and was surprised when I practically flew out of the parking lot because the car felt much more responsive, and I got that smooth, quiet feeling back, at least for part of my drive. I looked at my RPMs, and it seemed the engine more effortlessly went to higher ones. The biggest difference I noticed was in that when I was going up a hill and had to pause for a moment, when I accelerated the car didn't feel like it missed a beat.

    No check engine light on the vehicle came on- do you think I could have a problem with my transmission? Or could this be something very minor?

    Thanks! This is my first Honda, and if this is just a small issue, it likely won't be my last since I'm otherwise very impressed with the vehicle.
  • Hi there I'm not a car expert, but I do own a 2003 Honda Accord.

    Do you know if you've had the transmission fluid changed? If not make sure this is being done every 60,000 miles (I think thats what it calls for).

    Also, I would consider getting the throttle body cleaned. Like you said the problem seems to be minor...but to much carbon in the throttle body could affect acceleration.

    I could be way off base on the what I've said above, but I believe they are items worth looking at.
  • srizvi1srizvi1 Posts: 232
    edited September 2010
    I thought I'd reply to tell everyone how the repairs finished off on my old (now my sister's) 2004 Accord I4. Last time I posted (what I'm replying to) was after a call I got from the dealer on what eveything would cost. So that same day (9/6), I had him finish off the repairs and the final price paid was $211.85.

    Ultimately what was done was:
    1) oil change - $10.39, since I Brought in my own oil -
    2) complimentary inspection - $0
    3) the Idle speed inspection + the ABS service Light - $54.98 - due to the 50% off coupon I had - the idle speed was fine (now I have to figure out when I check it next since there's no more mileage intervals in the owner's manual/ownerslink) and regarding that ABS light, the right rear wheel speed sensor will need to be replaced and it will be $232.28 installed
    4) Brake fluid flush - $101.92- I mentioned the breakdown in my last post for this. It was supposed to be $170 but since I brought my own brake fluid it went down to $125, then another 15% off due to coupon was supposed to make it $85 (although the math isn't adding up right). They forgot to use my brake fluid but kept the price around where it should ahve been. I know it's a bit more, but earlier there is a savings of $10 randomly on the diagnostic thing I mentioned so it evened out.
    5) headlight -$13.35
    6) other fees-28.61-random admin serrvice fee, hazrd waste, and shop supplies added $28.61

    So 2 of the items that were remaining I will take care of later:

    1) the ABS rear wheel speed sensor mentioned already
    2) The drive belt ($175)

    And the brakes had a final price of $1055 for both front and rear pads and rotors, which was too high for me. So I went to Firestone for that same day. Total was $628.27 w/ $162 in labor, $430.16 in parts, $9.72 in shop supplies, and $26.39 in tax. I saved 10% using a coupon I had.

    The one other service item I didn't mention in my last post was my usual walmart visit for the complimentary lifetime rotation and balance. Something I've been doing.. I want to say for 100k miles now? That's usually how I kick off my 10k service cycle - walmart for the rotation balance, firestone for alignment, dealer for oil change. sometimes I'll do the oil change wherever but usually I keep this pattern. The visit to walmart was in august when the car was at 164470 miles.

    Last interesting note. My sister hydroplaned today and hit a curb and now one of the front axles is all messed up. I'm assuming the tire is flat and rim is bent too. So.. this will be fun.
  • 4toms4toms Posts: 1
    I have a 2006 Accord EX with 39000 miles on it. When I went in for the last oilchange, dealer service recommended a power steering fluid flush with a price tag of $115.00. Seemed way too expensive. Any idea of what the typical pricing is ? Is it common to have to flush PSF at such low mileage?
  • colkidcolkid Posts: 9
    edited October 2010
  • colkidcolkid Posts: 9
    edited October 2010
    I fixed them, I pulled the covers off and moved the light bulbs forward
    in the bulb holder. At one postion the lights came on one at
    a time. Understand this was an individual postion for each of the front
    courtesy lights.
    The have continued to work correctly for 3 days now. They didn't work for seven months.
    Thanks to all of you for the suggestions, I probably will have this
    problem again.
    REPLY to my original post of #5254
  • michael2595michael2595 Posts: 72
    edited October 2010
    you shouldn't have to flush it unless you contaminate it with some other type of fluid or water. I am pretty sure it is just a money maker and should not be done. What does the owners manual say.? Did you ask the dealer why.... Thats a lot of money when you can basically do it yourself... Take the fluid out of the reservoir with a turkey baster and add new fluid.. As the reservoir gets lower add more fluid... Just call the service parts dept and ask them what fluid to use... I changed my fluid at 100k.. If there is something wrong I would ask if they use the BG Flush system.. If not, find a dealer that does. It is simply amazing.. It will probably cost about the same

    http://www.bgprod.com/products/steering.html
  • 2003 EX V6 - Two problems diagnosed by dealer that I don't understand, any help much appreciated! 1) Engine light is the Air-Fuel Sensor. How many do I have? What's the difference between a $50 one and a $300 one? -and- 2) Brake light is the "Brake Fluid Level Switch" - is this a replaceable part or do I have to buy a new Master Cylinder? Cheers, steve
  • stickguystickguy Posts: 13,602
    Do you mean oxygen sensor? Not sure how many a V6 has, but it is more than 1. If it is the MAF sensor, that is probably more money.

    The brake light fluid level is supposed to indicate the fluid has dropped due to the pads wearing out (unless it is leaking somehow). As the pads wear, they don't release as far so essentially there has to be more fluid pushed into the lines to create contact. The manual even says not to add fluid, since it is an indicator of pad wear.

    Unless you mean that the fluid is full, but the low level light is on anyway?

    Probably best to have a shop check out the brakes at least. The chains all do it for free.

    Oops, I see that the dealer told you these were the problems. So in that case, I have no idea about the switch, but it sounds like it does not require a new MC, since they would have told you that, and those babies are expensive! How much to replace the switch?

    2013 Acura RDX (wife's), 2007 Volvo S40 (when daughter lets me see it), 2000 Acura TL (formerly son's, now mine again), and new Jetta SE (son's first new car on his own dime!)

  • elroy5elroy5 Posts: 3,741
    You need to know the error code number, to know which sensor. Here is a Service Bulliten on those numbers.
    http://ww2.justanswer.com/uploads/HondaJosh/2009-04-19_222730_zzz.pdf
  • chucko3chucko3 Posts: 793
    Level switch is replaceable. It's a 2-pin connector at the bottom of the brake fluid reservoir.
  • elroy5elroy5 Posts: 3,741
    2) Brake light is the "Brake Fluid Level Switch" - is this a replaceable part or do I have to buy a new Master Cylinder? Cheers, steve

    I used to have a TSB about this problem. From what I remember, the float gets stuck in the down position, and the float is not removable. Tap on the master cylinder near the switch/float (with a big screw driver handle), and see if you can free the float, if not the master cylinder would have to be replaced. This is what I remember from the TSB, so it may not be totally accurate.
  • I have 2004 Honda Accord EX 4-door automatic with 77.3k miles....about 2 weeks ago I noticed a squeaking noise while driving and and today I realize the squeaking noise occurs when I initially step on the gas pedal but by the time I press it down further the squeaking stops.

    Also, when I let go of the gas pedal near the top it also squeaks--so my gas pedal squeaks only when it is positioned slightly away from its "rest" position. Do you think the squeaking can be resolved by applying grease/lubricant to the gas pedal mechanism?

    I won't be going to my auto mechanic until about 2 months for my scheduled maintenance, so do you think it's better to wait until I go to my auto mechanic to get the problem diagnosed?
  • chucko3chucko3 Posts: 793
    Looking at the brake pedal repair picture, it shows an application of grease at the bolt. So give it a try.
  • I have a 2003 Accord that just had the compliance bushings fall apart. This was very disappointing. I bought this Accord for its supposed dependability - my first Honda. I should not have a $400 repair plus alignment at less than seven years. If Honda can't use quality materials in their parts, they will lose their dependability reputation. Oh yeah, the serpentine belt was also falling apart. I might as well have bought a Hyundai or Ford for less money.
  • thegraduatethegraduate Posts: 9,731
    How many miles are on this car?
Sign In or Register to comment.