Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Ford Bronco Problems

11113151617

Comments

  • sabroncsabronc Posts: 1
    Hi, need help in South Africa.
    We own a 1993 Ford Bronco. The electronic speedo has started giving problems. It sometimes works and then not. I have spoken to a couple of auto electricians here but they do not have an idea how to fix it, any suggestions? Have to do quite a far trip with it soon and really do have to fix it.
    PLEASE HELP!
  • seterseter Posts: 5
    I'm having a lot of trouble putting together my E4OD from my '93 Bronco. Everything checks out and is put together right, but everytime I bolt in the front pump, the whole works locks up and won't turnover. It would seem that something must be up too high, but I can find nothing wrong. Has anyone else had this trouble? What am I doing wrong?
  • leonidas3leonidas3 Posts: 1
    1993 Bronco EB 5.8 E4OD. I'm lost. If I sart up my Bronco and put it in drive it will drive for about 5 miles just perfect. Transmission shifts smooth, everything is great. After about 5 miles when I come to a stop and then try to move forward again it will not shift out of first gear. If I shut it down and let it cool off it will drive normal for another short distance. I have changed the transmissoin fluid and filter and was about to put in a whole new transmission until yesterday when someone with a 1996 Ford Bronco told me they were having a similar problem and fixed it by changing a sensor?
    Any Ideas?
    I went down to the auto parts store and they priced a speed sensor? solenoid sensor? throttle position sensor?
    to be quite honest, I don't have a clue!
    any help would be greatly appreciated..thanks.
  • wpgjuggalowpgjuggalo Posts: 1
    hook up a fuel pressure guage and watch it... Chances are the high pressure pump located on your frame rail is toast. It will run while it is cold but once the pump heats up it will fail...
  • Bronco_BobBronco_Bob Posts: 4
    Worked good Had low pressure changed the pump runs like champ
  • dennisfbdennisfb Posts: 1
    96 Bronco 200k absolutely identical symtoms to what you describe. Were you ever able to fix yours and if so how did you do it? Any help will be appreciated.
  • seterseter Posts: 5
    I would like to know the resistance specs on the coolant sensor for a 93 Bronco 5.8L. Can anyone answer?
  • I just bought a 94 full size EB Bronco 5.8 4x4 with only 69,000 miles. I've noticed that when I accelerate at full throttle from a stop it will lag, almost slow before it shifts to second. Not like slipping, but like it is being held back. This is annoying me.

    Also, there is a kind of loose u-joint feeling when stopping and taking off, but it does it three or four times each time. :confuse:
  • rcbasherrcbasher Posts: 2
    I have a 1993 Bronco with a 302 that is usually very reliable. This morning it was doing fine on the interstate cruising along at about 70. When I got stopped at the exit it acted like the throttle was stuck, idleing around 2000 rpm. Didn't need to use much throttle to get the rest of the way to work. Once put in neutral revved even higher. Cut motor off and restarted idled fine but had a little miss. Cut motor off again and restarted and idled normal. When I left work now it won't even start. I'm getting spark from the coil. Don't know what to check next? Any ideas.
  • rcbasherrcbasher Posts: 2
    My truck started the next morning. Bought a code reader and it was the throttle position sensor and the egr position sensor. Changed both and runs like a champ.
  • tidestertidester Posts: 10,110
    Glad you got that fixed and thanks for the follow up!

    tidester, host
    SUVs and Smart Shopper
  • how much force can the leaf springs on my ford broco 2 4x4 withstand
  • how much force can the leaf springs on my ford broco 2 4x4 withstand the reason way i was in a car wreck and the person that hit me was supost to be only go 30 and hit me in the side and broke my leaf springs and i realy need to know
  • tidestertidester Posts: 10,110
    The leaf springs are designed to support the weight of the vehicle but that would be a vertical force on them. Being hit from the side or rear is a different matter altogether. When you say your leaf springs are broken, do you mean the metal was sheared, torn or otherwise physically split (hard to do) or simply deformed or displaced (relatively easy to do)?

    tidester, host
    SUVs and Smart Shopper
  • miesk5miesk5 Posts: 35
    SETER,
    For the Engine Coolant Temperature Sensor (ECT) - Not the coolant sensor for the TEMPERATURE Gauge...
    See Ryan's Info & Specs
    http://fordfuelinjection.com/index.php?p=28
    -----------
    Ford part Number; in Vehicle Emission Control Information (VECI) for 88 and up, PUK (49 States) Decal, PGP (Canada) Decal, Vacuum Diagrams & Calibration Parts List for 88 & UP - if hot Link does not take you direct; CLICK Quick Guides Scroll to bottom; Provides Vehicle Emission Control Information (VECI) and a related calibration parts list. Enter applicable info (need to know your Calibration number from your B-pillar sticker)
    Source: by Ford motorcraftservice.com
    http://www.motorcraftservice.com/vdirs/retail/default.asp?pageid=&gutsid=

    see my broncolinks.com site for more ECT LINKS incl. location/troubleshooting, DTCs etc.

    Hopefully the Admin won't delete this reply because I posted my site's URL, but there is no way I'd use a lot of bandwidth here to list all possible ECT Info.
    be well!
    Al
  • seterseter Posts: 5
  • motor has no power runs 10-15 mph and oil is pumping out the top of the oil dipstick
  • So, my 78 Bronco's starter, solenoid, battery, clutch and flywheel are less than a year old. When I try to start it, the solenoid clicks, and there's no juice to the starter. Positve battery cable was very hot. Changed the solenoid, and still the same result. Battery has a good charge, and the ignition switch appears to be ok.

    Anbody have a clue?

    Thanks...
  • dannitdannit Posts: 1
    I'm looking for a 89" Ford Bronco II Cab Visor. I can't find one locally and I am stuck on getting one. Does anyone know where one can be found; and how I could buy one over the internet from a private seller without getting ripped off. I'm up for any suggestions? Thanks.
  • try changing the gas filter
Sign In or Register to comment.