Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Ford Bronco Problems

168101112

Comments

  • My problem is it kills my battery in 2 days when i hook up my battery i hear the vacume solenoids clicking on the right fender well and there is a relay on the kick panel by the puter and also clicking there is a solenoid on the back of the carb that is clicking what is the possibility a bad ignition switch any info would be appreciated please
  • I have a 93 bronco 5.0. I love my truck but it is always something.
    First i cant get it to start. I moved it in the driveway and when i went out to drive it the next day it would not start. (1) It is getting fire when we checked. (2) when we checked the fuel rail it is getting fuel. (3) we primed it with starting fluid and it still wont catch. It turns over fine but wont start. H E L P! PLZ
    Next it has a hurkey jerkey at about 30 -40 mph.
    Thanks
  • POS2,

    Mine was doing the same thing. Check out my post #190.

    Hope it helps.
  • Where is the computer module? Did this start it up AND stop the jerking?
    Will try and let you know what happens
    Thanks for the input
  • It is not the computer mod. Checked the rotor, and every thing else and still wont start. HAS GAS> Has fire and gas flow just wont start. It almost turned over and caught today twice but once again it just turns over without catching.
    I am lost. Ether wont even catch it. Should i just set fire to it??
    Any other possibilities that one might try??

    thanks
  • Red Raider,
    I took all the spark plugs and cleaned them. It started up with a little ether. It runs a little rough though. Why is the MSD parts so expesive. Is there a cheaper alternative to changing all the parts out that you suggested?
    It also has that shudder, herkey jerkey around the time it shifts. Is that fixable. It is around 20 to 50 mph. If i gun it, it takes off fine but when I let off the gas a little it starts to shudder until i give it a steady flow of gas.
    HMMMMMM

    Jutmac
  • JUTMAC,

    Another alternative to MSD would be ACCEL, or you can go back with stock MOTORCRAFT parts. I would change the plugs, wires, coil, and dist. cap and rotor for starters. I prefer MSD for their high-end performance, but whatever you choose, all those parts should be new.

    I'm only a shadetree mechanic, but I've had a car that jerked before and I thought it was my transmission. Turned out to be a cracked spark plug......who would've thunk it?

    Remember, just because you're getting SOME spark, doesn't always mean you're getting ENOUGH spark. Stock coils put out about 38,000V....the MSD puts out 48,000V.

    Hope this helps.
  • i have the computer and complete electrical harness for an 86 with the 302 in it. I bought the truck and put the motor in my 91. kept the interior and engine harness in perfect shape. computer is with it if that will help you. let me know.

    jay
  • Hello Jay, thanks for the offer, but I got it all sorted out, I managed to find the harnesses I needed right here in my home town( got lucky) I was checking out the wreckers and I stopped by one that deals only in fords, and they were unloading a 91 bronco off a tow truck when I got there. So, thanks again, Derek.
  • I have a 1988 bronco II. When the out side temp is below 32 degrees F it fires once and will not start. But when the temp is above 32 degrees it starts fine I have added HEET to the feul it does not seem to be helping
  • tidestertidester Posts: 10,109
    It sounds like your engine's not getting enough air. Try holding the pedal to the floor (don't pump) when starting and see whether that makes a difference.

    tidester, host
    SUVs and Smart Shopper
  • I have a 94 Bronco 5.8 lit, When i turn the vehicle on the engine roars at idle like it was in a full out drag race RPM's way up at idle. Once I put it drive the engine slowa itself back down, but at stop signs it revs right back up. Any suggestions? The "Check Enigne" light is not on... Help
  • MOST LIKELY YOUR THROTTLE POSITION SENSOR. LOCATED ON THROTTLE BODY AND COSTS AROUND $50.
  • Ya my bronco is really weird. Sometimes it starts no problem. Sometimes it woult start at all and when i do get it started everytime i shut it off it woult start again for at least a day or so. I've bought a new battery, egnition start box and new distributer cap. I have no clue what the problem is. I just keep on spending money on stuff i dont need.
  • I changed out all to MSG....had to wait for taxes to come in....I also replaced the fuel regualtor and the timing was off....now set at 10 degrees.
    All is well except for the herky jerky at 35 mph....it used to only do it at this speed now it does it at whatever speed, unless i trounce on it....it runs good.

    HERE IS THE KICKER:
    It does not do it when it is cold. I am sure it has something to do while on a closed loop but when it warms up back to normal...bucks and snorts....any shade tree answers..lol

    by the way...thanks for all your past help...and anyone is welcom to reply
  • JUMAC,

    Glad to hear most of the problems are gone. Did you change out ALL of the spark plugs and also the spark plug wires?

    Sounds like we're on a role to getting you running smooth.
  • jutmacjutmac Posts: 7
    Raider..
    I did change them all out....Like i said though....it only does it when it warms up??
    Someone told me that when i use my tester on the wires and plugs that a fords should show blue spark.....i show orange...any truth to this??
    Everything is MSD. Someone also said it feels like a dead miss in it....do you think there could be a blown valve??/ I would like to know what you think before i do a compression check.

    Again...Thanks

    Jutmac
  • i have the 91 silver series 5.8. and my 4wd will not kick in. its just the push button one and at first the 4x4 light didn't even com on but my bud told me to tap the little electric engine that locks the 4x4 into place and that might work. i taped it then the light came on but wen i put it into drive u don't hear the clunk and it doesn't go into 4wd. help me out please. im a new bronco owner and i really wanna mess some trails up with this thing. haha
  • khawleykhawley Posts: 1
    I just got a 94 with the 5.8 and can't get it started. The vehicle has been sitting for about 5 years and there hasn't been an attempt to start it in at least 2.
    With the ignition on I pushed down on that stem on the fuel rail and no fuel came out. I changed the fuel filter, checked the inertia swith, fuses, and relay.
    I'm thinking it has to be the fuel pump but wanted to see if you had and advice before i went out and bought one.

    Thanks!
  • jutmacjutmac Posts: 7
    As Redraider once told me." I am just a shade tree mechanic" but if you have no fuel coming out of your fuel rail then you have your problem narrowed down. I know it sucks throwing money at them but sometimes you just have to.

    On a side note to Redraider....the hercky jercky or "trailer-hitching" effect, as someone put it, turns out to be the torque converter in my tranny. Go figure...I knew my motor was running to smooth for something cheap and simple. HA. Thanks for all your help.

    Jutmac
  • JUTMAC,

    Glad you got it figured out. I had to think about that one and asked a buddy at work. I was going to say start with the simple things.....fuel addative to take care of any BAD GAS, fuel filter, etc. Next would be the speed sensor, or torque converter......one located on your tranny and the other on your differential.

    In any case, glad to help any time.
  • yimmiebyimmieb Posts: 1
    Anyone know what causes the pick up coils to go bad. I replaced the first one with a new one from auto zone. it started right up but didn't run 100% and lasted 2-3 weeks and let me set. I replaced it again with a new one from auto zone. This one started right up but ran poor, missed & cut out, the tach would also fall to zero when it was miss firing. It ran worse on a hard pull in overdrive. I was told to replace it with oem, I did and it ran great even in O.D. on hard pulls. it was in about 3 weeks and today it let my son set. When I try to start it the tach makes one jump and falls to zero staying there while cranking. I know if I replaced it again it would start right up, and while cranking the tach would go up to 200-300 rpm's before starting.Any ideas what keeps killing them?
  • My 1988 Bronco II was running fine when the engine began to lose power almost like a plugged fuel filter. The filter was pretty full so I changed it and then it ran for a week (about 100 miles) then it did it again it stopped 5 minutes after starting it. I messed with it for awhile that it started running again it ran down the highway for ten minutes the it stopped again. The weather was about 70 degrees and sunny so it is not freezing up. The took off the line at the filter and there is fuel there. then I took the line off the fuel regulator there was no fuel there. The only thing I can think of is the high pressure fuel pump. It that what it acts like when it goes out?
  • I did it and it worked purfectly thanks
  • shifty01shifty01 Posts: 1
    i ran it without exhaust mostly idoling for about 10 mints and it started to run ruff...i put on an exhaust and it still ran bad...it makes a popping noise on the left side of the motor not quite a back fire but like it's a dead miss...it does it when i give it gas to...like it's gettin choked out on 1 cylander...i think it might be a burnt valve but would like more opinions
  • 94 Bronco 143K never any major problems, All of a sudden has a problem getting it started. Acted like it didn't want to start but after holding the gas pedal down it come to a shaky start. :mad: After getting it going act like it wont acclerate, shakes almost like it getting no gas. That day began to run fine no more problems after driving around for about five minutes. Now it hard to start and has problem accelerating. It will only accelerate very very slowly then almost bog down if I press the gas down hard at all? I think it is some kind of fuel problem please help?
  • I OWN A 1984 FORD BRONCO AND I'M TRYING TO FIND LEGAL EXHAUST SYSTEM WITH HEADERS. I FOUND A LOT OF PLACES THAT SELL HEADERS THAT ARE NOT STREET LEGAL.EVERY PLACE THAT I CALLED SAY THAT NOBODY MAKES THEM.
    PLEASE HELP ME!
  • Hello deb34,
    I have an 88 Bronco II and had the same trouble. Fortunately, a freind was a mechanic and told me about a part I did not know existed on my Bronco. Right behind and below the rotar is a small chip, like a stick o RAM memory. It fastens in with a small screw and slips out. It cost about $245 at Ford, but I was able to locate 1 at a salvage yard for $20. It takes a short, 3" screw driver to get to it. Removal of rotar is not required, but may make it easier. Once I replaced that all the problems went away. It is unfortuante that I spent all the money on the other parts!!

    classiclo1959
  • Just yesterday I started having a problem with the original starter on my 1988 Bronco II. The bendix or solenoid does not seem to kick out when it should after vehicle starts and runs on for a short time. Is this the starter itself, or the solenoid on the right fender?

    classiclo1959
  • howard31howard31 Posts: 2
    Where can I get a transmission?
Sign In or Register to comment.