Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevy Silverado and GMC Sierra Transmission Problems

1121315171850

Comments

  • Had a new motor and tranny replaced 14 months ago. When I take off to drive the truck, I have to push firmly on the accelerator to get it going. Once the RPMs get high enough it shifts into 3rd gear and does fine from there. It seems to be skipping 1st and 2nd gear. Transmission shop did diagnostics, said it threw a code 66. He then bypassed the computer and said the transmisssion works fine. He sent us to electric shop, for electrical problem. They checked the wiring from the ECM to the transmission and said its fine, so it must be the main computer. We have replaced the main computer and still Not working correctly. Any clues, these diagnostic fees have emptied our pocket. Please help">
  • byanceybyancey Posts: 3
    My 2004 GMC started in 3rd gear off and on...Mechanic did tests, changed fluid, filter, etc....found out it was the ignition switch (not the key tumbler part) that was bad. Seems new electronic trans need 12v to work right. $30 part, $20 labor...problem solved.

    Good luck
  • hi,i need some help please.I just rebuilt a 4l60e with a rebuild video.I used a master overhaul kit.put new vette servo and new 2-3 shift solenoids.i didnt replace the wiring harness.i had rebuilt it cause i lost 3-4 gear.i put the transmission in and it doesnt have reverse,jumps when you put it in park.and drives forward in neutral.but as far as 1-2-3-od they work great shifts are better then ever.if anyone can help please do. thank you
  • helpnickhelpnick Posts: 2
    i have an 03 1500hd, and the transmission started overheating for no reason. I replaced the transmission and flushed out everything and it is still overheating. if you have any information about this problem please help me out. thanks, nick
  • helpnickhelpnick Posts: 2
    there is a sprag on the valve body with some teeth on it. if it is not on the right tooth it will cause your problem. also make sure the valve body has sealed properly if there is any fluid bypassing it will also cause these problems. I have access to alldata that can further assist you if you need it.
  • firejj09firejj09 Posts: 1
    I have an 07 Chevy 1500 Silverado 4x2. 10 -15 seconds after being at a complete dead stop not moving at all or anything, my truck will clunk and surge forward almost like i was rear ended. The dealer keeps lubing my driveshaft and yolk but that is not it. It almost feels like the truck stops in 2nd gear and 15 seconds later goes "O crap i'm in 2nd and shift down to 1st." i don't know if it is a computer thing or tranny thing or what. Has anyone had this problem as well and got it fixed. I have the settle back clunk from the extended leaf springs that the lube fixes but this is way different. Please post back if you know the fix or anything that could help.
  • thank you i will be checking that out today. i tore the pan of yesterday and 2 or 3 bolts were loose. and i think one of the valvebody bolts are in the wrong place.im going to take the valve body down was wondering if you would know where i can get a bolt diagram at to double check my bolt locations.thanks for the help.
  • well in stead of dropping the valve body i decided to tighten up the bolts and found that they were all in the right place and that didnt do anything.still moving in neutral and nothing in reverse.weird how i can dive it though and still have all gears but reverse has nothing.park jumps and neutral drives. i will be checking the spacer plate and gaskets next any tips on putting the gaskets on while tranning still in would be appreciated.And any other info would be helpfull at this time.thank you
  • dotr04dotr04 Posts: 1
    I have a 1994 chevy dually 3500 1-ton and am having trouble with the tranny. After driving on the freeways for a period of time then getting off an off-ramp, the truck ssems like it is in neutral - when I shift to a lower gear nothing happens and when I try to put it in park or reverse it won't go in (makes a grinding noise). It drives fine and their is no slippage when I just drive around town, stoplight to stoplight, and drives fine when on the freeway, but when I get off the freewayit;s like it gets stuck in the gear it's in and wont downshift when I slow down. Eventually it will go back into gear, but not because of something I do - just does it by itself? any ideas?
    Thanks,
  • I was test driving a Z-71 4X4 and I noticed a Service 4WD message in the cluster. I tried to press the 4WD buttons but nothing seemed to happen. Also noticed a red led that indicated "N" that is located between 2 of the 4WD buttons. The truck has193K miles on it. If the transfer case or transmission needs servicing, will it deactivate the 4WD function??????
  • akjbmwakjbmw Posts: 231
    Any other folks thinking heat related?
    Plastic pistons in the valving process start to crack (older Sable/Taurasourus do) and get stuck in position from freeway speed heat? Maybe gunk collection?
    Find a trans shop or mechanic you trust.
    I would expect a shop to be required to do a whole trans redo. Liability issues would prevent a less expensive valve body "patch".
  • I have an 07 GMC Sierra and experience the same problem. It doesn't happen every time. Let me know if you find out anything and I'll do the same.
  • kevinc70kevinc70 Posts: 3
    I have a check engine light on in my 2003 GMC sierra 2500 h.d with the allison and when I scan it a p0700 transmission code comes up and wont erase. The truck also has no reverse lights and the steering column indicator does not work, along with DIC (driver info center) could this be linked or just a coincidence. It seems to shift and operate fine. Just wondering if anybody had a issue like this or simular.
  • wwc_dawwc_da Posts: 1
    PLEASE HELP ME OUT ANY WAY YOU GUYS CAN!! I JUST BOUGHT A 1995 CHEVROLET SILVERADO Z71 TRANNY WAS NOT SHIFTING OUT OF 2ND TO ANY OTHER GEAR!!!!! SO I HAD IT REBUILT PUT IT BACK IN AND IT SHIFT'S HARD FROM 1ST TO 2ND... JUST LIKE IT WAS DOING BEFORE I HAD IT REBUILT... AS WELL AS IT STILL WON'T SHIFT OUT OF 2ND TO ANY HIGHER GEAR!!!????????
  • Hi, this is my first post. i am a former Dodge service advisor so I have some mechanical experience in trucks. I currently purchased an 03 chevy Z71 ext cab with 5.3l. I have the steering shaft clunk issue. a buddy of mine got a new steering shaft put in which is just like the original. he is starting to have issues again. my suggestion is purchasing a updated heavy duty one through LMC truck catalog. it runs about $379.00 and claims to solve this issue. second, I also have the 2nd to 3rd gear shift clunk underneath my truck at low speeds or going up hills. Another buddy of mine has an 04 sierra ext cab Z71 with 5.3l and had the same issue at 22k miles. He got this issue fixed at the gmc dealer where he lives, they replaced his driveshaft with a beefier one which looks like a 2500hd shaft not sure though but definately beefier than the stock one. he now has 40k miles and says he has had no further problems. Hope this is helpful, I plan to do the same with mine and also put the steering shaft from LMC when i have the money to do so (Damn Economy!). Overall i am pleased with my truck and absolutely love the ride, though not as exciting when flooring it like a Hemi but still satisfies my needs!
  • I would suggest you have someone check the speed sensor it tends to get stretched out then it shorts out.
  • eug3eug3 Posts: 2
    I have 2007 Sierra that does the same thing. they lube the shaft today I dont believe this will work. I will let you know
  • guitaroguitaro Posts: 1
    My '97 chevy does not want to shift from 1st to 2nd at first, but after it does I can drive a hundred miles and its fine. This problem is getting more frequent and lasting longer everytime. If anyone knows anything I could sure use some help. Other than when I very first take off there is no hint off a problem.
  • 05radoinbg05radoinbg Posts: 1
    Hey everyone. Bought a 05 Silverado 1500 5.3L last week. It has 87k on it. I am a fleet manager and I only run Chevrolets and have been proven to the durability of these trucks but I may be proven wrong with this truck. I started noticing the other day that while driving at around 45 mph, without the cruise control, the truck has a lot of bucking and jumping and vibration. Had the tires rotated and balanced today and it still seems to be getting progressively worse. I have also noticed that when driving from 40-60 without cruise, the RPM's have a lot of fluctuation... and by the way, this is annoying as crap now that I have Flow Masters! I have also started noticing that every once in a while, the transmission slips when shifting from first to second. I have never seen this kind of problem out of my trucks at work so I am stumped on where to start. Anyone have any ideas?
    Thanks!
  • I have a 2008 Sierra 1500 that does the same thing. I can be sitting at a stop and all of a sudden it will clunk almost as though I've been slightly bumped from behind by another vehicle. Also has slight clunk on 2nd to 1st down-shift at 12 mph. I've had it to dealer 4 or 5 times. Changed out yoke, did nothing. At present time I'm battling GM at the national level and locally. I won't give up.
  • obyoneobyone Posts: 8,065
    At present time I'm battling GM at the national level and locally.

    Battling to get it fixed or battling to get GM to buy it back?
  • pondrockerpondrocker Posts: 18
    i have noticed a few people mention the tranny clunk after stopping, mine doesn't clunk but it does seem to still be engaged when I try to stop,it is very hard to get it to stop easily, almost like having a very heavy trailer on the back. If i take my foot off the gas pedal, it will basically maintain that speed for at least 6-10 blocks, mainly between 45-55mph. I have never driven a vechile that doesnt slow down when your foot is off the gas? The tranny also hesitates for 2-4 seconds between the 2-3 shift point, almost slams your head into the steering wheel. I can feel vibrations through the floorboards & it seems to shutter in all the lower gears & the exhaust is extremely loud & odd sounding. On 4 occasions I have experienced a "surge", that is I released my foot from the gas pedal & the RPM's increased 500 & the engine sped up, lasts 3-5 seconds. Guys I have had this death trap into 3 dealerships, 1 of them 3 different times, the 3-4 clutch plates have been replaced, pcm upgrade, new PCM/computer installed, the pcm relearned many times, by the way this solves all the issues for about 500-800 miles & it morphs back into its old self. GM is of no help, 80 hours on the phone with them, now district rep in detroit is on the case, laughable. So please do not feel alone in your troubles, keep fighting, they want you to just go away that is their idea of customer service. If your new GM product works then I'ld knock on wood.Good luck
  • sonny24sonny24 Posts: 1
    Ihave a 06 Sierra with 34000 miles on it. Ive taken it to 2 different dealers for the clunk noise. The first told me it was backlash from the driveline.And that this was normal.The 2nd told me it was something about the 2nd to 3rd clutch, and that this was normal. So to make me happy the lubed the slip yolk and that lasted about a week and its back to doing it. Least to say Im takig it back again and now I have GM service rep from the factory involved. Also I had a black 05 and it never made this god awful noise.
  • txrednecktxredneck Posts: 8
    I HAVE A 89 CHEVY HALF TON PU, TRANSMISSION IS SLOW TO SHIFT, HAVE TO WIND UP THE RPMS, THEN IT SEEMS TO SHIFT FROM 1ST TO DRIVE SKIPPING SECOND. YOU NEVER FEEL IT SHIFT INTO OD AND DRIVING DOWN THE ROAD I CAN SHIFT BACK AND FORTH FROM D TO OD AND YOU CANT FEEL ANYTHING BUT IF I LET OF THE GAS AND SHIFT INTO D OUT OF OD YO CAN FEEL IT SHIFT DOWN. ALSO IF I SLOW DOWN TO MAKE A TURN IT WILL SHIFT BACK DOWN INTO 1ST OR 2ND, CANT TELL WHICH ONE FOR SURE. ANYBODY GOT ANY IDEAS?
  • mikesquidmikesquid Posts: 1
    I Have a 1993 Silverado, My transmission only leaks when I go over 55 mph for more than an hour or so. Im not sure if it is the seal or maybe the vent? If any one can help me I would appreciate it?
  • hoookuphoookup Posts: 1
    I started hearing a grinding noise from what sounded like the transmission. It would happen when at low speeds in 1st or 2nd gear. I would have to pull over, shift to neutral, and stop to get the noise to stop. It happened intermittently but started happening more and more. Assumed it was the trans, and had it replaced with a rebuilt. Two days later the sound returned, and getting progressively worse. the drive shaft looks like it's within limits, they looked at the rear differential and it looks fine.
    Any ideas?

    thanks

    2003 Chevrolet Silverado
    5.3L V8
  • txrednecktxredneck Posts: 8
    I WOULD GUESS THAT IT IS THE SEAL AND THAT IT STARTS TO LEAK WHEN IT GETS HOT. I HAD A CAR THAT DID THAT AT ONE TIME. ADDED SOME LEAK SEALER FOR TRANSMISSION AND IT QUIT. IT TOOK IT A COUPLE OF DAYS BUT HAS BEEN GOING NOW FOR SEVERAL MONTHS WITH NO PROBLEMS. I AM NO EXPERT BY ANY MEANS BUT THIS DOESN'T COST MUCH AND I WOULD THINK IT WOULD BE WORTH A TRY.
  • txrednecktxredneck Posts: 8
    IT COULD BE A LOT OF THINGS BUT SINCE YOU REPLACE THE TRANNY AND IT DIDN'T HELP I WOULD LOOK AT U JOINTS, BEARINGS, OR MAYBE EVEN THE BRAKES. WOULD HAVE TO NARROW IT DOWN AS TO WHERE IT IS COMING FROM TO TELL ANYTHING MORE.
  • I have an 01....we bought it about 2 months ago and it has been in the shop for the last month, we can't figure out whats wrong with it. It has an allison tranny, computer was reading bad tranny codes so we had the tranny rebuilt, had GM re-flash the computer. It didnt work, It was putting itself in limp-mode. Going to about 40 mph then shifting into neutral. It's still doing it even after the tranny rebuild. EVERYTHING in that tranny is new. Have tried a lot of things, replaced switches, rebuilt torque converter, etc. nothing has worked...still is in fail safe limp mode. Any one know anything about this? maybe give me some suggestions on what to check around for?
Sign In or Register to comment.