Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevy Silverado and GMC Sierra Transmission Problems

1161719212250

Comments

  • had transmission fluid changed. now my transmission vibrates at 40-45mph goes away if i give slight acceleration or back off. Had them check it they said nothing is wrong, . Truck has 38000 miles on it and is not driven "hard" at all. Had same problem with 2000 gmc with the transmission right about the same time it started...Transmission went out 2 months after final payment made. I'm sure it is the tranny humming because it is centered at the center well of the truck and only occurs at that speed it is a hum type vibration.
    Any thoughts, made sure they did not "pump" the fluid out of tranny like some places are doing these days as I hear that does mess with internal parts of tranny.
  • obyoneobyone Posts: 8,065
    When they checked it what exactly did they do to come up with nothing wrong?

    I would take whoever worked on it for a ride and let them hear and feel to make sure you're both on the same page.
  • I would like to know if you had the truck dropped to a 2/4 or 3/5.?
  • I have a 2002 Chevy Silverado Z71. My Problem just started . I drove my truck home Shifted it into park and noticed that the selector indicated it was in park but the truck was slowly creeping backwards never had that happen before anyone have any ideas (my truck is a 4x4 ) i tried several times to get it to lock in park but it would not just kept creeping backwards (I park on a driveway with a incline. (HELP)
  • Not bagging on ya, but there are more than a handful of threads posting problems with Chevy transmissions. I have an '02 Silverado and though I wouldn't trade it for anything, I've been through 4 transmissions. The first 2 GM replaced under warranty, the 3rd was a custom performance build, and the 4th because the stall took a crap in my new transmission that by the way was perfect.

    My suggestion, if you are knowingly going to keep your truck for life like I am, is to find a highly reputable transmission builder in your area and go for it.
  • hi i have 2000 silverado, i went out this morning and i only had 1,2 and reverse. so i checked my fluid which was a little low, and i topped it up. I let the truck run a quite awhile and decided to drive it in second, after about 8th a mile and shifted into 3rd and then over drive. When i slow down only 1 and 2. Do you think it could be a solinoid. Thank you Bruce
  • i never had that problem...... I only had 1 of my 6 silverado trucks get a tranny rebuild but that was at 225,000 miles. I did have the NBS 2007 replaced at 7,000 with no problem, it now has 50,000 on it. Sorry i couldnt help.
  • Though my truck is not HD, I did have a Vig 3400 Stall take a crap in my brand new FLT Stage 4 Transmission. The blades for the stalls turbine was not properly heated and finished. Stall was under warranty, money out of my pocket for the transmissions r&r. Check your fluid, if it's not red, you have a problem.
  • do they make allison transmission for the gmc 1500?
  • All of a sudden our truck is having problems going into gear. It started when I put it in 4 wheel drive. Then I couldnt get it to go into Drive. Finally after about 5 mins I finally got it into drive. But it wouldnt show it was in drive on the steering column. Then the next couple days it ran fine again. Now today it did it again without using 4 Wheel drive. Now its stuck in low and wont shift back out. Hubby got under it and can find nothing wrong.

    Any suggestions?
  • worked then 10 minutes later it didn't. found fluid low, filled , still not quite working other gears ok.
  • hi i have a 2004 sierra 4x4 if i start the truck and put it in gear its fine but if i stop or put it in park and try to put it in drive again its like its in neutral but if i shut the truck off and wait a minute and restart it it will go into gear again but it will happen all over again i have replaced the push button control and the transfer case motor anyone ever have this problem any help would be great
  • trans will not shift out of lower gears,the fluid looks and smells good. are there any electrical components that would cause this?
  • jweston84jweston84 Posts: 2
    edited February 2010
    wonderin if anyone has had problems with newer trucks the reverse on mine takes about three to five seconds before it actually kicks into gear. 1-3 seam ok but dont really wanna shift to 4 anyway its in the shop getting fixed under warranty thank god. just wondering if anyone else has had same proplem let me know
  • 2002 silverado 3500 w/ auto trans w/OD and towing, goes out of gear shortly after starting out, not even out of parking lot. I rev engine -nothing- I down shift all gears -nothing-. I shut down and restart and every thing works fine. I have had truck for short time and this has happened twice. I was told by a mechanic it is electrical problem! I dont know!
  • Have you gotten an answer yet? I have a 2001 Silverado 2wd, with the Allison trans and last week started it up and the trans would not engage. Today it drove just fine.
  • aclubbaclubb Posts: 1
    My transmission will shift from 1 to 2 just fine. It will rev to about 6000 rpms before going to third gear. After that it will not go into overdrive unless i let off the gas and as soon as i touch the gas it will jump into third gear and rev high rpms. Is there a bad sensor or is it the govenor?
  • No answer as of yet! No one I talk to is sure what could make this happen. Will keep trying.
  • Most of you are having the same type of problems. We had the same problems also and actually found someone to diagnose it. When the truck shifts but feels like it goes into neutral first, or shifts 1st to 2nd then straight into neutral (would make high RPMS) it is called fail-safe mode, or limp mode. It is a computer problem that would come from a number of things, ours came from the "back-up neutral safety switch" or "PRNDL" switch, it tells the dash in the truck, and the transmission what gear YOU want it to go into when you put it in PARK, REVERSE, NEUTRAL, DRIVE, 2ND, or LOW. If when you put it in gear and it does not highlight that gear on the dash, chances are, there's something wrong with the PRNDL switch in your truck, ours went out because of water damage, they are attached to the side of the transmission and have 2 shields to protect them, but sometimes the shields are faulty. This part is a 100% electronic part and water doesn't do it any good haha. As a result of that part going out, and trying to coherse the truck into gear, the clutches burnt out in a matter of 5 days and we had to pay a total of $6000 to have it rebuilt and have our GM dealer "flash" the computer 3 times (an hours labor charge, which is $132 up here). Hope I have helped someone with this, just remember when you're asking around, Limp mode/fail-safe mode, and PRNDL switch.
  • catamcatam Posts: 331
    Most likely it's the NSBU switch. (Neutral Safety Back up).
    Its an electrical switch mounted on the drivers side of your tranny. In earlier Allison trannys it was poorly shielded from the elements and prone to failure. I'd start there.
  • Hi im new to this forum. I have a 2005 GMC Sierra. the transfer case slips into neutral when taking off from a stop sign or when throttling in to it. the transmission was replaced about 2 years ago. i was thinking the encoder motor? what do you guys think.
  • smg78smg78 Posts: 1
    I am looking to buy a good condition input gear for my 261xhd, why used? its simple cause I’m broke. But not having one keeps me from fixing my truck, not having my truck keeps me from making money, No money means I cant pay retail prices and the circle keeps going. If you have one that’s new or dealer or whatnot feel free to email, but my preference is used.

    If you have one let me know price, your location and if you accept paypal or how you would like paid. I live in Maryland(20832) my email is shawnmili@yahoo.com
  • I just bought a 2001 chevy 2500hd 4x4 with the 6.0 and auto trans. most of the time it ran at about 100 - 110 temp then it hit 210 and blew the external cooler out. I replaced the cooler and added the new dex 6 fluid to refill it. it ran at about 50 deg running 70 in 60 deg temp after that and for the last week, today while pulling into the drive the motor stalled out several times and the trans temp hit right at 200 deg, any ideas? It also shifts hard into 1st but shifts fin after that.

    I unhooked the egr valve elect. when it begain to act up to see if it would change the running of the truck, it didnt. after the truck sat turned off for a min i re started it and it ran fine. but the trans temp stayed up around 200.

    Anyone have any isdea or help?
  • chevy did redesign those hoses, and they still leak. there is a really great fix available at http://www.redsautorehab.com
  • jonmic1jonmic1 Posts: 1
    My problem is with my 2001 Silverado. I've had it for about 6 months and recentley it has been hard to shift (auto) from 1st to 2nd. Not all the time just somtimes. Also while driving my power seat starts moving, until I hit the control. And lastly sometimes i get in the truck and I notice the time on my dashboard has changed, but not the presets. Otherwise it has been a great truck. It was previously used as a 5th wheel. Any thoughts would be appreciated
  • Hi,

    I parked my truck for 2 weeks and come back home. When i started it up and put the trans in overdrive it don't want to shift right. It takes it awhile to shift from first to second and takes awhile to pickup speed. When u let off the gas it shifts fine, but if u get on it, with the pedal mashed down it wont shift right. ANY HELP WOULD BE APPRECIATED.

    Thanks
  • I need to install a trans cooler for towing approx 4000lb trailer for now, anybody have some pics on the install???
  • Forgot to mention 2001 Silverado 1500 4.8L
Sign In or Register to comment.