Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





GMC Jimmy Starting and Stalling Problems

1568101114

Comments

  • etubbsetubbs Posts: 7
    my 97 jimmy 4.3 v6 keeps on blowing relays now it wont start at all could somone help me tell me what to look for now ............thanks ed
  • sknight1sknight1 Posts: 2
    HELP! I have a 2000 GMC Jimmy. About a month ago the fuel pump went out. Got that and the fuel filter replaced. Ran good for about 2 weeks then it died on me going home from town. Let it sit over night as 2 tow bills later I was stuck. Went back the next morning and it started just fine. Now the darn thing, will start once it sits for about an hour after being ran, but once ran (Even just a couple of blocks) will not turn back over. I have had a mechanic come to the house 3 times but it doesnt act up when he is here, and had a diagnostic ran on it and it doesnt throw a code. Does anybody have any clue as to what might be wrong?
  • etubbsetubbs Posts: 7
    wish could help u more but it sounds like a cobe found under the hood on passengmputer problem should er side looks like a black box try replacing that or it could be the coil pack module ull find it on the side passenger try replacing it get it from a junk yard lots cheeper there not high stuff and trace ur wires see if you got any naked i no it s a lot but its worth it let me no what u come up with ed
  • etubbsetubbs Posts: 7
    look for the computer passenger sorry typing bad
  • steverstever YooperlandPosts: 40,011
    Welcome Ed - after posting, you may edit your post for 30 minutes. Just click on the Edit link.

    Moderator
    Need help navigating? stever@edmunds.com - or send a private message by clicking on my name.

  • kingpl456kingpl456 Posts: 1
    hi i have a 2000 jimmy 4x4 i starts when it is cold after driving for awhile it stalls and wont start until it is cool again replaced fuel pump plugs wires cap rotor and it still dow it it has spark it has fuel to the injector rail but still wont start replaced fuel pump relay in fuse box an still the same problem spray quick start in the trottle body wil kick like it wants to start as soon as it cools it starts write up can you suggest any thing thanks
  • immanaimmana Posts: 2
    if had the same problem years ago on a nissan 280zx. car would just die when it got hot. once engine cooled, it ran fine.

    not even sure if the jimmy has the same thing but the problem was (if i remember correctly) the ignition module. i remember it was a small black electonic module that sat on side of the distributor. easy replacement and fixed the problem.
  • I have had my 2000 GMC Jimmy in the shop now for 2 weeks... starting to figure it out
    I had the fuel pump replaced about 2 months ago... still having problems with starting after it gets hot... Mechanic just replaced the wiring harness for the iginition switch, and it starting throwing codes right and left... mechanic thinks the main computer brain for the Jimmy went out.. will post as we know more.. just wanted to give an update... Good Luck
  • FWIW:
    My '91 jimmy would start and run until it got up to temp....then die and not restart until cool. I pulled the codes and it said something about the "temp. read -15 degrees" or something to that effect.
    I replaced the temperature sending unit to the ECU (brain) and all is fine.
    jon
  • I have a 2005 GMC Canyon light duty truck and the engine light is on. Went to Autozone and they gave me the following problems?
    1. Purge or vent solenoids defective
    2. Check connector and wiring
    3. Fuel Saturated vapor canister
    4. Failed EVAP vent solenoid

    They said it could be one of the above. My question is how much does replacing/repairing any of these costs? As you know, auto shops are charging anywhere from $49.99 - $89.99 to check to see why the "check engine light" is on. I don't want to be charged for that since I already know what the problem is. Also, they may try to incorporate that cost into the repairs anyway if they knew that I didn't know how much it costs to repair in the 1st place. I've been going online but still can't find assistance with costs.
    Thanks, Sue
  • well one day shut it off, went for lunch, then it wouldn't start, poured gas in throttle body, it would run till gas ran out, so I disconnected the inlet to the fuel filter and tried starting, but no fuel came out...
    went for some supper called tow truck, while waiting with the inlet line still disconnected, i tried starting and gas started pouring out?, so i connected fuel line to filter and it started no problem drove it home.

    Next day started no problem, drove around town, came home shut it off, and wouldn't restart, this time poured gas in throttle body and still wouldn't even start this time, "scratching head"

    check all fuses, replaced relay, disconnected fuel line and re tried, no fuel coming out...
    Left for a few days, went out tried to start started right up, tried 3 times then wouldn't start with or with gas in throttle body, i have ordered a new pump, and have changed fuel filter, just not sure why it all works one day then nothing, what really gets me is it will crank over know but seems to be getting no spark and no fuel, even pouring gas in throttlebody wont run, hmmm

    Any help would sure be nice.

    thanks
  • just installed a fuel pump....new battery...worked friday....next day went out to start it won,t start... nothing ...won,t even try to kick over..... next day sunday...started up.......monday comes guess what it....it won,t start.....at least its trying to turn over......please please help what could it be.......
  • I'm having problem starting my jimmy it turns over but dose it kinda slugdish I went to state it this moring and it won't start but i tryed after i got after work and it started
  • i have a 2000 jimmy, started having trouble starting it few months ago, then wouldn't start all all, chgd fuel & air filter, started for while but would never start first try....then it wouldn't start again, back to the shop it went, they chgd cap & rotor, started for week after that but never on first try, then stops again, back to the shop, chgd crank sensor, started but never on first try for few days, now back in the shop again....need help, this is crazy, thx

    laney
  • I had the same problem! Some days it would start fine, some days it would start with starting fluid, other days wouldn't start at all! I replaced the fuel pump in July '08, then in Dec. starting troubles began. I ran many tests and found a few little things like weak coil and battery! The major cause was the fuel pump! Jimmy's '96 and newer require a higher pressure 55-68 psi. Test with ignition on engine off! I just put in a new Carter pump that has good pressure! I also read that the deqaler oem parts work! The link is for the same problem with a '99
    http://www.automotiveforums.com/vbulletin/showthread.php?t=939145
  • I have a 1998 Jimmy that I'm ready to roll over a cliff. It starts up for just a second and then stalls. This can go on and on. After a half hour or so it cranks right up. I've gone through everything I can think of. EGR valve, ignition switch, fuel pump/filter. Could it be the security system? That light is always coming and going...
  • Please help! My car is broken and we are lost on what to do. The car has been "stalling out" mid drive. I was going 65 on the freeway and it completely shut down. It also does this when I am driving around town. We have done the following:

    complete tune up
    new battery
    TWO new fuel pumps within weeks of each other
    new center port fuel injectors ? or something like that

    STILL stalls. Today it failed smog ONLY because " fuel evaporative controls functional" area failed The smog guy told me gas vapors are leaking.

    HELP! I need my car for my kiddos and am soo lost on what needs to be done and no mechanic knows how to fix. THANKS!!! :sick:
  • tidestertidester Posts: 10,110
    Does your Jimmy stall when it's in overdrive?

    tidester, host
    SUVs and Smart Shopper
  • jonnyringjonnyring Posts: 74
    You may have to pull the codes from the computer.
    My '91 would stall after 15 minutes of driving. I pulled the codes and it said something like "engine temp. was at 32 degrees" or some [non-permissible content removed].
    I replaced the temp sending unit to the the computer (not the gauge nor light) and all was solved.
    What was happening was when the car got up to temp. the Computer temp. sender would shut it down. That was just my situation.
    To sum it up...don't throw money at it until you've pulled the codes.
    jon
1568101114
Sign In or Register to comment.