Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Dodge Ram Lighting and Electrical Problems

1679111215

Comments

  • g1812000g1812000 Posts: 1
    I just replaced the engine in my 2002 ram 1500 4.7 and when i connected the battery, the headlights and tail lights came on after about 30 seconds. I opend the drivers door and the lights went out but when I closed the door the cycle repeated.
  • hh85ushh85us Posts: 1
    I have 2002 ram 4x2 I have no paking lights all other lights work. I dont have power to fuses I have power to relay but no ground to relay. Any guess what it might be
  • help its a 2004 4.7 ram 2wd
    been fine but went to use it today and found out i got no horn,wipers,or lights well the head lights are on and wont switch off by light switch. dash has no warning lights on and lights up like its all ok flashers work inside but nothing out side :confuse:
  • andertandert Posts: 1
  • bj3932247bj3932247 Posts: 4
    i had similer problems like this with my dodge i researched and found a tsb here is a link to where you can find this hope it helps it saved me alot by finding out that my fcm just needed flashed but unfortunitly my instrument panal was also shorted and that computer was about $600 hope this helps you
    ">link titlehttp://dodgeram.info/tsb/index.html
  • just bought a 2004 dodge ram 2500 with the 5.7 hemi the tail lights and marker lights wont come on. checked all the fuses and switch they are good turn lights brake lights and headlights all work fine any ideas?
  • alvis1alvis1 Posts: 2
    my 2000 Ram 1500 p/u just failed inspection due to the high beam indicator light not working. I replaced the bulb but still no indicator light! What is wrong? Quick help needed, PLEASE
  • massram98massram98 Posts: 1
    My low beams went out while driving the other night. I was changing from high beam to low, as a car was on coming, the lights went out. If I hold the multifunction lever back, the high beams stay on, when I release, the headlights go out. I don't want to waste time & money chasing parts - any ideas would be very much appreciated.
  • ramhead1ramhead1 Posts: 15
    hi...1998 Dodge Ram 1500..4 wheel drive.Seems my air conditioning works at idle..When I run truck at normal street speeds
    it shuts down.after about 5 minutes..Had a friend put gauges on and all seems fine, yet the compressor is not running...Replaced low and high side switches...AC accumulator and AC evaporator..has anyone seen this before??...Please help...Thinking it may be the compressor itself...or whatever makes it shut down...Would appreciate electrical schematic link for this truck..or any helpful info..
    Thanks...Keith
  • ddrydenddryden Posts: 1
    My 2003 dodge 3500 diesel with the 6 speed manual has a problem with all gages going to zero. When this happens chimes for low fuel etc. go off and the gages recover. The pickup truck never has a issue of running badly but lately when this happens the wiper will go to the low speed constant on when they are in the intermediate setting. I also have had the head light turn off and on at their own will when the dash gages go to zero.
  • I have a 2003 Dodge Ram 3500, the instrument lights do not work, the cluster gauges work fine. I have changed all the bulbs, checked all the fuse. The dimmer control works for the odometer and radio, but no instrument lights, can anyone help?

    Thanks
  • I have a 2003 Dodge Ram 3500, the instrument lights do not work, the cluster gauges work fine. I have changed all the bulbs, checked all the fuse. The dimmer control works for the odometer and radio, but no instrument lights, can anyone help? I also discovered that the heater controls, radio buttons, and steering wheel controls are not lighting up either. Anyone have a guess??
  • keith96keith96 Posts: 2
    I have the same problem as what you guys are trying to solve, but might have a little more info that could help. I was replacing my hood hinges a few weeks ago, I had to remove the hood in order to do so. I unbolted the hood, and cut the wires to the under the hood light, but i had forgotten to disconnect the battery when i did this, and got a small spark as i cut the wires. I replaced the hinges and mounted the hood again, and reconnected the wires, but now the radio, dome light, and glovebox light arent working. I checked all the suspect fuses but didnt find any bad ones, i even tested them w a voltmeter,so I suspect it is a bad relay, but the haynes manual gives very little info on relays. Does anyone know which relay is connected to these items, and if there is a quick way to test if it is good? And if its not the relay, then what else could it be? Thanks in advance for anyone who can help with this
  • keith96keith96 Posts: 2
    Ok so i did some more research and found out that its the IOD fuse that causes this problem. This fuse is connected to the mirrors, dome light, radio, hood light, key ring light, and several others. Inside the cab on the drivers side between the door and the instrument panel is the interior fuse box. Fuse 12, (the first fuse on the bottom row) is the fuse you are looking for. It is protected by a black plastic cover, this is used by mechanics to quickly disable things that are causing battery drain. Pull the black cover straight out, then the face of the cover is hinged and latched on the side facing the engine, using pliers or I used the fuse puller provided on the fuse box cover, unlatch the the little door and you should be able to pull the fuse out. As soon as I put in a new fuse everything started working again! I hope this helps out! good luck!
  • Well, hopefully anybody/everybody else with this problem gets it resolved with such an easy fix as you described dodgefan99...BECAUSE IT WORKED FOR ME!
  • lshe1970lshe1970 Posts: 1
    did you find out the problem i have the same year of dodge and it does the same thing. i went to turn high beams on and the lights went out but the fog lights stayed on. swithced back to low beam and they stayed on. but ever so often my ligths still go off on low beam. but it don't do it all the time.
  • i have the same truck with the same problem a few months back all i did was switch the light bulbs of the brake lights and the signal light and problem solved hopefully it does same for you
  • When I put on my left turn signal the right turn lights (inside and outside) will blink. Then the right signal won't work at all. I thought I would start at the signal flasher unit but at the parts store they told me it's integrated into my computer. Any ideas?? How about wiring diagrams too? Help!!
  • KCRamKCRam Mt. Arlington NJPosts: 3,516
    The parts store is correct. Such previous electromechanical functions are now handled by the body control module (BCM).

    More than likely, the computer thinks a bulb is failing or has failed... I had a fender bender in my 05 dually a couple of years ago, and the right front turn signal was broken in the collision - when I pulled over and turned on the hazard lights, EVERY exterior light except for the white ones took over hazard duty - this included all the roof, rear fender, and tailgate clearance lights.

    kcram - Pickups/Wagons Host
  • That was going to be my first attempt to fix the problem. I was able to get the 3157na bulbs but not the w5w bulbs. When they come in I'm changing all the bulbs...
  • slimbo2slimbo2 Posts: 1
    First time posting so probably won't do this right. Have a 98 2500 4x4 diesel and just came back from a trip. Ran great but next morning the ABS and brake lites remained lit and the speedometer and odometer were inoperative. So far I haven't gotten a NO BUSS msg. Read dodgefan99 post Jun 14, 2008 and not quite sure about the screw mentioned. I have a large hex hd screw with phillips slot that is listed as "Engine Inline". Backing out that screw came up snug and I didn't want to force it. Help would be appreciated.
  • mka1957mka1957 Posts: 1
    My 2002 Dodge Ram 1500 will not start. The dome light came on when I opened the door to get in, but when I put the key in and turned it to start, the starter kicked breifly once and everything went out. Dash, domelight, everything is dead and the truck will not start. There is now a faint clicking noise like a relay repeatedly clicking over and over again, even with no key in the ingnition. When i opened the hood, the engine compartment light comes on , but flickers in time with the clicking noise. Any ideas?
  • After changing all the bulbs the problem still exsisted. So I had a thought.... Since everthing is ran by computers now, I thought I would re-boot my truck. It seems to have worked, for now at least!!! I disconnected both batteries for about 15 minutes and then gave it a try, so far so good. Now if I can only remember how to change my clock.
  • KCRamKCRam Mt. Arlington NJPosts: 3,516
    Pretty soon, the dash will have a full QWERTY keyboard, and we can just hit Ctrl-Alt-Delete for that (he said, dripping with deadly sarcasm towards the automakers).

    kcram - Pickups/Wagons Host
  • I tried to install led lights on my 05 ram 1500 ,when I plug the lights in they light up even with the key off and removed .When I do test them the turn flashes erratically and so does the stop when the brake is pressed.Is there an after market controller for these? or are they like a windows computer (random glitches and malfunctions)?I have talked to the dodge dealer and they have never heard of this.. :confuse:
  • I'm not too sure if your truck has an electronic control box or not.
    I would start by disconnecting everything that you added for those lights, disconnect it at the power source.
    Now see how your original system is working. If there is still a problem see if dissconecting the battery for 15 minutes will work for you too...
    Good Luck
  • KCRamKCRam Mt. Arlington NJPosts: 3,516
    Biggest problem with adding LEDs to a vehicle that wasn't delivered with them is, the computer will not necessarily recognize them as actually being on properly, since LEDs have a very different (lower) current draw - the computer doesn't see the resistance it expects and tries to analyze a problem that actually isn't there.

    The company that made the LEDs should be aware of this issue, and they should be your first call for help.

    kcram - Pickups/Wagons Host
  • thank you for the info .I have also heard there is an adapter that will plug in to make the voltage read better.I will call first to make sure though.
  • i also have a 02' dodge ram 1500 that did the exact same thing today that stranded me in the bank parking lot. i was woundering if you have heard anything about the problem??
Sign In or Register to comment.