Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevy Silverado and GMC Sierra 4x4 Questions

189101214

Comments

  • I ended up taking mine into a four wheel drive shop and it ended up being a short in the wiring. It took them a few hours to diagnose the problem. Hope this helps.
  • I have a 06 Silverado 1/2 ton 4x4 with approximately 79,000 miles. My "service 4wd" light came on the dash occasionally but the 4x4 still worked, then every time I started the truck the "service 4wd" light came on. I pulled the switch and checked it and think that it was bad (internal lights burnt). I bought a new switch from the dealer, disconnected the negative battery cable and installed it. Reconnected the battery cable, checked the switch, no lights whatsoever, but the "service 4wd" has gone away.

    I've heard that this is common on chevy's. Has anyone run into this problem and if so what was your fix? I've already spent $98 on the switch from the dealer, so I'm commited now.

    Thanks,
    Dan
  • im not sure what the switch looks like but if there is a ground wire required to to connect to the switch, it will make the light work if it is connected to the right terminal. from what i know, the light wont work on any switch if there isnt a ground hooked up. Does your 4 wheel drive work at all now even with the light off?
  • It has 4 buttons, top button is Auto 4wd, next is 2wd, next is 4Hi, and finally 4Lo.

    The 4wd does not work whatsoever. I'm sure that I'm now looking at replacing the encoder motor which is between $185-$200 depending upon where you get it.

    Fortunately I have studded tires so getting around town and such is fine, but I own a rental that is located in the mountains and with the snow that we've been getting I might get in there but I probably won't get out without the 4wd.
  • gmcustsvcgmcustsvc Posts: 4,082
    djw52566,
    I understand you are working on fixing this yourself. Unfortunately, I cannot assist with diagnosing your vehicle. You could have the dealer assist you in diagnosing the vehicle. Please keep me updated on your situation.
    Christina
    GM Customer Service
  • 96chevy4x496chevy4x4 Posts: 1
    edited March 2011
    I have a 96 chevy silverado with the floor 4x4 shifter. But cannot get my front tires any power, 4x4 diagram wont light up either. I have checked the front drive shaft and its fine. i have checked the 4x4 fuse and thats fine, i have check the voltage going to my actuator and that is fine.I tested the actuator and it did not activate, so i bought a new one and that one wont activate. does anyone else know what the problem could be?
    last year i installed a new engine and before it was installed the 4x4 didnt work and as soon as i got it back with the new engine it worked, but has recently gone out again? really strange.
  • Has anyone answered this yet.??. I'm having the same problem and getting really tired of messing with it..
  • havatokerhavatoker Posts: 39
    Dude, had the same problem with a 2000,so finally , i decided to let them put the computer on it, it had 27 bad codes, after they were cleared it, worked well, but :shades: check to make sure you are getting voltage to the front drive, it won't read 12 volt, more like 3 1/2 volts.
  • jnl798jnl798 Posts: 1
    I have a 05 gmc sierra 1500 Z71 the service 4wd light keeps coming on and is now aotomatically shifting into 4low any ideas?
  • gmcustsvcgmcustsvc Posts: 4,082
    jnl798,
    My best recommendation is to take it to the dealer. Even if only to have it diagnosed. I apologize for you frustrations. Please keep me updated on your concerns. Have a great 4th of July weekend!
    Christina
    GM Customer Service
  • i have THE EXACT same PROBLEM did u figure out what the problem was, this prob is annoying me? if you could email me it would great , abraheim.elalighe@gmail.com
  • tmw4tmw4 Posts: 1
    My 2004 GMC Z71 had all the lights on the 4x4 sw panel come on and the truck was in 2 wheel dr. Dealer said they reloaded the software to fix it.
  • Hi guys....I have a 2001 GMC sierra 1500 extended cab with only 40,000 miles on it. I'm the original owner, so I know it's never been mistreated. Never had occasions to use the 4 wheel drive mode (hi or lo) and always drove in 2 wheel drive. Last week I tried to use it and something is wrong. It shifts into and out of 2wd, 4wd hi, lo and auto fine. The problem is when I'm in either 4wd hi or 4wd lo and I turn the wheels a bit to the left or right to navigate a curve (even starting out from a standing still position), when it starts to move in the direction of the turn, the truck jerks badly in both forward and also in reverse. There is a loud clunking noise every time it jerks. If I'm going straight without turning the wheels...no problem. All 4 wheels pull and no clunk or jerk. The 2wd mode has no problem whatsoever. Any suggestions as to what may be causing it?????

    Thanks in advance....Wayne
  • If you read your owner's manual, I think you will find that the truck should be driven in 4 wheel high at least once a month. I usually run mine about a mile in 4wd to keep things lubed. Also, all four wheels & tires should be close to identical or your driveline will windup and pretty much make the steering wheel impossible to turn in 4wd. If you ever plan on using the 4wd, you need to get it checked out by a pro. Hope this helps.
  • Your transfer case is low on fluid. Guaranteed. I own three of these trucks. Good luck!
  • Thanks, stoneybroke!! Like a dummy, I never completely read my owners manual and didn't know about driving in 4wd hi once a month. Also, all 4 wheels and tires on my truck are identical.

    I put a call in to GM...they said a dealer had to check it out, so I took it to my GM authorized service department. They checked it out and said there was nothing wrong with it.... that all 4wd's "hop" and clunk when turning on dry pavement and that it's just the way they are built. I find it hard to believe that it's normal for it to do that since it sounds as if something would tear apart in short order if you had to use the 4wd on pavement. But.....they are the experts....not me, so I guess I have to believe them. Thanks again for the advice.
  • Back to the owner's manual: I NEVER use 4wd on dry pavement. On corners, the ouside wheels will turn at different speed from the inside wheels-thus winding up the driveline. The hop and difficult steering is caused by things trying to equalize. If you have access to a dirt or gravel road, run it once a month to lube things. If you have to run on pavement, find a straight stretch of about a mile. Do you have the push buttons with "auto 4wd" as a choice? If you do, the truck will only use 4wd when a wheel slips.
  • donl1donl1 Posts: 109
    I can't believe you didn't know enough not to run a four wheel drive vehicle in 4 high or 4 low on dry pavement ...unless you have an Obama sticker on your bumper. :confuse:
  • Yeah it is completely normal for it too hop on dry pavement. Because if your turning the wheel your front tires arent going the same speed as your back tires so it jumps
  • You should avoid turning on dry pavement while in 4wd. This can be extremely bad for the ring and pinion gears in the difs. The problem is that when you go into 4wd it locks the axles so that they are all always turning at the same speed. This sound like it would always be the case but it is not. When you are turning (especially if it is a tight turn) the outside wheels are travelling a greater distance the the inside wheels and thus need to turn at a faster speed. If the axles are locked then this can not happen and causes the hop you are experiencing because one wheel is hopping to either speed up or slow down to match the other. Other than engaging 4wd on a long straight away occasionally for lubrication purposes you should only engage 4wd when you need it, which the vast majority of 4wd owners never really need to do.

    Gary
  • Well put, Gary. Thanks for the great information. I guess I was expecting the smoothness of an "all-wheel" drive vehicle. It's good to know I'm not having to look at a ton of money for repair bills.
  • i push the buttom and it just flashes but dont engage.
  • So, I read through this forum, but couldn't find anyone with the same problem as mine.

    The truck has the 4WD shifter on the floor (no push button nonsense), no service 4x4 light going on.

    The issue:
    Four-wheel drive not working. 4 low, 4 high, nada. Indicator lights for 4wd not working as well (even though the bulbs are fine).

    Checked fuses, checked front actuator (it's an electrical actuator).

    The thing is, the front actuator works. The piston will extend / retract like it's supposed to when switching from 2WD to 4WD, (with the key switch on) however: As soon as you start the engine the actuator piston retracts and stays retracted... hence no 4WD. Tested with an indicator light in the socket and it works as intended, on with key on, off while cranking, and back on again once running... the actuator on the other hand... not so much so.

    I'm thinking about putting it into 4WD then disconnecting the actuator so that it'll be 4-only to be able to at least plow snow with it for the winter. But I'd rather fix the thing correctly.

    Can anyone tell me what the problem is?
  • aj7314aj7314 Posts: 2
    I have 1997 GMC 3500 4x4 and am having the exact same problem with my 4x4. Has 4wd shifter on the floor and 4wd indicator lights not working when in 4wd and 4wd NOT working in 4lo or 4hi. Please let me know if you resolve this problem because I have the same issue with my 4wd. Thanx, AJ
  • aj7314aj7314 Posts: 2
    UPDATE: Check to make sure your wiring harness isn't fried like mine was. Look right between frame & exhaust to make sure wires arn't all burned up.
    Otherwise your actuater is most likely junk, mine was junk but didn't work at all, it may work when no pressure is applied but as soon as you put it in place with all the force against it, it may fail to work properly. Try replacing actuater with new one and I'm sure this will solve your problem as long as your wiring harness is good and not all burned up. Good luck
  • when i lock my truck in 4hi or 4lo it engages and all wheels rotate,problems is that the right front is dragging and doesnt wanna rotate....its a eletronic shift...anybody have any idea where i need to start?
  • I just fixed this exact issue on a '00 GMC sierra 1500. There was no "sevice 4x4" light, just constant blinking and no engaging of front drive. Local shop had it for a week but coulnd't find anything wrong. I got under the truck and listened while someone engaged and dis-engaged the 4wd. There was sound at transfer case but nothing from front axle. Ordered a front axle shift actuator for around $80. It took 15 minutes to install and fixed the problem.
  • i had the same thing happen to mine but havent fixed it yet
  • i have a 1993 gmc sierra 1500 1 ton it wont go into 4x4. i believeit is the actuator but i was told that there is an aftermarket part that i can use. if there is such a part plz tell me i relly need help
  • I have a 95 Z-71. One day I was driving down the snowy road here in Montana and I was looking at the 4x4 front wheel light indicator on the floor shift panel. For some reason, it just blinked a couple of times like a shorted circuit would and then it went out all together. So did the 4x4. It hasn't worked since! Ant ideas on what the problem could be?
Sign In or Register to comment.