Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevy Silverado and GMC Sierra 4x4 Questions

11415171920

Comments

  • I have a 2001 Chevy Silverado and recently the service FWD service light turned on. It all started when I was driving the lights and radio started to flicker on and off as if a battery cable was loose. I went home turned off the truck checked the battery and it was fine and when I turned the truck back on the FWD service light was on. I replaced the transfer case select switch and I am not pulling any codes from my code reader, I am thinking a loose wire? Any suggestions?
  • What does the encoder motor do? And thanks for the help!
  • The encoder motor is an electric motor which is used to shift the transfer case from high to low range. Also included in the encoder motor assembly is a position sensor which sends the actual position of the transfer case shift shaft to the Transfer Case Control Module.
  • "The Electric Actuator/Motor Is Used To Engage Transfer Case In And Out Of Four Wheel Drive On Chevy Truck Equipped With Electronic Shift 4x4. "

    I have a floor shifter and this makes it sound like its only on push button shift models?
  • Can someone tell me where to find a wiring schematic of the 4x4 system on a 1997 K series with a floor transfer case shifter?
  • About a half pint of Autotrac II transfer case fluid was added to the automatic transmission of my 99 Sivlerado. Is this going to cause problems? Should I change the fluid as soon as practical? It has been in there for about a week already; I cannot feel any problems as of yet.
  • I have a 2004 GMC Sierra with the dreaded "Service 4-wheel drive" message in my display. It happened a few weeks ago and is on-going, although intermittent. One time after turning off the truck (went into a store for some parts) and came back out, it was in 4-wheel low. I shut it off and restarted it and it was back in 2-wheel hi.

    I took it to the dealer and they said I needed to replace the encoder motor. I bought it from them and replaced it. Easy to do, I might add.

    3 or 4 days later, the same message reappeared. I went back to dealer and they said it could be the switches instead. I bought the switche and replaced them (in about 5 min).

    Few more days, message is back. I called the dealer and now they want $90 more to "reset" the code. They say it's not really broke, but I just need to pay them to reset the code and all will be fine.

    My question is, if the parts have been replaced, do I really need to have the code reset or should it reset on it's own. I hate to pay them more money if it doesn't fix the problem.

    I'm in for $90 for reading the code the first time, $400 for the encoder, $90 for another read, $100 for the switch. that's almost $700 and the truck is still doing the exact same thing.

    Any other options for what this cause is. I checked the battery ground and it isn't corroded at all.

    Your help is greatly appreciated...

    Jaymee
  • 2006 4x4 auto z-71 5.3L truck is going into neutral while still in gear. When I push the all-wheel drive button all gears work again I than push 2-WD button and it works for a while as norm. but than will kick back to N again. Makes a loud clunk if I don't stop to put in all wheel. Now it wont ingage in 4 -L ??? any help??? there is some Metalic in the transfer case oil..
  • has anyone found an answer to this problem..I also wanna convert my 02 over to manual 4wd.
  • Have you yet to find a solution to the problem? If so please fill me in. I just had the same issue with my 02 Silverado. The lights just went out on the 4x4 indicator and I am getting no 4x4 function. I changed the switch and it still wasn't working. Next is the transfer case actuator from what I am told, if that is bad you will lose power to the 4WD. Let me know if this was your solution too. Wouldn't mind saving the $79 if it's the wrong direction.
  • I ended up taking mine into a four wheel drive shop and it ended up being a short in the wiring. It took them a few hours to diagnose the problem. Hope this helps.
  • I have a 06 Silverado 1/2 ton 4x4 with approximately 79,000 miles. My "service 4wd" light came on the dash occasionally but the 4x4 still worked, then every time I started the truck the "service 4wd" light came on. I pulled the switch and checked it and think that it was bad (internal lights burnt). I bought a new switch from the dealer, disconnected the negative battery cable and installed it. Reconnected the battery cable, checked the switch, no lights whatsoever, but the "service 4wd" has gone away.

    I've heard that this is common on chevy's. Has anyone run into this problem and if so what was your fix? I've already spent $98 on the switch from the dealer, so I'm commited now.

    Thanks,
    Dan
  • im not sure what the switch looks like but if there is a ground wire required to to connect to the switch, it will make the light work if it is connected to the right terminal. from what i know, the light wont work on any switch if there isnt a ground hooked up. Does your 4 wheel drive work at all now even with the light off?
  • It has 4 buttons, top button is Auto 4wd, next is 2wd, next is 4Hi, and finally 4Lo.

    The 4wd does not work whatsoever. I'm sure that I'm now looking at replacing the encoder motor which is between $185-$200 depending upon where you get it.

    Fortunately I have studded tires so getting around town and such is fine, but I own a rental that is located in the mountains and with the snow that we've been getting I might get in there but I probably won't get out without the 4wd.
  • gmcustsvcgmcustsvc Posts: 4,004
    djw52566,
    I understand you are working on fixing this yourself. Unfortunately, I cannot assist with diagnosing your vehicle. You could have the dealer assist you in diagnosing the vehicle. Please keep me updated on your situation.
    Christina
    GM Customer Service
  • 96chevy4x496chevy4x4 Posts: 1
    edited March 2011
    I have a 96 chevy silverado with the floor 4x4 shifter. But cannot get my front tires any power, 4x4 diagram wont light up either. I have checked the front drive shaft and its fine. i have checked the 4x4 fuse and thats fine, i have check the voltage going to my actuator and that is fine.I tested the actuator and it did not activate, so i bought a new one and that one wont activate. does anyone else know what the problem could be?
    last year i installed a new engine and before it was installed the 4x4 didnt work and as soon as i got it back with the new engine it worked, but has recently gone out again? really strange.
  • Has anyone answered this yet.??. I'm having the same problem and getting really tired of messing with it..
  • havatokerhavatoker Posts: 39
    Dude, had the same problem with a 2000,so finally , i decided to let them put the computer on it, it had 27 bad codes, after they were cleared it, worked well, but :shades: check to make sure you are getting voltage to the front drive, it won't read 12 volt, more like 3 1/2 volts.
  • jnl798jnl798 Posts: 1
    I have a 05 gmc sierra 1500 Z71 the service 4wd light keeps coming on and is now aotomatically shifting into 4low any ideas?
  • gmcustsvcgmcustsvc Posts: 4,004
    jnl798,
    My best recommendation is to take it to the dealer. Even if only to have it diagnosed. I apologize for you frustrations. Please keep me updated on your concerns. Have a great 4th of July weekend!
    Christina
    GM Customer Service
Sign In or Register to comment.