Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevy S10 - GMC S15 and Sonoma Transmission Problems

1567810

Comments

  • I have a 1998 Chevy S10 with an Automatic transmission. Yesterday we went to the river and the transmission died on us. I was turning the truck around to pull off when suddenly the truck sounded like it was in neutral. I made sure to see if it was in gear and it was. I turnewd it off and then turned it on and put it into drive. It still sounded like it was in neutral and doesn't run at all. I have heard taht it's a shift linkage but I'm not sure. Can anyone help me, please? :confuse:
  • I forgot to say that it's a 2 wheel drive and 4 cyc. Thanks!
  • lindskaklindskak Posts: 2
    I have a 1998 Sonoma with 170,000 kms on it. i ended up going through a puddle wich ended up being quite a bit deeper than i had expected. i got stuck and ended up with about 3 inches of water inside the cab. of course i had to get pulled out. i also sucked up water through my air intake and filled every cylinder with water. after pulling every plug, emptied and dried all of the cylinders. it took a bit but i eventually got it started again. i went to back out of the driveway and my reverse turned into a second neutral. i can push it back with it in reverse just as if it were in neutral.i pushed it into the road and put it in drive and it took off just as normal but then reved high before it would shift into second. i took it back home and turned it off and started again and it took two tries to get it started. i drained the tranny fluid and replaced the filter and it still does the same thing. i was about to get a new tranny when i started reading this forum. im not really sure what i should do. i can handle the rough starting and shifting into second but no reverse is driving me mad. if it is the sun shell, would u be able to tell me what it looks like and how to change it myself.
  • lindskaklindskak Posts: 2
    i have a 98 sonoma with a 4.3 i lost my reverse, its as if i have two neutral gears. and revs high then shifts real hard into second. still have origonal engine.
  • gonogogonogo Posts: 872
    Reverse is mechanical, most likely sun shell. Repair not for the timid. Google and you should come up with instructions.
  • I have a 1996 gmc sonoma,4.3 v-6 auto trans.The truck does not shift out of 2nd. gear.Reverse,1st and 2nd gear are normal.No 3rd. or OD.Fluid level and condition is normal.Hoping for a reply from gonogo but any help appreciated,Thanks
  • zardoz1114zardoz1114 Posts: 12
    Been there, done that.
    I ended up getting a trans from Craigs list.
    My mpg started dropping, trans was trying to run in 2 gears at tge same time and wore out the bands above 2nd. Might as well bite the bullet and swap it out.
    I tried al the fixes I knew and I've been working on them 40+years.
    Sorry for the bad news.
    '95 4.3 4X4 AUTO.
    '95 2.2 2wd 5 speed
  • cbldgcbldg Posts: 1
    I have a 98 s10 and it is shifting rough what could that be it is an automatic transmission. I was told that I may need to replace the control solenoid. where is that located at and how hard is it to replace.
  • gonogogonogo Posts: 872
    Have it scanned. Other problems can cause hard shift, like a bad IAT sensor.
  • bleed1bleed1 Posts: 1
    what and where is the brake sensor?i have a 99s10 with same problem.can't find any thing.can anyone help? thanks- bleed1
  • my reverse went out on it and also the 1st gear went out was told it could be a fuse for the trans thet was blown but no idea where to look for it at ?anyone have/had the same problem what fixed it
  • gonogogonogo Posts: 872
    The sun shell is broken, did you hear a bang at anytime. Any transmission shop knows all about it, needs tear down.
  • thanks gonogo, every transmission place i have talked to tells me its a rebuild but i dont have funds to rebuild it at the shop prices :cry:
  • gonogogonogo Posts: 872
    Yes, they don't like to do repairs. If it ever happens to mine, I can repair it, hope it lasts, 4 cylinder.
  • Transmission started acting funny, it was not shifting properly. I pulled over and checked fluid level and all was good. Started it up and had no reverse. I made it in to work but no 4th gear or reverse now. It has HIGH miles on it but had the fluid and filter changed 18months ago. Any help
  • gonogogonogo Posts: 872
    Read post #286.
  • Yes, this is it. Thanks for the help. With 288,500 on this almost 10 year old truck I think I wiull retire it.
  • anyone know where i can buy the sun shell to repair my transmission :mad:
  • gonogogonogo Posts: 872
    Any transmission shop will sell you one , or google for online.
  • Recently, my 99 S-10 2.2L auto transmission failed at 130,000 miles. It was not "fixable" and had to be completely rebuilt for +/- $1,500. Works great now, and still beats a $500/month payment (for several years) for a new truck. It was disapointing that it crapped out at only 130,000 miles. I'm hoping that the re-built tranny lasts at least a few years.
  • got a question hope u guys can help..i have took the transmission off an s10 and left it hanging with four bolts on it for about six hrs...is the transmission going to have a problem with anything now...ps i didnt mean to leave it hanging i left it supported by a jack and the jack lowered by it self...
  • gonogogonogo Posts: 872
    No problem, your good to go.
  • I have a 99 s10 2.2 auto, 1st, 2nd, 3rd, and reverse work, sort of. The gears don't slip the fluid level is fine but it won't shift on its own, you can shift it your self and it starts in the gear you select except 3rd. 3rd gear will only work if your above 20mph and drive doesnt work at all I was thinking the shift selenoids are bad but I'm not sure any feedback would be awesome
  • gonogogonogo Posts: 872
    Probably no power to the transmission, need to troubleshoot to find out why.
  • kpa1merkpa1mer Posts: 1
    edited February 2012
    My son nas a 95 s-10 4.3 5 speed. When he takes off first gear is ok, but shifting to the other gears, the truck shudders, and he has hardly any power to the driveline. Me semi had the same issues but it was because the bolts on the bell housing was shearing from the motor, but his is fine. Can anyone help me to tell me if this is a clutch needing adjustment or will it need replaced. I got a haynes book, but didnt see anywhere to adjust the clutch, only replace it. Looking to just adjust the clutch, if possible before needing to replace it. Any ideas will be helpful. Checked trans fluid and it's ok as well.
  • Sounds like he burnt the clutch out. Hyd clutch, no adjustments. Have fun,been there, done that.
  • I have a 97 sonoma 4.3L 4 wheel drive. I just bought from a guy who had it sitting, I have replaced the water pump, battery and altenator. the problem now is right after I got it registered and tagged--will not shift to 3rd and 4th gears (auto trans). I can start out in "D" and it will not go above 2nd. If I start out in 1 then got to 2 it is fine but when I put it in 3rd it is like it is in neutral. I can rev the motor and get it to engage briefly. fluid level is ok. any suggestions?
  • zardoz1114zardoz1114 Posts: 12
    edited February 2012
  • gonogogonogo Posts: 872
    Do you have reverse, if no, the sun shell is broken.
  • I do have reverse 1st and 2nd gears
Sign In or Register to comment.