Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevy S10 - GMC S15 and Sonoma Transmission Problems

15791011

Comments

  • nucormannucorman Posts: 2
    The only code its shown is that the TPS was bad and I replaced that, but it still acts up from time to time. The odd part is if I shut it off and turn it right back on the problem is gone. The truck has 100k miles on it. Thanks
  • Every time i press my clutch pedal and go to shift it feels like something is blocking the way. Now i cant even shift into any gears. The clutch pedal goes down and i go to shift i can feel the teeth just slipping by. I havent had to deal with a clutch too much so any comments would help
  • kikocalkikocal Posts: 1
    Drive the truck for about mile ,tranny starts to slip will not accelerate,make a complete stop ,turn truck off and start again and this time it will move and does it again....
    CAN ANYONE OUT THERE HELP ME???,someone told me it was some sort of switch or something like that..
  • djslimdjslim Posts: 2
    I have lost overdrive and reverse. When I drive it now it shifts real high and real hard. I have heard that it could be the shift module or it needs to be rebuilt. I really dont have the money to rebuild it. If any one has any idea please let me kno.
  • gonogogonogo Posts: 872
    No reverse, not good , you need a rebuild, no way out.
  • djslimdjslim Posts: 2
    Thank you, now i have to just find someone to do it. Anyone ?? I'm not payin shop labor rates!
  • s13s13 Posts: 3
    my truck has 160,000 and today while going up a steap driveway it wouldnt go it just reved but no movement then it did but now reverse wont work and it moves foward when in neutral ....whats that all about
  • s13s13 Posts: 3
    its a two wheel drive 6 cyl
  • gonogogonogo Posts: 872
    Sounds like broken sun shell, need tear down.
  • s13s13 Posts: 3
    I was afraid of that ,is there a diffrence in price rebuild or replace
  • gonogogonogo Posts: 872
    Not sure about pricing, make some calls to local shops. From what I have read stay away from chain shops, reputation not good. I have read Jasper makes a good replacement.
  • fmacoyfmacoy Posts: 1
    1984 gmc 2.8 v6 4speed auto will not shift to 3rd and overdrive gears, trans has new oil and filter, speedo doesnt work, could this have anything to do with the problem? fmacoy.
  • i have a 98 s10 automatic v-6. My s10 shifts really hard from first to second gear when i get off the freeway its fine if i drive it around town it only does it when im getting off the freeway any ideas?
  • gonogogonogo Posts: 872
    Google PO 1870 code, you will find lots.
  • i have a 98 s-10 yesterday while stopped at a red light tranny decided not to engage when light changed went thru all the gears and only reverse worked truck wont shift into 1 2 3 od only reverse any good news would be appreciated automatic 2.2 litre thanks
  • gonogogonogo Posts: 872
    No good news, no forward in 1, not good. No electrical used in manual 1. You need a good used one or rebuilt.
    Did you check fluid level?
  • nick652nick652 Posts: 1
    Have a 98 Sonoma 4x4 was driving down the highway at 65mph and got this loud whining noise at cruising speed. When I accelerated harder the noise quieted a bit but loudened as I slowed again.

    As I pulled off highway the noise grew from a whine to a loud buzz and clicking. The noise persisted for a while. The transmission seemed to shift fine, no loss of power. The belt, brakes, are fine. I gunned it testing out the and the noise cleared up.

    Any thoughts?
  • jdslcbjdslcb Posts: 2
    ok i just bought this nightmare of an S10 looked and ran great..... at 1st now its about impossiable to put in gear and for some reason it will not regester my oil on my dashboard will some1 plz tell me what the prob is and how to fix it and also about how much it will cost me
  • anyone know if a 5 speed off of a four cylander will work on a v-6
  • I got this pickup recently not running for just $200 and was able to get it going pretty well after fixing the ignition and doing a number of other needed repairs. The only major concern I still have with it is this metallic clunking noise during downshift from 2nd to 1st. It often is good only if I've just come off the freeway, but other than that every time i come to a stop I can hear it. I think it's a problem with the torque converter still being in lockup during this gear change. If I pull the valve body, what do I do or look for?
  • i was wondering if someone could help me out, i have a 97 chevy s10 when i drive to work in the morning my tranny shifts funny it seems to go into gear fine but sometimes i"ll run 70 at 2500 rpm and then usually it runs 3000 rpm in the afternoon but sometimes it don"T matter if its morning or night. Also when i stand outside my truck i can hear what sounds like a vacuum leak and sounds like its coming right from above the gas tank
  • put a used tranny in my 99 s-10 4x4 4.3L auto flushed system changed filter fluid everything goes threw all drive gears good but like shimmies to get into reverse then wont catch really tired of this truck wont can i check or do i have to replace again :mad:
  • Vehicle has been sitting for about two months. I backed out of garage and seemed fine. Drove about 10 miles and went to accelerate and it downshifted and heard some kind of "clunk" type noise. I slowed down and all seemed to be fine. Stopped to clean vehicle and found that it would not go into reverse. It also now seems to "wind out" from 1st to 2nd gear. Still no reverse. Fluid smells good, it's red and full when hot. The only other other info that may help, is it did have a dead battery after sitting for a while. It was jump started and let it run for awhile to charge battery. Truck sat for another 2-3 weeks, when I went to pick it up, it started up fine. That's when I backed out of the garage and had these other issues. PLEASE HELP !!!!!! Oh yea, I did put it in 4x4 and tried to back up and that didn't work either. HELP!!!!!!
  • I have a 2000 sonoma that seems to be leaking fuel. At least it smells alot like it. Can't find any injectors leaking. I'm at a loss as to what it is. Sometime a small amount of smoke will appear when at a light and then it's gone. Can anyone out there suggest anything? :confuse:
  • The clutch in my truck is leaking hydraulic fluid somewhere in it. I've taken it to a mechanic, who believes the slave cylinder is leaking. The price of fixing this, assuming it is the problem, depends on where the slave cylinder is located. I've been looking, but cannot find any information. I need to know if the slave cylinder is inside the transmission on this truck, or outside. If it is outside, it will be cheaper, and I want to make sure he doesn't charge me the inside price even if it is outside the transmission. It has a 2.8L V6 engine. Any help would be grateful, thanks.
  • when shifting to 4x4 the light on the left of the shifter comes on the transfercase light stays off, 4x4 does not wok (worked fine last winter) could there be a fuse problem??
    thanks first time poster (rookie car owner)
  • tugs10tugs10 Posts: 1
    engine sounds like a diesel, chevy dealer said its normal, only 95k. trans takes long time to shift into overdrive when cold
  • gonogogonogo Posts: 872
    Piston slap, oil needs to warm up before OD.
  • jdb84jdb84 Posts: 1
    I have a 97 4.3 with a 5 speed trans, The trans grindes going in to 2Nd gear. I found a trans for a 97 s-10 but its out of a 4cly. Will it work on the 4.3???
Sign In or Register to comment.