Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Ford Ranger Lighting and Electrical Problems

17891113

Comments

  • I have a 2000 Ranger XLT The door locks work sometimes and other times they move only slightly when the switch is pushed. I've checked the grounds under the hood. Anyone else had this problem and found a solution?
  • my 94 ranger was running good but now i step on the gas and it stubles and bogs out for a few seconds and slowly goes away and runs ok but it has cut out on the highway going 65 70 i have to put it in neutral and rev and it comes back to life i drop back into drive and it goes again and cuts out again but it only does that at highway speed the the bogging out is every time i start the car and is worse when its cold . i changed the fuel filter plugs wires and air filter but it is still there !!! could it be the trottle sensor or air/idle sensor ??? please help
  • My truck started with a problem with the lights dimming out under acceleration. Also, gauge needles moving (vibration effect) while driving. All fuses are good and cannot see any shorts behind cluster. Battery and alternator were tested to be good. Finally, the lights did not come on for a day or two and then suddenly they just started to work again. I since replaced the light switch. Any ideas on the gauges and lights dimming. I know there must be a short somewhere.

    Thank You! :confuse:
  • I have the same problem right now. All, the gauges bounce around while driving. Headlights dim under acceleration. Alternator and batt tested good too. I remember in some older cars I had in the past it was always the alternator. Im assuming it could still be even if it tests good as I believe the diodes are inside. I might try that next. If you have discovered anything new please let me know when you get this post ok.

    Thank You and good luck to you.
  • bolivarbolivar Posts: 2,316
    Just saw your post, I see it's about 3 weeks old.

    But, wild guesses - a plugged up fuel filter - oh, never mind I see you've changed that.

    Or a failing fuel pump. Get a pressure gauge and screw into the fitting on the fuel line under the hood. Find out somewhere what the pressure should be. I think it probably needs about 45 pounds of pressure.
  • bolivarbolivar Posts: 2,316
    Well, you replied to a 3 year old post - doubt that guy is still waiting around for an answer.

    With ribbed belts, they don't slip often. But if you've got oil or something on the belt driving the alternator, that might be the problem.
  • My truck started with a problem with the lights dimming out under acceleration. Also, gauge needles going crazy while driving. (vibration effect). All fuses are good and cannot see any shorts behind cluster. Battery and alternator were tested to be good. I even sprayed all contacts with contact cleaner. Finally, the lights did not come on for a day or two and then suddenly they just started to work again. I since replaced the light switch. Any ideas on the gauges and lights dimming out while driving? Otherwise truck runs fine.
  • Parki n g lights on 99 Ranger stay on with switch off. Replaced switch-still can't turn lights off.Any suggesttions? THANKS!
  • bolivarbolivar Posts: 2,316
    Bad multi-switch (turn signal,dimmer etc stalk)?
  • webb24webb24 Posts: 1
    my husband has a 2003 ford ranger, he got a new stereo and a repair man volunteered to put it in for him, while the truck was running he cut the stereo wires instead of using a wiring harness since then the speedometer quit working and the windows wont work and the windshield wipers wont work. the next night on the way to work the truck lights got dim and the truck stopped..... we replaced the alternator and had a few blown fuses and fixed them... that still didn't fix the windows speedometer or windshield wipers and the truck wont run for a long period of time there is juice gong into the alternator but none coming out... any ideas of what the problem could be?
  • jac55jac55 Posts: 1
    I have a 1999 Ranger Pick Up, when I start the truck the Air Bag light in the dash will blink 2x then 7x, this will occur 4 or 5x then stay on constant. Any Idea's out there?
  • dont know where to begin, i recently bought used ford ranger from private seller. after driving around i notice electrical issues, when heater is turned on engine surges,when blinkers are on work fine until brake is applied then they flash rapidly, tried hooking up computer diagnostic shows error like its not connected,any ideas or should i just take it in to repair shop? thanks
  • My trucks hesitates when it starts then the radio comes on like the battery was disconnected with no presets. Everything else works fine, the charing gauge shows fine, the lights are not dim. Any ideas?

    Thank you
  • I have a similar problem with my 1999 range; however, it is limited to the lighting circuit. When I step on the brakes, the left turn signal is illuminated. When the left turn signal is on, it functions correctly (blinks normally) until I step on the brake. Then the left turn signal illuminates same as the brake lights and no longer blinks.

    The truck has not been used in two weeks and I just checked the blinkers to confirm my description was correct. To my surprise, EVERYTHING IS WORKING FINE. This is frustrating. I should mention that I replaced the multifuntion switch on the steering column, however, this did not solve the problem initially.

    I know your post is a couple of months old, however, were you able to fix the problem?
  • I have a 1990 Ranger. I have been getting an electrical-burning type smell which seeps into the cabin even if I don't have the fan/blower on for the ventilation system. I have done a thorough search under the hood, looking for plastic in contact with something hot, melting, etc, nothing. I do get a pretty good whiff of the smell when I initially pop the hood but then it dissipates rather quickly even though the engine is still running. All fluid levels are correct. The odor was present on my most recent trip of only 1 mile. Thinking back, this odor may have started just about the time I replace the temperature sensor (runs the temp gauge in the cabin), but that is just a guess/maybe a coincidence? Could the odor be coming from the alternator--something about to give out internally? ANY suggestion are welcomed. THANKS.
  • I have the same problem with my 2001 ranger. if you have a solution please pass it on to me. I'm going nuts trying to figure it out, I've hooked it up to a code reader but there's no fault code.
  • I got one for you guys. My lights were working fine up to about 2 weeks ago then something funny happened. When I apply my brakes, either in park or while driving, the passenger side front and rear directional lights come on. Also, when I have the right directional on, the drivers side brake light flashes. Weird, huh?! So when I make a right turn, I apply the brakes and it cancels the flashing of the directionals and holds them steady.

    It sounds like the wires are possibly exposed and touching somewhere. I'm not sure where to start troubleshooting this. Instead of taking it to a shop where they'll charge $100/hr, I turn to you guys for advice. Thanks much!
  • sealanubissealanubis Posts: 1
    edited March 2011
    So I've read through a few pages on this forum, and I haven't noticed any responses to the electrical problem on the Ford Rangers.

    I have an 07 Ford Ranger, my battery light started coming on, which then turned into losing all dash lights around 2k rpms. I took it to Autozone the battery and alternator test fine. The truck went about a week to a week and a half without anything happening again.

    Driving home tonight the battery light started flickering again and when it did all the lights dash and headlights got brighter. If I turn the dome light on it sounds like the inside fuse panel on the passenger side is clicking.

    what could this be? Any suggestions would be great.

    Anubis
  • jpiaseckjpiaseck Posts: 5
    My 99 Ranger had the same problem as the previous comment. Turn on the right turn signal and step on the brake and the blinker stops with the turn signal on but faded.
    An on-line mechanic told me the problem was in the multi function switch. I replaced it but there was no improvement. Next I replaced the brake switch. From the wiring diagram, it appeared to be a potential source of the short. No effect. Finallly I changed the turn signal flasher relay. It still did not solve the problem, however, a week later the problem disappeared and the electronics have been working without issue since. This is hard to explain what actually fixed the problem.
Sign In or Register to comment.