Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Dodge Dakota Transmission Problems

14546474951

Comments

  • Ok heres. My deal i have a 97dodge dakota 318the auto 4x4. And recently it snowed and i put my truck in 4x4good and well after wards my truck wouldnt move so i fooled with it for a while and finaly it drove but recently my truck while in drive only when completly stoped the i go again the whole truck shakes and shudders the stops and drives fine only happens when stop completly and go again please help me....
  • I was told it could u joints or my low gear is going out idk
  • DODGE CAN KISS MY A--, THEY WILL NOT HONOR MY WARRANTY SINCE I BOUGHT MY TRUCK IN FEB.NOT JUL 07, DODGE WILL NOT WARRANT MY TRANSMISSION. WELL I WILL NEVER BY ANOTHER DODGE OR CHRYLER PRODUCT AND WILL TRY AND INFORM CONSUMERS NOT TO BY THEIR PRODUCTS.
  • bk007bk007 Posts: 1
    Hey tim any luck whit this issue, my truck have the same problems
  • Dan Did you find out a solution to your Dakota noise problem? I have the exact same problem. I would appreciate some help with this. Thanks Bill360
  • tim684tim684 Posts: 2
    yes i was able to fix the shifting problem by changing out the shift selenoid pack cost was a little over $100.00 for the pack. it mounts on the valve body so you have to loosen that and drop it. it was messy but saved a ton of money
  • have you checked your transmission oil.... even though it may look nice and new... or not burnt... your filter may still be clogged... a transmission filter will run you under 30 dollars... and may clear that up for you.. its not hard to do ... (if you have 46re transmission...they did have a lot of problems...the filter fixed mine)
  • I've got a 95 dakota v8 automatic 4wd that I just got and the torque converter doesn't seem to want to lock up for the last gear so rpms sit at 3000 for 60 mph. anyone with ideas as to the problem? It had some seals done on the transfer and wasn't driven in a few years except by previous owners daughter when she needed it. It is my only mode of transportation, so I'm hoping quick fix, but I can't find anything unplugged and i don't have codes and a reader won't work for some reason.
  • had a problem with my 4 wheel drive when engaged,,i hear a clunking noise..when i check my drive shaft,, pilot bearing was worn,, anybody who has the same problem?
  • had a problem with my 4 wheel drive when engaged,,i hear a clunking noise..when i check my drive shaft,, pilot bearing was worn,, anybody who has the same problem?
  • I have a 2002 dodge dakota... my rpm's were jumping like that as well... I got it checked out.. and it was the shifting part that needed to be replaced.. the part cost like 150.00... give or take... I thought it was my transmission goin... I got so scared.. i felt sick sitting the the waiting chair.. but when he said 150.00 or whatever it was.. i could of gave him a KISS... lol ... hope u got it fixed by now... good luck "may dodge live on"
  • jboyd20jboyd20 Posts: 1
    I have a 2001 Dakota base model, 4x4, V6, automatic transmission. When it's in cruise control the cruise will kick in and out like its being cut off and then cut back on real quick. I just had the clock spring replaced because it was bad and the pcm flashed and it still does it. It shoots no codes or lights or anything. The dealer said they couldn't fix it because there wasn't a code and they didn't want to mess with it. I'm at my wits end as to what it can be. I'm tired of driving along and the truck have a stall like I'm cutting cruise on and off. It's to the point were it'll even make your head rock back and forth. Do you think the tcm is bad or should I get it flashed or what? Has anyone else had this problem? Any help will be appreciated.
  • merna123merna123 Posts: 2
    Does someone know the transmission fluid capacity of a '99 Dakota, 5.2, 4x4? I need to replace the pan and am wondering how much is in there.
  • I've been working on my buddy's 94 Dakota for a week now...His transmission went out about 40 miles from home and we towed back to my driveway and garage and set about to replace the transmission. Neither of us are mechanics, but I know my way around a Chilton book and toolbox.
    We (finally) replaced the transmission, flushed the lines out, and got everything hooked back up- at first, we had all gears working, but then a few minutes into the "test-run" down the street- all we have is 4-Low on the transfer case...so- rather than risk chewing up another transmission- it's back in my driveway...

    About the truck-
    '94 Dakota 4x4 with the 318 (or 5.2L) throttle-body fuel-injected engine
    Automatic transmission (apparently the only transmissions that fit in this truck are the 94-95 year transmissions.

    The previous owner obviously didnt maintain the vehicle to standard because there was about an inch of nastiness in the tranny-pan when we changed the fluid & filter two weeks before the transmission totally went out.
    There was some grinding noises when driving and shifting when he pulled into the driveway- first thing I did was drop the tranny-pan- sure enough black fluid, disgusting filter, and about an inch of sludge in the tranny-pan...got a new filter, new fluid, cleaned out the old nastiness, installed the new- grinding was gone- truck ran fine. Two weeks later, it started again- and then all of a sudden we only had 1st gear and Reverse (though it grinded like crazy)...then after limping it around- we had no gears at all. Get it back home- drop the tranny-pan, and the NEW (two week old) filter was totally SHREDDED- nothing left to it at all...new fluid totally black and disgusting. So began the search for another transmission. Finally found one (one of two in the state of Colorado)- a rebuilt number from a 95 Dakota. Came with a torque converter and a one-year warranty.
    After much cussing and sore knuckles, old tranny & torque converter out, new tranny/T.C. installed....flushed the lines out, added fluid (has brand new filter in it)- went for test run. Fail.

    Here's the current issue:
    When hooking back up the linkage between the transfer case and the shifter, the little bracket that holds the linkage rod in place snapped. In an effort to just get his truck driving in 2WD, we haven't connected the linkage from the transfer case to the shifter (or the short drive-shaft from the T-case to the front diff. Seeing as how we might be dropping the transfer case out tomorrow ANYWAY, at this point, I'm not seeing a point to hooking that particular peice back in yet-
    When initially backing out of the driveway, all gears worked (forward and backwards)...however, upon trying to go forward down the street for the test-run, it seemed we were stuck in 4-Low...we reversed back to the driveway, put it in drive to pull back in- no longer had any gear but 1st and reverse- and the truck stalled and died. We got it back on and limped back into the driveway in 1st gear and immediately shut her down.

    My questions are:

    Would the t-case "jump" in or out of gear since that linkage isn't connected?
    Could the old tranny that was shot to crap have also taken the t-case with it when it went to hell?
    If a new t-case is needed, is it just as year-model specific as the transmission or are there other options? (Another buddy of mine with a newer model Dakota was able to pull an automatic transmission from a durango and use in his dakota- but the 94-95 years are very specific)
    Since the transmission & torque-converter are from a 95, does the transfer case need to also be from a 95? If so, does that mean that newer drive-shafts would be needed?

    He's supposed to leave for Montana in a couple of days, and I'm packing up to move to TX in the middle of the month, so time & funding are NOT on our side with this one. I'm open to advice & suggestions...
    Seven-One-Nine. 434. 007-Zero. Text messages are awesome- since I'll probably be spending most of the day away from the computer (and under a truck)...

    Side-note: The wife's truck is the same truck- only manual transmission...and if something major like this ever goes wrong with it- I'm trailering that thing to the shop, throwing some cash their way- and sayin: "here- have fun"....LOVE LOVE Dodge/MOPAR....don't want to work on another 94 Dakota for a LONG time...glad I drive a Ram.
  • jbhodjjbhodj Posts: 1
    Background: As title states I have a 1999 Dakota 4x4, 5.2L with 160K on it. Yesterday when I went to put the truck in reverse there was a loud whirring noise, not grinding really. Truck would go forward no problem at that point until I drove a little further then lost all forward momentum. It started to slip then go back into gear then quite altogether. Putting the truck in park with engine running, the same whirring sound was noticed

    Got the truck towed home and then it sat it driveway for an entire day.

    Today, I started the truck up to have someone listen to the sounds I was hearing and the truck went into drive, park and reverse just fine with no abnormal noises or issues.

    Would like opinions on next step on what I should do or if its best to just start looking for a new tranny
  • I lost reverse in my 46re, and found a piece of snap ring in my trans pan. From what I know, this points to a broken snap ring in the OD unit. (?) I'm planning on buying a reman. OD, but I need to know if the unit for sale will match the one in my truck. The reman unit has #09104 and #19104 stamped on the bottom. My truck is a 2001 Dakota/5.9, and the OD is still in the truck. I don't want to take it out until I have the replacement in hand. Any help with id?
  • dekemp81dekemp81 Posts: 1
    My overdrive and cruise control stopped working in my 01 Dakota. It worked just fine until I went through a big water puddle after a heavy rain. What could be the problem?
  • I have a 1996 dodge dakota base line model automatic trans. its been runing fine a few times it has like chugged when accelerating...when today I went to drive away and would not go anywhere put in reverse went right into gear. put it back in drive and had to floor it to get it to move checked the tran fluid was a little low put some in nothing someone mentioned a transmision module tried to look up could not find such a part. got any advice before some garage trys to rape me .....
Sign In or Register to comment.