Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





2007 Toyota Avalon

11011121315

Comments

  • rpfingstenrpfingsten Posts: 154
    tjc.. thanks again for the speedy reply. As it turns out, I had some business just down the street from the dealership where I bought our avy, so I stopped in and explained about the glove box door. The service writer went out there, and dropped the door but couldn't find any obstructions. I was standing there and noticed this "tube" or shock just hanging to the side and asked them if that needed to be connected to something.. sure nuf, they hooked that back up and Bam, door works fine. Heres' the strange thing about that, I believe that "shock" has never been connected. Up until 2 weeks ago when they first took the door down, whenever I would open the glove box, it would just " fall " open. Now that the shock has been connected, when I open the glove box, the door "eases" downward, almost like it was on hydraulics. So it appears to me that it was "never" hooked up til today.. which surprisingly enough is the same thing they told me about the drain lines from my sun roof last year.. pouring rain, rain water litterally coming thru the speakers on the A-pillars. Car was 3 months old with about 2K on it. Service writer says my "drain" lines from the sunroof are probably 'clogged "..well that didn't make sense, a car that new, with only 2k on it, and a car that sits in a garage all night. Not likely.. once again, turns out the drain lines were "never hooked up at the factory" according to the service rep... by the way, you asked about the mileage on our avy, as of today it has alittle less than 16K on it. Bought it new in Sept. of 06, so the mileage is pretty low, although there was a 3 month period there where I didn't drive it much because I broke my right leg.. My wife would drive it once a week or so just to put alittle drive time on it. Still love the car, can't get over the power this thing puts out for being a 6 banger. Please remember I grew up in the Muscle car era... shelbys, goats, etc.. if it wasnt' cranking out 350 ponies (minimum) you were driving grandma's car. Oh for the good ol days of affordable Hemi's and 39 cents a gallon gasoline... :-)

    Roland ( the old hippy )
  • tjc78tjc78 JerseyPosts: 5,023
    What really upsets me here is if the "shock" was never connected why the hell wouldn't the tech replacing the air filter just connect it. That is the height of laziness. I am sorry to hear about the sunroof drains, I guess someone at the factory was having a bad day.

    I wish I grew up with the muscle cars! You are right about that V6 though. Powerful and pretty good at the pump too! I have a year left on my lease and even though the Avalon will be pretty much be unchanged for '09 I will most likely end up in another one. Unless the Hyundai Genesis is all its cracked up to be.... but that's another story!

    1999 Chevy S10 / 2004 Merc Grand Marquis / 2012 Buick LaCrosse

  • johnnyb5johnnyb5 Posts: 1
    Does anyone know how to disable the bell on a 2007 Avalon that comes on when you open the door with the key in the ignition?
  • rpfingstenrpfingsten Posts: 154
    Hey guys... sometime back, somewhere on one of these boards, I read a post from someone that said the odometers were not perfectly accurate on the avy's. As a result that has an impact on your actual mileage as well as your computer displayed FE. Could somebody direct me to the archived post on this subject so I can go back and get a better understanding of just how "off" the odo's are and how it effects FE. I ask because tonight my car was showing me at 28.2 mpg in mixed city / hiway driving. But when I actually checked the mpg myself on a calculater, the actual mileage I got was 26.74 mpg. I appreciate the help. Thanks

    Roland
  • finfin atlantaPosts: 586
    The odometer is off by about 3% in most current generation Avalons. The speed is OK... just the distance (miles) is wrong. You will actually travel about 3% more miles than indicated.

    An easy check is to travel an interstate and watch the mileage as you pass the mile marker signs. Within 5 miles you will see a stunning difference in the miles indicated and the mile marker signs. I have done this on at least 3 different interstates, same result each time. How the speed can be right and the mileage off, I have no clue... Speed checks fine on roadside construction warning radar. Others have posted similar results.

    Hope this helps, try a search on "3%" without the "" marks. :)
  • wwestwwest Posts: 10,706
    Or if you have a more modern GPS/Nav system, such as the Garmin 680, you can compare the GPS distance travelled with the odometer to discover how accurate it may, or may not be.

    You might even be able to adjust the operational temperature of the tire pressure to the correct level and bring the odometer into closer "tolerance".

    And by-the-by my GPS indicates that those road markers are correctly placed on the average but not necessarily otherwise.
  • 49364936 Posts: 15
    How do I stop the annoying seat belt chime?
    Requested and Answered by Smuook on 30-Jan-2007 23:53 (69 reads)
    1. Turn the ignition ON but don't start engine (Ignition ON by pressing ENGINE START STOP button twice with foot OFF the gas)
    2. Make sure speedometer is in odometer (ODO) display
    3. Turn ignition OFF
    4. Turn ignition ON again without starting it
    5. Press and hold odometer button. After 10 seconds and while still holding the button, buckle your seat belt.
    6. ODO display will change to b-on or b-off depending on the pressing of the odometer button.
    7. When odometer is set to b-0ff you ar
  • tjc78tjc78 JerseyPosts: 5,023
    Not sure what year Avy you have.... but as far as I know this procedure only works on '05 and '06 Avys. It worked on my '06 thank God!

    1999 Chevy S10 / 2004 Merc Grand Marquis / 2012 Buick LaCrosse

  • ajmtbmajmtbm Posts: 245
    i have an 06 Lexus IS250 and when set on floor only, the front cents seem hotter rthan the floor (i never measured). the fact that any heat gets expelled from the top when the floor vent selected annoys me. i wonder if its just the way the system is designed.
  • randy100randy100 Posts: 1
    Looking for the instructions to change oil filter and where can i find the wrench to remove the housing to get to the cartridge.
  • marstilmarstil Posts: 5
    Read and print the enclosed link, it's a picture assisted set of directions for changing the Avalon oil filter. You'll need two tools; a standard 3/8" ratchet and short extension for the removal of the filter drain and a filter socket to remove the housing. You'll also want a short piece of garden hose to direct the filter drain oil. You can work without it by strategically placing the oil drain pan but the short length of hose makes it easier. The filter socket is a 65/67mm size. Don't buy the metal one; I did and it doesn't work well. Go to Wal-Mart and buy the plastic one; it works much better.

    http://members.cox.net/n0v8or/avalon_oil_change.pdf
  • marstilmarstil Posts: 5
    Oh...one more thing. My local parts store sells the Avy oil filter for 12 bucks. My local Toyota dealer sells it for 6 bucks. Weird, eh...the dealer being cheaper than the aftermarket? So, check your dealer before paying too much at a parts store.
  • rpfingstenrpfingsten Posts: 154
    Hi people.... just curious about the post I read earlier stating that the avy odometers were off by .03% Has that actually been confirmed? I ask because the other day on the interstate, I tried to reset my odometer and check it with the mile markers. However I was trying to zero the odometer at "exactly" the same time I passed the marker, which is kinda hard to do at 70 mph. Even so, it looked like my odometer was right on the money. Just curious if this problem was confirmed and if so, what year of the avys has it appeared? Thanks for your help.

    Roland
  • finfin atlantaPosts: 586
    Several members, including myself, have observed this error in our Avalons. Is it all of them?... don't know. I have checked mine all over the southeast on different interstates. Always off by about 3%. Speed is correct, just the mileage travelled is off.

    All you need to do is watch the mile marker as you pass, observe the mileage shown on the dash and say it out loud. Watch when you pass the next marker, and again, say the mileage shown out loud. If your car has the error, within 5 miles you will hear the difference. Use the trip mileage with tenths. Have fun, post your results... :)

    Let me add for anyone interested that at 21k miles my '07 Limited w/Nav is still near perfect. Nothing but oil changes and tire rotations so far......
  • captain2captain2 Posts: 3,971
    same experiencce as fin - if you are attermpting to check the odometer over a short distance, it will be tough to see 3% - try a nice long 100 mile trip and I think you'll see 97 miles indicated on the odometer is actually 100 miles travelled. What I don't understand is how this is possible because the speedometer is right on the button. Back in the old days speedos were notoriously optimistic but then again so was the odometer.
  • rpfingstenrpfingsten Posts: 154
    Well I've had my 07 Avy now for more than a year and a half.. gas mileage is nice, averaging alittle better than 26 combination city / highway. Overall reallly like the car, but I've got two things that are really becoming big irritants for me. First of all, I will never never never ever buy another yota with a sunroof... when I first got it I noticed during the cold months that the sunroof would rattle if the temp got down below 40.. well since I live in Louisiana and temps are "usually" above 40, no big deal, especially since the rattle stops when the heater warms up the cars interior... but now the rattle starts when the temp falls below 50..... Last time I had the car in for service, I mentioned the rattle to the service dept and they said, huh, thats not usually an issue with the avalon... he obviously dosnt read this forum... and then last night, my windshiels washer "low" indicator lights up. I grab a bottle of windshield washer and start pouring it into the reservoir only to realize that it's running striaght thru onto the garage floor...what an odd thing to go wrong... a hole in the reservoir.. I realize these are non mechanical things, but what happened to that world wide reputation for toyota reliability... especially in relationship to the sunroof rattle...

    Roland
  • rpfingstenrpfingsten Posts: 154
    well we've all heard about the cold temp. sunroof rattle on some of the avy's... I myself have posted that this is probably the only thing on my car that drives me crazy.. funny thing though, there are 2 toyota dealerships in my area... called one last week and asked them about the sunroof rattle. they told me that they had heard about the rattle but not actually repaired one, and that they would have to send it out to a trim shop who would have to drop the headliner and then fix the metal flex rattle in the sunroof mechanism... then I called the other toyota dealership and told me that the car would only have to be sent to a trim shop if the sunroof was installed as an after market item.. when I said no, that the car was manufactured with the sunroof, they told me that they could fix it in house, without dropping the headliner.... any thoughts on this... actually taking the car into the dealership tomorrow so I'll let you know what the outcome is.

    Roland
  • nimiminimimi Posts: 249
    I have the intermittent moonroof rattle (2008 Limited), however, I didn't notice it until the weather started getting into the 50's so it's not cold-related but is heat-related. And it is EXTREMELY intermittent. It's right above my head and will stop if I push up on the front left edge of the glass roof panel.
  • rpfingstenrpfingsten Posts: 154
    Nimimi.... took my avy to the dealership earlier today.. temps in the 70's and with summer on the way, no way to know if my moonroof rattle has been fixed until this coming fall and the temps start to drop. but..... the dealership told me that by using a stethoscope while driving the car, they could hear some "metal" flex issues in the mechanism that operates the moonroof... today they wrapped some of those metal rods with " felt " to try and buffer the rattle. Wont know for sure til october or so, but I'm hopeful this takes care it.. this has been the "only" issue I've had with the car in my year and ahalf of owning it.. Other than that one thing, I absolutely love this car... oh by the way I think you and I may be talking about different rattles... my rattle actually sounded like it was coming from the dash board on the passenger side, but would stop when I applied pressure on the moonroof.... I think you said you could hear your rattle right above your head...

    Roland
  • finfin atlantaPosts: 586
    At 23k miles my '07 Limited finally hit 30+ mpg on a trip. Been close but never made it up to now. There was a lot of construction and police were everywhere for about half the 325 miles. Avg speed was about 60-65 instead of the 75+ we usually travel so that must have made the difference. This is great considering gas is $3.79 a gallon for mid-grade in GA and the FL panhandle. What a ride... all this room and 30 mpg too... :)
Sign In or Register to comment.