Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





2007 Toyota Camry Problems and Repairs

1259260261262264

Comments

  • mcdawggmcdawgg Posts: 1,666
    edited April 2012
    The fuel filler flap - I know what you mean, my old Corolla had one, but I know for a fact the 2007 Camry does not have one, none of the newer Toyotas do.
  • chuck28chuck28 Posts: 257
    Hi Zaken, wanted to give you an update on the Camry V-6 2007. Last week after code reset by disconnecting battery went almost 100 miles until check engine light came back on. Same codes 138 and 2195. I was running premium and had the Chevron full treatment in the last tank.

    I was going to put more chevron treatment in my next tank but I let the guy at auto zone talk me into this product called Lucas 10020 upper cylinder fuel injector cleaner. He claimed it is better than Chevron. I went head and tried it though I should have talked to you first.

    I filled up with Shell Premium and added the bottle. Car had noticeable more power. However the check engine light came on only after 20 miles. I have disconnected battery again and will recheck today.

    Am I hurting anything by using this product?

    Thank for all your help, Happy Easter, chuck
  • zaken1zaken1 Posts: 556
    Two points here: 1> Despite the claims of some other people on this site; it is still my opinion that it is not as effective nor as permanent to clear codes on an OBDII emission control system like yours by disconnecting the battery as it is to clear the codes with a scanner. Take that as you see fit.

    2> While Lucas fuel injector cleaner is a good product; it has a narrower range of effects than Chevron Techron. Each product has its purpose and strong points; but each also has a degree of solvent action; which has enough of a diluting effect on the oil in the cylinders that it should not be repeated more often than about 3,000 miles. What I'm saying here is that I do not recommend using any fuel injector or combustion chamber cleaner more often than once every 3,000 miles; and only one product at a time. So, if you use one brand, no other brand or no more of the one you just added should be used for the next 3,000 miles.

    3> If you want to make the motor more efficient; have the mass airflow sensor cleaned; using only mass airflow sensor spray, and have the throttle body thoroughly cleaned (paying particular attention to both sides of the butterfly and to the entire bore; especially where the edges of the butterfly touch the bore). This can be done as often as 3,000 miles; but most vehicles will not show noticeable benefit if it is repeated more often than 6,000 mile intervals.

    4> As I have previously recommended; I believe that replacing the ignition coils with the Airtex/Wells model specified for your car will improve the running. I can also suggest an alternative spark plug choice; if you so request.

    How's that for "2" items?
  • chuck28chuck28 Posts: 257
    Hi Zaken, thanks for your last response. I respect your opinion over any other. When I get a chance I will have my mechanic reset the code with his OBD reader. In the mean time I like to reset the code by unhooking the battery so I don't have to be reminded of my car problems when looking at the check engine light. I know I should go buy a OBD meter. I will hold off for now on any more fuel treatment as I have not gone close to 3000 miles after I put the Chevron treatment in. Thanks for that advice.

    On another note I was under my car today removing the plastic shield underneath the front of the engine so I can get a better look at the windshield fluid resevoir that I thought might be leaking. Still not sure about that but while under there I notice a dime size jagged hole in the casing of the motor mount. This seems to be a heavy duty steel and can't figure out how that got there. Is there anything inside that casing that could have busted through that?
    I'm sure this is a new request of you. I figured if anyone has an answer it would be you. Thanks again Zaken.

    PS Is there any way I can connect with you outside the website?
  • zaken1zaken1 Posts: 556
    I really can't say much about the hole in the motor mount casing. The only thing that is inside the casing (assuming you really are looking at the motor mount) is a rubber block. Here's a link to a photo of the motor mount: http://www.rockauto.com/catalog/moreinfo.php?pk=1572462

    Those mounts are sometimes not finished nicely; and could have some slag or rough edges on them just as a normal imperfection. I can't imagine anything punching through it.

    I have mixed feelings about connecting outside of this site. I realize it would reduce the time lag; but it would also have the potential to be an intrusion into my personal life. You see; I feel very responsible about answering people's questions promptly; and thus am not comfortable about knowing that there is an unanswered question hanging. If such questions are limited to the Town Hall and Edmunds Answers websites; I can control how often I log on; and that allows me to concentrate on my other activities as desired. But if questions or requests were to show up on my e-mail account; I would find them much more difficult to ignore. As it now is; I often feel pressured by the various demands on my time from activities in which I take part. And I try to maintain a relaxed pace of life; which allows me to choose when and what I do at any given time.

    Perhaps if you explain why it would be desirable for you to be able to contact me outside this site; I could be in a better position to respond about such a request.
  • chuck28chuck28 Posts: 257
    Hi Zaken, I respect and understand your position about connecting outside of the site. You have been great answering my questions. For reasons you mentioned about convenience for me and quicker responses is why I requested this. I'm good with the way it is now.

    The picture of the motor mount is what I was looking at. The hole is located about an inch or two above the factory whole that is shown in the picture. I took a picture of it but not sure if I can post it to show you. I'm assuming the casing is just there as a cover and the mount is still working properly. Wondering if there is any fluid in these mounts.

    Thank again and I'll keep you updated, chuck
  • chuck28chuck28 Posts: 257
    I have a 2007 Camry V-6 which has a check engine light with code 2195 and 138 Fuel air ratio and oxygen sensors. Toyota says to fix it they need to apply the TSB which includes changing the exhaust manifold. ( $18,000)

    They claim this is not warranty work under the power train warrany only the 3 yr -36,000 bumper to bumper/

    I have an extended power train warranty which clearly states what is covered under the warranty and it list the exhaust manifold.

    How can Toyota say this would not be covered?

    Thanks for your insight, chuck
  • chuck28chuck28 Posts: 257
    Ooops! cost is $1,800 not $18,000 my bad,
  • zaken1zaken1 Posts: 556
    Is your extended powertrain warranty through Toyota? If it is; you need to work this out with Toyota's warranty department. Explain to them that the exhaust manifold is listed under the items covered by that warranty; and see what they say. If it is through another company; you need to discuss this with that company.
  • chuck28chuck28 Posts: 257
    Hi Zaken, I did just as you mentioned. Talked with Toyota Extended care and they confirmed the manifold is covered. They said the car needs to go back to the dealership so they can start a new R.O and get the milage off the car. My wife will be taking the car there this morning. The deaership reminded me that I will still have to replace the sensors. I' m hoping they don't try to double charge me on the labor for the sensor replacement seeing that the manifold labor includes removing the sensor.
    I will keep you informed, thanks chuck
  • chuck28chuck28 Posts: 257
    Hi Zaken, here is the latest, had my wife take car to Toyota. Service manager said he had to fight with Toyota extended care to warranty the manifold. He then told me the only way they would agree to warranty it is for me to have all the sensors changed which includes 3 sensors even though only 2 of the codes were coming up for Bank 1 sensor 1 and 2. The other one was Bank 2 sensor 1 Fuel ratio. I questioned him on it and he said this is the agreement Toyota told him. Cost for parts and labor $675 minus 10% coupon. Manifold no charge. I told him to go ahead with the job seeing that I now have a 1 year 12,000 miles warranty on the new parts. He tried to discourage me calling back Toyota extended care saying he already did everything he could. I called them anyhow and they had a different story saying they recommended only changing out the sensors that applied to the specific manifold even though they can't cover the sensors under the power -train warranty. Called back dealership and he said "that's not what they told me" Someone is lying and I think it's the serve manager.

    I tried to negotiate not to change the Bank 2 sensor which would save me $212.00 and he said he had to check to see if they started taking it out yet. He then said mechanic said sensor looked week and he wouldn't be able to warranty the work if I chose not replace it. For the peace of mind I agreed to have him replace it.

    All and all I'm pleased to have the job done to Toyata's specification. I have all the updated parts including the redesign manifold. This would have been close to a $1800 job with out the warranty of the manifold.

    Rock auto also agreed to give me credit on the sensors I bought from them. Very nice of them.

    I have all the original sensors. As I inspect the Rock auto's sensors they say Denso on them but not Toyota. The old Toyota's sensors say Toyota with there part number on them. I did notice that there was a design difference in the two oxygen sensors. Toyota's had a few small holes in it and the Rock auto had multiple holes up and down. I can't say each sensor is exactly the same/ The fuel ratio's were closer in looks.
    This has been a long journey and I hope it's over. I still hate dealing with the dealerships but seeing that they covered more than half the job I'm happy.

    Thanks for all your insight and I look forward to continue to gain more wisdom from you in the days to come. You have been a great help! Chuck
  • chuck28chuck28 Posts: 257
    2007 Camry V-6

    Car is running better than ever. Check engine lights gone after TSB performed. (replaced manifold and fuel-air sensors).

    Car is shifting better and gas milage is better. It's a joy to drive agian.

    Thanks again for the knowledge we learn on this site.
  • akumotoakumoto Posts: 1
    have you found a solution to your intermittent problem u0101
  • iraheeliraheel Posts: 1
    Were you able to get it fixed , i have the same issue with my car
  • banditboybanditboy Posts: 54
    edited August 2012
    I have 74k on my 07 camry I4 with moonroof package . Oil changed every 5k. Had 1 failure. the car seat motor stopped working at 34k miles. fixed under warranty.At 73k needed new rotors and brakes. i have a tow hitch and it has towed some heavy weights a few times and around 1000 pounds for extended time.

    Cannot believe the brakes lasted so long. Mine i was the first batch after the hesitation fix , i made sure of it in 07 . great car and many more miles to go.It has become the older vehicle in the family and sees limited usage as my winter commuter when its too cold for the motorcycle. But 4 yrs it carried our family everyday and was our primary vehicle.
  • chuck28chuck28 Posts: 257
    HI I have a 2007 Camry v-6 SE with moonroof. Today I noticed my dome lights in the ceiling in front of moonroof are diming an orange maybe a touch of blue/white. At first I thought it was a reflection, It;s like a glowing sensation. I've checked all switches. The lights work fine when switched to on.
    Does anyone know what can be causing this diming glowing.

    Thanks chuck
  • I was having the vibration allso with 70000 miles and it started about a year ago. The dealer keep telling me it was normal for the vibration. I took it to another dealer and he found that the airflow senser was dirty and cleamed it and reset the computor to factory and the vibration went away. Who ever has this problem might have the dealer to check it out. I was also told that you should get an engine check light which I never got.
  • chuck28chuck28 Posts: 257
    Can anyone suggest a good brand rotor and pads that would work on the 2007 v-6 SE Camry. I'm on a budget bit don't want to buy cheap quality.
    Also has anyone done there own brakes and found any problems with aditional shims that are requrured?

    Thanks for any insight you may have, chuck
  • chuck28chuck28 Posts: 257
    I have a 2007 V-6 Camry. I noticed recently wipers were moving very slow. Weather has gotten cold in Chicago. Today Battery light came on. Made it home turned off car and car wont restart.. Just a click...
    Took battery to auto zone battery tested good ( meaning cells good) but needs charge.
    Auto zone is charging the battery for me and I will pick up tomorrow.
    It's seems it might be an alternator problem.
    If anyone has any insight on this matter it would be much appreciated.
    Thank you, chuck
Sign In or Register to comment.