Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Toyota Tacoma Engine Questions

1235»

Comments

  • What does MAF stand for? I'm having similar issues w/ my 98 Tacoma, 6 cylinder, 4x4
  • KCRam@EdmundsKCRam@Edmunds Mt. Arlington NJPosts: 3,495
    MAF = Mass Air Flow sensor

    kcram - Pickups/Wagons/Vans+Minivans Host

    KCRam - Pickups/Wagons/Vans+Minivans Moderator

  • Hi, I have a 2000 Toyota Tacoma with 106K miles that usually begins to shake and vibrate when it(the engine) is cold, usually in the mornings, and when it is not moving. I have no idea of what might be wrong with it or what causes it to shake. I would really appreciate it if y'all can tell what might be causing this.
  • I am getting my 2012 back from the dealer in a couple of hours from having the same problem looked at. The service dept. took the intake off my truck, took the valve cover off, checked and micrometered every thing and can find nothing wrong. I first noticed and fussed about a slight ticking at a couple thousand miles. It has gotten louder as time has gone on, so at 8300 miles, I had the dealer check it out. Now that they tell me they can find nothing wrong, I am more baffled than before. The dealer pulled a new 2013 truck with less than 10 miles on it in beside mine. It makes the same ticking noise. Crazy!
  • Kirstie@EdmundsKirstie@Edmunds Posts: 10,676
    Please take a few minutes to answer our survey:
    https://www.surveymonkey.com/s/EdmundsForums

    It's really important for us to hear from our members and visitors to get direction going forward. Only good things are planned for the future, but we need to gather insights to get there! Whether it's your first time or you're a regular, we'd love to hear from you.

    Need help navigating? kirstie_h@edmunds.com - or send a private message by clicking on my name.

  • tacoman8tacoman8 Posts: 3
    make sure all your hoses and clamps are tight and you didnt accidently miss any hoses sounds like a vaccum leak some were dont omit any sensors just one could fowl up the idle
  • tacoman8tacoman8 Posts: 3
    It sounds like you have a bad EGR valve and there some issue with your engine I would bring that puppy back to toyota with 4,500 miles on the board and let them go thru it do not waste time or it could come unglued and check your oil to make sure you do not blow it with low oil or none see your toyota people a.s.a.p
  • i have the same truck and the dealer in va told me it comes from the gas we have to use it cleaning ur injector from the gas.
  • I have a 2009 toyota tacoma with the 2.7 engine in it mine makes the same ticking noise at idle toyta makes crappy trucks they do not stand behind their product last toyota product i will buy ever this truck is a gas pig and toyota did nothin to repair flaws with truck their dealers are con artists and rip off artists and i hope their country sinks in the sea they screwed me for $18,500.99 every body should stop buying toyota put them out of business for good..
1235»
Sign In or Register to comment.