Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Oldsmobile Alero Starting-Stalling Problems

1171819202123»

Comments

  • tbs10tbs10 Posts: 3
    hello,

    I have a 2002 olds alero with a 2.2 ecotec 4 cyl with 201,000 miles. I bought a new car earlier this year and gave the alero to my fiancee and she has had nothing but trouble with it since. She is experiencing random stalling while she is coming up to a light or stopped. Usually it starts back up but one time she had to wait 2 hours for it to start.

    Before this started happening she stated the car would start fine in the morning but when she would leave for lunch it would "hesitate to start". I replaced the crankshaft position sensor, and looked at the starter while i was doing it and decided to replace that as well. That corrected the starting problem, but she has been experiencing the stalls since. The battery is 2.5 years old.

    I replaced the ignition module last week (easy enough- took about 10 minutes) and when test driving it stalled again.

    I've also repalced the fuel filter and spark plugs and air filter, still stalls. I put lucas in to clean the fuel system and put premium gas in, still stalls.

    I purchased an entire new fuel pump last weekend but have not had a chance to put it in yet. After reading the forum i am skeptical. I would like thoughts/opinions on what this could be. I am planning on changing the pump within the next 2 weeks.

    The car DOES have an aftermarket python security/remote start system. Best buy said they would remove it for 50-75.00.

    Do you think it is the fuel pump? Could it be the aftermarket system is the cause of it? Battery? Alternator? BCM/PCM? Thank you.
  • TBS10,

    It sounds like you pretty much hit everything that deals with fuel delivery. However, you missed one item that would cause that. Replace the fuel regulator. I have a 2000 Alero and she eats fuel regulators about every 2 years. I just replaced my regulator 2 days ago. It should cost about $75.00 plus tax at your favorite auto parts store. There is a good test for the regulator. If it is like mine, there should be a vacuum hose attached to the top of it. Pull that hose off and turn the key to the "ON" position. WARING DO NOT TRY TO START THE ENGINE. If fuel comes out where that vacuum hose was attached, the regulator is shot.

    Hope this helps

    Daniel
  • You GAVE your fiance an 11 year old ALERO, with 201000 miles on it?
    Is she still your fiance?
  • tbs10tbs10 Posts: 3
    edited December 2013
    im not sure if im not looking in the right place but it seems the "hoses" on mine are all aluminum. Can you tell me where i should be looking? I thought i knew where it was but i guess not.

    edit: yes, i did give it to her and yes she is still my fiance. At the time it had 193,000, and she was driving a 1999 sunfire that needed quite a bit of work and wasn't running. :)
  • TBS10,

    Let me look in the book and I will find it. Hang tight for alittle bit

    Daniel
  • TBS10,

    The book does not differentiate between the 2.4 and the 2.2 so I am guessing that the only difference between the 2 are the bore and stroke. The regulator on mine is right above the alternator on the end of the fuel rail. It only has one bolt that keeps the bracket attached to the fuel rail. As you are standing in front of the car, it should be on the left, right behind the timing chain compartment. It looks like a "top hat". Be warned, when you find it, and you remove it, fuel will spray everywhere. there is between 40 and 60 PSI of fuel in that rail.

    Let me know if you find it.

    Daniel
  • appellofappellof Posts: 54
    edited December 2013
    TBS10,

    I am going to try this. I am going to see if I can paste a picture here.

    Well that does not work. I was hoping that it would allow a picture to be posted. The moderators will not allow personal phone numbers to be posted. otherwise, I would text you the picture. You may be able to google the fuel regulator location and there may be a picture of it there.

    I hope this helps

    Daniel
  • tbs10tbs10 Posts: 3
    I really appreciate all the help so far. There is no definite picture of the location on google images that i can find for the yr/model of car, just of the engine. I will play more later to see if i can find the exact location.
  • http://bergerweb.net/PasslockFix/

    Went here and tried this a couple of years ago. Starting problems all fixed. Good luck. I know have a mechanic friend who told me when I bought my 03 Alero that it would last 15 years or 300,000 if I took it for yearly check-ups. I bought it with 12,000 miles on it in 2004, and it is still running pretty well. Pray you'll be okay. Mine only has 124,000, so I'm praying I still have 5 - 8 years left, as the loans been paid off for 4 years now. Happy Alero trails to you!
  • OK. I was just kidding around about giving it to your fiance. Anyway, after reading further posts and seeing you are trying to find images that show the fuel pressure regulator, I checked in my manual for 2002 Grand Am with 2.2L L4 engine, which should be same as yours. I scanned the pages regarding replacement of Fuel Pressure Regulator, and posted the pics on my website. Take a look and see if they are helpful. You can access them at:

    http://www.bergerweb.net/graphics/FuelPressureRegulatorReplace1.jpg

    http://www.bergerweb.net/graphics/FuelPressureRegulatorReplace2.jpg

    http://www.bergerweb.net/graphics/FuelPressureRegulatorReplace3.jpg

    Here is the "Description and Operation" section of the manual:
    The fuel pressure regulator is a diaphragm relief valve. The diaphragm has fuel pressure on one side and regulator spring pressure and intake manifold vacuum on the other side. The fuel pressure regulator maintains a constant pressure differential across the fuel injectors at all times. The pressure regulator compensates for engine load by increasing fuel pressure as the engine vacuum drops.

    You might check for vacuum leaks too, since by the description, the fuel pressure is controlled by manifold vacuum.
    Dick Berger
  • conley3conley3 Posts: 1

    I have a 2003 Olds Alero 2.2 ecotech. I have had trouble with the security system and have had to reset it by turning the key on for 10min. I always works for me. Last week my car would not start, it turned over and wanted to fire, but just wouldn't go. I had the battery checked and replaced, still the same thing, then I changed the spark plugs thinking it was flooded, still no change! I read some comments here and checked the fuel regulator, it was good, there was fuel pressure in the rails. I finally took the fuel relay out and started the car to run fuel out, then reconnected the relay and the car fired right up! Thank you to everyone who posts on here, it gave me ideas of what to weed out to find the issue.

  • tim618tim618 Posts: 0

    This is tbs10 not sure why but i couldn't sign in under that name- anyway I have an update with my alero stalling problem- it seems to be fixed! After changing the fuel regulator it still stalled, changed the battery, it still stalled, also changed the IAC valve. Finally Daniel said to change the ignition switch and that was it! Runs fine now and test drove for over an hour and no stalls, it was stalling between 20-25 minutes of drive time. Thank you so much for your input and I am so relieved to have this issue taken care of (knock on wood). In the last 6 months i have dumped parts in this car, and while I get great deals on parts (25-40% off) i was getting annoyed that the problem wasn't fixed. Things this car got the last 6 months:

    battery fuel filter spark plugs crankshaft position sensor tires fuel pump idle air control valve fuel regulator air filter brakes/rotors/calipers front wheel hubs shocks/struts starter tie rod ends ignition module ignition switch

    With all this I am hoping it will last another 100,000 miles with all the new parts.

    Thanks again!

  • gculpexgculpex Posts: 1

    tim618/tbs10 I got over 300,00 miles on my 2003 2.2L without half the stuff you replaced. Still, I'm very lucky to get this far.

  • wvpipvwwvpipvw Posts: 1

    I am having some difficulties with my 04 Alero. I think is is the security system but doesn't sound exactly like anyone else's problems.

    It is 2004 3.4 V6. The car starts fine cold and will drive for approximately 15-20 min and then while driving it shuts down. It will not restart for 30-50 min. No codes are thrown and the security light doesn't come on.

    Any help is much appreciated thanks!

  • MrShift@EdmundsMrShift@Edmunds Posts: 43,637

    That doesn't sound like a security issue actually. Not every component in a car throws a code, especially fuel system components. What you'll have to do to solve this is have you or a technician jump right on the car while it is misbehaving, to determine the cause of the no-start when it occurs. This might include a spark tester, fuel pressure gauge, NOID light (for injector pulse) and VOM meter.

Sign In or Register to comment.