Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





GMC Yukon AC and Heat Questions

1910111315

Comments

  • Could be due to a plugged cabin filter. You need good air flow to keep this from freezing. The guy that told you that the unit had a low pressure switch was partially correct. The switch on a car is to detect low pressure as in the coolant is lowering in pressure due in part to low air flow or low coolant. Slightly low refrigerant will usually cause more cycling of your compressor. This is to prevent ice build up. Because in a car you can adjust the speed of your fan whereas in your home your ac runs at one speed usually there is no need for a shutoff switch. I have heard that condensate off of your line dryer "where this switch is located gets in the switch and causes problems". The clogged line is improbable as this would cause low flow in the refrigerant and low cooling not greater. The problem seems to be related more to the pressure switch and air flow than anything else.
  • dduck56dduck56 Posts: 1
    I am having the same AC on left side Heat on right side problem.
    I see someone tried TWO recalibration remedies!
    Can anyone tell me what they are?
  • i have tried plenty, but try starting car with hvac in off mode wait 1 minute then turn on again.
  • on the module next to the rear fan motor, when a ground is supplied to the center small purple wire, the fan works. this wire is not receiving a ground from the front controls regardless if it's set on aux or auto. please advise next troubleshooting step.
    thanks
  • my 2003 yukon air conditioner blows cold air on driver side and hot air on passengers side.was on vaction in new york they said they could not fix it at that time.they disconnected the heather hose and the ac blows cold air on both side would it be expensive to repair to get the sytem working the right way.
  • puzzled17puzzled17 Posts: 2
    edited September 2011
    Not sure if anyone is familiar with the hooking up the stereo in a 2002 yukon. I wasnt but i figured since it was a simple harnest and not the more expensive one that is used in later models. I figured I would give it a try well I got the aftermarket deck hooked up but could not get any sounds from the speakers only my sub and amp were working but no vocals. So I contacted the harnest 800 num and they made me aware of a pink wire that was supposed to be ran to the power wire which i did still no vocals. So I figured forget it i would put the factory back in and run a high/ low adapter to the speakers so i bought it but was not sure whick speakers to hook it up to it just says right and left but the wires arent labeled from my truck so as im guessing i get a little spark andy my dash lights go out like no fuel light no PRND321 only turn signals on the dash. so i give up man is there anyone that thinks they can help me out im in over my head with this one its a BOSE system BTW Thanks
  • When i turn up the heat on my Yukon XL it stays at full unless i turn the car off then turn it down to cold again and start the car. The AC works fine unless hte temperature dial gets turned to hot then it wont come back. Any ideas?
  • I had the problem of the ac switching to heat. With winter coming up I dont care if the ac was not working correctly but I tried to recalibrate the system by pullling the fuses in dash and under hood and disconnecting the control panel. Now the problem is air wether hot or cold only comes out of the defrost/windshield vents, no matter what setting I use. Is this now a problem of the blend door actuator?
  • My 07 Tahoe will not run heat or air to any vents other than the top vents. The selector switch seems to work fine, as the light is on, and if you press the rear defrost button, it works. I just need the FRONT defrost to work....

    Any thoughts?
  • I have a 2003 Yukon that the battery went dead yesterday. After replacing battery the dual climate control will not come on. Was working fine after jumping car off. Anybody know what may be wrong?
  • My 2005 Suburban Heater started running at full speed, even when the Truck was turned off. I read several posts about replacing the thermister, which I did, but now nothing happens. The heater and AC wont run at all! The thermister was after-market and required cutting off the original 3 wire connector and splicing the new Thermister in and the auto parts store did show me a picture of the original part plus the after-market one so I think it was the correct part, but all I can come up with is that it was defective. Any ideas?
  • In case you haven't figured it out already. Your problem is probably with the A/C blend door actuator. Whichever side you are unable to change the temperature of is the side you need to replace. It's tight getting to it, but it's a pretty easy fix.

    You can google 2003 yukon xl blend door actuator and find sites that show pics and videos of how to repair this. The part is under $100.
  • bosn1bosn1 Posts: 1
    I have a 2006 Yukon Denali XL, today my AC stopped blowing air in the front however the rear ac stills blows like new. Have no ideal what's going on but need to fix it before I deploy in two weeks. Pulled both fuses and still same issue
  • gmcustsvcgmcustsvc Posts: 4,003
    Bosn1,
    First – THANK YOU for your service to our country. My brother is working through the ROTC program. May you be kept safe on your upcoming deployment!
    In regards to your HVAC concern, if Customer Assistance can help you work with your dealer towards resolving this, please email Christina with your name, contact information, VIN, and dealer name.

    Best,
    Sarah
    GM Customer Service
  • My 2005 Yukon will not blow any heat out of the rear vent on the ceiling (passenger side vent). The fan speed dial operates the blower speed correctly. The temperature dial does nothing. I can turn it to full hot and still get cool air blowing out the back vent. I took it to a GMC mechanic and he said, it was the module and actuator in the back on the vehicle near the back door. First, does that sound correct? Second, I can't find any information (not even Haynes manual) on how to replace the actuator. How do I replace it and program it?
  • bowzmanbowzman Posts: 1
    edited November 2011
    My 2003 GMC yukon isn't blowing heat or ac in the rear of the vehicle. The rear blower works fine and the front heat and ac work great but nothing in the rear. Is this a relay problem or an actuator problem? Thanks
  • Our 2003 Yukon had the exact same problem. We had a friend who knows everything about cars check it out. He told us we would need a new HVAC controller, which was located on the back rt. passenger side of our Yukon. In the back remove the entire plastic panel on passenger side, there will be a relay plug switch where the wiring plugs in to the HVAC controller. I recommend you disconnect the wires and reconnect them making sure they are securely connected. We went without heat all winter and were too cheap to but the HVAC controller ($135) but needed to reconnect the A/C in the back when the summer months came around. Guess what when we hooked it back up the heat worked perfectly, as well. So before you do anything else I would do that. Also, my husband and I have no mechanical experience other than holding the flashlights for our dads when they worked on cars so it has to be pretty basic for us to fix.
  • Our 2003 Yukon had the exact same problem. We had a friend who knows everything about cars check it out. He told us we would need a new HVAC controller, which was located on the back rt. passenger side of our Yukon. In the back remove the entire plastic panel on passenger side, there will be a relay plug switch where the wiring plugs in to the HVAC controller. I recommend you disconnect the wires and reconnect them making sure they are securely connected. We went without heat all winter and were too cheap to but the HVAC controller ($135) but needed to reconnect the A/C in the back when the summer months came around. Guess what when we hooked it back up the heat worked perfectly, as well. So before you do anything else I would do that. Also, my husband and I have no mechanical experience other than holding the flashlights for our dads when they worked on cars so it has to be pretty basic for us to fix. Hope this fix works for you!
  • I have a 2003 Tahoe and I am having an issue with the rear heat. My blower motor would work intermittently and then stopped all together. I have checked all the fuses, ran voltage to the blower and that works great,and also replaced the blower motor resistor twice. The resisitor clicks and I get 12 volts going to the blolwer motor but it still does not work. Any suggestions?
  • Did you ever receive a solution to your a/c problem? I am having the same issue.
Sign In or Register to comment.