Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Isuzu Rodeo Maintenance and Repair

1246789

Comments

  • bugsy1bugsy1 Posts: 16
    can any one tell me if its a big job to replace your front wheel bearings in a 2000 isuzu rodeo ls, im planning on doing it my self , any help would be greatly appreciated.
  • When Rodeo is cold putting in reverse it surges backwards. If you stop and then start to go feels like it wants to surge forward. When driving at 25 mph Rodeo keeps hesitating, after it warms up drives okay. Had this problem last winter/spring and mechanic said they couldn't find a problem. When the weather got hot problem went away, now that it's getting cold again, problem has started back up. Has anyone had this problem?
  • I am needing to replace the signal/park light bulb. The last time I had it replaced was by the dealership. Can anyone recommend what bulb I am going to need to buy from the auto parts store?
  • I have a 98 isuzu rodeo bought new . first the turn signals would short out and the dash lights would act crazy fixed that.then a recall on the fuel sending unit dealer fixed it. 5 months later it went out again. This time I had to fix it dealer would not warranty the work cost me 150 bucks. then a recall on timing belt. dealer fixed this, about 3 months later im changing the oil and I notice sprocket shims sticking out from behind timing belt cover. dealer denied that was their falt. So I took it apart and removed the extra parts myself. then a recall on the serpentine belt tensioner. dealer inspected said it was fine. 6 months later tensioner failed and broke. This caused all the intake valves to get bent and locked up the motor. dealer would not warranty work. tenisioner cost 280 dollars and I had to take bottom half of motor apart to replace tenisioner. A head cost me 700 dollars. and the truck is still not right. the dealer said I was 3 months and 700 miles out of warranty coverage from the recall. and will not even discuss it with me. Isuzu is a trouble filled truck with a bad track record and dealerships who won't back their experimental badly designed products. get away from them before they get even deeper into your pocket and have no answers for all the existing and future problems. Im parting the truck out because I would feel guilty selling someone such A PIECE OF JUNK. Thanks for listening, I hope this will help someone else not make the same mistake... :sick: :lemon:
  • girlfriend has a 2wd 3.2 with 30k mi. original serpantine belt is developing minor cracks. she was quoted $70 to have it replaced. her uncle ( a previous Isuzu exec.) said that there were too many adjustments for me to replace it and save $40. I replaced the tensioner and belt on my old CAT C12. looked at the Isuzu and looks like a 5min. job. whatdya think? thanks, Brian.
  • Hey, did you ever find the problem in the 4X4 locking problem? I have a 2000 that just started having the problem today.
  • My 2000 Rodeos' front wheels will not engage. The front drive shaft does turn but the wheels do not. Are there internal hubs or a solenoid that should lock the wheels in?

    Please advise potential fixes
  • Hi Folks,
    I have a 1999 Isuzu wizzard with a 3.0L turbo diesel engine, the vehicle will crank but will not start. Sometimes it will start but will not run, this only happens in the morning. Once the vehicle is started it will run all day.I replaced the gow plugs checked all the fuses they are ok. what could my problem be

    Tyrone
  • If you will, please send me any info that you receive about this problem. My Rodeo started experiencing the same problem about a week ago. It may have started earlier but, it was the first time I needed to engage the 4 wheel drive.

    I will push the button to engage the 4 wheel drive, the 4 wheel drive light on the dash flashes but, never fully engages into 4wheel drive. Is this the same problem your receiving?

    Thanks,

    Chad
  • The right front shaft lost a retainer clip that keeps the splined plate in contact with the splines on the driveshaft and the shaft moved inward towards the differential. The repair in this case was simple. The splines were filed clean so the plate would slide easily and the retainer clip was replaced which held the driveshaft inposition to transmit torque. When the shaft moved inward it was not in the splines and just spun freely. The 4x4 system gave all the front wheel torque to the spinning wheel and we went no where.

    Hope this helps
  • Hi, saw your message, had the same issue with my 2002 rodeo with 12k miles. Serp belt with all cracks in it. I did mine myself all I used was a very large screw driver as a prybar on the belt tensioner so I can take the tension off and then slip the belt off. 10 minute job, DIY
    I made a drawing of the belt and pully setup so I new how it went back on. I would suggest doing that makes it even an easier job. Good luck.
  • does the #one piston on top before timing a 1999isuzu rodeo 3.2L 6 cylinder
  • 99 isuzu rodeo 2wd. My question has two parts to it. One is that my fan (radiator or fan that blows a/c i don't which one really) keeps blowing after my engine has been shut off. It will blow for about 15 seconds or so. However, it usually stays on when i have my air condition (or just air) blowing. So usually to fix the problem, before i turn off the ignition, i shut off the air and it doesn't do it. But in the morning, regardless if i turn the air off, it still does it.
    The second thing is also in the morning when i first turn on the rodeo, the RPMS stay high while changing the gears (it's a standard), this happens for about a good 5-10 minutes i guess while the engine warms up, then i can change gears and they stay where they're supposed to be.
    I just wanted to know if anyone can help me out or give me ideas as to what the problem might be before i take it into a mechanic. Thanks a lot.
  • tmitmi Posts: 1
    I have 95 Passport LX w/auto trans. I have intermittent problem starting the car - turn key and single click. battery is fine. when this does not happen, starter is fine - no sluggishness. When it doesn't start, found that jiggling the shifter - or resetting battery terminal connector will sometimes get car to turnover. Anyone have suggestions on this intermittent problem? mechanics have said to replace the starter - but this was done a few years ago (should last longer than that...) and when it starts okay there is no sluggishness.... ??? any ideas?
  • My 99 Rodeo is having the same problem. I was just about to attempt replacing the starter when I saw your post. If replacing the starter doesn't fix the problem, does anyone have an idea what will?????
    Lisa
  • Brian,

    Have a 14 mm socket on a 1/2 drive ratchet ready. I drew a diagram of the way the belt routes and it's saved the each time I've had it off to either replace or do other maint. You will need to pry the tensioner downward (the idler pulley side) and then you can remove the old one and replace it. It's got a good bit of tension, that's why I've found a 1/2 drive ratchet makes it a bit easier.

    Mark
  • have been told will need a motor for rodeo ls. where can i find one? have knocking noise loudly in left side of motor now.
  • transducertransducer Posts: 7
    Can you remove the valve covers on a Rodeo with the 3.2 with the intake still on?
  • 02bigblue02bigblue Posts: 1
    Did you happen to get an answer from anyone? I am having the exact same issue on my 2002 rodeo but I'm getting nowhere.

    Thanks
  • usmc4424usmc4424 Posts: 1
    How many miles do you have on it. I have a 2000 S model and had a new engine put in for free under warranty. Here I am now getting a new trasmission now at 115K. Don't understand it but all covered by warranty. New truck so to speak.. Check out the 10y 120K warranty.
Sign In or Register to comment.