Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Isuzu Rodeo Maintenance and Repair

1234579

Comments

  • komakikomaki Posts: 1
    My rodeo (2001) just flashes the light when I push the button. I have noticed this topic goes back quite a long while, but I have never heard of a way to repair it. Has a repair been found? If so will someonr please tell me where it is? thank you all.
  • The first thing I would check is the vacuum line connecting to the front wheel drive actuator on the drivers side. It sometimes falls off or is cracked. This happened on my 2000 numerous times.
  • I have a 1998 isuzu rodeo 4 by 4 3.2 v6,the transmission shifts hard, i noticed that this happens when the lights for the trans selector go out, example p,r,n,d.I can usually fix it for a while by turning off truck waiting a few minutes lights come back on truck shifts fine for a while than problem comes back .If anyone is aware of this please respond thank you very much
  • wlbrown9wlbrown9 Posts: 837
    It is the transmission mode switch. It gets gummed up and the contacts feed the computer inacurate info on the placement of the shifter. Sometimes holding the button on the shifter in (foot on the brakes please) and cycling the shifter all the way through the range will seem to clean it up. Then power off and back on will reset it sometimes as well. At one time I found instructions on removing, disassembly, cleaning and re-assembly but last time I looked I could not find that.

    Found one of the discussions but the link to the instructions does not work anymore

    http://forum.planetisuzoo.com/viewtopic.php?t=1707

    Here are instructions for replacemnt on a Honda Passport http://www.justanswer.com/questions/1abjz-i-need-to-replace-the-transmission-ran- ge-sensor-in-my

    About the only other things I really remember is that placement is critical. If you remove to clean or replace, it must be installed back in the same location. If it installed otherwise, the position indication can be off, ie. the shifter is in D but the indicators show it is in R.

    Yes...inconsistent p,r,n,d,l lights are an indication this might be the issue.

    Good luck

    Bill '00 Trooper LS
  • maloprmalopr Posts: 14
    1998 Isuzu Truck Rodeo 2WD 2.2L MFI DOHC 4cyl. Replaced the intake manifold gasket and cleaned the throttle body, replace engine vacuum lines. There are no leaks. But, on start up If the brake pedal is depressed the idle speed increases but after driviing around for a while when the brake is applied the idle speed is noraml. What could be the cause of this probelm? Any solution?
  • tronz83tronz83 Posts: 1
    edited August 2010
    hello, I have just replaced the heads on my '01 holden rodeo 2wd due to having a burnt out valve, have just put everything back together (correctly) and the car will not start
    when i turn the key it chuggs but never turns over,

    the timing isnt out, their is spark in all cylinders, i just cant figure out why it wont
    turn over, any suggestions would be totally helpful... i dont knew what else to check

    when I turn the key trying to start the engine and battery lights come on and then after a few seconds the trans light starts to flash aswell,

    the battery isnt flat, the fuses are fine, the car was running before i stripped it (just badly) and now im lost... please help
  • is it a 4 or 6 cylinder engine, did you replac the head gasket,
  • I bought a headlights relay because it had been removed by someone, all other lights work but headlights wont come on What can I do?
  • ok, so my heater core is most likely cracked. Coolant leaking into the passenger foot-well when after the car heats up and starts circulating coolant.

    Is it possible just to bypass the heater core/heater? Perhaps create a loop at the end of the heater hoses back unto themselves. I'm in southern California, and other than blowing fog off my window, I never use my heater.

    If not, is there easier way to change the core other than removing all the instrument panels and evaporator to get to the core?

    Thanks
  • Yes you can bypass the heater core. You can disconnect the two (2) hoses at the firewall in the engine comparment and make a loop there but you have to make sure that there are no kinks in the hose at the loop. The coolant has to flow freely
  • my 92 rodeo has headlight relay under the hood in fuse and relay control box . if it is bad the ligths won't work
  • maloprmalopr Posts: 14
    Did you replace the fuse click on this link or copy and paste to your web browser: http://www.familyhandyman.com/DIY-Projects/Car---Truck/Auto-Repair/replacing-aut- o-fuses.
    And after you check the fuse and if it is good then check the relay click on the link or copy and paste to your web browser:http://www.ehow.com/how_4596906_test-car-relay.html
    hope this is helpful
  • Did you ever solve that problem? My Amigo is doing the same now.
  • Resolved when my motorhead friend found a short in a wire in the wiring harness. did not replace the whole harness, just repaired the short and it was fine and has been fine since.
  • My ignition switch was to blame for this, not sure if you're still looking for an answer or not, but I hope this helps. Just turn your key back and forth slightly to see if it is the problem.
  • I have a 2000 isuzu rodeo LS in Venezuela because I took it there for my daugther. It was taken to the mechanic to fix the engine and when trying to install timing belt they can not make it work correctly. Even some valves were damaged after trying to do it as second time. It is any information on site where i can get a copy of the pictures and instructions how to change it? If there is something else i can use and you know could you please let me know? I really appreciate all you can do.
  • maloprmalopr Posts: 14
    what size engine do you have a 2.2, or a 3.2
  • maloprmalopr Posts: 14
    While driving came to a stop light after light turn green clutch will not go onto first gear as a matter of fact will not go into any gear. I replaced the slave cylinder. But still the dame thing will not go into any gear. New fluid. new slave cylinder. Any ideas of what else I can look at, I checked the master clutch cylinder and it seems to be working fine, the slave cylinder seems to be working fine also. Any suggestions on what i can do.
  • i replaced the flex plate 3 months ago and the new one cracked already, any ideas why?
  • I have 2001 Rodeo -- just had new battery and fuel pump w/sending unit replaced. Trying to get sticker (MA) and inspection computer can't/won't hook up w/OBD. Vehicle has been driven over 300 miles -- highway & city. Anyone know how long/far vehicle must be driven before OBD resets/recycles? Thx.
Sign In or Register to comment.