Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Pontiac Grand Am Electrical/Lighting Problems

1234568

Comments

  • Last week my horn went off at 3:30 in the morning. I had to disconnect the horn relay to turn it off. I waited 10 minutes, put the relay back in. and it started sounding again. I took it out and left it out. Yesterday, I disconnected the battery for about 30 minutes to clear the service engine light. It worked. Now, at 3:30 this morning the horn sounded again. I had to take the relay back out. This 2005 grand am is driving me nuts. Headlight issues, interior lighting issues, does anybody have a clue as to what may be causing this possessed car to wake the neighbors up ?
  • i have a 02 grand am and when i turn the headlights on one is brighter in the other one, its real dim also the signal lights dont work can anyone help?? i checked the relays and fuses :confuse:
  • burdawgburdawg Posts: 1,524
    As far as the headlight, it's probably a poor ground or a corroded connection at a harness connector or in the bulb socket itself. I would look for a loose or corroded ground first.
    Do the signal lights not come on at all or do they come on but don't flash? If the fuse is good it's probably either the flasher unit (part of the emergency flasher switch) or the multifunction switch itself (which can be a problem on N body cars) or some wiring defect. Have you checked the bulbs? It's not likely they would all fail at the same time though.
  • loosenuploosenup Posts: 1
    i have no exterior lights, (headlights,tail lights, hazards or turn signal lights.) i have checked the fuses and they are ok. my interior work fine, any have an idea what might be the problem.
  • burdawgburdawg Posts: 1,524
    Check to see if the associated fuse (or fuses) are even getting power. There could be a problem before the fuses. Also, it could be an ignition switch problem. This is when a wiring diagram comes in very handy.
  • sturdysturdy Posts: 1
    Did you ever find out why lights stayed on? I'm having the exact issue with my 2001 Grand Am...
  • rachie1021rachie1021 Posts: 1
    i have a problem with my temp gauge and rpm gauge ..their not working at all...my oil pressure light, battery light,theft system,coolant lights are all on..i just changed my battery...i notices that some of the pontiac owners have similar problems ..i jus wondering if any 1 from the problem ....ima bout to check all the fuses but i have no idea what it could be ???????????? :confuse: :sick: :mad:
  • I know this is an old thread, but if someone still has a 1997 Pontiac Grand Am and has this problem, you can call your local GM dealer and have this recall done: http://www.automotive.com/1997/49/pontiac/grand-am/recalls/72894.html

    It might be worth checking into.
  • igor056igor056 Posts: 1
    I have a Grand AM SE '97 with the 2.4L engine.
    I have I think two separate problems.
    1. If the car stands in the hot Florida sun all day, it is very difficult to start. Any other time, when the temp is cooler or in the winter no problem starting at all.

    2. I have a problem I have seen on these boards before but never seen a fix for.
    My warning lights will all come on and the instruments, apart from the speedo, will all go off. Just as though the engine were not running but the ignition turned on ready to start. A few seconds later the lights go off and the instruments start reading again. It makes no difference if the car is stationery of doing seventy miles an hour. The engine keeps running fine. I feel like it should be Christmas with these fairy lights flashing at me. Anyone found an answer to this please?
    I have recently replaced the battery, which was due for replacement and it made no difference. I thought maybe the central computer, so I replaced that and still the same. I am dubious of taking this vehicle too far until I know the problem and I need to do some miles very soon. Help Please.
  • clo3clo3 Posts: 1
    Recently I have been having some issues with my 96 Grand Am. About a week ago my car randomly wouldn't start. I was able to jump it a couple of times, and after that it was working fine and starting up like normal. Just this morning, I was on the HWY and my speakers in my car stopped working, then the cd player was turning on and off by itself. Then my battery, air bag, break and oil lights came on, soon after that my fule gage and all other gadges went to 0. I quickly pulled over and parked, turned it off, and tried to start it again. It would not even turn over. I am wondering if this could be just a battery issue, or if it is something more serious. Please Help!!!! :sick:
  • burdawgburdawg Posts: 1,524
    Sounds like battery to me. Could be a bad alternator also.
  • I have a 96 Pont. Gran Am...all of a sudden my electric windows and air conditioner blower will not work while the car is running....but when I shut the car off...my windows will work and my air. Turn the ignition on and they will not work...also...when the car is on...my high beam indicator light flashes, even though the lights are not on...my running lights will not work.....the head lights only come on if I turn them on manually...and my rear defroster will not shut off manually when the car is running. I have checked the battery and the alternator..and both check out fine......ANYONE HAVE ANY ANSWERS TO THIS MISTERY????? I feel like my car is suddenly possessed here..lol
  • Hi,My name is richie.I have THE DAME PROBLEM.NO DRL NO REAR TAIL LIGHTS NO DASHLITES. IT STARTED OFF WITH A LEFT TURN SIGNAL FLASHING FAST> THAT WAS FIXED BY REPLACING THE CIRCUIT BOARD ON THE DRIVER SIDE READ TAIL LAMP.
    I DO NOT HAVE A MANUAL> SOMEONE SAID IN AN EARLIER POST THAT YOU HAVE TO DISCONNECT THE BATTERY, THEN THE AIR BAG FUSE, THEN THE AIRBAG CONNECTOR ( WHICH ONE IS THAT ? ) AND TAKE OUT THE TORX SCREW> I HAVE AN ) 02 GRAND AM 2.2

    DO I NEED A MANUAL?

    IF SOMEONE CAN SUPPLY A REMOVE REPLACE PROCEDURE WITH PICS I WILL PP MONEY TO THEM___I AM SERIOUS
    POLEASE HELP. MONEY IS SO SHORT FOR ME.
    BTW I AM NOT SCREAMING JUST VISION ISSUE
  • hello...i'm not sure if your problem is the same as mine...but you may want to try just replacing the switch in the ignition....this is what I did and it only cost me 40 bucks....and it seems to have fixed all my problems...everything is working like new again (thank goodness). I also went ahead and replaced all the fuses too. Just a suggestion to try before you fork out exteme amounts of money. Good luck to you, hope you get things running correctly again.
  • hobguehobgue Posts: 1
    Having the exact same issue. Did you ever find out what the problem was?
  • ant9ant9 Posts: 1
    i have the same problem i really need to no if you ever found a fix im going crazy
  • i got a 1996 Pontiac grand am gt with a 2.4 4 cyl i got a problem with the electrical problem my fan for the hvac shut down i checked the fuse and the fuse is still good and today the daytime running lamps stopped working so im at a loss on what to do or what to have fixed
  • baught the grand am buddy said needed an alternator ok so i got one put it in the battery is overcharging for one and when ya try to drive it it spits and spudders and the dash gage lights flick on and off slow on...off...on...off...tried 3 different alternators and same thing any suggestions. thanks
  • It happened about a year ago then not for a long time but now is doing it regularly. The first time i had gotten to work was finishing listening to a song when i shut the car off i heard something kinda of zap/click funny and the car was completely dead. jumped it after work and all was fine for about 7 months or so. i was in it one day it was running fine, shut it off, went into the house to grab a few things came out and when i turned the key everything lit up as usual then just completely dead in the blink of an eye. jumped it and it was fine for a bit. now it's started doing it every few weeks or so. sometimes it will eventually just start on it's own which leads me to think it's a short somewhere. but the computer testing thing doesn't ever find anything. when it's in it's "dead" state i can hear something under the dash making a faint clicking sound like it's trying to work, i am assuming this is because the dome light is trying to work because after a short time it stops. i have two dummy lights that come on but nothing else, no headlights, no dash, no interior, nothing. it won't even attempt to turn over. i have noticed all of the gauges for the speedometer and rpms and gas and temp try to work, but the rpm and speedometer bury themselves all the way up. and sometimes they just jump all over like crazy. anybody have any ideas? i'm wondering if it's not the ignition switch.
  • im having the same problem with my 96 grand am. and from what i think it has to be the transmission. i just replaced the rack n pinion, hub bearings, and axles and theres nothing else to seem like bearings going out to make a grinding noise excpet the tranny. and theres a TSB on grand ams for this issue and it just says possible cause transmission.. so i guess tranny bearings are going out on the shaft outputs possibly..
  • thejake2thejake2 Posts: 2
    I have the exact same problem, any luck figuring it out?
  • thejake2thejake2 Posts: 2
    Super weird, but mine does the same thing, did you ever fix the problem? I'm lost. thx
  • Kirstie_HKirstie_H Posts: 10,907
    Hi thejake2,
    When responding to a post that's really old like that (5+ years), the best way to get help is to describe the problem you're having, rather than sending members on a search back in time. :)

    MODERATOR
    Need help navigating? kirstie_h@edmunds.com - or send a private message by clicking on my name.
    Share your vehicle reviews

  • blahhh000blahhh000 Posts: 1
    the same thing happens to me, i have a grand am 02' actually happening right now and its been not starting for 2 days now
  • there are two different relays that you can look into one is 22 under the hood in the relay box that controls day time running lights, now there is another relay that is number 20 under the fuse box that one controls the head lamps the service engine light is a a b code from the bcm if you can get some with a tech two scanner to get you the code try replacing both relays first
  • So I stopped my car and put on my hazards, which worked fine, and then when I started driving again, the blinkers wouldn't turn on, and I had a sinking feeling that the brake lights were also malfunctioning. Turns out they were. The headlights still work, but blinkers and brake lights do not. I'm going to have to check if the reverse lights still work.

    What could possibly be the problem? I don't think it is the fuse, which looked fine, so I am completely lost.

    Any help would be greatly appreciated!
  • had same problem..changed hazzard switch with no help..what it is is the blinker switch itself..easy fix..take cover off stearing wheel around blinker and washer switch..unplug wire clips..there are 3..you will see there are a few screws holding the top cover of the blinker housing..remove the cover and spray with electronics spray and wipe off the contact ends..let dry a few minuts and reinstall..done mine two weeks ago and no noise yet..saves 100.00 on new switch
  • vovikvovik Posts: 2
    I have a pontiac grand am 1999 and sometimes whenever i start the car the dash lights don't turn on the a/c doesn't work and the power windows don't work. However if you you hit the dashboard on top with your hard hard enough everything starts to work again.

    I have replaced the ignition switch and checked the fuses, but the problem still occurs and each time you have to hit the dashboard harder and harder for it work again.
Sign In or Register to comment.