Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevy Silverado and GMC Sierra Electrical and Computer Questions

17810121326

Comments

  • There isn't a fuse for the chime. The airbag controller or body controller sends a message to the radio or amp module across the class 2 bus to perform the chime. You can't disable this message unless it is in the module's calibration. I don't think the dealership offers cals with the chime turned off.
  • my 2006 chevy silverado would not pss emissions in MA. they said it could not read the computer said it may be a fuse can anybody tell me were to find this fuse or what other problems i may have thank you
  • On some models, one of the pins where you hook up the scan tool is fused with the cig lighter fuse under the hood. mine wouldnt work either and I found that the cig fuse was blown in the fuses in the electrical center under the hood. replaced it and scanner worked fine.
  • I have a 2004 Silverado that went through the same situation. Mine turned out to be the same fuse that controls the aux power outlet (cig. lighter). The fuse is located in the fuse box that is under the hood (drivers side). I can't recall if it was a 10A or what...but there are only so many to check. Test your aux power first (my guess is that it is not working), then after replacing the fuse you should test it again: if the aux power works with the new fuse, you should be all set. Good luck.

    - CJ
  • thanks you guys so very much for the info.
  • I have a 87 tbi truck and I am installing a 94 tbi motor. Most items look as though they will swap out but the 94 seems to have two temp sensors and the 87 only one?
    Do I use the 87 computer (1227747) or should I use the computer that came with the 94 (16146299) and just not hook up the temp sensor that is in the left side cylinder head as there is no provision for it on the 87 wiring harness. Thus only using the temp sensor in the inlet manifold?
    Thanks............
  • did u check the relays for the driver door? when i recently put window tint on my truck i found 2 relays one for the driver side door and one for the passenger side so i pulled both of them so my tint wouldnt get messed up. relays should be under the hood in the fuse box driver side.
  • if the chime is on a chevrolet pickup hd or 1500 theres a harness onnector connected to the speaker that runs to the fuse box driver side inside cab that 4 wires snap to the fuse box u figure out which wire does what and wala u can disable the chime. i know bcus the fuckn speaker works when it wants to.
  • thejake1thejake1 Posts: 1
    Exact same problem on my 07. Did you fix yours??
  • redcurlzredcurlz Posts: 9
    I have a 1998 Chevy Silverado - Extended cab - Long bed.
    Why is it that only my wipers will work on "High" and if I shut them off when their moving thats where they stop. They don't return down to the bottom of my windshield. My cruise control wont work either. Can I just replace that lever on the steering column? Thanks for anyone input. :blush:
  • redcurlzredcurlz Posts: 9
    This sounds wierd but it seems that when the temp outside gets above 75deg my window wont open. It's electrical so can I just replace the switch on the door or is it more complicated you think? Thank a bunch for the input. :shades:
  • KCRamKCRam Mt. Arlington NJPosts: 3,516
    That definitely sounds like the place to start. Usually when several functions on that lever act up together, replacing the assembly cures it.

    kcram - Pickups/Wagons Host
  • I have owned this truck from the start and it was getting around 20 MPG not pulling,I have a 38 ft 5er and in the past I could get 14 MPG give or take.
    After leaving Utah and heading to Salida Co when twice this thing over heated to the point both the engine temp and the trans temp went all the way over,it boiled out the antifreeze to the point I had to add a half gallon.
    This truck has pulled the Mountains two to four times and never had a problem.
    Since this happened my fuel milage has gone down to about 11 to 14 empty.
    GM said they don't find a thing wrong,so if I leave AZ. pulling my 5er what the heck you think I'm going to get.
    Trading it is the last thing I want to do,any ideas??????????? Is it the computer its got me.
    Seabeemax :mad: :lemon:
  • I have owned this truck from the start and it was getting around 20 MPG not pulling,I have a 38 ft 5er and in the past I could get 14 MPG give or take.
    After leaving Utah and heading to Salida Co when twice this thing over heated to the point both the engine temp and the trans temp went all the way over,it boiled out the antifreeze to the point I had to add a half gallon.
    This truck has pulled the Mountains two to four times and never had a problem.
    Since this happened my fuel milage has gone down to about 11 to 14 empty.
    GM said they don't find a thing wrong,so if I leave AZ. pulling my 5er what the heck you think I'm going to get.
    Trading it is the last thing I want to do,any ideas??????????? Is it the computer its got me.
    Seabeemax :mad:
  • I have owned this truck from the start and it was getting around 20 MPG not pulling,I have a 38 ft 5er and in the past I could get 14 MPG give or take.
    After leaving Utah and heading to Salida Co when twice this thing over heated to the point both the engine temp and the trans temp went all the way over,it boiled out the antifreeze to the point I had to add a half gallon.
    This truck has pulled the Mountains two to four times and never had a problem.
    Since this happened my fuel milage has gone down to about 11 to 14 empty.
    GM said they don't find a thing wrong,so if I leave AZ. pulling my 5er what the heck you think I'm going to get.
    Trading it is the last thing I want to do,any ideas??????????? Is it the computer its got me.
    Seabeemax :mad: :lemon:
  • akjbmwakjbmw Posts: 231
    A couple years ago, my '98 K1500 Silverado developed a wiper issue. I seldom used the cruise control (can't go anywhere without up and down hills here in the Sierras) so I don't know if it was affected. The fix for mine was the controller "black box" that is attached to the side of the wiper motor. Get the box from Napa (or equivalent), remove the wiper assembly, replace the part, and reinstall. No more problems.
    With my new truck, I will have to use a ladder to do that...
  • richrushrichrush Posts: 1
    I have an 01 3500 serra duramax and am having a problem with my ignition. when it turn the key to the on position not start everything is normal but when i try to start the engine everything electrical shuts off the dash, my lights, everything. the truck wont start. im no mechanic but i think it may be the ignition switch. any ideas?
  • I am having the same problem with my 2004 truck. Can you tell me where
    the flasher is located?
    Thx
  • Anyone know what these fuses go to? I only have the diagram on the cover and it says stud#1 and on the other end is stud#2.They're the big colored fuses. I was trying to see if the fuse to my w/w pump went out, and I noticed the "stud#1 was blown. I replaced it and it's still good,but I cant figure out what it goes to. I looked in the chiltons and they got nothing. Please Help

    Never mind......I figured it out. Its for the acc. power and trailer wiring feed. Thanks anyway
  • lester55lester55 Posts: 1
    I was at the chevy dealer one time:) and asked how to reset a message light. He said to don't start the engine but turn on the key and step on the gas peddle all the way to the floor 5 times and then turn the key off and then on. I tried it and it worked. sounds funny but at least give it a try.
  • joem1974joem1974 Posts: 1
    does anyone have a wiring diagram for the 2004 sierra. looking for a bad ground wire that is affecting gages, power windows, door locks, dome light and key less remote.
  • Thank you for the great write up. Recently on my dual blower switch, the light went out on the right side. I have been trying to figure out how to fix that one little back light. Of course the owners manual says NOTHING about it. I guess I will have to take the truck to the dealer. Thanks again, it was helpful.
  • pamcrabbpamcrabb Posts: 1
    :confuse: I called our Chevrolet dealer and asked about the recall and was told that it was for vehicles that were 70000 miles and below.
    Well mine is over 100000 miles and the speedometer went to 120 for a day and then the next day it apprears to be ok.
    I haven't checked the mileage yet with my garmin to make sure that it is correct now.
  • barnowl3barnowl3 Posts: 70
    That is true, they don't cover it over 70,000 miles. There was recenty a lawsuit was won, where they now have to cover it to 80,000 miles here is the link http://www.speedometersettlement.com/

    It is too bad a lawsuit is required when GMC knows they have a defect. Our Volvo had an issue and they voluntarily extended the warranty on the part to 10 years or 200,000 miles. Too bad GM does not get customer satisfaction or understand that you get customer loyalty if you stand behind your product.
  • canayjun64canayjun64 Posts: 34
    Hi everyone,

    My new 2009 5.3l Silverado has an erratic voltage display. When driving, the voltage gauge will move up and down from 12 volts up to 15 or 16 volts. I went to see the dealer and they told me that it was a normal operation and that the computer controled the charging.

    Is this true? He also said that should the light come on, I would then have to bring in the truck for servicing and to ignore the gauge.

    It's a trange thing seeing the voltage change that way. I've never seen this before unless there was a wiring problem.

    Any help/suggestion would be greatly appreciated.
  • lucusblucusb Posts: 1
    im having the same problem with my 06 gmc sierra i was wondering if u found what the problem was.
  • robskotrobskot Posts: 6
    I have a 07 Sierra Crew with the new body...when I first got it, it actually had a bum battery in it (had 1 dead cell) and was replaced on warranty about 6 weeks after I got the truck...it's worked 100% for just about 2 years now.

    Since then, I have been very observant on what the battery has been doing...and SINCE I got the battery replaced, I have noticed the same as you...but have never had any other issue, so I assume that this is a normal thing.

    Normally I notice it most on the highway...but even with iPhone and GPS and any other crap plugged in, it's been fine.
  • donl1donl1 Posts: 109
    I recently bought a new 1500 Silverado with the 5.3 and I also noted the voltage guage seems irregular. Hope it's nothing to worry about but it seems to be more erratic than anything I've had before.
  • barnowl3barnowl3 Posts: 70
    Your fluctuation does not seem normal to me, unless your battery is low or you have a large fluctuating load. My 2003 did this (no odd loads), but the swings actually were a lot worse and went higher than 16 volts. It happened in one day, and the swings were severe, so I had little warning and had to take it right in. They ended up replacing the alternator and my dealer found there was a bulletin on this to replace alternator wire harness" to maintain continuity" ( which makes sense for the swings you report). It was bulletin /PI. 73170D. I have an 03 GMC 2500 HD, 6.0 liter, with plow package and aux battery. It failed at 2.5 yrs, 27,000 miles. It has been good now for the past 3 years.
    I've learned that the dealer's are not always aware of the bulletins, so it helps to bring the info.
  • attindallattindall Posts: 1
    My Chevy has about 65000 miles and back in October my speedo went out. Dead. A month later the oil pressure gauge went, followed by the tach and today went the gas gauge. Sometime in November the radio started to cut out randomly. Usually when it cuts out the right green light on my rearview mirror turns red (the vertical one next to the Onstar buttons). When it cuts out the little red blinking security light comes on. If i turn the truck off and then turn the key to run it will come back on for a second and cut off again. Also randomly the lights in the power locks and windows go out, and they stop working. I only notice it at night when the lights are visible. Now that the gas gauge has gone out, if it wasnt for the Distance to Empty button on my steering wheel I'd be screwed. Anybody have ideas?
Sign In or Register to comment.