Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevy Silverado and GMC Sierra Electrical and Computer Questions

1131416181926

Comments

  • Hey Guys,

    I have an interesting problem, My truck will not start when I try to start it in the morning. I have to crank the motor for a good minute or two and consistently play with the throttle for it to start. After it starts it doesn't run right, and by that I mean it idles and if I WOT (wide open throttle) it revs up fine. But if I slowly open the throttle it miss-fires like mad and doesn't really run. When it reaches 190ish degrees and the O2 sensors kick in the problem completely dissapears. Now it didn't always do that I just recently replaced the Throttle Position Sensor and the MAF sensor, After Chevrolet told me my problem was and I quote "Sticky Valves" But before I ever replaced the TPS and MAF the truck just flat out miss-fired and was undrivable... I have thought about there being un-metered air getting in somewhere after the MAF, and I had left over upper intake and throttle body gaskets from when I had to replace the intake manifold gasket (coolant leak) so I went and replaced both of those and the problem still exists. I feel I have come a Long way from what the dealer told me and I think there is only one problem left... But I am Stumped. Any Ideas??? Thanks In Advance
  • 240sparky240sparky Posts: 2
    check the fuse for the fuel pump, not the pump relay, if fuse is bad then the fuel pump is most likely out or going out
  • 240sparky240sparky Posts: 2
    on my 2003 gmc 1500hd the door locks started unlocking while i,m driving, stopped, or shut off. key in or out. once the unlock you can hear it keep trying to unlock. may do it once or 10 times in a row. it is real random. I pulled both lock and unlock relays out as well as the fuse and it still happens.
  • Hi promotorsports,

    I just notice the exact same problem with my 2004 GMC Sierra ExtendedCab on Friday (7/23/10). Today is Sunday (07/25/10) and the problem seems to be intermittent. I notice when the truck sits for a while (i.e. half hour/over night) the keyless entry will not work on the driver's door. I open the driver's door manually by insereting the key into the door lock and no courtesy light (readward on the door panel at the botton behind the map pocket) nor the dome light on the ceiling. When I insert the key into the ignition no chime sounds. When I turn the key to the on position (do not start engine), only the battery light comes on on the instrument cluster. Not the usual full lights system check during power on. No power to the windows, door locks, mirrors on the drivers door, yet the switches and courtesy light work on the passenger door work fine.

    If I give it a few minutes and turn the ignition key off anf back on again twice or three times its like the system resets itself and everything returns to normal. Funny thing though, it rained here east of Toronto a lot over the past 3 days. Every time it rained the fault happened. Today it is dry and sunny - problem has not resurfaced.

    Question for you - what was the source of you issue with your truck. What did you end up doing to fix it.
    I would sincerely appreciate hearing back from you.
    thanks...2004gmcsierra.
  • trichietrichie Posts: 2
    This truck 05 GMC 2500hd has been an electrical nightmare since about 6 months after it was purchased new in Jan'05, latest is that after sitting for 10 days that the battery is totally dead. Multiple battery replacements @ the urging of the dealer still no change in the battery status after 10 days.
    The most recent piece of the puzzle is with the 4 wheeler trailer (new wiring and lights) sitting on a rubber pad with the ground disconnected from the trailer, no ball contact, no safety chain contact , the trailer lights come on, both lights blinking with only one blinker, step on brakes and the lights go out acting like a poor ground, but there shouldn't be one.
    Any help would be greatly appreciated.

    This was cut and pasted from another part to the site. Again any help will help, I have several more gray hairs because of this.
    trichie
  • gmcustsvcgmcustsvc Posts: 4,134
    Hello Trichie,
    I apologize that you are experiencing an issue with your vehicle. Can you please email me your VIN and current mileage so I can look into this further? Is the vehicle at the dealership currently or is it at your home with a dead battery? You can get my email by clicking on gmcustsvc. Thank you,
    Mariah GM Customer Service
  • so im playing ball saturday and strom rolls in my truck gets hit by lightning and all the fuse are blown so i replaced all of them and still will not start and im have no clue about working on truck ect. so has any one ran into this prob. or know someone that this has happen to thanks, the truck is a 2001 1500 4x4 so any info will be great
  • what exactly was your truck doing? mine will show the engine light and the heater on the passager side will blow hot air. Light goes out and tach acts up, signals quit, and the AC quits. sometimes the dash lights flicker. Sound familar?
  • sp206sp206 Posts: 1
    edited August 2010
    I have the same problem with my 2005 Chevrolet Silverado dually and was wondering what you had to do to fix the problem ?
  • chevelkchevelk Posts: 1
    99 Chev Silverado 4.8 engine. I went through some water several weeks ago and a couple of days later the cesl came on and hasn't cleared. I took off the battery wire to clear it but the light is still on. Any ideas?
  • Guys, I could really use some help with this one. I was comming back from a fishing trip towing my atvs on a trailer. I had the tow haul enabled and the cruise control set at 70. When I would go up a hill or tap my brakes to take the cruise off, my gauge cluster, radio and computer display would turn off and immediately turn back on. I have had my mechanic look at it and he cant find a problem. There are no problems in the wiring harness and no loose wires. Pleeeease help
    Thanks
  • crusin57crusin57 Posts: 20
    Hey can't help you but i also have an 06 Z71 and its does wierd electrical stuff also. i hope you figure it out, My anti theft activated a few weeks ago when my truck was parked in my driveway by itself it then deactivated 2hrs and 15 minutes later. in the meantime the truck wouldn't start, after it started like nothing ever happened. Never happened again.
  • gmcustsvcgmcustsvc Posts: 4,134
    Hello Redraider36,
    I apologize that you are experiencing and issue with your vehicle. Has this concern only happened the one time? Or is it an intermittent concern? Have you checked the connections to your trailer? Did any codes come up on the DIC? Thank you,
    Mariah GM Customer Service
  • Mariah, This problem just started on the was home from the trip last sunday, during the 6 hour drive it happened 30 times or so. I have pulled the same exact trailer for the past two years and have never had this problem which makes me think that the trailer isnt the problem but we are double checking the wiring. There was no errors that showed up on the DIC and my mechanic drove it for over an hour without a problem. Today i am going to hook the trailer up again and try to recreate the same conditions to see if it happens again.
    Thanks
  • Yea its crazy....its frusterating that we cant find the problem...my truck is running great. I travel to our ranch once every couple weeks and i dont want to have this problem get worse when i am out there and hours away from any help...
  • gmcustsvcgmcustsvc Posts: 4,134
    Hello Redraider36,
    Please keep me informed on how everything goes. Thank you,
    Mariah GM Customer Service
  • Mariah,
    Have you ever heard of wierd electrical problems because of altitude????
  • gmcustsvcgmcustsvc Posts: 4,134
    Hello Redraider36,
    Unfortunately, I am not a certified mechanic and cannot diagnose your vehicle. However, I have heard that altitude can affect vehicles. If you are unsatisfied with your diagnoses I can locate a different dealership in your area and you can get a second opinion. I would just need your zip code in order to do that. Thank you,
    Mariah GM Customer Service
  • My zip code is 79424. I am hesitant to take it to a dealership because if it is in the shop for a day and they dont find anything they will still charge me. My mechanic does not charge me unless he finds a problem
  • Greetings,

    My 2005 Silverado (4-door) front and rear passenger electric windows quit working, both at the same time. The front makes no noise at all and the rear window makes a faint click when the buttons are energized. Doesn't seem to matter if the window lock is off or on. The driver side windows are okay.

    Any suggestions?

    Thanks,
    BigJohn18 :cry: :)
  • Okay all,

    Figured out this one myself... Found the "MBEC" 50 amp maxi fuse blown. It is located in the fuse box under the hood. The fuse apparently feeds the smaller MBEC fuse box under the dashboard just to the left of the brake pedal.

    Hopefully it doesn't blow again and was just a aged-fuse failure (it didn't look like a massive blow, just a gentle separation). Otherwise, I'll be tracing the cable harness from the main fuse box to the MBEC fuse box.

    Hope this post helps someone else.

    BigJohn18
  • I have a 2007 gmc sierra 4x4 bought new in 2008. It has around 60,000 miles. It has been relatively problem free until last week.

    The circumstances are as follows: I was listening to my MP3 player through the auxillary port on my factory stereo. I have played the MP3 with the truck running with no problem. I was outside, truck off, with radio playing MP3. The music turns off and truck will not start. Seems like a low battery. Replace the battery a couple days later and dash lights come on, but no dome lights, tail lights and truck will not start. The safety mechanism for the brake/gear shift is overriden as well as I can get it in gear without applying brakes. Checked all fuses and have continuity at each.

    Gave up and went to dealer who informs me that my two year old truck needs a BCM replaced to the tune of well over $500. They then continue to tell me that until the new BCM is in place they will have no way of knowing if the original BCM just "went out" or if there is a cause somewhere in the truck.

    My questions are as follows:
    1. In the event there is a problem in the truck, will said problem ruin the new BCM ?

    2. What are the chances that the original BCM died of its own volition without a "cause" lurking somewhere else in my truck? What typically causes these things to quit? I'm guessing if my truck will run ok, the dealership will kick it out to me and hope I get another couple years off this module. Problem is I'm a woman who travels extensively to nether-regions in texas and I don't wish to be stranded...especially if my new BCM won't let me use my onstar....

    3. anyone else have a similar problem?
  • I dont think its your trailer. I have an 07 silverado 1500 Z71 that has done the same thing. All the gauges went off like it was turned off and the doors unlocked and locked as if i was puting it in park. when i would turn on the blinker a service light would come on. After then pushing on the brake it would go out and something else would come on. Have you figuered out your problem yet or can someone else please help with this problem?
  • cOULD BE THE RADIO DRAINING THE BATTERY !
  • I was just driving my Silverado today and had to press my horn but nothing. Checked the fuses but none were burnt. But when I hit my lock button on my keys twice the horn comes on. Could it be the horn button in my steering wheel.
  • I have a 2003 GMC Serria 4wd 4.8 . Started having problems with the rear signal lights. When the brake is pressed the signal lights flash faster and noticed the Center top brake light flashes also. Signals work fine until brake is pressed. Checked bulbs, fuses, wiring at back of truck. Disconnected the wiring for the trailer brake control to rule it out. Any other things to check before head for help? Any help would be great.
  • I need major help at first just left and signal stopped working now both brake light and rear signal isnt working front signals still work cab brake light works fine please help someone
  • I have a 2001 4X4 sierra. I had to do a rebuild after putting the engine in it turns over but won't start I rechecked the engine timing its good. I was told that after a rebuild the ignition timing needs to be reset does anyone knows how this is done.
  • grampy1grampy1 Posts: 140
    I have a 2004 Sierra and am wondering if i should be concerned about replacing the battery. I see nothing in the manual.
Sign In or Register to comment.