Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevy Silverado and GMC Sierra Electrical and Computer Questions

1161719212226

Comments

  • pinetreebpinetreeb Posts: 2
    edited April 2011
    This morning I used my keyfob to unlock the doors like I always do. The parking lights flashed like normal but this time they didnt go out. They are dim but still on. I thought it may be the headlight switch on the dash so I unplugged it and they stayed on. Then I thought it may be a relay so I switched a bunch of them around and got nowhere. The only thing I could do was find the fuses to the parking lamps(1 for the front and 2 for the rear)and pulled them so the battery doesn't die. The next thing I wanted to do was pull the fuse to the keyless module but have no Idea where it is. Any help would be greatly apreciated. Its a 2005 silverado extended cab LS 4.8 4X4. I would like to solve this without having to pay the dealership. I've had some pretty bad experiences with them in the past.
  • jscott79jscott79 Posts: 1
    Curious to see if you've rec'd any information on what the problem is? I have a 06 1500 Chevy Silverado with what sounds like the same problem. For whatever reason, the message ctr displays "Service 4WD, Service Brake System," the ABS light and Brake light on the display illuminate, and the heat shuts off. I was told to try and replace the dashboard control switch for ESOF 4WD. I did and this did not correct the problem. The problem comes and goes for no apparent reason. The hole system will go haywire, then 30 seconds later go back to normal operation, storing no fault codes at all. Any ideas where to start? Thanks.
  • pinetreebpinetreeb Posts: 2
    Here was the solution to my problem. The trailer light plug was all corroded and made an open circuit so my lights wouldn't shut off. Unplugged the plug from the wiring harness and presto...problem solved. The dealership wanted to replace BCM(body control module). For several hundred dollars. Hope this fix helps someone else with a similar problem and saves them some serious $$$
  • sordavsordav Posts: 1
    I have a 2009 chevy 2500hd, I had the same problem and traced the wire from the plug to the engine compartment. It is a red wire and was coiled up and taped underneath the master cylinder. I had to hook it to a terminal outside the fuse box on the radiator side of the fuse box. I had to buy a nut and washer for the terminal and add a fuse inside the fuse box. Hope this helps.
  • temeshatemesha Posts: 1
    hi All, I was wondering and in hope to find someone that has a similar problem as to my new 2009 Chevy silverado truck I bought 2 months ago...and have barely driven!..I have a very bad Electrical Gremlin and the GM dealership cant seem to douplicate it or find this cause....it only has 30,000 KM and I wish to fix it so I can feel safe to drive my truck...at the meantime i am unsafe as I cannot take it on road trips or anything..Here are my causes....intermittent but if driving for an extended time it goes bonkers and will not stop... When I brake the Interior and Exterior lights dim/flicker and or cut off as well with the music along with it!. The Airbag light comes on and chims with the Stabilik track control OFF signal goes on as well and ABS breaks light comes on all due to this breaking, and if you break frequent the whole truck goes nuts. As well!!! with alot if chimming.!! when you break and SIGNAL to right or left...when truck is acting up, the Door locks go crazy locking and unlocking on their own..AND THAN MY TRUCK DOWNSHIFTS ON ME! Which I dont find acceptable for anyone to drive a NEW truck that has this suituation...Expecially when it happens on a road trip in the middle of nowere going 110...and your truck downshifts to 2nd!....I have never been so scared in my life...and I thank god I do not live in a BIG city....imagine what would happen if on a busy busy street...Or freeway...it is an accident waiting to happen. I really just wish I was able to Drive my new truck and feel safe...or even have it as dealership takes it, tries to get time to work on it, but finding nothing and has given up until I can get it to go crazy for them..I am so fllustered if anyone has anything for help at all that would be amazing.. I wish to feel safe and drive my truck...it seemed beautiful when iIwent and looked at it to buy..but now it been bugging me daily
    THANKS
  • gmcustsvcgmcustsvc Posts: 4,168
    temesha,

    I apologize for the problems you are experiencing with your vehicle. I would encourage you to contact GM of Canada at 800-263-3777. Hours: M-F 7:30am - 11:30pm, Sat 7:30am - 6:00 EST.

    Thank you,
    Caron, GM Customer Service
  • aducilleaducille Posts: 1
    3 months ago,the "check tire pressure" warning began appearing on the dash of my 2008 Silverado HD. 3 weeks ago, the headlights began staying on after turning off the ignition and locking the doors. 2 weeks ago, the sunroof stopped working. We've had it in for the recall to disable the heated washer fluid. Otherwise, no mods have been made to the electrical system that I'm aware of. Any ideas?
  • gmcustsvcgmcustsvc Posts: 4,168
    aducille,

    Were you planning on taking the vehicle into the dealership to be looked at? Please keep me posted.

    Thank you,
    Caron, GM Customer Service
  • nljewellnljewell Posts: 21
    I've got an 89 Silverado with close to 200k miles. My problem is that the negative terminal melted with I was putting in a new battery. About a week ago it wouldn't start so I had the starter tested and it was good. I checked my battery terminals and noticed the positive terminal was stripped out. The parts store gave me a new battery, I hooked up the + first and when I was doing the - I heard some sparks and then the whole damn thing melted. I am thinking I have a short somewhere but don't know where to start looking. Like I said its got close to 200k miles so I hope its a cheap fix. Thanks.
  • i have a 2011 silverado 1500, 4x4, flex fuel, 5.3L that is having electrical problems, they started at 1,300 miles and has happened 4 times now and im at 1,500 miles. When driving the a/c will start blowing hot, the speedometer and tachometer will go to 0, the door locks with start locking and unlocking, i will loose throttle response, on my display it will read stability control off, traction control off, parking assist off, service stability control, and the check engine light will come on. then everything will go back to normal. the only thing i have done to the truck is change out the dome lights with led lights and change the headlights with hid lights. the dealership told me to take the hids out and put the factory lights back in, which i don't see how that will affect the computer. So i went to the dealership and changed them for them. the next day i was told to pick the truck up, i got two miles down the road and it happened again. I did a u turn and took it back. I lost throttle response on the freeway at rush hour. not cool. ive only had my truck for 3 weeks. The dealership does not know what the problem is.
  • gmcustsvcgmcustsvc Posts: 4,168
    carlmoore3,
    I apologize for you concerns and frustrations. Can you please email me with your complete contact information, VIN, current mileage, and involved dealer? I would like to look into your situation more. I look forward to your response.
    Christina
    GM Customer Service
  • I have to go in to the dealership in the morning to remove the led dome lights and replace them with the factory ones, They are telling me that could be causing my problems now, which I don't see how that is causing the problem either. It seems they are guessing what the problem is since they released the vehicle after saying it was the hid headlights and I only made it a few miles up the road before loosing the accelerator pedal plus the other issues. I told the service department that i also needed a truck to drive for work and other everyday purposes, that's why i purchased one, but they said Enterprise didn't have one. They have me in a Chevy Aveo at the moment. I will have to speak the service manager in the morning. Also I don't see why I have to go to the dealership and have to do these simple light bulb changes without getting charged. I live over an hour away from the dealership and this will be my forth trip to the dealership which also brings me to my other concern, I took my truck to Parkway Chevrolet in Tomball, TX which is the closest to my house. I took it in on a Wednesday when the truck was acting up when i was driving it. the service person told me I would have to leave the truck and they might be able to look at it on Friday but no guarantee and it would probably be another week before it was finished. I said that was fine but I would need a vehicle to drive, he asked me if I purchased from them and I said no. He told me that they don't give vehicles to drive I would have rent one or to take it to the dealership that I purchased it from they might give me one. I told him that I didn't feel safe driving the truck but I could not rent a vehicle either. I asked if I could just bring it back on Friday but he said I would loose my place in line. This bad customer service is why I didn't purchased from Parkway Chevy since I experienced problems with them back in 2007 when Purchased my 2007 Silverado, that's why I went to Landmark Chevy. Ive purchased from Robbins Chevy before that's why I went back there for my 2011 Silverado. Ive only had my truck for about 3 weeks now and if I can't have this problem solved I will not be confident driving this truck since I do have to drive an hour to work everyday not to mention it is a $43,000 truck.
  • nljewellnljewell Posts: 21
    It seems when that in the process of putting my starter back on the positive terminal post had loosened up and wasn't getting a good connection causing the short. Even though they didn't have to Advance Auto Parts replaced my battery twice free of charge so a big thanks to them, it took me some time to figure this mess out it ended up not costing me a thing. Hope this helps someone in the future.
  • wingnut58wingnut58 Posts: 1
    I have a 2007 Chevy 1500 with the 5.3 liter. It has 33,000 miles on it and I just got it about 2 months ago. I have had two occasions where I get in it in the morning and turn the key and it there is absolutely no power. After a jump it starts right up, even after shutting it off soon after the jump it starts no problems. Few weeks later, same deal. The dealer checked the battery and said it's good and they thought a relay may have stayed on. No problems for 4-5 weeks then my wife drives it and shuts it off at the gas station, she goes to start it and turns the key, no power, turns key off then on again and gets a slow labored turn over of the engine, turns key off for about a minute and again turns the key forward and it fires up like nothing was ever wrong. Battery cables are attached securely, is this a starter issue, ignition issue, or what? Thanks for any input.
  • gmcustsvcgmcustsvc Posts: 4,168
    wingnut58,
    I would recommend asking the dealer to involve technical assistance. Please feel free to email me with any further questions comments or concerns. I hope this helps your situation, I look forward to your response.
    Christina
    GM Customer Service
  • jano5jano5 Posts: 1
    I just notice the exact same problem with my 2004 GMC.How did You fix it? Please help me!
  • ggosseggosse Posts: 1
    I have a 2005 Silverado. It has 73 000 km on it. At 40 000 km, I noticed a slip in the transmission. That is, when you start from a complete stop, there is a hesitation. I took it to the dealer (it was still under warranty) and said this was normal. This continues to occur. I have seen many posts with people experiencing the same issues. This year, my speedometer has gone wonky, going up to 120 km/h while I am just starting off; the tack has gone down to zero while driving on the highway. Finally, my driver's side window has been going down on its own over night, but not all the time. First couple of times, thought I left it down, but since we have insured it was up prior to leaving it for the night. Anyone else have similar issues? I am going back to the dealer in the morning to see what they have to say. Any advice?
  • I have 2010 Silverado 1500, My electrical problems started with the passenger window functioning on randomly in 2003. I thought it was because I left the window open when it rained. Then noises from behind the glove compartment, Then the fan/AC would stop working ( for three years I was able to take the keys out and restart the truck and the AC would work. now It works went it wants to. Now, water won't shoot out of the wipers, it makes the sound as if the blinker is on (the sound stops when I put my foot on the brake) the radio turns off sometimes.
    I don't know but I'm thinking of replacing the relay to see if that helps.
    Has Any one had these problems?
  • gmcustsvcgmcustsvc Posts: 4,168
    chevytruck2,

    Were you planning on having the vehicle diagnosed? Please keep us posted when the issues have been taken care of. If you have any questions please feel free to contact us directly.

    Thank you,
    Caron, GM Customer Service
  • KCRamKCRam Mt. Arlington NJPosts: 3,516
    Could you clarify those years you posted? Would seem impossible to have a 2010 truck that has had problems since 2003. :)

    kcram - Pickups/Wagons/Vans+Minivans Host
  • labeldtlabeldt Posts: 1
    Have you gotten any of this resolved? My husband recently had a similar experience with his airbags deploying on a gravel road in a 08 Chevy silverado and Chevy says that the pickup is only designed for paved roads ?!?!. We are going to have to have our insurance company pay but he is concerned about it happening again.
  • 2004 6 cylinder Silverado with 120,000 miles on it. Had a tune up at 96,000, new battery, points& distributor at 108,000.

    Engine light came on and the error was "Random Misfire" The injectors were cleaned but didn't solve it. Cylinder 1 misfires at 1800 rpm (60 mph). A pressure test was done on the injectors and 5 of them came out at 13.9 and the misfire cylinder was 13.7.

    Problem not fixed.
    Mechanic said one idea would be to replace the injector on #1 ($500) but could not be sure that would solve it.

    Any ideas??
    Thanks
  • gmcustsvcgmcustsvc Posts: 4,168
    labeldt,

    I apologize for the problems you have experienced with your air bag. Have you spoken with GM Customer Assistance? Please keep me posted on any information.

    Thank you,
    Caron, GM Customer Service
  • I have the same problem with mine it's an 08 z71 5.3Lt
    It's been to the dealer 3 times and they cant find out whats wrong with it. I need help and suggestions?
  • gmcustsvcgmcustsvc Posts: 4,168
    jhollis716,
    I apologize for your frustrations. Can you please email me directly with your VIN and complete contact information? I would like to speak with your further regarding your concerns.
    Christina
    GM Customer Service
  • Next week we will be taking our truck to the dealer to have it checked out. Prior to taking it in, I wanted to see what others with similar experiences have found.

    Early this year we fell in love with and purchased a loaded 2009 LTZ Silverado Crew Cab 4x4 that was Certified by the dealer. I would say 95% of the miles I have put on the truck are highway miles to and from work (40+ miles one way).

    Of a morning, usually at my second traffic stop, I am almost certain there is a very brief flicker of the headlights. Several afternoons when I have exited the expressway, it feels like the temperature of air from the a/c changed warmer then cooled back off. Off and on I have heard chimes but they have usually been of an afternoon in traffic so I have not been able to see what was being displayed. Last week I heard the chimes numerous times over several days. I was finally able to see the message being displayed was that the parking assist was turned off. I did not turn it off and was unable to get it to come back on. This week it seems to be on and working.

    Over the weekend my wife and I made a trip. During the trip we noticed the a/c blower speed slowed down then sped back up. I was surprised when the cruise control turned itself off at least twice on our return trip.

    Monday and Tuesday I heard the chimes again when I made full stops for traffic lights when I was almost home. The message displayed this time was stating the stabilitrack was off. Today it seems to be working.

    Today, Wednesday, a few miles short of my house, I am certain my a/c briefly turned off and on similar to the flicker of lights of a morning. While discussing everything with my wife and mother-in-law, my mother-in-law said she noticed the a/c problem every time she has been in the truck including as soon as I bought it (thanks for telling me).

    IN addition, I do not believe I am getting the kind of mileage I should be getting for the truck. As I said earlier my driving is mostly highway. Of an afternoon I am in traffic but able to move at 65 - 70 mph the entire time. I have installed a Magnaflow exhaust and a Jason bed cover on the truck to try to increase the miles per gallon. Each tank of gas used, I have averaged between 14 and 16.5 mpg. On our recent trip, driving about 73 mph, I averaged 16.6 mpg strictly highway. I feel this is a lot less than I should be getting.

    Years ago I used to be a big Chevy fan until in the 80's GM changed transmission design. Once I had to start having transmission rebuilt I started buying other brands of vehicles. This was the first Chevy I have bought in quite a few years. I hope the electrical problem on the truck is minor. Until these problems started happening we really loved the truck. We liked this truck so much we recently bought a 2011 Chevy Convertible Camero RS (Bumble Bee).

    While I am on here, are there any more rumors about GM building a truck to compete with Ford's Raptor? (A good friend just bought a Raptor and I'm thinking a head to my next vehicle).
  • gmcustsvcgmcustsvc Posts: 4,168
    bad_horsie,
    Can you please email me your complete contact information and your VIN? I would like to look into this further. I do recommend getting it into your dealer. I look forward to your response. Have a great weekend!

    Christina
    GM Customer Service
  • biggabbiggab Posts: 1
    2000 Chevy Silverado. I hit a brick wall and and the air bags didn't go off. GM sent out a investigator to check the computer and after about three weeks they said. i did not hit in a specific area of the truck even though certain parts of the frame was severed off. they said if it was life threatening then i would need a attorney. that was it no appologies case closed .what kind of stuff is that. if youre in a silverado and your in an accident make sure you hit just right. it could cost you your life property damage as well as what ever else may be in the way.
  • bad_horsiebad_horsie Posts: 2
    edited August 2011
    Electrical Gremlin Removed

    We took our 2009 Chevy Silverado to the dealer yesterday. What they found was high resistance in both battery cables. They replaced both of them under the GM warranty. (We did not have to pay anything). Today I did not experience any of the issues I saw over the last couple of weeks.

    Our experience with Gunn Chevy on IH 35 in San Antonio has been great. The sales staff treated us like professionals. There was no game playing like some dealerships. Other than an oil change, this was the first trip to their service center. Again, we were treated like professionals and explained everything to us. Now if Chevy would just build something to compete with my friends Raptor ...
Sign In or Register to comment.