Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevy Silverado and GMC Sierra Electrical and Computer Questions

13334353739

Comments

  • 1500medinaoh,
    I had the exact same issues right down to the complete electrical failure after a shutdown.
    I first started noticing a slight flicker in the lights at night, but chalked it up to the
    kicking on. This was quickly followed by the radio time resting but none of the presents. I had the alligator checked and replaced the battery. The issue seemed to go away for a couple of months and then suddenly the brights issue would go on and off. The ignition chime would stay on when the key was removed. The doors would lock and unlock, the passenger seat airbag sensor would randomly go on and off. The traction control would cycle.....and now suddenly complete power failures at the most opportune times.I have a 2007 GMC Sierra Crew Cab TEXAS edition with around 60K miles.
  • Good morning 1500medinaoh,

    We see that you currently have your Silverado in at the dealership; if you would like for us to check into the progress of the repairs please email us the following information to get a Service Request going at socialmedia@gm.com: your name and Edmunds username, phone and address, the last 8 of your VIN and current mileage (approximate works fine), and the name of your dealership.

    Sarah, GM Customer Service
  • Good morning jgagnon,

    We're sorry that you're having these difficulties with your electrical system in your Sierra. If we can check into this further with your servicing dealership, please send us the following information via email so we can get a Service Request set up: your name and Edmunds username, phone and address, the last 8 of your VIN and current mileage, and the name of your involved dealership. We can be reached at socialmedia@gm.com

    Sarah, GM Customer Service
  • Sarah

    Thank you for following up. Please provide an email address where I can send this information.
  • You're welcome! We can be contacted at socialmedia@gm.com

    Sarah, GM Customer Service
  • ricschricsch Posts: 540
    gmcustsvcsarah, I recently sent an e-mail to socialmedia@gm.com regarding a similar issue as posted by the others with these random electrical problems on a '07 Silverado Crewcab 1500, have you seen the message yet.
    ?
  • Good morning,

    My coworker Christina answers inbound emails - have you heard back from her? If not, I will check with her to see if it came through; you may want to try resending. I apologize for the delay!

    Sarah, GM Customer Service
  • I just got a 2008 chevy silverado crew cab and I am having the same. I was wondering if you ever found out what the problem was and what the solution is. I would really appreciate your help.

    Thank you for your time,
    Robert Reed
  • Our issue was the window switch that went out. We had to replace 2 switches and the cruise control relay switch. Total out of pocket was much less than we thought since it was only the switches that needed to replaced vs window motors.
  • I have an "08 GMC Sierra 3500 and my ghost turned out to be a loose ground on the frame under the driver's seat. There are several grounds attached to the frame. If your truck spends any time in the cold climate, I am sure that you have noticed rust on the frame. GM's solution for corrosion control was to have the frames dipped in some sort of wax instead of painting them like the rest of the world. As soon as a single drop of water gets behind this wax it is all over and the wax starts to literally peel off. When GM installed the grounds to the frame they never cleaned the connection point off and the grounds were screwed on top of the wax. This works for a little while but once water gets behind that little 10mm bolt and freezes a couple of times, the wax and the bolt are loosened and the grounding point is compromised. You would think that they would have a service bulletin on this by now. You would also think that GM would have gotten away from those waxed frames by I just took a look at a 2012 and yep, wax frame that was already rusting. Reminds me of the early 70's. Check all of your ground points. Loose grounds drive the ECM's bonkers.
  • I have had this happen 2 times now. After driving my 2008 GMC 4x4 the indicator for the shifter keeps loosing P,R,N 1,2,3 and all the lines under them ------- it starts off with one disappearing then one by one they disappear. until they are all gone. Then all of a sudden they are all back just like nothing happened
  • gmcustsvcgmcustsvc Posts: 4,003
    Hello thegiver61,

    If you decide to get this checked out by a GM dealership and wanted for us to follow up on that appointment with them, please contact us at socialmedia@gm.com (include your name and contact information, the last 8 digits of your VIN and mileage, the name of your dealership, and a summary of the situation).

    Sarah, GM Customer Service
  • have seen this post, or something like it and was wondering of anyone ever figured out a fix.. I have 2010 Silverado 2500HD - like the truck, but after three scary experiences I am loosing the faith..
  • gmcustsvcgmcustsvc Posts: 4,003
    Good morning cjsm1982,

    We're sorry to hear that you are not feeling confident in your truck. If you would like for us to follow up on this with your involved dealership, please contact us via email at socialmedia@gm.com (include your name and contact information, the last 8 digits of your VIN and mileage, a summary of the situation, and the name of your involved dealership).

    Sarah, GM Customer Service
  • I rebuilt a 2002 and it fired right up...no ignition timing needed, but im no mechanic...that same truck is forgetting the key occasionally and I have to train the key to the truck for ten minutes before it knows it not being stolen and will allow it to run. After u attempt to start the truck leave the key in the on position and if the diagnostic screen on the dash flashes the security light at u then back to the battery light leave it on for ten minutes until the security light is no longer flashing then turn off and retry...sometimes it has taken two to three times of doing that then all the sudden it will fire right up and no problems untill that sob forgets again...have no idea what keeps cusing this to mine... good luck maybe this will help u
  • dbvzdbvz Posts: 1
    Has anyone resolved the electrical "Gremlin" as described in post #556? I have experienced this and it is quite frightening while driving. Called my local dealership and he said he had never heard of anything like that happening. Don't want to waste a bunch of money there if they have no idea what is going on. Seriously considering a trip to my local Ford dealership for a trade. What a shame, I really like my Silverado.
  • There was a guy on here that documented similar problems on youtube and it was scary. He apparently got some deal from GM and the youtube video was erased. MY GM truck lost brakes early in life due to brake lines that rotted out in less than 4 years. Endless warranty issues and I was nearly always greeted with the "deer in the headlights" look at my dealer, but at least they fixed at 1-3 warranty items at nearly every oil change ( several repeats in 3 years) . I know of many accounts of the early failing brakes, and in fact it was investigated by NHTSA, only to see the case suddenly closed. GM Customer Service kindly contacted me on this board, only to tell me, 'sorry, we know nothing about those brake line that burst early in life' (many accounts on the internet though). After 35 years, I bought a Ford. You will be glad you did. Had a warranty issue, no deer in the headlights look, they just fixed it.
  • I had the same issue with my "07 Silverado 1500 as well a couple months ago. It reminded me of a cold start on an old pickup. I had to attempt to turn the engine 3 times for it to start. I knew it was not a battery/alternator issue because I had power, but it just did not want to turn over. I told my husband about it and he did not seem concerned as it has never happened before or since, but there are many other issues with this truck that I have experienced and have read about on this forum. It almost seems worth it to look into trading it in before it goes kaput on me.
  • tracyvttracyvt Posts: 1
    edited February 2013
    Sarah,

    Can you please assist me, as well? I am having the same issues with the ABS and Parking Brake lights on my 2000 Silverado 1500, 5.3L V-8 Z71. It has 181,000 miles on it. I can email you the VIN. Thanks so much!
  • I have read in the forum about other owners having the shifting issue and the bump after braking. Has anyone found or recieved a resolution to those? My shifting issue has come up very recently and it is during upshift instead of down shift. It is not really a slip, but more of it putting itself in neutral. The bump does not bother me, but it concerns me if is something that needs to be replaced as mentioned before about a selanoid or some time of slip yoke(?).
    Also, I have experienced an issue with my interior electrical system that coincides with the weather. I have been told to check the fuses, but honestly I have yet to do so as I cannot locate the fuse box in the new vehicles ( I am used to the old fords). Anyway, the speakers fade in and out during good weather and will alternate between front and back. However, if it is below 65 degrees or raining, only one speaker works. I have tried adjusting the settings on the radio, turning off bass, raising/lowering treble, going between F/B and L/R, etc. Those appear to have no affect on whether or not they will work. On a good weather day, they work fine. This is minor and trivial, however it does affect the turn signal sound. I have checked to make sure they work, and they do. So, at this point I am stumped. I luckily have not had any problems with my indicator lights, tachometer, speedometer, locks, or any of the other ghost electrical problems, but am curious to know whether the poster that had the ground issue under the seat had anything similar going on before he resolved his ghost problems. Oddly enough, I had a 2008 Cobalt that had the same interior electrical issue as this truck. I was never able to have it looked at or resolved, as it was totalled in 2011. I had previously wondered if it was a issue with condensation getting in the wiring harness or connections. If anyone has any ideas or input, I would love to speak with you.
Sign In or Register to comment.