Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Mercedes 380--450--560 SLs

1202122232426»

Comments

  • fintailfintail Posts: 32,902
    I know they made these for R129 SLs, I can't imagine there wasn't one for the 107...maybe it could be adapted? I'd contact one of the accessory sellers who advertises in Hemmings or The Star etc and see if they know of one.
  • MrShift@EdmundsMrShift@Edmunds Posts: 43,637
    I agree with fintail, I'd adapt something that already exists. You may also find that just putting something between the gap in the front bucket seats will help a lot.
  • jonimjonim Posts: 5
    I bought my '88 MZB 560 SL in '89 with 20,000 miles on it. It has always had good maintenance. Recently, at 127,000 miles, the odometer quit turning, but spedo still works. Also, the A/C fan has become erratic. Sometimes it will come on, run for a while & then just quit. After turning it on & off repeatedly, sometimes it will work again, sometimes not. I can hear the A/C itself working; just seems to be the fan that stops. Are these issues related? Sound like a fuse problem? Wiring?
  • fintailfintail Posts: 32,902
    I am pretty sure those have an old style mechanical odometer, unless the faults happened at exactly the same time, it might just be coincidence - the old dear isn't getting any younger :shades: Does the speedometer work fine?
  • yeah I bet the little gears in the odometer are just worn out. As for the AC, well, welcome to old German AC. I suspect that's a problem in the control head for the AC system. You may need to spend some time prowling around the forums at www.benzworld.org to get more technical advice.

    Here's where you'd want to be posting: http://www.benzworld.org/forums/r-c107-sl-slc-class/
  • I had the same issue with the AC fan turning on and off on its own in my 89 560SL. After i turned it on and off a few times it would finally stay on. In my case it was a loose connection behind the control panel. If you have done any work behind the main console in the last while that may be your issue as well.
Sign In or Register to comment.