Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Toyota Prius Dash & Instrumentation Questions

124

Comments

  • Unfortunately my warranty is out but my problem is solved. It turns out the "radio" is the key to the display problem. A new radio was installed ($600) and all was well. Apparently the "radio" unit controls an awful lot of the car's functions.
  • I realize this is about a year old, but I have to agree, they are too dim...I suppose I should have learnd the steering wheel by now, but at night, I can sometimes not see what a button is.
    I do wonder if anyone has experienced the following:
    After pressing the power button, the car starts...the screen turns on, I can drive the car, however, there is no information on the dash, none of the "dummy" lights work, with the exception of the passenger air bag lights. the screen does not turn to the camera when I put the car in reverse. Anyone else had this happen? This has happened to me twice...the first time, the car would not even shut off...finally, I decided to try the computer technique and held the Start button for several seconds and, oddly enough, it did turn off and then when I turned it back on, everything was OK. Just recently, I drove 13 hours then the car sat in cold wather for a couple of days. Same thing, only this time, it WOULD shut off. I was driving to a dealer to have them look at it and it all turned on. I had even let the car run for a while to warm up in the cold weather.
    I asked the service tech about it when I took it in for service and they didn't know...just said to bring it in the next time it happened....well, I was 13 hours away this last time. I'm just worried it is an electrical problem....no matter how cold, that should work.

    Thanks!
  • This happened to me today on my '06 Prius. Instrument panel lights didn't come on and I couldn't power off unless I held and pressed the button for about 20 seconds. When I came back from my meeting, it seemed to be fine. This morning it was -6 degrees here and by the time I got out of the meeting it had warmed up to a balmy 10 degrees! This is the first winter I've spent outside of California. Never had a problem before, so I'm assuming it's related to the COLD!
  • This happens to our 08 intermittently also. We bought ours in April 08
    and I would estimate it happens about 10 times or so.

    I have the same problem with the instrument panels being off when the car
    is started. The car runs fine. I just don't know how fast I am going.
    Occasionally, I would not be able to power it off. The instrument panels will always
    come back on after 15-25 minutes of driving. I would then have no problem
    turning off the engine.

    I went in to the dealer a couple of times already but both times they
    couldn't trace the problem with the instrument panel working. I was
    finally able to show the service manager with the instrument panel not
    working and the car couldn't be turned off yesterday. I was then told to leave the
    car and was told that it could take them 2-5 days to try to re-create
    and debug the problem. I live in Ottawa, Canada and am currently
    enduring a 5 weeks old bus strike. Since I only have 1 car, I told them
    I couldn't leave them the car for up to a week unless I get a loaner.
    No loaner was offered.

    I then called Toyota Canada and explained the problem to them.
    I got a call today from the dealer to go it to have them read the codes from
    the micro-processors. It took them 10 minutes and the codes were
    clean. The service manager told me to bring the car in next time
    the instrument panel is off and they would read the codes to see
    what happens.

    I will update if they find anything.

    In my case, I don't think it's related to the cold weather. We had
    -30C both yesterday morning and this morning and the instrument
    panel was working fine.
  • The dealer were finally able to read the code with the dashboard off.
    They then kept the car for 3 days running tests and ended up
    replacing the combination meter.

    We have had the new combination meter for about 1 month and haven't
    had any problem since.
  • circle12circle12 Posts: 1
    Have a 2007 prius and the instrument lights keep going black. This happens when ive been driving and shut it off.It will run and drive ok but dont know how fast your going. Ive found that if i unhook the white connection on the 12volt batt for a few seconds then put back on, everything is up and running again. It doesnt go black everytime but its getting annoying. Any help would be great
  • maxx124maxx124 Posts: 8
    I have a 2005 prius with 160 K ..Did the dealer find the problem with your prius , I've had this problem happening 5 times or more every week. with no power, or the alarm going off. or it reboots itself . I have to reset the clock at least 10 times a week. I seem to find new ways to get it running ..the latest fix is opening and closing doors. of course the dealership has never heard of prius not starting or no power ..what makes me think is a major defect that toyota dealers are either very stupid or told not to say anything....
  • frank883frank883 Posts: 6
    Haven't addressed my one-time issue w/Guidance orientation.
    Haven't requested Nav update download either.
    Have had no experience in this area: 87k and running strong with no computer issues.
  • I have had the exact same problem - the display panel went black so I did not know how fast I was going. After taking the dash apart and testing all electrical components they found that it was the combination meter. I had that replaced just today. Unfortunately my Prius (2004) is no longer under warrenty and it is EXTREMELY expensive to repair.
  • hihostevohihostevo Posts: 59
    Eric,

    are you still working for Toyota?

    My wife and I have an '08 Prius and are looking at purchasing a very low mileage '05 Prius.

    Are there any "issues" with the '05 that we should be aware of??

    I tried to send you a private email for this question, but you are listed as private so I am posting it here in hopes that you see it.

    For the rest of you please forgive the off-topic post, but I would be very interested in any comments that folks have on the '05 models with Nav!
  • krismuhlkrismuhl Posts: 2
    I guess this is more of a suggestion for Toyota, maybe it is fixed on the new models. If I have my climate control going, then switch to AUTO AC on the steering column, then switch it again, using the steering column, it turns everything off! Why wouldn't it just revert back to what it was on before? VERY annoying...then when I turn something back on, usually to vent, with the controls on the dash (not the steering column) the ac is automatically on etc... just annoying. Not too difficult to make the car revert to where things were before I wouldn't think.
    Otherwise, a great car. wish i had the money to buy the 2010...mine is a 2008.
    Thanks!
  • I can not find my toyota book for the prius but today the maitenence light came on and wanted to know if I'm supose to take it to a maitenence place to get it work on or somthen.
  • stevegoldstevegold Posts: 185
    That light comes on every 5,000 to indicate an oil and filter change is due.
    Shut it off by holding down the ODO button while pushing start.
    After a sequence of flashes, the reset will be complete and the light will be out.
  • Hi -
    I have a 2001 Toyota Prius with 49000 miles on it.
    Off-late I am seeing the the MIL indicator coming up (& staying on) when I insert the Key and turn it to 'ON' position. However the indicator goes away when I start the engine or drive. Does anybody know what might be wrong? Is this something I should be worried of?
  • Could someone please help me buy new manuals for my 08 Prius. Wife was house cleaning & tossed the whole packet out.Please help me find the cost effective & easy way to purchase them.
  • sas9sas9 Posts: 28
    You can download the Prius guide online. Remember that this isn't written by Toyota - but by Prius owners. I've fouind it helpful and written more simply than the manual. Not sure if this is what you want but the web address is:
    http://john1701a.com/prius/documents/Prius_User-Guide_classic.pdf

    As for the manuals, if I was you, I would search for some used ones on amazon.com, ebay.com and craigslist.com, etc. Hope this helps!
  • whitey9whitey9 Posts: 138
    If by manuals, you mean "owner's manual", and "warranty" manual, and the like, you can get it from the parts department.
  • I have a 2010 toyota prius and had my first oil change done at jiffy lube, They were terrific, but could not reset the light due to reset specs are not yet available. I dont want to pay more money at the dealership. Jiffy Lube was nice enough to offer to reset it if I brought in the instructions. please help ..
    mzabovetheinflence@yahoo.com
  • On the 2004-2009 - Engine off, hold down the ODO button while turning on, keep holding the ODO button until the light goes off. Just did it the other day.
    2010 may be different.
  • At one time I saw how to disble the greyed out screen on 2007 and older Prius' has anyone figured out how to disable the grey out screen on a 2008 Prius
  • I realize that I am replying to a 2008 Message. My 2005 Prius which I bought new has a touch screen display that is slowly getting dimmer as it ages. I used to work on touch screen displays that had the same problem. The answer is to replace the small florescent bulb that no longer is outputing the same lumens as it once did. Unfortunately, Toyota doesn't have a part number for the bulb and will only replace the entire touch screen display at a cost of over $3000 . I am going to research how to get at the display to see if the light source is replaceable.
    Anybody else have anything to add to this?
  • mickeyrommickeyrom Posts: 936
    I bought a 2007 Prius a couple of months ago,and honestly in sunlight I can't see anything.Not the speedometer or the information screen.Anyone think that anything could be done.My car is still under a bumper to bumper warranty.
  • I checked it out. There is no part number for the florescent tube. It doesn't even look replaceable. The entire touch screen assembly would have to be replaced. The cost of that is over $3000. A refurbished one is half that. Try turning the brightness up all the way or buying a sun shied for it.I have seen them on Prius Chat web site
    See if they will replace it.
  • mickeyrommickeyrom Posts: 936
    I have the brightness set to high,but although it looks fine when it's overcast,when it's sunny...I have to use my Garmin GPS to see my speed.
  • hihostevohihostevo Posts: 59
    This may sound strange... but the small dial on the panel to the left of the steering wheel. Where do you have it set?

    Did you roll the dial all the way to the top past the detent?

    Or do you have it rolled down towards the bottom?

    Normally I have had friends have their display set in day mode so it is too bright at night, but is yours in night mode during the day?
  • mickeyrommickeyrom Posts: 936
    edited March 2010
    I have tried it in several ways.Seems like it makes a change only if your headlights are on.Otherwise,it has no effect at all.I have the info panel lights set on medium which seems to work the best.Actually when you adjust it brighter and max contrast,I cannot see any difference.Of course that affects the back up camera view too,
    BTW the service manager at my dealer said that this is a common complaint,but the 2010s are a bit brighter.(helps me a lot)
  • shay2shay2 Posts: 9
    Can't find my message from yesterday.
    69K miles on Prius 2005. No problems except water pump at 65000.
    Went to start car and got error with PS, red triangle do not drive, tow to nearest dealer. Dealer checked and say it is the computer. The computer "went out" and is "shot, I need a new computer and it will be $2000.
  • Me too. 76,000k miles, but while I was driving. Toyota didn't help me either. Did you get help from them?
  • shay2shay2 Posts: 9
    no help but I haven't told them to fix it
    I may try another dealer
    They say it can happen if you hit a pothole. Gee I thought it was a car.

    "recommend replace skid control ECU"

    how much did yours cost?
    thanks
  • llearylleary Posts: 1
    Our 2005 Prius with 79K miles has twice now popped up with all the warning lights which direct us to have it towed to the nearest dealer. Only the last time we were in heavy traffic going very slow for over 30 minutes and as soon as the problem cleared and we could accelerate, all the lights went on and the car wouldn't go over 45 mph. We had to pull over and re start the car twice to achieve decent acceleration. Just the opposite problem all the other Toyota's are having.
    The lights were still on when we got to the dealer, but when they went to work on it both times, the lights are off and they say there is no problem with the car.
    Does this sound like a computer issue or a mechanical problem? Should we pursue it with another dealer?
    Obviously we are concerned because this is a potentially dangerous situation as we could get hit from behind.
Sign In or Register to comment.