Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





HHR Engine Problems

13468911

Comments

  • ray80ray80 Posts: 1,187
    Sorry you had to test the safety of the HHR, but glad it worked out well for you.
  • stackerstacker Posts: 3
    I just purchased a 2008 hhr ss and it also wouldn't start after 50 miles, but when the tow truck arrived about an hour later it started so we went on home then the next day it did the same thing after a 5 mile trip to the store, and once again after about an hour and the tow truck arrived it started , but this time it got towed to a chevy dealer and they couldn't get it to do it again so I brought it home , where it did it again. but this time it just shut down while I was driving and then wouldn't start,but this time the mechanic came with his test box and it threw no codes so it now has 203 miles on the vehicle and two wrecker trips to a chevy dealer. Any ideas or tips on what the problem could be??
  • I puchased the HHR about six months ago and I have had no problems....I travel a lot for my job and I've been noticing since the weather is warmer, when the A/C runs the car will pull and jerk at higher speeds. Now if I'm sitting idol, the car just dies and won't start. All my lights are on and I can tell it's not the battery....but if I shut the A/C off, it will evetually start back up....What in the world is going on??? :(
  • stackerstacker Posts: 3
    Yesterday the dealership that has our hhr called to tell me they think they have found the problem. They think it's the ECM module breaking down when the tempature gets to a higher tempature and GM is trying to locate one, so we'll see, I really hope it works because we really like the vehicle and it's 34 mpg.
  • ray80ray80 Posts: 1,187
    My 06 had an issue with A/C where the air flow would be freezing cold than be warmer for a bit, back and forth. At the same time engine was sort of stuttering/fluttering performance wise. I had already heard of the problem and had the dealer check (and correct) and refridgerant (overcharged). I have also heard of a couple cases where compressor locked up and resulted in broken belt (tow time), which may be due to same thing.
  • So I bought my '07 HHR (LT 2.2) in Nov. '06. LOVED the car at first and had the dealer install a sunroof. Good to go! Then, within the first 2K miles I had to take the car back to the dealer to have the whole exhaust system fixed. It was chirping loudly all the time. My 3 year old kept asking where the crickets were! Was told by the dealer it was installed wrong from the factory. OK. Fast forward to today (it is in the shop AGAIN), it just turned 17K miles, has had the rotors worked on, has had a safety recall, the headliner is coming down caused by wind from the sunroof, and it is currently in the shop for the second time due to the car sputtering, chugging, and trying to stall out on me while slowing down or coming to a stop. Was told it had something to do with the ECM and that it was fixed the last time. I believed them until I about got t-boned last Friday on my way home from work because my car couldn't get out of it's own way. No Service Engine light comes on, and the dealer says the car is not producing any codes. I'm only getting @22-24 mpg at best. I thought that was normal 'til I started seeing other people report mpg in the 30's! What the... Anyway, does any of this sound familiar to anyone else, or does anyone think I should look into the Ohio Lemon Law? I know I only have until 18K miles if I do so. I would really love to just swap it for a Trailblazer and be DONE.
  • stackerstacker Posts: 3
    We bought a 08 hhr/ss and started having problems on the way home and had possession of the car for less than 12 hours in the first 15 days. It had more miles on a wrecker than it had on the road during that time. We were getting very frustrated, but had a great service manager and service tech that found a male prong in the ECM plug that hadn't lined up and was losing contact when the car reached operating tempature and would sometimes lose power and shut down. They installed a new plug and ECM, and everything seems to be working fine now and we are loving the car again. Oh yea, around 28 mpg average when we can keep our foot out of it. Did have a one time 34.4 mpg
  • My problems were tag lights not working and left front side light. Turned out to be the car was leaking water when it rained and the wiring harness under the seats and rear floor area were literally under water. Shorted out the electrical system. I would advise you to take it to them and make them strip the inside of the car to check for leaks.
  • ljumpljump Posts: 4
    I went to check the air filter on my wife's 2008 HHR SS (turbocharged - different than the other models) and I couldn't even find it!! Can anyone tell me how to find it and remove it for inspection? Thanks.
  • Hi, thanks for your response. we did install front splash guards but not before the damage was already done. I am working with our dealership right now to try to resolve the issue. we are waiting on word from the general manager. hopefully I will be able to get things repaired without costing me so much out of pocket.
    does anyone have a good source of HHR parts? I can not find the running boards they say I need to install to fix the problem. any ideas?
    thanks everyone,

    kathy
  • dmathews3dmathews3 Posts: 1,739
    So what do these last couple posts have to do with HHR engines?
  • not sure what you are talking about?
  • dmathews3dmathews3 Posts: 1,739
    This Thread is about HHR Engine Problems and rocker panel damage has nothing to do about this subject. There are other threads that deal with this.
  • the post I have been responding to have been answers from my original post to this forum concerning rocker panel damage to my car and also a response to a question about replacing the air filter. you are correct, it has nothing to do with engine issues but then, I have not been replying to a post about engine problems.
    If my message got posted in the wrong place, I apologize.
    kathy
  • I will move this post to the main HHR forum so it can be a general area where a variety of replies can be submitted.
  • thank you! I appreciate your help and welcome any insights on this issue.
  • I bought a HHR/SS and love it very much. I have four thousand miles on it and had my oil change. I can't reset the oil percent gauge. Can some one tell how? I thought it was turning the ignition slightly and depressing the gas pedal three times...nope didn't work.
  • dmathews3dmathews3 Posts: 1,739
    Doesn't it reset like the other readouts do by pushing the bottom button on the left side steering wheel after putting it in the oil life display?
  • Oil Life reset:

    -turn ignition to ON possition (NOT Accessory or Start the manual has a diagram), its the postition where the instrument cluster lights up with all the Symbols, just before starting. Leave all these indcator lights on while reseting.

    -Go to INFO button (on steering wheel)

    -scroll to OIL LIFE

    -pump gas pedal 3 times

    -Some will beep or just reset.

    -turn ignition off, start the H, and check if reset. Should read 100%

    Shounds like you were on the right track.
  • HAPPENS OUT OF THE BLUE...once during cruise control about 70 mpg, another time after starting it again 20 minutes lator. It is unable to accelerate past say about 20 rpm..Park, Turn off, pull key, start again..works..ANY THOUGHTS HERE? :confuse:
13468911
Sign In or Register to comment.