Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Caravan/Town & Country Electrical Problems

17810121322

Comments

  • hello all haynes does not have the diagrams they told me to try chiltons however it costs $150 + no gurantee that what i need will be in it. so to make a long story short If any one says that its impossible to make the handle for a sliding door on a van call them a liar as I have made on for my van a 1986 dodge caravan and believe it or not the made handle works 5 times better than the oem handle mechanisim if they have a place to upload pis here i will glady uplad every angle possible of the one that i mad so you all can have it as a referance in case you all need to make on for your van ........whats that a rough estimate .....eh ? I believe metal that i used ( scrap 1/4 inch) like is found on old water heater tanks (the inner tank) about 3- $10 at a scrap yard, the weld arc/ mig 135 about $4.00 the electric about .70 - $1.00 and the grinder wheels for angle grinder abt. $3.50 (from lowes) or fleamarket
    and last but not least sawsall blades 1 blade abt $1.50. it roughly costs about $25.00 to make a handle asuming that you dont have to purchase any of the tools special for this project.
    not sure on the arc rods exactly how much they run they were my buddies he let me use his arc welder.thanks for all of you help guys and gals helpso far.
    God Bless you all ! ;) :) :shades:
    P.s. if yall know how to upload pics please tell me how if you want to see the finished product btw I didnt go for prettiness just a working one. but i could dress it up and make it look better
    by the way in case any of you all want to email me instead of posting a response on here or to email me for pics here is my emai address truckinforjesus@windstream.net
  • I too just experienced a 'power door lock falure'... out of nowhere my door locks stopped working. Thank you so much for posting your experience online. I am sure you saved my a lot of money. All I did was remove 10D fuse counted to 30 and vuala! My locks now work! Thank you so much!!
  • Karen_CMKaren_CM Posts: 5,030
    I'd be interested in seeing those pictures. You can upload them to your CarSpace page and then provide a link to it here in the discussion.

    Community Manager If you have any questions or concerns about the Forums, send me an email, karen@edmunds.com, or click on my screen name to send a personal message.

  • Could you help me find some pictures to show which joints to solder? I have tried to take the circuit board apart and fix it myself. I'm not sure which board or which joint is is though.
  • i will take them tommorrow then and send them via email if that will also be wanted otherwise i can take and upload them to a photobucket page (an online image viewer) or to my web page and post a link in here for you all want which ever or however will be best for you and all members
    :) :shades:
  • I tried pulling the two plugs and putting the car on for 20 seconds. I plugged everything back in and got a check engine error. I reset the computer which said the BCM had been reset.

    It worked great for 4 days and now the lights are turning off again while driving. I deliver pizza part time and one of these days the pizza won't get there. I am waiting until it really stops working before taking it in. Otherwise they will think I am nuts.
  • I had a similar problem, after taking it in MANY times, a very nice mechanic at the dealership decided it was a bad ignition switch. They replaced it, and I have not had a problem since. Apparently the switch was bad (or lose) and so when it moved inside it thought the car was starting and would flash the headlights and dash lights like it was starting up. Hope this helps.
  • This does work (I think I read the same forum!) but unfortunately it's temporary. In some cases it may not even last a day. I've read some tips like don't use the remote to lock the doors, use the lever on the door. I'm not really convinced. I have to reset it once every two or three days for my wife. It's a pain, but I'm not ready to pay the $$ to the dealer for the software upgrade that we should really all get for free. If they know there is a problem with the original software they should recall it for a free fix.
  • I own a 1997 Chrysler town and country, and have had electrical problems since the day I bought it. I have had the van towed home many times only to have it start a few hours later. It would start but then shut off after a few seconds, the one thing I noticed was that some of the dash lights would not come on when this would happen. Anyway one day my better half was out working on it and he decided to hit the dash right above the instrument cluster and on came all the dash lights and it starts right up. We have limped along with this problem and it seems to be worse in cold weather. I found one website that shows that you need to take the instrument cluster apart and re-solder a couple of connections, I have yet to give it a try.
  • I totally agree that Chrysler should recall the vans to fix the electrical problems but with the company facing economic hardship, it's a fat chance they'd pony up to do the right thing. :mad:
  • gg1328gg1328 Posts: 16
    Hi there:

    I have a 1998 Dodge Caravan 3.3 engine, 147,000 miles on it. I came home last night and parked my car. This morning I went outside to start the car and put the key into the ignition. The key won't turn. I thought maybe the key was bent or something like that, so I went to get the spare key. It did the same thing. Key won't turn. The steering wheel is not locked.

    Can anybody out there tell me what the problem might be and What do I have to do to fix the problem?

    Thanks,
    George
  • pal6pal6 Posts: 3
    I have a 2002 T&C. When we turn on the Climate Control, the Climate Control, Radio, Windows, Wiper all power off for a 5 to 30 sec, turn back on, then power off again. Somethings it will constantly occur then others it will occur every 10 minutes. The battery terminals are clean. Any ideas on how to troubleshoot?
  • Same issue here (started this morning). Thinking it was battery issue (jumped - without success). Could this be starter or alternator?
  • wilanzwilanz Posts: 4
    oh...2 more months of payments on the van. The problem is intermittent enough that I may get away with trading it in. But who wants a car payment in this economy.

    I had to give up my part time pizza delivery job because the headlights just don't want to cooperate.

    Reseting the BCM didn't work anymore but taking the battery terminals off for 30 mins seemed to get everything working again. On occasion the lights will not turn on. It takes 3 or 4 times cranking the switch for the headlights to come on.

    I did figure out while on a recent road trip that pulling the bottom plug of the BCM as described by kpeglow on 10/26/08 makes the head lights turn on but disables the entire dash board. I had headlights to get home but no gauges, blinkers or wipers.

    For now the van only gets used twice a week when I have to go into the office. The rest of the time I carpool or share my better halfs car.

    Good luck out there and let me know if there's a fix.
  • I have a 1996 Dodge Caravan with a non-functioning windshield washer pump. I picked up a kit at the parts store that is nothing but a pump motor, it looks like it must mount right on the bottom of the washer fluid bottle. Am I correct in this assumption and can someone tell me how to get to the fliud bottle to replace it?
  • donniedonnie Posts: 24
    Starts for a couple secs at low rpm then dies. When it's hot out & It happens taking the gas cap off/on has always worked. Haven't found a remedy for when it's cold below 40 degrees i have tried the suggestions posted was wondering if anyone has any new suggestions. Thanks :cry:
  • okay you are probably gonna tell me im loonier than a dang fruit bat but hey what im about to tell you worked on my 1987 dodge caravan it also done the same thing that yours is doing the only difference is that mine eventually started to jerking and spitting and sputtering like crazy thought the tranny was going out at first.......
    but any way take and replace the egr valve, the o2 sensor and the idle engine temperature sensors this will take care of your problem if it hasn't already sent a loop or register to your computer..... on a 1997 that one is almost fully electronic everything......no big deal if it has though either get you a code reader with a resetting capability or take it to a trusted shop and pay about $75. - 150 to have it reset. let me know how it goes truckinforjesus@windstream.net
  • My van does that and I can tell you what it is it is your factory alarm,I have a 1999,there will be a time when you can't drive it.
  • Great news. the lights stopped turning off now. Since they were now acting up when turning on/off, I thought it was the head light switch. I popped off the cover and could feel where it was loose and kept the cover off and can do it by hand now. It's not pretty to see the opening but it works.

    I keep the cover on and when it acts up, I pull really hard on it and just do the switch manually.

    The replacement part is only $50 but no rush since I can get the thing to work. I'll replace the part once I get ready to trade in or sell.

    Good luck out there and be sure to check your headlight switch.
  • my 97 caravan is acting up the battery light keeps coming on,I just had my timing belt replaced ,and now I am having this problem with the light,had alternator checked on and off the car,both checked out good,put new battery cables and battery in also hoping that was the problem,and woohoo it started and ran for 5 minutes and then the light comes back on any help would be appreciated thanx in advance
  • I have a '97 T & C with intermitant starting problems like what you describe. Engine will start, settles to an idle, maybe 2-3 sec, then dies?? Also, all dash guages are dead. Even when turn the key to ACC, lights come on but no gauge.

    Checked fuses, wiggled key??? Any ideas?

    Thanks
  • This sounds very simular to my '97 T'nC. Except it is the guages that do not come on?? Have not tried hitting the dash. Have you had any luck at finding a solution?

    Thanks,
  • I have a 97 town and country doing exactly the same thing - except I didn't just have the timing belt replaced. It started last week when driving down the freeway with the cruise control on it started jerking real bad and the battery light came on. I cancelled the cruise, stopped (didn't shut off engine) and checked things under the hood but all looked in tact. I finished driving home without the cruise control. Now if I start it up all is good for a while and then intermittently the battery light comes on and stays on until you shut off engine. I have tested the alternator for charging and it is charging whether the battery light is on or off. The battery appears to be in good condition and the battery posts are clean. Ideas anyone????
  • Problems you Have I fixing it changing the gauge cluster I get that for 75 Dollar s from the junk yard take me 15 minutes to Change
  • mine ended up being the alternator fixed my battery light problem ,take the alternator off,and have someone bench test it
  • Thanks! Replaceing the alternator took care of it. Mike
  • b42l8b42l8 Posts: 1
    I have a 2003 T& C 3.8, yesterday the inst panel just went blank, the guages all at zero and the turn signals don't work.....is there a fuze for the panel?? the maint manual does not show any help in this area............the local dealer wants $120 just to check the computer and "talks" about the instr panel as being a "Block" and may have to replace.....this sounds like a pricey deal, so any help would be greatly appreciated, thanks B42L8
  • I have a T&C and sometime my panel would not work. but my van is a little bit older. somone on here wrote about the same problem I was having (which is a little different) but it still deals with the instrament panel. they wrote that one day the guy got mad and hit the top of the dashboard above the panel hard but not hard enough to break anything and that after he did this the problem was fixxed. it worked for me now you can try it
  • We have 04 Town & Country and it won't start. All systems seem fine - checked cables/cable track of doors. Antitheft light is on. Resodered instrument circuit board as was suggested in some of the answers. No change. Could it be the key code lost out of control module? Can you disable antitheft feature or wire around it?
  • rtreetrtreet Posts: 1
    Hello I have a RB4 and the OK knob does not work...is it expensive to repair..??? I bought the unit off of ebay and got it like that ...should I return it or fix it..???
Sign In or Register to comment.