Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Caravan/Town & Country Electrical Problems

1101113151632

Comments

  • ive tried this many of times even had my computer reset and new software added to the computer.
  • maxima8maxima8 Posts: 8
    I have been having the same problem with my 98 T&C It will start and die three times and then not star at all. until next morning
  • Hi. I hope by now you have solved this. For others with this problem, however, have your fuel pump wiring checked. A rodent had chewed through mine (1997 T&C), resulting in continuous successful engine cranking without ignition, because the engine was not getting fuel. Repair of the wiring took care of it. Do not let the mechanic charge you for an expensive fuel pump replacement until they have first checked out the wiring!

    Let me know if this helps.

    McDocs
  • Hi. I hope by now you have solved this. For others with this problem, however, have your fuel pump wiring checked. A rodent had chewed through mine (1997 T&C), resulting in continuous successful engine cranking without ignition, because the engine was not getting fuel. Repair of the wiring took care of it. Do not let the mechanic charge you for an expensive fuel pump replacement until they have first checked out the wiring!

    Let me know if this helps.

    McDocs
  • the problem is that my van would start one day and it would be fine for a couple days to a week. Then out of no where, the van doesn't start anymore until a couple days later. The mileage light on the dashboard doesn't turn on resulting that the car doesn't start.
  • The problem is that my van would start one day and it would be fine for a couple days to a week, then out of no where, the van doesnt start anymore until next day, the mileage light on the dashboard doesnt turn on resulting that the car doest start
  • :mad: I have a 2005 Dodge Caravan. The power door locks have been going nuts. They will unlock and lock when it wants too and it keeps going until it wants to stop. I mean we lock it at night and in the morning the doors are unlocked. I just tryed unhooking the battery. No Help. I also pulled the fuse someone said and no help. Has anyone else had this problem and was able to fix it please let me know.
  • jpfjpf Posts: 496
    Sometimes a weak battery causes the electircal system to go haywire. Consider having a charging system check to make sure the alternator is charging the battery properly. If the battery is weak, then replace it. Good luck.
  • Replaceing clock spring in dodge caravan invlove pulling wiring harness thro steering column and right by wiper switch, or can it be replaced some other way with out pulling wires.
  • my 97 T&C lx - does the same thing... gauges go out & power door locks go out airbag lights but "clears" like normal but brake stays on. Some minutes later the "take me to the repair shop $$" light comes on. The problem can last a few days or a few minutes. All of a sudden everything begins working. The "repair light" will stay on for maybe a day and then it goes out. Think that's the circuit problem too. Is it ieasy to find and to get to or do you have to un install it?
  • sorry did you ever get this fixed it cost me about 2000.00 to get it fixed and 2 trips to the dealer
  • I have a 1999 Chrysler T&C Limited with a 3.8L engine. For the past couple of weeks the battery has been draining quicker than it should. I have found that the Transmission Control Relay is energized even when the ignition key is off. With the key off, when I pull out the fuse for the Transmission Control Module the battery drain goes down to normal and when I re-insert the fuse the Transmission Control Relay clicks on and the battery drain increases. What would cause the Transmission Control Relay to be energized when the ignition key is off?

    Thanks!
  • I've had the same problem with my '99 t&C LXi. I thought there was something that was draining my battery over a period of time. Turns out it was a defective starter. Had it replaced and solved the problem.
  • We have a 1999 T&C. We just had the transmission rebuilt and the next day the van would "choke" when we would start to drive after being at a redlight, etc. Took it back to the service place today and he checked the fuel pressure..no problems. Ran some tests & went to get a temp sensor and when he came back, the parking lites were flashing on/off and the batter was almost dead. He's charging battery to run test on electrical system. Also, we bought the van used 3 years ago and ever since we bought it, the AC control panel lites flash on/off for about 15 minutes then go off. It does this every time we start the car. Any ideas on what the problem could be?
  • I am having the exact same problem. When my husband removes the fuse and puts it back in it works for a few hours. Then it goes back to the same problem. He replaced the fuse and it did the same thing. Just wondering if you found out what it was. I would love to save a trip to the dealership.
    Thanks
  • We were having the same issue with out 99 T&C. I have found that if I try to start it and it doesn't start don't try it again because 3 strikes and your out. If I start it and it dies I take my fist and hit the top of the dash above the steering wheel and then try to start it and it starts up just fine. I know that sounds weird it did it just Saturday and my husband calls me the FONZ. Its worth a shot. If I can get what I mean on video I will but it may be a while because you never know when its going to be testy.

    Oh to the previous poster above my post the removal of the fuses worked for a while for us and then didn't anymore. If it doesn't start right up just give it a good whack on the top of the dash above the instrument panel and then try to start it.
  • What did they say the $2000.00 problem was?
  • I have a 98 T&C and I have had a starting problem for over a year. One day I would not start ( the battery weak) jump starts works like a charm. Would go for weeks, days or months everything OK. Then it starts again. The charging system always test good so does the battery. Checked several times at Sears and Advance Auto. I have swapped the battery with another car it it is running for the last few days. So I want to believe the battery is weak and the system does not like it. I will update this in a few days or if there is a change.
  • with the minivan alot of times when you remove a fuse the system has to reset itself my suggestion is try removing the hot cable from the battery for about ten minutes then reattaching it this also helps in reseting the transmission when it want switch into overdrive
  • OK so far both vehicles going good. I seem to recall this was the identical situation last year. After a while when the original battery is used the problem would go away. When I do so I would update again.
Sign In or Register to comment.