Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Caravan/Town & Country Electrical Problems

12627283032

Comments

  • My town and country broke down and it seemed like the alternator. We replaced the battery and alternator. Three weeks later..again with my three young children, the battery light came on..then all lights started coming on..radio going off and on..it looked posessed! We replaced the computer and it's not fixed!! Does this sound like it could be the same thing. I live in birmingham but may have to call your mechanic!
  • I have 2001 caravan, no alarm on it. The remote starter system quit working about a month ago., We have been starting with the key every morning. This morning the van started as normal, but the head and turn lights are flashing back and forth like there is an alarm going off. (no sound) I pushed all the buttons on the remote starter thinking maybe we push it by chance. The relays under the hood are clicking too. I pulled the two relay that were clicking, but the lights are still flashing?? Any help? Thanks Bill
  • I have a problem and all of this stopped working at once...my turn signals don't work, my electrical seats don't work, my heater or air don't work, and my door locks don't work.....i checked all fuses and relays and they are good.....It's very strange because all my other electrical component's work...like the head light's, wipers, etc....and all these thing stopped at once. If there is anyone out there who have experienced this problem...please can you tell me what fixed it.
  • samiamwvsamiamwv Posts: 1
    My 2005 T&C is having the same problem. Have your problems been corrected and what was. I replaced the alternator when I lost all power but my gauges are still dropping, radio pops and lights blink.
  • rpaul3rpaul3 Posts: 14
    check codes..

    try thumping the dash and see if gauges come to life - if any change could be problem with instrument cluster bad connection or solder joint bad.

    fro more info search :
    http://forum.chryslerminivan.net/forum.php
  • dick90dick90 Posts: 2
    I have an 2002 town and country and some times it will start and then shut off. All I have to do is tilt the steering wheel either all the way up or down and have no problem starting. It might be okay for a few days and then it will do it again. Dealer thinks it's in the security module. Cost $80.00 to run test on computer.
  • rpaul3rpaul3 Posts: 14
    Chrysler is not the only one with the problem many of the VATS type security systems from the past are having issues. There are bypass solutions for most systems. Also sometimes it helps to clean the chip on the side of the key and the ignition with a small amount of rubbing alcohol and a Q-tip. I have also heard that carring a big bunch of keys on a key ring can confuse the chip in the ignition key.
  • dick90dick90 Posts: 2
    Thanks rpaul3
    I'll give that cleaning method a try. dick90
  • hlp1973hlp1973 Posts: 6
    Save
    Reply
    Edit
    Delete

    #2 of 2 check engine light does not work by hlp1973

    Mar 24, 2012 (4:59 pm)
    when i bought my 1996 dodge caravan we found that the check engine light did not work.
    codes could still be read, and since i have purchased the van a few years ago i have replaced 6 or 7 codes along with a new fuel pump and of course routine stuff.

    finally had all the codes gone and thought i was good to go for my inspection.but faile because they want the light to come on when they turn the key.
    the mechanic sudjested a new bulb so i you tubed how to do this and replaced all the bulbs while i had it appart.

    it still did not work, so we purchased a used part and replaced the symbol panel. guess what still does not work.

    the symbol panel is on the top of the dash, while below that is my gauges for speed and gas.i assume that they are not connected, is this correct?

    the reason why i am asking is because my dash board light does not work. the gauges all work fine but the light at night does not come on.could this be linked??

    do i need to remove the steering wheel to remove the dash and replace the light bulb for the dashboard light?

    i also have a blue wire that hangs above the pedals, i assume a radio wire or something?

    does anyone have any sudgestions on what i should look for now and where to look for it, i have two weeks left and a small purse to get this car ready for its inspection. any help would be great!!

    thanks heather
  • rpaul3rpaul3 Posts: 14
    check the fuse box under the dash for a blown fuse - also check the voltage on the loose wire if it has voltage and goes away when you start the engine it could be related.

    does the "need oil" lamp work and go out when you start it - connect them both :shades:

    #1: Panel

    #2: Guages,Right High beam headlight and the high beam indicator

    #3: Rear Wiper, Left headlight High Beam

    #4: RH park, backup lights switch and relay,Speed porpotional steering module,power door lock switch illumination and daytime running lights(Canada)

    #5: Power Door locks,Power Mirrors,vanity,dome,map,ignition and trunk lights,sunroof,radio,power antenna,body control module and power for the data link connector

    #6:Heated mirrors,heated rear window indicator

    #7: Instrument cluster illumination,park and tail lights

    #8: Cigarette lighter,Radio Amp and horns

    #9: Power door lock motors

    #10: Not used

    #11: Radio

    #12:Left low beam head light

    #13,14,15,16 not used

    http://www.justanswer.com/dodge/3dntt-need-dash-fuse-box-diagram-1996-dodge-cara- van.html
  • hlp1973hlp1973 Posts: 6
    hi first thank you for a quick response i will check all the fuses.

    all my lights on the symbol cluster work except for my check engine light it is the only one that does not work, does this usually have its own fuse?

    the guage panel which i believe to be seperate all works however the light that lights up the dashboard so you can not see your speed at night does not work.

    the symbol for my lights on the symbol panel does work.

    thanks heather
  • rpaul3rpaul3 Posts: 14
    not sure why you lost dash ligts at night - check the dimmer switch rotate knob or wheel to full - may be turned all the way down to no lights. was thinking - you could jumper the check engine light to the oil light - just to see if it lights - then check engine light would light and go OFF then you start the engine - probably the same as it should work during an inspection - if you know what I mean. ;o) -
  • suzidogsuzidog Posts: 2
    edited March 2012
    Two weeks ago while we were driving out T&C, the horn started honking, the lights started flashing, and the wipers started with the windshiled washing fluid squirting. We pulled over, turned it off, and restarted. Everything was fine until last night. About 10 minutes after we parked and shut the car off, --while the car was OFF, the horn started started beeping, the back hatch lifted, the lights flashed, the wipers --front and back--were going, and the washer fluid was squirting. The doors had locked themselves. We tried to start the car, and it made odd noises that went away when we gave it some gas. We shut the car off, and everything was back to normal...for about five minutes. Everthing started going off again, except the back hatch didn't open. This time, the key fob would not unlock the door. We used the spare fob to get it unlocked, restarted, and back to quiet. Today, it is at the garage. They said they never heard of this happening. Anyone have any ideas?????
  • rpaul3rpaul3 Posts: 14
    sounds like a problem with the security system - many times a sliding door needs to be adjusted so switch in the door works properly - check alignment and closing of the doors and switches in the door/s
  • hlp1973hlp1973 Posts: 6
    i had trouble finding this sight again to see if i had anymore replys, finally came back acrossed it thankfully.

    my husband and i were thinking the same thing about toggling the wire from oil lamp over to check engine being how oil lamp works and they are side by side. my husband is very good with electrical stuff...but on laptops and what not he can take them appart and rebuild them...but a car is different before he adventures to do this do you have any sudjestions on how we should do it?
  • hlp1973hlp1973 Posts: 6
    @ rpual3 which fuse would i check for the check engine light? do all the lights on symbol cluster operate off the same fuse? the other lights are working so should i even bother with this?

    is there a relay for the check engine light?

    i went to the part store yesturday to see if they had any sudgestions on what i could try, to no surprise they did not have any ideas. i had them read my codes and discovered i have a damn code "target idle not reached" what the hell i thought i had all the codes gone. i just replaced some idle sensor (i think egr valve or something) a few weeks ago and had to have them adjust my idle a few times, they get it just right and poof a day or two later and it is back to a roough sounding idle...any idears on what could cause this? any hoses i should replace? how about the air filter probally could use one of those i am sure but would a clogged one cause a "target idle not reached " code to come up?
  • hlp1973hlp1973 Posts: 6
    i did not see a dimmer switch for the dashboard lights.

    i tried what you said and connected the oil light and check engine light together and guess what the appearence of them working looked great but it still failed. no codes came up..only because i did repairs after repairs until all codes were gone.

    the mechanic who did the inspection said that the obd failed but no coeds where found.

    any idears?
  • hlp1973hlp1973 Posts: 6
    does the mil have a separate wire that connects to the obd? anyone have an idea on what color it is? where do i find the ground wire for the check engine light, what color is it?

    i have two fuse boxes one under the dash and one under the hood, the one under the dash says what all the fuses are for but the one under the hood does not indicate what each fuse is for i see that a few relays are missing but was told that could be for power windows and cruise control which i do not have.

    my obd reads codes... fixed them all so i know that it works, but the mil does not read it does not even come on when i first turn the key . my obd failed inspection today, he could not tell me why he said the good thing is i do not have any codes... little does he know i just spent over 600 in sensor repairs in the past 3-4 months to clear all codes.

    we did the usual repairs..... replaced bulb and cluster and still no light.
  • rpaul3rpaul3 Posts: 14
    so same old problem - but did it pass ?
  • reonreon Posts: 19
    Regarding the dash lights:

    Regarding your dashboard lights, if your van is the same as my parent's 1996 Dodge Grand Caravan, then there is a dimmer switch that is the same switch for the interior lighting. If it is turned to the left, the interior lights go out and the dash dims. If you spin it 3/4 to the right, the dash gets brighter, and all the way turns on your interior lights. It is located at the bottom left side of the steering wheel.
Sign In or Register to comment.