Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Caravan/Town & Country Electrical Problems

1262728293032»

Comments

  • harp2uharp2u Posts: 1
    Hey all! I have a electrical issue with the drivers side tail light doesn't work, all bulbs have been replaced. As well as the dash board crashing while driving ( no lights, gauges etc..) never happens right after a fill up but only lasts until the vehicles next stop..... :confuse:
  • rpaul3rpaul3 Posts: 14
    search the web - repair for dash cluster - also reprogram routine for ECM
  • jims77jims77 Posts: 3
    Driver door switch will not lock all doors normally. Unlocks OK and will lock all doors if hold switch up in unlock position. Passenger door switch and remotes work normally. Tried replacing switch and removing IOD fuse.
  • jims77jims77 Posts: 3
    I should add that I have searched this and other forums and didn't find similar issue. Looking for help because I don't think a wiring issue.
  • rpaul3rpaul3 Posts: 14
    check relays and swap them if same number
  • jims77jims77 Posts: 3
    Do not see any door lock relays in fuse/relay box. Could not find location for 2004, unless none and only thru BCM. Thanks fo rhelp.
  • lacountrylacountry Posts: 1
    edited May 2013
    Hello fellow owners i am a 2007 chrysler town and country owner and it has been giving me some problems with the mph speedometer when i put the van in gear the needle will jump to 50 mph and the next is that the miles are running up on neutral while putting the vehicle in gear the tranny makes a jerking motion . I took it to my local mechanic only to change two sensors and the lower links but the check engine light is still on and is still doing the same things my mechanic assured me that the tranny is good but that it might be an electrical problem. Please help any insight will be truly appreciated thanks.
  • i ahve the same problem Ive bot a used 1998 chrysler town and country batery light comes on radio goes out dash lights goes out acts like it isnt getting any gas if i stop ehrn its doing this then i cant start it for 15 to 30 min i took it to autozone and they put it on there comp battery was fine but voltqage regulator is going bad they said but thats in the computer
  • Same problem! So thankful that we got the extended warranty. We have had wiring replaced, alternator replaced, battery replaced, and the corroded connector to the battery replaced. Problem is still happening. I suspect that the air conditioner is the culprit.
  • dale3nj8dale3nj8 Posts: 2
    Mine did exactly the same thing and it cost me over 1000 at Chrysler to replace a computer, but it worked.
  • kai229kai229 Posts: 1
    Please help!!! My battery keeps going dead! Had battery replaced, continued to die. Had new battery checked, was told that the battery was fine. Used a gage, checked the fuses, the iod (ignition off draw fuse) was drawing off of the battery, when ignition was off! Thought that was the problem, so pulled the fuse. In the morning, put in fuse, battery was dead! Now it sounds as though battery is boiling! This is a brand new interstate battery! I am currently out of work with a back injury and need this fixed promptly and cheaply to get to my appointments! When the car is running, everything is fine, all systems work. Please advise!
  • srs_49srs_49 Posts: 1,394
    You need to figure out which circuit (fuse) is drawing the excessive current. Once you have that narrowed down, you need to determine which module or load on that circuit is the culprit.

    You can use an ammeter or an oscilloscope with a current probe to trace the current flow. You could also measure the voltage drop across each fuse in the fuse panel when the van is supposed to be off. This last measurement can be tricky because of the low (millivolts or less) voltages involved.
  • jd495jd495 Posts: 2
    Help please its cold out side.

    I have a 1997 Chrysler town and country LXi
    3.8 motor

    My blower fan was making some noise awhile back and has now went out.
    So i replaced the motor and the fan it self. Still don't work.

    I replaced the Relay in the fuse box under the hood and still nothing.

    I replaced the resistor under the hood on fire wall passenger side.Still don't work.

    I'm out of ideas here, I keep getting told to test this or that but i haven't got a tester nor do i even know how to run one if i did.

    Here a re a few other things going wrong with my van,
    #1 My Air bag light is on and my cruise and horn don't work. I suspect the Lock Ring is shot.

    #2 My car will start and then shut off 3 seconds later. And act like it out of gas. Gauges will read nothing.

    #3 I'm driving and all the gauges will just shut off. i smack the dash and they pop back on.

    #4. My door lock will unlock and lock back up on there own. i have to pull the battery cable at night so they don't unlock and somebody steals my stuff inside while i sleep.

    I was told this stuff is because of the body control module is going bad.
    Not sure what or were this is.

    Thanks
    Jon
  • I have a 2006 T/C with the delux enterainment system. 6 disc DVD player, and 1st round of navigation, and such. The other day the entire system will not power up. Nothing on the flat screen, nothing on the display screen, no radio, no TV and nothing.

    My family and I actually have to talk with one another now... (The iphones fix that sometimes) but any ideas on what is going on? Would love a simple fuse or relay fix.

    Jon
  • Hallo outinthewoods, I got same issue engine runs radio and blower goes on and off for 1 second, Mine 2006 Caravan ECM located in the front driver side wheel well, witch wire you cut it ??? there 4 plugs going to ECM all colored , green, white,brown, and black , black has yellow wire I cut it and wouldn"t start, green has bunch of mixed yellow wires like : yellow green stripe, orange , black etc. Help me out witch one to cut , cause car sitting for a week now no use.Any body has more suggestions I will listen, I don't know why they sell these crapy cars to population, just a shame.

Sign In or Register to comment.