Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Caravan/Town & Country Electrical Problems

1679111222

Comments

  • ive tried this many of times even had my computer reset and new software added to the computer.
  • maxima8maxima8 Posts: 8
    I have been having the same problem with my 98 T&C It will start and die three times and then not star at all. until next morning
  • Hi. I hope by now you have solved this. For others with this problem, however, have your fuel pump wiring checked. A rodent had chewed through mine (1997 T&C), resulting in continuous successful engine cranking without ignition, because the engine was not getting fuel. Repair of the wiring took care of it. Do not let the mechanic charge you for an expensive fuel pump replacement until they have first checked out the wiring!

    Let me know if this helps.

    McDocs
  • Hi. I hope by now you have solved this. For others with this problem, however, have your fuel pump wiring checked. A rodent had chewed through mine (1997 T&C), resulting in continuous successful engine cranking without ignition, because the engine was not getting fuel. Repair of the wiring took care of it. Do not let the mechanic charge you for an expensive fuel pump replacement until they have first checked out the wiring!

    Let me know if this helps.

    McDocs
  • the problem is that my van would start one day and it would be fine for a couple days to a week. Then out of no where, the van doesn't start anymore until a couple days later. The mileage light on the dashboard doesn't turn on resulting that the car doesn't start.
  • The problem is that my van would start one day and it would be fine for a couple days to a week, then out of no where, the van doesnt start anymore until next day, the mileage light on the dashboard doesnt turn on resulting that the car doest start
  • :mad: I have a 2005 Dodge Caravan. The power door locks have been going nuts. They will unlock and lock when it wants too and it keeps going until it wants to stop. I mean we lock it at night and in the morning the doors are unlocked. I just tryed unhooking the battery. No Help. I also pulled the fuse someone said and no help. Has anyone else had this problem and was able to fix it please let me know.
  • jpfjpf Posts: 496
    Sometimes a weak battery causes the electircal system to go haywire. Consider having a charging system check to make sure the alternator is charging the battery properly. If the battery is weak, then replace it. Good luck.
  • Replaceing clock spring in dodge caravan invlove pulling wiring harness thro steering column and right by wiper switch, or can it be replaced some other way with out pulling wires.
  • my 97 T&C lx - does the same thing... gauges go out & power door locks go out airbag lights but "clears" like normal but brake stays on. Some minutes later the "take me to the repair shop $$" light comes on. The problem can last a few days or a few minutes. All of a sudden everything begins working. The "repair light" will stay on for maybe a day and then it goes out. Think that's the circuit problem too. Is it ieasy to find and to get to or do you have to un install it?
  • sorry did you ever get this fixed it cost me about 2000.00 to get it fixed and 2 trips to the dealer
  • I have a 1999 Chrysler T&C Limited with a 3.8L engine. For the past couple of weeks the battery has been draining quicker than it should. I have found that the Transmission Control Relay is energized even when the ignition key is off. With the key off, when I pull out the fuse for the Transmission Control Module the battery drain goes down to normal and when I re-insert the fuse the Transmission Control Relay clicks on and the battery drain increases. What would cause the Transmission Control Relay to be energized when the ignition key is off?

    Thanks!
  • I've had the same problem with my '99 t&C LXi. I thought there was something that was draining my battery over a period of time. Turns out it was a defective starter. Had it replaced and solved the problem.
  • We have a 1999 T&C. We just had the transmission rebuilt and the next day the van would "choke" when we would start to drive after being at a redlight, etc. Took it back to the service place today and he checked the fuel pressure..no problems. Ran some tests & went to get a temp sensor and when he came back, the parking lites were flashing on/off and the batter was almost dead. He's charging battery to run test on electrical system. Also, we bought the van used 3 years ago and ever since we bought it, the AC control panel lites flash on/off for about 15 minutes then go off. It does this every time we start the car. Any ideas on what the problem could be?
  • I am having the exact same problem. When my husband removes the fuse and puts it back in it works for a few hours. Then it goes back to the same problem. He replaced the fuse and it did the same thing. Just wondering if you found out what it was. I would love to save a trip to the dealership.
    Thanks
  • We were having the same issue with out 99 T&C. I have found that if I try to start it and it doesn't start don't try it again because 3 strikes and your out. If I start it and it dies I take my fist and hit the top of the dash above the steering wheel and then try to start it and it starts up just fine. I know that sounds weird it did it just Saturday and my husband calls me the FONZ. Its worth a shot. If I can get what I mean on video I will but it may be a while because you never know when its going to be testy.

    Oh to the previous poster above my post the removal of the fuses worked for a while for us and then didn't anymore. If it doesn't start right up just give it a good whack on the top of the dash above the instrument panel and then try to start it.
  • What did they say the $2000.00 problem was?
  • I have a 98 T&C and I have had a starting problem for over a year. One day I would not start ( the battery weak) jump starts works like a charm. Would go for weeks, days or months everything OK. Then it starts again. The charging system always test good so does the battery. Checked several times at Sears and Advance Auto. I have swapped the battery with another car it it is running for the last few days. So I want to believe the battery is weak and the system does not like it. I will update this in a few days or if there is a change.
  • with the minivan alot of times when you remove a fuse the system has to reset itself my suggestion is try removing the hot cable from the battery for about ten minutes then reattaching it this also helps in reseting the transmission when it want switch into overdrive
  • OK so far both vehicles going good. I seem to recall this was the identical situation last year. After a while when the original battery is used the problem would go away. When I do so I would update again.
  • I hope someone can help me, I am at my wits end! I have 2005 Chrysler T&C that the dash lights/gauges/headlights/radio turn on and off while driving. Sometimes it will do it every few minutes, sometimes just endlessly over and over. It makes it impossible to listen to the radio, and at night it turns the headlights off! I have taken it to two garages and two Chrysler dealerships. They replaced the battery and a corroded wire, still, the problem persists! I have 3 kids that I need to transport in this car and no one can diagnose the problem. What can I do?
  • I had a similar problem - You need to reset the BCM.

    You will find 2 plugs below the fuse box on the left side of the brake pedal. Unlug both of them, turn your key to "on" wait 20 seconds, turn key to "off" plug noth plugs back in, you're done.

    Let me know
  • I just began having this same problem last night... I have 132.000 miles on my 2001 T&C. It drives fine, radio works and air. I noticed something wasn't right when I unlocked the car and the tail lights didn't blink. The blinkers do not work and all the instrument panel doesn't work either. This morning when I went to get the paper the panel would come on for a second and then as soon as I flipped on the blinker it would cut off. Iwould love this guys contact info if you still have it available. Thanks so much!
  • Did replacing the TIPM solve your issue with the electrical system? We are having similar problems. Intermittant, no radio, AC, nav, turn signals, door locks.

    Thanks.
  • We ended up taking it to the dealership. Everything we tried did not work. They said they had to do some reprogramming. It cost us $80. Worth every penny.
  • i have a 1986 dodge caravan se the passenger side sliding door (manual type) door handle and internal guts busted on me the van only has 195856 miles on it. how can i fix this and where can i find diagrams of the complete mechanisim (blueprints) for it or any ideas where I can get the peice for this I need the inside handle including the lever(handle) spring the little bar grommets this is a dual locking mechanisim door; 2 locks which are as follows one catch on the front of the door and one on the rear of the door they both have to go towards the front of the van in order to open the sliding door; but the one on the rear pulls towards the front of the van and the one on the front of the sliding door pushes towards the front of the van to unlock it also I am needing to find out the specs of the driver side lock for the left door
    the door is extremely hard to shut and usually requires 3 or 4 times of slamming before the door will fully shut. does any one else out there have one of these older type of vans and have you had the smae problem(s) yet? if you did what did you do to correct the problem(s)?
    :lemon: :mad: :confuse: :sick:
  • I just got a used 2005 and the lights went out last night. I looked for 2 plugs. Is the fusebox the white box behind the brake pedal on the left? It has 4- larger plugs....the botton one is empty. Please reply. Thx
  • jpfjpf Posts: 496
    Try a Haynes auto repair manual for the diagram. Maybe a local auto salvage place has the door parts that you need. Good luck.
  • donniedonnie Posts: 24
    I have have a 1997 Chrysler T&C LXi. I have had previous problems where the vehicle would start for about 5 seconds and then shut down. After having it towed to the dealer where they found no problems, it started. After going through this a couple times I found that removing and replacing the gas cap would resolve the problem. Now a few years later with no problems my vehicle will not start. It starts for a second and shuts off. This time no gauges are working but the radio does, any thoughts?
  • LisaZLisaZ Posts: 1
    YES!!!!! And I'm about at the end of my rope! We have a 2008 T & C - and it went in to the shop for the fifth time today for a very similar problem, except everything blinks on and off, complete with constant dinging and the windshield wipers coming on to join the party.

    Have you tried calling Chrysler's Customer Service yet? If not, you are in for a thrill. You'll get to talk to a lot of agents in India. If you are persistent enough, they'll transfer you to someone in the US. Good luck!!!!!!
Sign In or Register to comment.