Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





New Lexus RX 400h Owners - Give Us Your Report

124»

Comments

  • tomnltomnl Posts: 2
    Just picked up my RX400h and driving it to work.
    First impression ---> LOVE IT and felt like helping hand to the GREEN planet.
    Very comfort and quiet. Still need to learn to adapt Hybrid Driving Style.
    I am thinking to keep this car for at most 10 yrs and don't care much about the battery replacement cost. By then we maybe driving with Hydrogen or some other fuels.
  • gx470818gx470818 Posts: 16
    I'm in the market for one of these baby as well but a dealer sales told me that there will be no 09 model coming out and the 2010 model will be completely redesigned with better fuel milage and probably a higher price as well. The 2010 should come out next May. I might just wait out for another year.
  • bmlexusbmlexus Posts: 755
    2010 model will be completely redesigned with better fuel milage and probably a higher price as well. The 2010 should come out next May. I might just wait out for another year

    Finally someone is saying that it will be out in May, How am I going to wait that long... :blush: :sick:

    I dont know anymore what I even like... Well maybe I do I like the x6 but trust the lexus...
  • tomnltomnl Posts: 2
    Pick BMW X6, it is a nice looking cross over SUV.
  • I bought a 2006 RX 400 H with 35000 miles on it. Since May, 2009 I have had it at the Lexus dealer 4 x because if it doesn't get driven every single day, when I get in to go somewhere, it won't start, and that's after only one day of not running the car. I just found out this last weekend that the regular batter, NOT the Hybrid battery had already been changed and the previous owner didn't put in a Lexus battery so Lexus is now saying that is the problem. My thought is, "I am expected to spend $500 on a Lexus battery and it doesn't even last three years?" So I have not had a good experience with my car at all. If anyone knows if there is a difference in a Lexus battery and a regular 12 V battery let me know. Thank you.
  • We just bought 2006 RX400H. My partner had no problem using his Blackberry Bold (AT&T) with the bluetooth for a week. I started driving the car with my own key and connected my Samsung Blackjack 2 (AT&T) to the bluetooth successfully too. The connection problem started when he got back into driving the car. When I rode with him, my phone was connected. From that point on, things just yo-yo-ing between his and mine. More often than not, none of ours connect regardless of who drives (whose key is used), which User setting we select.

    These are the behaviors we observed: 1. Using our personal key doesn't seem to the driver's phone is the one getting connected.

    2. Memorising the User setting while the driver's phone is connected does seem to help either.

    3. Removing the Device entry on our phone and reregister seems to be the only way to get connection again. Temporarily disable the device on the phone doesn't do any good.

    Any tips from any one to fix the problem will be appreciated. Thanks.
  • 1dkupp1dkupp Posts: 4
    I've had my 400h since 2006 has 75,000 miles . Coming back from vacation saw a puddle of anti-freeze on ground. The hybrid section broke a seal and lost all the fluid. No actual fix for this problem except replace the entire transaxle at $6400.00!!

    Have spoken to Lexus customer service and expect an answer/relief from them next week. Anybody else have this problem?

    To think that a $5 seal can't be fixed and nesessitate such an expensive and wastful solution does not seem like the Lexus way of doing things.
  • Hi 1dkupp, did you get your problem resolved? I just niticed a leak in my 2007 rx 400h as well but I don't know where the leak is coming from. Will take it in for a check up and a preassure test. I'm keeping my fingers crossed that is a simple problem like a hose leak. Did you get any replies to your post?

    Thanks ang gl!
  • Hi Ang,

    My repair was major even though the problem seemed small. In fact there was no repair they had to replace the drive train to the tune of $6,000.00 !!!

    I raised a stink with the national customer service person and they responded by absorbing the whole bill!

    I called out the local dealer for not standing up for me and they apologized and gave me a credit towards my next service.

    BTW I kept the 400h but bought a new Range Rover Evoque for my new car and it's a lot more vehicle for the money and gets better mileage than the hybrid!

    Good luck, don't let them push you around!

    Doug
124»
Sign In or Register to comment.