Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Suzuki XL-7 Problems and Solutions

12467

Comments

  • I have a 2007 xl7 with 20000 miles the radio shuts off for no reason and the info center stops working then the engine light came on started running real rough. Had it towed to dealer they said it was a sludge build up in the engine paid $170 the next day same thing towed back again told me it needed an induction service for $180. When I questioned the service writer I asked if the codes were read he said not yet so how could he know i needed an induction service done? Then he tells me they need to contact suzuki because they dont know whats wrong. I am thinking it is time to get a lawyer and get out from under this. Any suggestions?
  • I've got a 2007 XL7 AWD with 20K miles. The dealerships are useless & clueless. American Suzuki told me to take the vehicle to a different Suzuki dealership since they have different mechanics next dealership is 60miles away. American Suzuki & the Dealership told me they could not repeat the problem so there was no problem. I've had continous problems since December 07 when I bought it new.

    I believe I've isoloated the electric failures with mine, it has to do with the factory remote starter. When I've used the remote starter on seperate occassions I've lost:
    Climate control, Radio, DVD, Turn Signal audible (clicker noise), ability to dim dash, no crusie control.

    other issues: roof rack rail plastic flapping in the wind , rear window defroster faliure, squeaky dash console, DVD LCD rattles... all the anoying stuff. Keep finding screws on the floor when I vacuum, I know they are coming out somewhere, but where?

    I hope this helps because I know I'm sick of this car too. Attorney told me to keep taking it back until I build up enough visits to use the lemon law on them.

    Almost forgot the randomly appearing ruff engine and check engine lights and the 'tighten fuel cap' light which was replaced, twice I think?
  • Thanks for the info, today they told me that they think it is a cam shaft sensor but they are still not sure and need the vehicle through the weekend with no loaner. I will let you know when I actually talk to someone who knows something.
  • ceuserceuser Posts: 6
    Sludge buildup sounds exactly like my problem stated in response # 46 on this thread. The dealer told me it was rust on the cams ,,they ended up keeping the suv for 2 weeks and changed alot of parts in the engine. Its a lemon,,,,Suzuki has sold a crummy vehicle with this 2007 xl7. Wish I never went there. Never again :mad: :mad: :mad:
  • The 4 wheel drive does not disengage the only way is to go in reverse and then forward again then back into reverse . I assuming there is a shim or pin when engage that is locked in place . It seems that the reverse motion loosens the engagement so it will then disengage . Which sounds to be lubrication problem on the front wheel drive. Is there a link for a service manuel that can be seen on line either the drive train or the 4 wheel drive section.
  • Hi;
    We purchased a XL7 on November 23,2007, and it was back at the dealership on Dec 19th and did not get back till Dec 31.

    I am from Canada and while out driving on a morning after a snow storm, it started beeping at me telling me to "Service ABS", Servce Traction Control and Servie Stability Control. The Service dept had no clue why this was happening, the computer would not clear the code, they replace a few of the computer modules, they finally said it was the break sensor module, seemed to be ok for a couple of weeks, till the breaks started pulsating. Took it back in and they said that I had faulty rotors, the truck at this time only had 1500km. They replaced thenall seems fine. Now my breaks are squealing when I first start the car and continue to do so.

    This truck is babied and is parked in the garage and gets driven about 30km per day.

    Today while driving again in the snow, the same problem with the "Service ABS", Servce Traction Control and Servie Stability Control, happened again.

    I honestly believe I was sold a lemon!! I have spoke with the Suzuki Canada rep, and he was very rude to me , basically because I am a woman, he felt that he could talk down to, me. Yes I hope Suzuki reads this forum.

    We have been Suzuki brand loyal since 2000, we have owned 3 motorcyles and a Suzuki Swift all purchased at the same dealership, and this is how we get treated by someone that represents the company.

    We are also having huge issues with the litres/Km. I fill my car up on a weekly basis and barely get 400km per tank. Granted I don't do any highway driving much, but this should still be better than what I am getting. I was told by the service advisor that "it has to be broken in", ok I can understand the first couple of gas tanks can be bad, but this long... He said you have to get at least 10,000 km before you start seeing the good gas mileage.. Well that is alot of money on gas being spent considering I owned a Suzuki swift for 3 year with bearly 30000 km when I turned it in on the lease for my new XL7.

    Sorry venting here, but there has to be some kind of "Lemon" law out there!! I am so fed up that I just want to drop it off give them the keys and walk away.

    Needless to say they will be seeing me bright and early tomorrow morning, and my husband will be there as well, and they won't be too happy when we walk in the door, we are fed up!! I have owned alot of cars, and have never had this many problems before.

    Does anyone else have any issues as stated above.

    Any feedback would be appreciated.

    Ginette

    THE SAGA CONTINUES:

    Well I am back again and hoping to get some answers, in the last year of ownership of my XL7, I have been back to the dealership 5 times with the same problems listed below. Driving home on Friday Dec 19, in a really bad snow storm the same problem happened, they told me on Monday after my truck being there over the weekend that it might be my battery. Well today Christmas eve, out to do some shopping and we got more snow last night and same problems comes up, not the battery I guess. There has to be a solution to get this fixed, I am fed up and at this time just want out of my lease and go purchase another more reliable vehicule somewhere else.

    I also have had problems with my radio cutting out, for 30 seconds to 1 minute and have noticed when this happens that my turn signals don't work, does that also mean, I have no working brake lights, or head lights? But the dealership cannot find the problem there either and have not heard about that at all.

    Please someone give me some insight, as I don't know what to do anymore, Suzuki Canada does not return our calls, and we are at a dead end. After the holidays, we are considering going to see a lawyer and suing them. Are they going to wait till a bad accident happens, before they step up to the plate. I have 3 children and don't feel safe having them in my vehicule.

    Another thing to point out, back in the summer we went to get the oil changed and there was another 2008 XL7, parked at the dealership, and all the Air Bags were deployed but there was no physical damage to the vehicule, it had not been in any accident, we inquired and the Service Manager told us the owner was driving along and the airbags just deployed on them, but the person was not hurt, he said with a chuckle..., he was on a city street going at a slow speed, I guess that makes it ok??? What would of happened if they had been on the highway?? SO that should be reassuring, I do not feel safe at all...

    Hope to get some responses to my venting, and hopefully some insight I can take back to them, for a possible resolution.
  • adnowoadnowo Posts: 1
    it was a cold day and i was picking up my daughter. i was parked in the lot and when she got in and shut the door, the back window blew out! has this ever happened to anyone else?
  • tidestertidester Posts: 10,110
    I take it that no one was hurt but I'm sure it was a jolting experience to all concerned.

    shut the door, the back window blew out!

    That is curious. You might expect the breaking glass to fall into the car. "Blowing out" suggests a buildup of pressure in the cabin sufficient to push the glass outward. But that doesn't really explain how the window broke in the first place. Ordinarily one would have to slam the door shut quite violently for the glass to break.

    tidester, host
    SUVs and Smart Shopper
  • Ginette,

    My name is Andrew. I have having similar problems with my 07 xl7. if you get this, i'd like to talk to you about this issue. my email is awpalladino@ymail.com .

    thank you so much if you find the time.

    -Andrew
  • 2003xl72003xl7 Posts: 1
    I have a 2003 Suzuki XL7 as does my sister. Both of our fuel doors have fallen off. As I drive around I see that this seems to be a common problem. Has anyone else experienced this?

    Thanks!
  • I have a 2008 xl7 and just purchased the roof cross rails. I need to know how to take off the black caps at the back of the side rails. Someone said theirs were coming off. Can you tell me what I need to do to take them off.
    thanks
  • reachjreachj Posts: 4
    Yep electrical nightmare about says it all. I have had problems with charging system for MONTHS.. they kept dragging their feet and now it's doing it again and they tell me warranty is over the miles allowed. They say "might need" new alternator. Will cost over 700.00 JUST for the part it "MIGHT" need. Even though alternator test fine. Then it just clicks when you turn key. They say starter is ok.
    I have been going through this for MONTHS and MONTHS..
    When check battery charging system comes on, then voltage starts dropping. Pull over turn key off and sometimes craks right back up at 14+ volts.. then fine for rest of day.
  • techguytechguy Posts: 2
    I have the same problem. I need a silver one for my 2003 XL7. Did you ever find one?
  • I have the same problem - looking for one too - Silver 2003 xl7
  • I have a 2003 XL7 and the problem is that it does not start, it´s like the battery is dead, but it is not....any ideas for this problem ???

    I check the fuses and they are fine

    please i need some help
  • We have a 2003 XL7, first after a heavy rain storm we noticed our brake lights were on all night. Couldn't shut them off. Took to dealer thought fixed. We are now in Mexico after washing car, lights came back on with fog lights but our biggest problem is in park the car does not shut off we have to put it in neutral. Now we have disconnected the battery. Do we have a loose ground wire ?
  • has anyone helped you?
  • Our fuel door to our 2002 xl-7 recently fell off, sounds like this has happened to more than a few of these =(. Does anyone know of an interchangeable part or where I can find something that will work? Thanks for your help, hope to hear from you!
    Brian
  • Everytime I put gas in my car, it will not start until 3 tries, seems like it loses compression, but ONLY when I fill up. When I start it later I don't have that problem. Also, my windshield leaks somewhere, last big rain of 5 inches netted me 5 gallons of water in my car. It has 100k miles, otherwise a darn good car, on my 2nd set of tires but 1st set of brakes. Tried warranty/recall on the windshield issue because frankly, a 2.5 year old car should not have that water issue-it's nothing to do with the mechanics, it's the body. Any suggestions would be appreciated. :sick:
  • We just purchased a '05 XL-7. It did not have an owners manual. Can you tell me if I have to shift in and out of 4-wheel drive in motion or sitting still? While in 4X4 mode, it feels like the drive is slipping when turning sharply (like into a parking place). Any suggestions or direction?
Sign In or Register to comment.