Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Toyota Tacoma Suspension and Steering

2»

Comments

  • I have an '07 Tacoma and put an ARB winch bumper and winch on my truck along with a Daystar leveling kit on the front to bring it back up to stock ride height. 3 months later I hauled 300lbs in the bed and it now leans almost an inch to the left. I have been fighting with the dealership as they want me to return the truck to completely stock before they will replace any of the springs. Even 4 Wheel Parts (where I had everything installed) said they cant find anything wrong and it has to be a bad spring. The dealership even put it on a frame machine to see if the frame bent and its not. So now they are saying its because of the bumper and winch that weigh less than 200lbs. This is complete [non-permissible content removed]. So heres what I need help with I need anyone that has or knows someone with the same bumper to take pics of your truck no matter what year and send them to me. The pics will help me fight the dealership. And has anyone else had this problem?
  • ffjamison: Same lean problem my bone-stock 2006 has so your mod's probably have nothing to do with it. Btw, my truck is a 4x4 w/tow package. I took it to the dealer and they 'checked' the suspension out and said everything looked fine. I told the service manager that it wasn't just my truck as others have complained about the same thing. Obviously, Toyota (not the local dimwit at the dealership..) is aware of the problem but won't address it.
  • My steering went from a firm steering to very easy steering all at once like turning a light out. If the pressure switch on the power steering pump goes bad, will that cause the problem?
  • lmiddlmidd Posts: 1
    So I bought my Tacoma (1996) about 5 months ago used. I had it inspected and the mechanic said it was good to go. A couple months later I noticed it was pulling to the right so i got the tires rotated. That helped for a few days but it started pulling to the right again.

    I went to Kaltire for an alignment, and they said they had to replace the steering rack because it wouldn't hold the alignment. That helped for a week or so.

    I returned to Kaltire again and they said that they had to adjust the alignment again and asked me if I had hit a curb and I had not. Right after I drove it away it actually felt worse than before. So i took it back the next day and they switched the front two tires, which helped for about a week.

    Fed up with Kaltire I took it to Toyota and they did a 4-wheel alignment and said that Kaltire missed adjusting a Tow-in. But even after that it still pulled to the right!

    I talked to Toyota that day and they said it could be a bad batch of tires or there may be a frame problem. I did a carfax on the vehicle and it came out clean.

    Any ideas/opinions of the problem?
  • Hello guys,

    I recently bought a 2008 Toyota Tacoma access cab TRD sport. Today on the Beltway 8 feater road a cop pulled right out in front of me and forced me off the road to avoid a collision (after breaking to about 15-20MPH). It was a pretty rough ride but after comming to a stop about 30 feet from the road the cop came over to make sure I was ok and to apologize. I was pretty mad but after getting back in the truck and driving I was amazed that nothing seemed to be off. Visual inspection showed not scuff or anything on either of the front 2 tires or rims. There was no sway left or right and no vibration (i even took it up to about 90mph to see). There is about a 1 degree left tilt in the steering wheel while it is going straight but i don't remember if it was like that previously. Am I being completely paranoid (brand new truck) or do I have reason to be worried?

    I was under the impression that no vehicle was made to take curbs like this (hit curb at about a 30 degree run (from road parallel)) with left front first the right front after. I guess my question is "How rugged are the TRD sport suspensions?". Should I take this in for a suspension check just to be sure?

    David
  • KCRamKCRam Mt. Arlington NJPosts: 3,516
    Had a similar incident when my 1996 Dodge Ram 3500 4x4 dually was fairly new. Was on an interstate when a bus pulled into traffic from the shoulder (and nowhere near up to speed), sending the vehicles in the right lane into my left lane, and me up and over a curb into a grass median to avoid an ugly situation.

    Like you, the steering wheel was just slightly off, so I took it to a suspension/alignment specialty shop. Just needed a minor correction and nothing was bent or out of spec. Was just fine after that. I say get the front end checked just so you're sure nothing was bent.

    kcram - Pickups Host
  • step2step2 Posts: 1
    My son is looking at a 2009 Tocoma. He will use it for commuting and wants to put racks on it for ladders. Also will be doing off roading on trails. And other times will tow a small boat. Which of the 3 packages would be best to meet all these needs?
  • My '98 Toyota Tacoma 4X4 (6 cyl) (290,000 kms) has started using twice the amount of usual fuel. I changed the fuel and air filters, spark plugs & spark plug wires. The garage says my oxygen sensors are fine. Toyota can't analyse it because no warning lights come on. The mused that maybe changing the timing belt might help but that's a lot of work and $ to do on spec.

    What else should I try? It's using almost double the amount of fuel it takes in winter yet runs fine and has normal amount of power.

    Thanks
  • My 99 Tacoma steering wheel cover is loose and rotates in my hand. Is there some way to make it adhere to the wheel or do i have to replace it? Makes it hard to maneuver quickly if the grip doesn't stay in place.
  • bigandybigandy Posts: 70
    Check out Wheelskins. There is a web site at wheelskins.com. They have nice leather aftermarket covers that will fit over the stock cover. Can make them custom sizes as well. Really nice under your hand.
  • juansokjuansok Posts: 1
    i drive a 96 tacoma 2wd. after i make a turn (left or right) the steering wheel is slow to return to drive straight. the steering is not hard or noisy. my steering wheel almost wants to stay turned. what could if be.
  • lostwrench1lostwrench1 Ct.Posts: 480
    It could be the thermostat which is stuck in the open position thus not allowing the engine to warm to normal operating temperature. The electronic "brain" of the truck then knows that the engine has not yet warmed up so continues to pump more than necessary gasoline into the cylinders.
  • I have a 05 Tacoma 4x4 . When I turn the seering wheel it bucks. I have filled the fluid but still have the problem. I also checked the ball joint I know you can not lube it but it sure looks like it could use some greese. Anybody have and ideas?
  • I have the same backfire problem with my 2006 Tacoma 4X4 TRD extended crew cab with 60K miles. I took it for a tune up and into the freeway at 55-60mph i heard a backfire and at first i thought it was from another vehicle. The following early morning (5 am) in a quiet neighborhood, i heard the backfire and I knew then that it was mine, so I called the dealer and ask me to take it in. I've been asked to drive with their master mechanic and drove into the freeway at the speed that it occurs, and i heard one backfire and the mechanic did not heard it, and we went on around and at that time it did not happened and went back into the dealership and was asked to leave it for the day and will call back. I took it in three times and was told the same thing to drive the truck as long as it is running! I am waiting for the customer survey on-line by toyota and definitely complain and express total dissatisfaction on the service and the quality of the truck. This will be my last toyota vehicle that i will own and will be a lesson learned. :mad:
  • dean40dean40 Posts: 2
    i just purchased a 06 2wd pre runner double cab with 41k miles, i like the truck but its making a funny noise from the rear end i think. When i turn out on a street and turn left or right and accelerate, the truck has a low grumbling/ vibration noise that goes away after the turn is completed. It doesnt do it while traveling on the highway, or on high speed turns, it only happens when turning and accelerating from a stop. Driving around in a parking lot is where it is most noticable. I have checked the rear brakes and they are fine, i even lubed the brake shoes backing plates and changed the diff oil, but this noise still persists. Anyone have any ideas?
  • dean40dean40 Posts: 2
    man i feel silly. i fixed this problem by adding lsd additive, problem solved.
  • eyezelleyezell Posts: 2
    When I turn left one of my front wheels makes an awful grinding noise, but not while I'm driving straight or turtning right. What could this be?
  • dthenesdthenes Posts: 1
    hello fellow car wizards!

    i have a question about my tacoma 4 door 2001 truck.
    it seems that it recently developed a very strange problem, and i am worried
    that the transmission is going out (scary thought). there are some events
    that happened that caused the problem. i went driving up the mountain with
    5 kids and another adult, car was loaded. it worked all good, but going down the breaks overheated and smoked... pretty badly. i stopped and waited for them to cool off, but when i started driving again i realized the
    breaks are not working too wel, i guess the break fluid boiled and created
    a bubble. desperately trying to stop i pulled on the hand break ( going about
    5 mph on somewhat level road ) and that didnt work so i pushed the tranny to park out of panic, it clicked a few times but didnt help, eventually i shifted
    down to 2nd and low gear and managed to stop the car. i didnt have a problem described below for q few days...but i been noticing the problem gotten worse... going uphill, especially, the car starts to jerk around as if something is slipping inside. yet, when on low gear this problem isnt so bad or even noticible. i also notcied that if i turn off the overdrive it helps the
    problem going uphill. anyone here may have a clue what this might be? i'd grately appreciate since i dont have a lot of funds to take it to dealer or expensive mechanic.

    one of my friends recommended to try to plug the vacuum tube that gives power breaks the juice, and see if problem goes away then its the vacuum chamber got screwed up with this break incidence. another friend recommended flushing transmission fluid and replacing filter. but i did look into the transmission fluid color looks red, and not burned.

    i will be checking this forum to see if anyone replied.
2»
Sign In or Register to comment.